No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples

Configuration Examples

Example for Outputting Logs to the Log File

Networking Requirements

As shown in Figure 5-9, the device connects to the FTP Server through the Internet and has a reachable route to the FTP server. The network administrator wants to use the FTP server to view logs generated by the device and learn the device running status.

Figure 5-9  Networking diagram of outputting log information to the log file

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the information center.

  2. Configure a channel and a rule for outputting logs to a log file so that logs are saved in the log file.

  3. Configure the device to transfer the log file to the FTP server so that the network administrator can use the FTP server to view logs generated by the device.

Procedure

  1. Enable the information center.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] info-center enable

  2. Configure a channel and a rule for outputting logs to a log file.

    # Configure a channel for outputting logs to a log file.

    [AP] info-center logfile channel channel6
    
    NOTE:

    By default, channel 9 is used to send logs to a log file. If the default setting is used, skip this step.

    # Configure a rule for outputting logs to a log file.

    [AP] info-center source ip channel channel6 log level warning

  3. Configure the IP address of the interface that connects the device to the FTP server.

    [AP] vlan 10
    [AP-vlan10] quit
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [AP-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [AP-GigabitEthernet0/0/1] quit
    [AP] interface vlanif10
    [AP-Vlanif10] ip address 10.2.1.1 255.255.0.0
    [AP-Vlanif10] quit
    [AP] quit

  4. Configure the device to transfer the log file to the FTP server.

    # Log in to the FTP server with the user name huawei and password huawei.

    <AP> ftp 10.1.1.1
    Trying 10.1.1.1 ...
    Press CTRL+K to abort
    Connected to 10.1.1.1.
    220 FTP service ready. 
    User(10.1.1.1:(none)):huawei
    331 Password required for huawei.  
    Enter password:
    230 User logged in.
    

    # Transfer the log file to the FTP server.

    [AP-ftp] put flash:/logfile/log.log
    200 PORT command okay
    150 Opening ASCII mode data connection for log.log.
    226 Transfer complete.
    FTP: 2761463 byte(s) sent in 26.062 second(s) 105.95Kbyte(s)/sec.
    [AP-ftp] quit

  5. Verify the configuration.

    # View information recorded by the channel.

    <AP> display info-center
    Information Center: enabled
    Log host:
    Console:
            channel number: 0, channel name: console
    Monitor:
            channel number: 1, channel name: monitor
    SNMP Agent:
            channel number: 5, channel name: snmpagent
    Log buffer:
            enabled
            max buffer size: 1024, current buffer size: 512
            current messages: 204, channel number: 4, channel name: logbuffer
            dropped messages: 0, overwritten messages: 0
    Trap buffer:
            enabled
            max buffer size: 1024, current buffer size: 256
            current messages: 256, channel number: 3, channel name: trapbuffer
            dropped messages: 0, overwritten messages: 29
    Logfile:
            channel number: 6, channel name: channel6, language: English
    Information timestamp setting:
            log - date, trap - date, debug - date
    
     Sent messages = 1514, Received messages = 1514                                

    # View the received logs on the FTP server.

Configuration Files
  • AP configuration file

    #
     sysname AP
    #
     info-center source IP channel 6 log level warning
     info-center logfile channel 6   
    #
    vlan batch 10
    #
    interface Vlanif10                                                             
     ip address 10.2.1.1 255.255.0.0                                              
    # 
    interface GigabitEthernet0/0/1                                                  
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    ip route-static 10.1.0.0 255.255.0.0 10.2.1.2
    #
    return

Example for Outputting Logs to a Log Host

Networking Requirements

As shown in Figure 5-10, the AP connects to four log hosts and has reachable routes to the log hosts. Log hosts are required to have reliability and receive logs of different types so that the network administrator can monitor logs generated by different modules on the device in real time.

Figure 5-10  Networking diagram of outputting log information to the log host

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the information center.

  2. Configure the AP to send logs of notification generated by the FIB and IP modules to Server1, and specify Server3 as the backup of Server1. Configure the AP to send warning logs generated by the PPP and AAA modules to Server2, and specify Server4 as the backup of Server2.

  3. Configure the log host on the server so that the network administrator can receive logs generated by the AP on the log host.

Procedure

  1. Enable the information center.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] info-center enable

  2. Configure a channel and a rule for outputting logs to a log host.

    # Name a channel.

    [AP] info-center channel 6 name loghost1
    [AP] info-center channel 7 name loghost2
    

    # Configure a channel for outputting logs to a log host.

    [AP] info-center loghost 10.1.1.1 channel loghost1
    [AP] info-center loghost 10.2.1.1 channel loghost2
    [AP] info-center loghost 10.1.1.2 channel loghost1
    [AP] info-center loghost 10.2.1.2 channel loghost2
    

    # Configure rules for outputting logs to log hosts.

    [AP] info-center source fib channel loghost1 log level notification
    [AP] info-center source ip channel loghost1 log level notification
    [AP] info-center source ppp channel loghost2 log level warning
    [AP] info-center source aaa channel loghost2 log level warning

  3. Specify the source interface for sending logs.

    # Specify the source interface for sending logs.

    [AP] vlan 10
    [AP-vlan10] quit
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port hybrid pvid vlan 10
    [AP-GigabitEthernet0/0/1] port hybrid untagged vlan 10
    [AP-GigabitEthernet0/0/1] quit
    [AP] interface vlanif10
    [AP-Vlanif10] ip address 172.16.0.1 255.255.255.0
    [AP-Vlanif10] quit
    [AP] info-center loghost source vlanif 10

  4. Configure the log host on the server.

    The AP can generate many logs, which may exceed its limited storage space. To address this problem, configure a log server to store all the logs.

    The log host can run the Unix or Linux operating system or run a third party's log software. For detailed configuration procedure, see the related manual.

  5. Verify the configuration.

    # View the configured lost host.

    <AP> display info-center
    Information Center: enabled
    Log host:
            the interface name of the source address:Vlanif10
            10.1.1.1, channel number: 6, channel name: loghost1
            language: english, host facility: local7
            10.2.1.1, channel number: 7, channel name: loghost2
            language: english, host facility: local7
            10.1.1.2, channel number: 6, channel name: loghost1
            language: english, host facility: local7
            10.2.1.2, channel number: 7, channel name: loghost2
            language: english, host facility: local7
    Console:
             channel number : 0, channel name : console
    Monitor:
             channel number : 1, channel name : monitor
    SNMP Agent:
             channel number : 5, channel name : snmpagent
    Log buffer:
            enabled
            max buffer size: 1024, current buffer size: 512
            current messages: 218, channel number: 4, channel name: logbuffer
            dropped messages: 0, overwritten messages: 0
    Trap buffer:
            enabled
            max buffer size: 1024, current buffer size: 256
            current messages: 256, channel number: 3, channel name: trapbuffer
            dropped messages: 0, overwritten messages: 150
    Logfile:
            channel number: 9, channel name: channel9, language: English
    Information timestamp setting:
             log - date, trap - date, debug - date
    
     Sent messages = 683, Received messages = 682
    

    # View the received logs on the NMS. The configuration details are not mentioned here.

Configuration Files
  • AP configuration file

    #
     info-center channel 6 name loghost1
     info-center channel 7 name loghost2
     info-center source FIB channel 6 log level notification
     info-center source IP channel 6 log level notification
     info-center source PPP channel 7 log level warning
     info-center source AAA channel 7 log level warning
     info-center loghost source Vlanif10
     info-center loghost 10.1.1.1 channel 6
     info-center loghost 10.2.1.1 channel 7
     info-center loghost 10.1.1.2 channel 6
     info-center loghost 10.2.1.2 channel 7
    #
    vlan batch 10
    #
    interface Vlanif10                                                             
     ip address 172.16.0.1 255.255.255.0                                              
    # 
    interface GigabitEthernet0/0/1                                                  
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
     ip route-static 10.1.1.0 255.255.255.0 172.16.0.2
     ip route-static 10.2.1.0 255.255.255.0 172.16.0.2
    #
    return

Example for Outputting Traps to the SNMP Agent

Networking Requirements

As shown in Figure 5-11, the AP connects to the NMS station. The network administrator wants to view traps generated by the AP on the NMS station to monitor device running and locate faults.

Figure 5-11  Networking diagram for outputting traps to the SNMP agent

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the information center.

  2. Configure a channel and a rule for outputting traps to the SNMP agent so that the SNMP agent can receive traps generated by the AP.

  3. Configure the AP to output traps to the NMS station so that the NMS station can receive traps generated by the AP.

Procedure

  1. Enable the information center.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] info-center enable

  2. Configure a channel and a rule for outputting traps to the SNMP agent.

    # Configure a channel for outputting traps to the SNMP agent.

    [AP] info-center snmp channel channel7
    

    # Configure a rule for outputting traps to the SNMP agent.

    [AP] info-center source ip channel channel7 trap level informational state on 
    NOTE:

    By default, the device uses the SNMP agent to output traps of all modules.

  3. Configure the SNMP agent to output traps to the NMS station.

    # Enable the SNMP agent and set the SNMP version to SNMPv2c.

    [AP] snmp-agent sys-info version v2c

    # Configure the SNMPv2c read-write community name.

    [AP] snmp-agent community write huawei123

    # Configure the trap function.

    [AP] snmp-agent trap enable
    Info: All switches of SNMP trap/notification will be open. Continue? [Y/N]:y
    [AP] snmp-agent target-host trap-hostname nms address 10.1.1.1 trap-paramsname trapnms
    [AP] snmp-agent target-host trap-paramsname trapnms v2c securityname public
    [AP] quit

  4. Verify the configuration.

    # View the channel used by the SNMP agent to output traps.

    <AP> display info-center
    Information Center: enabled                                                     
    Log host:                                                                       
    Console:                                                                        
            channel number: 0, channel name: console                                
    Monitor:                                                                        
            channel number: 1, channel name: monitor                                
    SNMP Agent:                                                                     
            channel number: 7, channel name: channel7                               
    Log buffer:                                                                     
            enabled                                                                 
            max buffer size: 1024, current buffer size: 512                         
            current messages: 242, channel number: 4, channel name: logbuffer       
            dropped messages: 0, overwritten messages: 0                            
    Trap buffer:                                                                    
            enabled                                                                 
            max buffer size: 1024, current buffer size: 256                         
            current messages: 256, channel number: 3, channel name: trapbuffer      
            dropped messages: 0, overwritten messages: 2190                         
    Logfile:                                                                        
            channel number: 9, channel name: channel9, language: English            
    Information timestamp setting:                                                  
            log - formate-date, trap - date, debug - date                           
                                                                                    
     Sent messages = 5647, Received messages = 5647                

    # View traps output through the channel used by the SNMP agent.

    <AP> display channel 7
    channel number: 7, channel name: channel7
    MODU_ID  NAME     ENABLE LOG_LEVEL     ENABLE TRAP_LEVEL    ENABLE DEBUG_LEVEL
    ffff0000 default  Y      debugging     Y      debugging     N      debugging
    c16a0000 IP       Y      debugging     Y      informational N      debugging
                                                                                    

    # View traps output to the NMS station by the SNMP agent.

    <AP> display snmp-agent target-host
       Traphost list:
       Target host name: nms
       Traphost address: 10.1.1.1
       Traphost portnumber: 162
       Target host parameter: trapnms
    
       Total number is 1
    
       Parameter list trap target host:
       Parameter name of the target host: trapnms
       Message mode of the target host: SNMPV2C
       Trap version of the target host: v2c
       Security name of the target host: public
    
       Total number is 1
    

Configuration Files
  • AP configuration file
    #
     snmp-agent local-engineid 800007DB030819A6D0269A
     snmp-agent community write %$%$sqZd.Z5;=9}%}USLx>3D,!HA%$%$
     snmp-agent sys-info version v2c
     snmp-agent target-host trap-hostname nms address 10.1.1.1 udp-port 162 trap-paramsname trapnms
     snmp-agent target-host trap-paramsname trapnms v2c securityname public
     snmp-agent trap enable
     snmp-agent
    #
     info-center source IP channel 7 trap level informational
     info-center snmp channel 7
    #
    return

Example for Outputting Traps to the Console

Networking Requirements

As shown in Figure 5-12, the PC connects to the AP through a console interface. It is required that debugging messages of the ARP module be displayed on the PC.

Figure 5-12  Networking diagram for outputting debugging messages to the console

Configuration Roadmap

The configuration roadmap is as follows:

  1. Enable the information center.

  2. Configure a channel and a rule for outputting debugging messages to the console so that debugging messages generated by the AP can be sent to the console.

  3. Enable terminal display so that users can use the terminal to view debugging messages generated by the AP.

Procedure

  1. Enable the information center.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] info-center enable

  2. Configure a channel and a rule for outputting debugging messages to the console.

    # Configure a channel for outputting debugging messages to the console.

    [AP] info-center console channel console
    

    # Configure a rule for outputting debugging messages to the console.

    [AP] info-center source arp channel console debug level debugging state on
    [AP] quit

  3. Enable terminal display.

    <AP> terminal monitor
    Info: Current terminal monitor is on.
    <AP> terminal debugging
    Info: Current terminal debugging is on.

  4. Debug the ARP module.

    <AP> debugging arp packet

  5. Verify the configuration.

    # View debugging message output through the channel used by the SNMP agent.

    <AP> display channel 0
    channel number: 0, channel name: console
    MODU_ID  NAME     ENABLE LOG_LEVEL     ENABLE TRAP_LEVEL    ENABLE DEBUG_LEVEL
    ffff0000 default  Y      warning       Y      debugging     Y      debugging
    c16e0000 ARP      Y      warning       Y      debugging     Y      debugging    

Configuration Files
  • AP configuration file
    #
     sysname AP
    #
     info-center source ARP channel 0
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 130208

Downloads: 312

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next