No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuration Examples for WLAN QoS

Configuration Examples for WLAN QoS

Example for Configuring WMM and Priority Mapping

Networking Requirements

As shown in Figure 27-17, a Fat AP accesses the Internet through wired connections and connects to STAs wirelessly. An enterprise branch needs to deploy basic WLAN services for mobile office so that branch users can access internal network resources anywhere at any time.

Voice, video, and data services are transmitted within the coverage of the AP. Users expect that video services preferentially preempt channels and have the highest priority to use wireless network resources.

Figure 27-17  Networking diagram for configuring priority mapping
Configuration Roadmap
The configuration roadmap is as follows:
  1. Configure basic WLAN services so that users can connect to the wireless network.
  2. Configure parameters used by the AP so that video services have higher priorities over voice and data services and preferentially use the bandwidth.
  3. Configure priority mapping in the traffic profile so that video services have higher priorities over voice and data services and preferentially use the bandwidth.
Table 27-14  Data planning

Item

Data

DHCP server

AP functions as the DHCP server for the STA.

IP address pool for the STA

10.23.101.2-10.23.101.254/24

Security profile

  • Name: wlan-security

  • Security policy: WPA2-PSK-AES

  • Password: a1234567

SSID profile

  • Name: wlan-ssid

  • SSID name: wlan-net

  • Configuring EDCA parameters on the STA

VAP profile

  • Name: wlan-vap

  • Service VLAN: VLAN101

  • Referenced profiles: SSID profile wlan-ssid, security profile wlan-security and traffic profile traffic

2G radio profile

  • Name: default

  • Configuring EDCA parameters on the AP

Traffic profile

  • Name: traffic

  • Configuring priority mapping

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure the AP to communicate with the upstream device.

    NOTE:

    Configure AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AP uplink interface GE0/0/1 to VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the AP as a DHCP server to allocate IP addresses to STAs.

    # Configure the AP as the DHCP server to allocate an IP address to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  3. Configure AP system parameters.

    # Configure the country code.

    [AP] wlan
    [AP-wlan-view] country-code cn
    

  4. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

  5. Configure a VAP and set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of the radio, and configure the channel and power for the radio.
    [AP-wlan-view] quit
    [AP] interface wlan-radio0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-vap wlan 2
    [AP-Wlan-Radio0/0/0] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/0] eirp 127
    [AP-Wlan-Radio0/0/0] quit
    

  6. Configure the WMM function.

    # Entering the 2G radio profile default, and configure the WMM function to enable video services to preferentially use network bandwidth.
    NOTE:
    The following example configures a 2G radio profile. The configuration of the 5G radio profile is similar.
    [AP] wlan
    [AP-wlan-view] radio-2g-profile name default
    [AP-wlan-radio-2g-prof-default] wmm edca-ap ac-vo ecw ecwmin 3 ecwmax 4 txoplimit 94
    [AP-wlan-radio-2g-prof-default] wmm edca-ap ac-vi ecw ecwmin 2 ecwmax 3 txoplimit 47
    [AP-wlan-radio-2g-prof-default] quit
    

    # In the SSID profile wlan-ssid, configure the WMM function to enable video services to preferentially use network bandwidth.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] wmm edca-client ac-vo ecw ecwmin 3 ecwmax 4 txoplimit 94
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-ssid-prof-wlan-ssid] wmm edca-client ac-vi ecw ecwmin 2 ecwmax 3 txoplimit 47
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-ssid-prof-wlan-ssid] quit

  7. Configure priority mapping.

    # Create the traffic profile traffic and configure priority mapping in the profile.
    NOTE:
    By default, the user priority of voice packets is set to 6 or 7 on the terminal, and that of the video packets is set to 4 or 5.
    [AP-wlan-view] traffic-profile name traffic
    [AP-wlan-traffic-prof-traffic] priority-map downstream trust dscp
    [AP-wlan-traffic-prof-traffic] priority-map downstream dscp 48 to 55 dot11e 4
    [AP-wlan-traffic-prof-traffic] priority-map downstream dscp 56 to 63 dot11e 5
    [AP-wlan-traffic-prof-traffic] priority-map downstream dscp 32 to 39 dot11e 6
    [AP-wlan-traffic-prof-traffic] priority-map downstream dscp 40 to 47 dot11e 7
    [AP-wlan-traffic-prof-traffic] quit
    # Bind the traffic profile to the VAP profile wlan-vap.
    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] traffic-profile traffic
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-vap-prof-wlan-vap] quit
    

  8. Verify the configuration.

    Run the display radio-2g-profile name default command on the AP to check the configuration of the 2G radio profile.

    [AP-wlan-view] display radio-2g-profile name default
    ------------------------------------------------------------                    
    Radio type                             : 802.11n                                
    Power auto adjust                      : disable                                
    Beacon interval(TUs)                    : 100 
    Beamforming switch                     : disable                                
    Support short preamble                 : support                                
    Fragmentation threshold(Byte)          : 2346                                   
    Channel switch announcement            : enable                                 
    Channel switch mode                    : continue                               
    Guard interval mode                    : normal                                 
    HT A-MPDU switch                       : disable                                
    HT A-MPDU length limit                 : 3                                      
    RTS-CTS-mode                           : rts-cts                                
    RTS-CTS-threshold                      : 2347                                   
    802.11bg basic rate                    : 1 2                                    
    802.11bg support rate                  : 1 2 5 6 9 11 12 18 24 36 48 54         
    Multicast rate 2.4G                    : auto adapt
    Interference detect switch             : disable                                
    Co-channel frequency interference threshold(%)        : 50                      
    Adjacent-channel frequency interference threshold(%)  : 50                      
    Station interference threshold         : 32                                     
    WMM switch                             : enable                                 
    Mandatory switch                       : disable                                
    Auto-off start time                    : -                               
    Auto-off end time                      : -                               
    Auto-off time-range                    : - 
    Wifi-light mode                        : signal-strength                        
    Utmost power switch                    : enable                                 
    Rrm-profile                            : default                                
    Air-scan-profile                       : default                                
    Smart-antenna                          : disable  
    ------------------------------------------------------------                    
    AP EDCA parameters:                                                             
    ---------------------------------------------------                             
           ECWmax  ECWmin  AIFSN  TXOPLimit  Ack-Policy                             
    AC_VO  4       3       1      94         normal                                 
    AC_VI  3       2       1      47         normal                                 
    AC_BE  6       4       3      0          normal                                 
    AC_BK  10      4       7      0          normal                                 
    ---------------------------------------------------                 

    Run the display ssid-profile name wlan-ssid command on the AP to check the configuration of the SSID profile.

    [AP-wlan-view] display ssid-profile name wlan-ssid
    -------------------------------------------------------------------             
    Profile ID                  : 1  
    SSID                        : wlan-net                                           
    SSID hide                   : disable                                           
    Association timeout(min)    : 5                                                 
    Max STA number              : 64                                                
    Reach max STA SSID hide     : enable                                            
    Legacy station              : enable                                            
    DTIM interval               : 1                                                 
    Beacon 2.4G rate(Mbps)      : 1                                                 
    Beacon 5G rate(Mbps)        : 6                                                  
    Deny-broadcast-probe        : disable                                           
    Probe-response-retry num    : 1                                                 
    U-APSD                      : disable                                           
    Active dull client          : disable                                           
    -------------------------------------------------------------------             
    WMM EDCA client parameters:                                                     
    -------------------------------------------------------------------             
           ECWmax  ECWmin  AIFSN  TXOPLimit                                         
    AC_VO  4       3       2      94                                                
    AC_VI  3       2       2      47                                                
    AC_BE  10      4       3      0                                                 
    AC_BK  10      4       7      0                                                 
    ------------------------------------------------------------------- 

    Run the display traffic-profile name traffic command on the AP to check the configuration of the traffic profile.

    [AP-wlan-view] display traffic-profile name traffic
    ----------------------------------------------------
    Profile ID                    : 1
    Priority map downstream trust : DSCP
    User isolate mode             : disable
    Rate limit client up(Kbps)    : 4294967295
    Rate limit client down(Kbps)  : 4294967295
    Rate limit VAP up(Kbps)       : 4294967295
    Rate limit VAP down(Kbps)     : 4294967295
    Traffic optimize ARP proxy    : disable
    Traffic optimize ARP unicast send : enable
    Traffic optimize DHCP unicast send : disable
    Traffic optimize multicast send deny : disable
    Traffic optimize bcmc unicast send mismatch action : traverse
    IGMP snooping                 : disable
    IGMP snooping max bandwith(kbps): -
    IGMP snooping max user: -
    Traffic optimize sta bridge forward : enable
    Traffic optimize broadcast suppression(pps): - 
    Traffic optimize multicast suppression(pps): - 
    Traffic optimize unicast suppression(pps): - 
    Traffic optimize multicast to unicast: disable
      Dynamic adaptive                   : disable
    Traffic remark inbound IPv4 ACL : -
      Traffic remark inbound IPv4 type  : -
      Traffic remark inbound IPv4 value : -
    Traffic remark outbound IPv4 ACL: -
      Traffic remark outbound IPv4 type : -
      Traffic remark outbound IPv4 value: -
    Traffic remark inbound L2 ACL   : -
      Traffic remark inbound L2 type    : -
      Traffic remark inbound L2 value   : -
    Traffic remark outbound L2 ACL  : -
      Traffic remark outbound L2 type   : -
      Traffic remark outbound L2 value  : -
    WMM priority downstream map mode: DSCP map 802.11e
                                      0-7 map 0
                                      8-15 map 1
                                      16-23 map 2
                                      24-31 map 3
                                      48-55 map 4
                                      56-63 map 5
                                      32-39 map 6
                                      40-47 map 7
    WMM priority downstream map mode: 802.1p map 802.11e
                                      0 map 0
                                      1 map 1
                                      2 map 2
                                      3 map 3
                                      4 map 4
                                      5 map 5
                                      6 map 6
                                      7 map 7
    ---------------------------------------------------------------------------------------------
    Traffic Type                        Direction  AppliedRecord 
    ---------------------------------------------------------------------------------------------
    ---------------------------------------------------------------------------------------------
    ----------------------------------------------------   
    

Configuration Files
  • AP configuration file

    #
     sysname AP
    #
    vlan batch 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     traffic-profile name traffic
      priority-map downstream dscp 48 to 55 dot11e 4
      priority-map downstream dscp 56 to 63 dot11e 5
      priority-map downstream dscp 32 to 39 dot11e 6
      priority-map downstream dscp 40 to 47 dot11e 7
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#(yk#Q+M[\CMK]1)AWMX7MjZ)=e`fy@fA+.J\ht3Y%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
      wmm edca-client ac-vi aifsn 2 ecw ecwmin 2 ecwmax 3 txoplimit 47
      wmm edca-client ac-vo aifsn 2 ecw ecwmin 3 ecwmax 4 txoplimit 94
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
      traffic-profile traffic
     radio-2g-profile name default
      wmm edca-ap ac-vi aifsn 1 ecw ecwmin 2 ecwmax 3 txoplimit 47 ack-policy normal
      wmm edca-ap ac-vo aifsn 1 ecw ecwmin 3 ecwmax 4 txoplimit 94 ack-policy normal
    #
    interface Wlan-Radio0/0/0
     vap-profile wlan-vap wlan 2
     channel 20mhz 6
     calibrate auto-channel-select disable
     calibrate auto-txpower-select disable
    #
    return

Example for Configuring Traffic Policing

Networking Requirements

As shown in Figure 27-18, a Fat AP accesses the Internet through wired connections and connects to STAs wirelessly. An enterprise branch needs to deploy basic WLAN services for mobile office so that branch users can access internal network resources anywhere at any time.

The enterprise network administrator needs to set the rate limit of upstream traffic on each STA associated with the AP to 2 Mbit/s and the limit of total rates of upstream traffic on all STAs associated with the VAP to 30 Mbit/s.

Figure 27-18  Networking diagram for configuring traffic policing
Configuration Roadmap
The configuration roadmap is as follows:
  1. Configure basic WLAN services so that users can connect to the wireless network.
  2. Set the rate for upstream packets in the traffic profile used by the AP to implement traffic policing on upstream packets on a specified STA and on all STAs associated with the VAP.
Table 27-15  Data planning

Item

Data

DHCP server

Switch functions as the DHCP server for the AP and STA.

IP address pool for the STA

10.23.101.2-10.23.101.254/24

Security profile

  • Name: wlan-security

  • Security policy: WPA2-PSK-AES

  • Password: a1234567

SSID profile

  • Name: wlan-ssid

  • SSID name: wlan-net

VAP profile

  • Name: wlan-vap

  • Service VLAN: VLAN101

  • Referenced profiles: SSID profile wlan-ssid, security profile wlan-security and traffic profile traffic

Traffic profile

  • Name: traffic

  • Configuring priority mapping

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure the AP to communicate with the upstream device.

    NOTE:

    Configure AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AP uplink interface GE0/0/1 to VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the AP as a DHCP server to allocate IP addresses to STAs.

    # Configure the AP as the DHCP server to allocate an IP address to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  3. Configure AP system parameters.

    # Configure the country code.

    [AP] wlan
    [AP-wlan-view] country-code cn
    

  4. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

  5. Configure a VAP and set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of the radio, and configure the channel and power for the radio.
    [AP-wlan-view] quit
    [AP] interface wlan-radio0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-vap wlan 2
    [AP-Wlan-Radio0/0/0] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/0] eirp 127
    [AP-Wlan-Radio0/0/0] quit
    

  6. Configure traffic policing.

    # Create the traffic profile traffic and set traffic policing parameters in the profile.
    [AP] wlan
    [AP-wlan-view] traffic-profile name traffic
    [AP-wlan-traffic-prof-traffic] rate-limit client up 2048
    [AP-wlan-traffic-prof-traffic] rate-limit vap up 30720
    [AP-wlan-traffic-prof-traffic] quit
    # Bind the traffic profile traffic to the VAP profile wlan-vap.
    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] traffic-profile traffic
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-vap-prof-wlan-vap] quit
    

  7. Verify the configuration.

    Run the display traffic-profile name traffic command on the AP to view the traffic profile configuration. You can see that the rate limit of upstream traffic on a specified STA is 2048 kbit/s (2 Mbit/s) and the total rate limits of upstream traffic on all STAs associated with the VAP is 30720 kbit/s (30 Mbit/s).

    [AP-wlan-view] display traffic-profile name traffic
    ----------------------------------------------------
    Profile ID                    : 1
    Priority map downstream trust : DSCP
    User isolate mode             : disable
    Rate limit client up(Kbps)    : 2048
    Rate limit client down(Kbps)  : 4294967295
    Rate limit VAP up(Kbps)       : 30720
    Rate limit VAP down(Kbps)     : 4294967295
    Traffic optimize ARP proxy    : disable
    Traffic optimize ARP unicast send : enable
    Traffic optimize DHCP unicast send : disable
    Traffic optimize multicast send deny : disable
    Traffic optimize bcmc unicast send mismatch action : traverse
    IGMP snooping                 : disable
    IGMP snooping max bandwith(kbps): -
    IGMP snooping max user: -
    Traffic optimize sta bridge forward : enable
    Traffic optimize broadcast suppression(pps): - 
    Traffic optimize multicast suppression(pps): - 
    Traffic optimize unicast suppression(pps): - 
    Traffic optimize multicast to unicast: disable
      Dynamic adaptive                   : disable
    Traffic remark inbound IPv4 ACL : -
      Traffic remark inbound IPv4 type  : -
      Traffic remark inbound IPv4 value : -
    Traffic remark outbound IPv4 ACL: -
      Traffic remark outbound IPv4 type : -
      Traffic remark outbound IPv4 value: -
    Traffic remark inbound L2 ACL   : -
      Traffic remark inbound L2 type    : -
      Traffic remark inbound L2 value   : -
    Traffic remark outbound L2 ACL  : -
      Traffic remark outbound L2 type   : -
      Traffic remark outbound L2 value  : -
    WMM priority downstream map mode: DSCP map 802.11e 
                                      0-7 map 0  
                                      8-15 map 1  
                                      16-23 map 2 
                                      24-31 map 3 
                                      32-39 map 4 
                                      40-47 map 5 
                                      48-55 map 6 
                                      56-63 map 7 
    WMM priority downstream map mode: 802.1p map 802.11e
                                      0 map 0
                                      1 map 1
                                      2 map 2
                                      3 map 3
                                      4 map 4
                                      5 map 5
                                      6 map 6
                                      7 map 7
    ---------------------------------------------------------------------------------------------
    Traffic Type                        Direction  AppliedRecord 
    ---------------------------------------------------------------------------------------------
    ---------------------------------------------------------------------------------------------
    ----------------------------------------------------   
    

Configuration Files
  • AP configuration file

    #
     sysname AP
    #
    vlan batch 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     traffic-profile name traffic
      rate-limit client up 2048
      rate-limit vap up 30720
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#(yk#Q+M[\CMK]1)AWMX7MjZ)=e`fy@fA+.J\ht3Y%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
      traffic-profile traffic
    #
    interface Wlan-Radio0/0/0
     vap-profile wlan-vap wlan 2
     channel 20mhz 6
     calibrate auto-channel-select disable
     calibrate auto-txpower-select disable
    #
    return

Example for Configuring Airtime Fair Scheduling

Networking Requirements

As shown in Figure 27-19, a Fat AP accesses the Internet through wired connections and connects to STAs wirelessly. An enterprise branch needs to deploy basic WLAN services for mobile office so that branch users can access internal network resources anywhere at any time.

The enterprise network administrator expects that users can be assigned equal bandwidth occupation time so that the overall user experience can be improved.

Figure 27-19  Networking diagram for configuring airtime fair scheduling
Configuration Roadmap
The configuration roadmap is as follows:
  1. Configure basic WLAN services so that users can connect to the wireless network.
  2. Enable airtime fair scheduling to ensure that users in the same VAP have equal bandwidth occupation time to improve user experience.
Table 27-16  Data planning

Item

Data

DHCP server

AP functions as the DHCP server for the STA.

IP address pool for the STA

10.23.101.2-10.23.101.254/24

Security profile

  • Name: wlan-security

  • Security policy: WPA2-PSK-AES

  • Password: a1234567

SSID profile

  • Name: wlan-ssid

  • SSID name: wlan-net

VAP profile

  • Name: wlan-vap

  • Service VLAN: VLAN101

  • Referenced profiles: SSID profile wlan-ssid, security profile wlan-security

RRM profile

  • Name: default

  • Airtime fair scheduling is enabled.

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure the AP to communicate with the upstream device.

    NOTE:

    Configure AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AP uplink interface GE0/0/1 to VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the AP as a DHCP server to allocate IP addresses to STAs.

    # Configure the AP as the DHCP server to allocate an IP address to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  3. Configure AP system parameters.

    # Configure the country code.

    [AP] wlan
    [AP-wlan-view] country-code cn
    

  4. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

  5. Configure a VAP and set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of the radio, and configure the channel and power for the radio.
    [AP-wlan-view] quit
    [AP] interface wlan-radio0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-vap wlan 2
    [AP-Wlan-Radio0/0/0] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/0] eirp 127
    [AP-Wlan-Radio0/0/0] quit
    

  6. Configure airtime fair scheduling.

    # Enter the RRM profile named default and enable airtime fair scheduling on AP radios.
    [AP] wlan
    [AP-wlan-view] rrm-profile name default
    [AP-wlan-rrm-prof-default] airtime-fair-schedule enable
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-rrm-prof-default] quit

  7. Verify the configuration.

    Run the display rrm-profile name default command on the AP to view the radio profile configuration, and you can find that airtime scheduling is enabled. Users can enjoy fair occupation of the network bandwidth.

    [AP-wlan-view] display rrm-profile name default
    ------------------------------------------------------------
    Auto channel select                                    : enable
    Auto transmit power select                             : enable
    PER threshold for trigger channel/power select(%)      : 60
    Airtime fairness schedule                              : enable
    UAC check client's SNR                                 : disable
    UAC client's SNR threshold(dB)                         : 20
    Band steer deny threshold                              : 2
    Band balance start threshold                           : 10
    Band balance gap threshold(%)                          : 20
    Client's band expire based on continuous probe counts  : 35
    Smart-roam                                             : disable
    Smart-roam check SNR                                   : enable
    Smart-roam standing SNR threshold(dB)                  : 20
    Smart-roam SNR quick-kickoff-threshold(dB)             : 15
    Smart-roam check rate                                  : disable
    AMC policy                                             : auto-balance
    Smart-roam rate threshold(%)                           : 20
    Smart-roam rate quick-kickoff-threshold(%)             : 20
    Smart-roam high level SNR margin(dB)                   : 15
    Smart-roam low level SNR margin(dB)                    : 6
    Smart-roam SNR check interval(s)                       : 3
    Smart-roam unable roam client expire time(m)           : 120
    ------------------------------------------------------------

Configuration Files
  • AP configuration file

    #
     sysname AP
    #
    vlan batch 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#(yk#Q+M[\CMK]1)AWMX7MjZ)=e`fy@fA+.J\ht3Y%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     rrm-profile name default
      airtime-fair-schedule enable
    #
    interface Wlan-Radio0/0/0
     vap-profile wlan-vap wlan 2
     channel 20mhz 6
     calibrate auto-channel-select disable
     calibrate auto-txpower-select disable
    #
    return

Example for Configuring ACL-based Packet Filtering

Networking Requirements

As shown in Figure 27-20, a Fat AP accesses the Internet through wired connections and connects to STAs wirelessly. An enterprise branch needs to deploy basic WLAN services for mobile office so that branch users can access internal network resources anywhere at any time.

The enterprise network administrator expects that an ACL can be configured to prohibit packets with the source IP address 10.23.101.10 and destination IP address 10.23.101.11.

Figure 27-20  Networking diagram for configuring ACL-based packet filtering
Configuration Roadmap
The configuration roadmap is as follows:
  1. Configure basic WLAN services so that users can connect to the wireless network.
  2. Configure an ACL to filter packets.
Table 27-17  Data planning

Item

Data

DHCP server

AP functions as the DHCP server for the AP and STA.

IP address pool for the STA

10.23.101.2-10.23.101.254/24

Security profile

  • Name: wlan-security

  • Security policy: WPA2-PSK-AES

  • Password: a1234567

SSID profile

  • Name: wlan-ssid

  • SSID name: wlan-net

VAP profile

  • Name: wlan-vap

  • Service VLAN: VLAN101

  • Referenced profiles: SSID profile wlan-ssid, security profile wlan-security and traffic profile traffic

Traffic profile

  • Name: traffic

  • Configuring priority mapping

Configuration Notes

No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression on switch interfaces connected to APs to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected. For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.

Procedure

  1. Configure the AP to communicate with the upstream device.

    NOTE:

    Configure AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add AP uplink interface GE0/0/1 to VLAN 101.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/1] quit
    

  2. Configure the AP as a DHCP server to allocate IP addresses to STAs.

    # Configure the AP as the DHCP server to allocate an IP address to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  3. Configure AP system parameters.

    # Configure the country code.

    [AP] wlan
    [AP-wlan-view] country-code cn
    

  4. Configure WLAN service parameters.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profile wlan-vap, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap] quit
    

  5. Configure a VAP and set channels and power for the AP radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the AP radios in this example is for reference only. In actual scenarios, configure channels and power for AP radios based on country codes of APs and network planning results.

    # Disable automatic channel and power calibration functions of the radio, and configure the channel and power for the radio.
    [AP-wlan-view] quit
    [AP] interface wlan-radio0/0/0
    [AP-Wlan-Radio0/0/0] vap-profile wlan-vap wlan 2
    [AP-Wlan-Radio0/0/0] calibrate auto-channel-select disable
    [AP-Wlan-Radio0/0/0] calibrate auto-txpower-select disable
    [AP-Wlan-Radio0/0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-Wlan-Radio0/0/0] eirp 127
    [AP-Wlan-Radio0/0/0] quit
    

  6. Configure ACL-based packet filtering.

    # Configure an advanced ACL that meet requirements.
    [AP] acl 3001
    [AP-acl-adv-3001] rule deny ip source 10.23.101.10 0 destination 10.23.101.11 0
    [AP-acl-adv-3001] quit
    
    # Bind the advanced ACL to the traffic profile traffic.
    [AP] wlan
    [AP-wlan-view] traffic-profile name traffic
    [AP-wlan-traffic-prof-traffic] traffic-filter inbound ipv4 acl 3001
    [AP-wlan-traffic-prof-traffic] quit
    
    # Bind the traffic profile traffic to the VAP profile wlan-vap.
    [AP-wlan-view] vap-profile name wlan-vap
    [AP-wlan-vap-prof-wlan-vap] traffic-profile traffic
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-vap-prof-wlan-vap] quit
    

  7. Verify the configuration.

    Run the display traffic-profile name traffic command on the AP to check applications of ACL-based packet filtering. The command output shows that the ACL has been applied to the traffic profile.

    [AP-wlan-view] display traffic-profile name traffic
    ----------------------------------------------------
    Profile ID                    : 1
    Priority map downstream trust : DSCP
    User isolate mode             : disable
    Rate limit client up(Kbps)    : 2048
    Rate limit client down(Kbps)  : 4294967295
    Rate limit VAP up(Kbps)       : 30720
    Rate limit VAP down(Kbps)     : 4294967295
    Traffic optimize ARP proxy    : disable
    Traffic optimize ARP unicast send : enable
    Traffic optimize DHCP unicast send : disable
    Traffic optimize multicast send deny : disable
    Traffic optimize bcmc unicast send mismatch action : traverse
    IGMP snooping                 : disable
    IGMP snooping max bandwith(kbps): -
    IGMP snooping max user: -
    Traffic optimize sta bridge forward : enable
    Traffic optimize broadcast suppression(pps): - 
    Traffic optimize multicast suppression(pps): - 
    Traffic optimize unicast suppression(pps): - 
    Traffic optimize multicast to unicast: disable
      Dynamic adaptive                   : disable
    Traffic remark inbound IPv4 ACL : -
      Traffic remark inbound IPv4 type  : -
      Traffic remark inbound IPv4 value : -
    Traffic remark outbound IPv4 ACL: -
      Traffic remark outbound IPv4 type : -
      Traffic remark outbound IPv4 value: -
    Traffic remark inbound L2 ACL   : -
      Traffic remark inbound L2 type    : -
      Traffic remark inbound L2 value   : -
    Traffic remark outbound L2 ACL  : -
      Traffic remark outbound L2 type   : -
      Traffic remark outbound L2 value  : -
    WMM priority downstream map mode: DSCP map 802.11e 
                                      0-7 map 0  
                                      8-15 map 1  
                                      16-23 map 2 
                                      24-31 map 3 
                                      32-39 map 4 
                                      40-47 map 5 
                                      48-55 map 6 
                                      56-63 map 7 
    WMM priority downstream map mode: 802.1p map 802.11e
                                      0 map 0
                                      1 map 1
                                      2 map 2
                                      3 map 3
                                      4 map 4
                                      5 map 5
                                      6 map 6
                                      7 map 7
    ---------------------------------------------------------------------------------------------
    Traffic Type                        Direction  AppliedRecord 
    ---------------------------------------------------------------------------------------------
    traffic-filter                      inbound    IPv4 ACL 3001
    ---------------------------------------------------------------------------------------------
    ----------------------------------------------------   

Configuration Files
  • AP configuration file

    #
     sysname AP
    #
    vlan batch 101
    #
    dhcp enable
    #
    acl number 3001
     rule 5 deny ip source 10.23.101.10 0 destination 10.23.101.11 0
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    wlan
     traffic-profile name traffic
      traffic-filter inbound acl 3001
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#(yk#Q+M[\CMK]1)AWMX7MjZ)=e`fy@fA+.J\ht3Y%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
      traffic-profile traffic
    #
    interface Wlan-Radio0/0/0
     vap-profile wlan-vap wlan 2
     channel 20mhz 6
     calibrate auto-channel-select disable
     calibrate auto-txpower-select disable
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 118988

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next