No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Intra-central AP Roaming

Example for Configuring Intra-central AP Roaming

Configuration Process

You need to configure and maintain WLAN features and functions in different profiles. These WLAN profiles include regulatory domain profile, radio profile, VAP profile, AP system profile, AP wired port profile,and WIDS profile. When configuring WLAN services, you need to set related parameters in the WLAN profiles and bind the profiles to the AP group or APs. After that, the configuration is automatically delivered to and takes effect on the RUs. WLAN profiles can reference one another; therefore, you need to know the relationships among the profiles before configuring them. For details about the profile relationships and their basic configuration procedure, see WLAN Service Configuration Procedure.

Networking Requirements

A small enterprise needs to provide WLAN services for employees. Since the WLAN needs to cover only a small area, one central AP is deployed to manage RUs. To differentiate department management, employees are assigned different subnets by department. The enterprise expects that users can move within the enterprise with nonstop service transmission.

As shown in Figure 19-8, a central AP provides services for enterprise employees. It connects to area_1 and area_2 through Switch_1 and Switch_2 respectively.

Figure 19-8  Configuring intra-central AP roaming

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure parameters used for communication between the central AP and RUs to transmit CAPWAP packets.
  2. Configure the central AP to function as a DHCP server to assign IP addresses to the STAs and RUs.
  3. Configure basic WLAN services so that users can connect to the wireless network.

Data planning

Item

Data

DHCP server

The central AP functions as a DHCP server to assign IP addresses to the STAs and RUs.

IP address pool for the RUs

10.23.100.2-10.23.100.254/24

IP address pool for the STAs

10.23.101.2-10.23.101.254/24

Central AP's source interface address

VLANIF 100: 10.23.100.1/24

AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-vap1 and regulatory domain profile domain
Regulatory domain profile
  • Name: domain
  • Country code: CN
SSID profile
  • Name: wlan-ssid
  • SSID name: wlan-net
Security profile
  • Name: wlan-security
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-vap1
  • Service VLAN: VLAN 101
  • Referenced profile: SSID profile wlan-ssid and security profile wlan-security

Configuration Notes

Configure port isolation on the interfaces of the device directly connected to RUs. If port isolation is not configured, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

Procedure

  1. Configure the switches and the central AP so that the central AP can communicate with the RUs.

    #On Switch_1, create VLAN 100 (management VLAN). Add GE0/0/1 connected to RU_1 and GE0/0/2 connected to central AP to VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 100
    [Switch_1] interface gigabitethernet 0/0/1
    [Switch_1-GigabitEthernet0/0/1] port link-type trunk
    [Switch_1-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch_1-GigabitEthernet0/0/1] quit
    [Switch_1] interface gigabitethernet 0/0/2
    [Switch_1-GigabitEthernet0/0/2] port link-type trunk
    [Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch_1-GigabitEthernet0/0/2] quit
    # On Switch_2, create VLAN 100 (management VLAN). Add GE0/0/1 connected to RU_2 and GE0/0/2 connected to central AP to VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 100
    [Switch_2] interface gigabitethernet 0/0/1
    [Switch_2-GigabitEthernet0/0/1] port link-type trunk
    [Switch_2-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch_2-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch_2-GigabitEthernet0/0/1] quit
    [Switch_2] interface gigabitethernet 0/0/2
    [Switch_2-GigabitEthernet0/0/2] port link-type trunk
    [Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch_2-GigabitEthernet0/0/2] quit
    # On the central AP, add GE0/0/1 connected to Switch_1 and GE0/0/2 connected to Switch_2 to VLAN 100.
    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 100 to 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AP-GigabitEthernet0/0/1] quit
    [AP] interface gigabitethernet 0/0/2
    [AP-GigabitEthernet0/0/2] port link-type trunk
    [AP-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [AP-GigabitEthernet0/0/2] quit
    

  2. Configure the central AP as a DHCP server to allocate IP addresses to STAs and RUs.

    # Configure the central AP as the DHCP server to allocate IP addresses to RUs from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 100
    [AP-Vlanif100] ip address 10.23.100.1 255.255.255.0
    [AP-Vlanif100] dhcp select interface
    [AP-Vlanif100] quit
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 255.255.255.0
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  3. Configure the RUs to go online.

    # Create AP groups ap-group1.

    [AP] wlan
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the central AP country code in the profile, and apply the profile to the AP groups.

    [AP-wlan-view] regulatory-domain-profile name domain
    [AP-wlan-regulatory-domain-domain] country-code cn
    [AP-wlan-regulatory-domain-domain] quit
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] regulatory-domain-profile domain
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AP-wlan-ap-group-ap-group1] quit
    [AP-wlan-view] quit
    

    # Configure the management VLAN for RUs connected to the central AP.

    [AP] management-vlan 100
    # Import RUs offline on the central AP and add RUs to AP group ap-group1. Assume that the RU's MAC address is 60de-4476-e360. Configure a name for the RU based on the RU's deployment location, so that you can know where the RU is deployed from its name. For example, name the RU area_1 if it is deployed in Area 1.
    NOTE:

    The default RU authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the R240D is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AP] wlan
    [AP-wlan-view] ap auth-mode mac-auth
    [AP-wlan-view] ap-id 1 ap-mac 60de-4476-e360
    [AP-wlan-ap-1] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AP-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-1] quit
    [AP-wlan-view] ap-id 2 ap-mac dcd2-fc04-b500
    [AP-wlan-ap-2] ap-name area_2
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AP-wlan-ap-2] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-2] quit

    # After the RUs are powered on, run the display ap all command to check the RU state. If the State field displays nor, the RUs have gone online.

    [AP-wlan-view] display ap all
    Total AP information:
    nor  : normal          [2]
    --------------------------------------------------------------------------------------
    ID   MAC            Name      Group     IP            Type            State STA Uptime
    --------------------------------------------------------------------------------------
    1    60de-4476-e360 area_1    ap-group1 10.23.100.254 R240D           nor   0   15S
    2    dcd2-fc04-b500 area_2    ap-group1 10.23.100.253 R240D           nor   0   10S
    --------------------------------------------------------------------------------------
    Total: 2

  4. Configure basic WLAN services on the central AP.

    # Create security profile wlan-security and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-security
    [AP-wlan-sec-prof-wlan-security] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-security] quit
    

    # Create SSID profile wlan-ssid and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-ssid
    [AP-wlan-ssid-prof-wlan-ssid] ssid wlan-net
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-ssid-prof-wlan-ssid] quit
    

    # Create VAP profiles wlan-vap1, set the service VLANs, and apply the security profile wlan-security and SSID profile wlan-ssid to the VAP profiles.

    [AP-wlan-view] vap-profile name wlan-vap1
    [AP-wlan-vap-prof-wlan-vap1] service-vlan vlan-id 101
    [AP-wlan-vap-prof-wlan-vap1] security-profile wlan-security
    [AP-wlan-vap-prof-wlan-vap1] ssid-profile wlan-ssid
    [AP-wlan-vap-prof-wlan-vap1] quit
    

    # Bind VAP profile wlan-vap1 to the AP group and apply the profile to radio 0 and radio 1 of the RU.

    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap1 wlan 1 radio 0
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-vap1 wlan 1 radio 1
    [AP-wlan-ap-group-ap-group1] quit
    

  5. Set channels and power for the RU radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The channel and power configuration for the RU radios in this example is for reference only. In actual scenarios, configure channels and power for RU radios based on country codes of RUs and network planning results.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AP-wlan-view] ap-id 1
    [AP-wlan-ap-1] radio 0
    [AP-wlan-radio-1/0] calibrate auto-channel-select disable
    [AP-wlan-radio-1/0] calibrate auto-txpower-select disable
    [AP-wlan-radio-1/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-radio-1/0] eirp 127
    [AP-wlan-radio-1/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AP-wlan-ap-1] radio 1
    [AP-wlan-radio-1/1] calibrate auto-channel-select disable
    [AP-wlan-radio-1/1] calibrate auto-txpower-select disable
    [AP-wlan-radio-1/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AP-wlan-radio-1/1] eirp 127
    [AP-wlan-radio-1/1] quit
    [AP-wlan-ap-1] quit

  6. Verify the configuration.

    The central AP automatically delivers WLAN service configuration to the RUs. After the service configuration is complete, run the display vap ssid wlan-net command to check VAP information. If Status in the command output is displayed as ON, the VAPs have been successfully created on RU radios.
    [AP-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------------
    AP ID AP name        RfID WID  BSSID          Status  Auth type         STA    SSID
    --------------------------------------------------------------------------------------
    1     area_1         0    1    60DE-4476-E360 ON      WPA2-PSK          0      wlan-net
    1     area_1         1    1    60DE-4476-E370 ON      WPA2-PSK          0      wlan-net
    2     area_2         0    1    DCD2-FC04-B500 ON      WPA2-PSK          0      wlan-net
    2     area_2         1    1    DCD2-FC04-B510 ON      WPA2-PSK          0      wlan-net
    ---------------------------------------------------------------------------------------
    Total: 2
    In the coverage area of RU_1, connect the STA to the wireless network with SSID wlan-net and enter the password a1234567. After the STA successfully associates with the network, run the display station ssid wlan-net command on the central AP. The command output shows that the STA with MAC address e019-1dc7-1e08 has associated with RU_1.
    [AP-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ------------------------------------------------------------------------------------
    e019-1dc7-1e08   1     area_1    1/1      5G    11n   46/59      -57   101   10.23.101.254
    ------------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1
    When the STA moves from the coverage area of RU_1 to that of RU_2, run the display station ssid wlan-net command on central AP. The command output shows that the STA has associated with RU_2.
    [AP-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ------------------------------------------------------------------------------------
    e019-1dc7-1e08   2     area_2    1/1      5G    11n   46/59      -58   101   10.23.101.254
    ------------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1
    Run the display station roam-track sta-mac e019-1dc7-1e08 command on central AP to check the STA roaming track.
    [AP-wlan-view] display station roam-track sta-mac e019-1dc7-1e08
    Access SSID:wlan-net
    Rx/Tx: link receive rate/link transmit rate(Mbps)  
    c:PMK Cache Roam r:802.11r Roam
    ------------------------------------------------------------------------------
    L2/L3           AC IP                  AP name              Radio ID
    BSSID           TIME                   In/Out RSSI          Out Rx/Tx
    ------------------------------------------------------------------------------
    --              -                      area_1               1
    60de-4476-e360  2015/02/07 17:48:30    -57/-58              46/65
    L2              -                      area_2               1
    dcd2-fc04-b500  2015/02/07 17:54:50    -58/-                -/-
    ------------------------------------------------------------------------------
    Number: 1

Configuration Files

  • Switch_1 configuration file

    #
     sysname Switch_1
    #
     vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
     #
    return
  • Switch_2 configuration file

    #
     sysname Switch_2
    #
     vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
     #
    return
  • Central AP configuration file

    #
     sysname AP
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    management-vlan 100
    #
    wlan
     security-profile name wlan-security
      security wpa2 psk pass-phrase %^%#]:krYrz_r<ee}|Cq@9V(W{ZD$"\-R-HD_y.4#U4,%^%# aes
     ssid-profile name wlan-ssid
      ssid wlan-net
     vap-profile name wlan-vap1
      service-vlan vlan-id 101
      ssid-profile wlan-ssid
      security-profile wlan-security
     regulatory-domain-profile name domain
     ap-group name ap-group1
      regulatory-domain-profile domain
      radio 0
       vap-profile wlan-vap1 wlan 1
      radio 1
       vap-profile wlan-vap1 wlan 1
     ap-id 1 type-id 19 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
     ap-id 2 type-id 19 ap-mac dcd2-fc04-b500 ap-sn 210235554710CB000078
      ap-name area_2
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 118610

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next