No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Fat AP and Cloud AP V200R008C00 CLI-based Configuration Guide

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an Agile Distributed WLAN

Example for Configuring an Agile Distributed WLAN

Networking Requirements

A school plans to deploy a WLAN to cover its dormitory building. However, the dormitory building has a high density of rooms, and WLAN signals are likely to attenuate severely when passing through obstacles between rooms, such as walls.

As shown in Figure 16-18, the central AP connects to and supplies PoE power for remote radio units (RUs). All RUs (one for each room) are uniformly managed by the central AP to provide a high-quality WLAN.

Figure 16-18  Agile distributed WLAN

Context

Table 16-6  Data preparation

Item

Data

DHCP server The central AP functions as a DHCP server to assign IP addresses to STAs and RUs.
IP address pool for the RUs 10.23.100.2-10.23.100.254/24
IP address pool for the STAs 10.23.101.2-10.23.101.254/24
AP manage VLAN VLAN100
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: CN
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure Layer 2 connections between the RU, central AP, and upstream device.
  2. Configure the central AP to function as a DHCP server to assign IP addresses to the STAs and RU.
  3. Configure the AP to go online.
    1. Create an AP group and add the RU to the group. The APs that require the same configuration can be added to the group for unified configuration.
    2. Configure central AP system parameters, including the country code and management VLAN used by the central AP to communicate with the RU.
    3. Configure the RU authentication mode and import the RU offline so that the RU can go online properly.
  4. Configure WLAN service parameters for STAs to access the WLAN.

Procedure

  1. Configure the central AP so that the RU and central AP can transmit CAPWAP packets.

    # Configure the central AP: add interface GE0/0/1 and GE0/0/2 to management VLAN 100.

    <Huawei> system-view
    [Huawei] sysname AP
    [AP] vlan batch 100 101
    [AP] interface gigabitethernet 0/0/1
    [AP-GigabitEthernet0/0/1] port link-type trunk
    [AP-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AP-GigabitEthernet0/0/1] quit
    [AP] interface gigabitethernet 0/0/2
    [AP-GigabitEthernet0/0/2] port link-type trunk
    [AP-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [AP-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [AP-GigabitEthernet0/0/2] quit
    

  2. Configure the central AP to communicate with the upstream device.

    NOTE:

    Configure central AP uplink interfaces to transparently transmit packets of service VLANs as required and communicate with the upstream device.

    # Add central AP uplink interface GE0/0/25 to service VLAN 101.

    [AP] interface gigabitethernet 0/0/25
    [AP-GigabitEthernet0/0/25] port link-type trunk
    [AP-GigabitEthernet0/0/25] port trunk allow-pass vlan 101
    [AP-GigabitEthernet0/0/25] quit
    

  3. Configure the central AP as a DHCP server to allocate IP addresses to STAs and the RU.

    # Configure the central AP as the DHCP server to allocate an IP address to the RU from the IP address pool on VLANIF 100, and allocate IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AP] dhcp enable
    [AP] interface vlanif 100
    [AP-Vlanif100] ip address 10.23.100.1 24
    [AP-Vlanif100] dhcp select interface
    [AP-Vlanif100] quit
    [AP] interface vlanif 101
    [AP-Vlanif101] ip address 10.23.101.1 24
    [AP-Vlanif101] dhcp select interface
    [AP-Vlanif101] quit
    

  4. Configure the RU to go online.

    # Create an AP group and add the RU to the AP group.

    [AP] wlan
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the central AP country code in the profile, and apply the profile to the AP group.

    [AP-wlan-view] regulatory-domain-profile name default
    [AP-wlan-regulate-domain-default] country-code cn
    [AP-wlan-regulate-domain-default] quit
    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AP-wlan-ap-group-ap-group1] quit
    [AP-wlan-view] quit
    

    # Configure the management VLAN for RUs connected to the central AP.

    [AP] management-vlan 100
    
    # Import the RU offline on the central AP and add the RU to AP group ap-group1. Assume that the RU's MAC address is 60de-4476-e360. Configure a name for the RU based on the RU's deployment location, so that you can know where the RU is deployed from its name. For example, name the RU area_1 if it is deployed in Area 1.
    NOTE:

    The default RU authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the R240D is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AP] wlan
    [AP-wlan-view] ap auth-mode mac-auth
    [AP-wlan-view] ap-id 1 ap-mac 60de-4476-e360
    [AP-wlan-ap-1] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AP-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AP-wlan-ap-1] quit
    

    # After the RU is powered on, run the display ap all command to check the RU state. If the State field is displayed as nor, the RU goes online normally.

    [AP-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    1    60de-4476-e360 area_1 ap-group1 10.23.100.254 R240D           nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

  5. Configure WLAN service parameters.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AP-wlan-view] security-profile name wlan-net
    [AP-wlan-sec-prof-wlan-net] security wpa2 psk pass-phrase a1234567 aes
    [AP-wlan-sec-prof-wlan-net] quit
    

    # Create SSID profile wlan-net and set the SSID name to wlan-net.

    [AP-wlan-view] ssid-profile name wlan-net
    [AP-wlan-net-prof-wlan-net] ssid wlan-net
    [AP-wlan-net-prof-wlan-net] quit
    

    # Create VAP profile wlan-net, set the service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AP-wlan-view] vap-profile name wlan-net
    [AP-wlan-net-prof-wlan-net] service-vlan vlan-id 101
    [AP-wlan-net-prof-wlan-net] security-profile wlan-net
    [AP-wlan-net-prof-wlan-net] ssid-profile wlan-net
    [AP-wlan-net-prof-wlan-net] quit
    

    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the RU.

    [AP-wlan-view] ap-group name ap-group1
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AP-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AP-wlan-ap-group-ap-group1] quit
    

  6. Verify the configuration.

    The central AP automatically delivers WLAN service configuration to the RU. After the service configuration is complete, run the display vap ssid wlan-net command. If Status in the command output is displayed as ON, the VAPs have been successfully created on AP radios.

    [AP-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    ---------------------------------------------------------------------------------
    AP ID AP name RfID WID   BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    1     area_1  0    1     60DE-4476-E360 ON      WPA2-PSK      0     wlan-net
    1     area_1  1    1     60DE-4476-E370 ON      WPA2-PSK      0     wlan-net
    -------------------------------------------------------------------------------
    Total: 2

    Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station ssid wlan-net command on the central AP. The command output shows that the STAs are connected to the WLAN wlan-net.

    [AP-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ---------------------------------------------------------------------------------
    STA MAC         AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ---------------------------------------------------------------------------------
    e019-1dc7-1e08  0     area_1    1/1      5G    11n   46/59      -68   101   10.23.101.254
    ---------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1

Configuration Files

  • Central AP configuration file

    #
     sysname AP
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/25
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    management-vlan 100
    #
    wlan
     security-profile name wlan-net
      security wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 1 type-id 55 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-01-11

Document ID: EDOC1000176006

Views: 117679

Downloads: 309

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next