No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, and sFlow.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Remote VLAN Mirroring

Example for Configuring Remote VLAN Mirroring

Networking Requirements

In Figure 6-14, all the hosts of a school access the Internet through SwitchA and belong to VLAN 10. The monitoring device (Server) is connected to SwitchA through SwitchB.

Internet-bound traffic from all the hosts needs to be monitored by the Server.

Figure 6-14  Remote VLAN mirroring networking

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLAN 10 on SwitchA and add the ports connected to hosts to VLAN 10 so that the hosts can communicate with SwitchA at Layer 2.
  2. Create VLAN 20 on SwitchB, disable MAC address learning in VLAN 20, and add the ports connected to SwitchA and the Server to VLAN 20 so that SwitchB can communicate with SwitchA and the Server at Layer 2.
  3. Configure GE0/0/4 of SwitchA as a remote observing port to forward mirrored packets to VLAN 20.
  4. Configure VLAN 10 as a mirrored VLAN to copy Internet-bound traffic from all the hosts in VLAN 10 and send the traffic to the remote observing port.

Procedure

  1. Add ports to VLANs.

    # Create VLAN 10 on SwitchA and add GE0/0/1 through GE0/0/3 to VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type access
    [SwitchA-GigabitEthernet0/0/1] port default vlan 10
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type access
    [SwitchA-GigabitEthernet0/0/2] port default vlan 10
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type access
    [SwitchA-GigabitEthernet0/0/3] port default vlan 10
    [SwitchA-GigabitEthernet0/0/3] quit

    # Create VLAN 20 on SwitchB and add GE0/0/1 and GE0/0/4 to VLAN 20.

    NOTE:

    VLAN 20 is used for forwarding only mirrored packets. If VLAN 20 already exists and has learned MAC address entries, run the undo mac-address vlan vlan-id command in the system view to delete all MAC address entries in VLAN 20.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 20
    [SwitchB-vlan20] mac-address learning disable
    [SwitchB-vlan20] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type access
    [SwitchB-GigabitEthernet0/0/1] port default vlan 20
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 20
    [SwitchB-GigabitEthernet0/0/4] return

  2. Configure an observing port.

    # Configure GE0/0/4 of SwitchA as a remote observing port.

    [SwitchA] observe-port 1 interface gigabitethernet 0/0/4 vlan 20
    

    After the configuration is complete, the observing port forwards mirrored packets to VLAN 20. There is no need to add the observing port to the VLAN.

  3. Configure a mirrored VLAN.

    # On SwitchA, configure VLAN 10 as a mirrored VLAN and copy the packets received by all the ports in VLAN 10 to the remote observing port.

    [SwitchA] vlan 10
    [SwitchA-vlan10] mirroring to observe-port 1 inbound
    [SwitchA-vlan10] return

  4. Verify the configuration.

    # Check the observing port configuration.

    <SwitchA> display observe-port
      ----------------------------------------------------------------------
      Index          : 1
      Untag-packet   : No
      Interface      : GigabitEthernet0/0/4
      Vlan           : 20
      ----------------------------------------------------------------------
    

    # Check the mirroring configuration.

    <SwitchA> display port-mirroring
      ----------------------------------------------------------------------
      Observe-port 1 : GigabitEthernet0/0/4
      ----------------------------------------------------------------------
      Vlan-mirror:
      ----------------------------------------------------------------------
      Mirror-vlan              Direction     Observe-port
      ----------------------------------------------------------------------
      10                       Inbound       Observe-port 1
      ----------------------------------------------------------------------
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    observe-port 1 interface GigabitEthernet0/0/4 vlan 20
    #
    vlan 10
     mirroring to observe-port 1 inbound
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 10
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20
    #
    vlan 20
     mac-address learning disable
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
Translation
Download
Updated: 2019-10-18

Document ID: EDOC1000178020

Views: 75028

Downloads: 10

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next