No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, and sFlow.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Local MAC Address Mirroring

Example for Configuring Local MAC Address Mirroring

Networking Requirements

In Figure 6-15, all the hosts of a school access the Internet through the Switch and belong to VLAN 10. The monitoring device (Server) is directly connected to the Switch.

Internet-bound traffic from the host with a MAC address 0001-0001-0001 needs to be monitored by the Server.

Figure 6-15  Local MAC address mirroring networking

Configuration Roadmap

The configuration roadmap is as follows:
  1. Create VLAN 10 on the Switch and add the ports connected to hosts to VLAN 10 so that the hosts can communicate with the Switch at Layer 2.
  2. Configure GE0/0/4 of the Switch as a local observing port to forward mirrored packets to the Server.
  3. Configure MAC address mirroring in VLAN 10 to copy Internet-bound traffic from the host with a specified MAC address in VLAN 10 and send the traffic to the local observing port.

Procedure

  1. Add ports to a VLAN.

    # Create VLAN 10 on the Switch and add GE0/0/1 through GE0/0/3 to VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] port default vlan 10
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access
    [Switch-GigabitEthernet0/0/2] port default vlan 10
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type access
    [Switch-GigabitEthernet0/0/3] port default vlan 10
    [Switch-GigabitEthernet0/0/3] quit

  2. Configure an observing port.

    # Configure GE0/0/4 on the Switch as a local observing port.

    [Switch] observe-port 1 interface gigabitethernet 0/0/4
    

  3. Configure MAC address mirroring.

    # On the Switch, configure MAC address mirroring in VLAN 10 and copy the packets that are received by all the ports in VLAN 10 and contain a MAC address 0001-0001-0001 to the local observing port.

    [Switch] vlan 10
    [Switch-vlan10] mac-mirroring 0001-0001-0001 to observe-port 1 inbound
    [Switch-vlan10] return

  4. Verify the configuration.

    # Check the observing port configuration.

    <Switch> display observe-port
      ----------------------------------------------------------------------
      Index          : 1
      Untag-packet   : No
      Interface      : GigabitEthernet0/0/4
      ----------------------------------------------------------------------
    

    # Check the mirroring configuration.

    <Switch> display port-mirroring
      ----------------------------------------------------------------------
      Observe-port 1 : GigabitEthernet0/0/4
      ---------------------------------------------------------------------- 
      Mac-mirror:
      ----------------------------------------------------------------------
      Mirror-mac       Vlan    Direction     Observe-port
      ----------------------------------------------------------------------
      0001-0001-0001   10      Inbound       Observe-port 1
      ----------------------------------------------------------------------
    

Configuration Files

  • Switch configuration file

    #
    sysname Switch
    #
    vlan batch 10
    #
    observe-port 1 interface GigabitEthernet0/0/4
    #
    vlan 10
     mac-mirroring 0001-0001-0001 to observe-port 1 inbound
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 10
    #
    return
    
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000178020

Views: 61990

Downloads: 7

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next