No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, and sFlow.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LLDP on a Network with Link Aggregation Configured

Example for Configuring LLDP on a Network with Link Aggregation Configured

Networking Requirements

As shown in Figure 3-13, SwitchA and SwitchB are connected through an Eth-Trunk; the NMS has reachable routes to SwitchA and SwitchB; SNMP is configured on devices and NMS.

A network administrator wants to obtain Layer 2 information about SwitchA and SwitchB to know details about network topology and configuration conflicts. The LLDP function can meet the network administrator's requirement.

Figure 3-13  Network with link aggregation configured

Configuration Roadmap

The configuration roadmap is as follows:
  1. Add physical interfaces on SwitchA and SwitchB to the Eth-Trunk.
  2. Enable global LLDP on SwitchA and SwitchB.

Procedure

  1. Add physical interfaces on SwitchA and SwitchB to the Eth-Trunk.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] trunkport gigabitethernet 0/0/1
    [SwitchA-Eth-Trunk1] trunkport gigabitethernet 0/0/2
    [SwitchA-Eth-Trunk1] trunkport gigabitethernet 0/0/3
    [SwitchA-Eth-Trunk1] port link-type trunk
    [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 100
    [SwitchA-Eth-Trunk1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100
    [SwitchB] interface eth-trunk 1
    [SwitchB-Eth-Trunk1] trunkport gigabitethernet 0/0/1
    [SwitchB-Eth-Trunk1] trunkport gigabitethernet 0/0/2
    [SwitchB-Eth-Trunk1] trunkport gigabitethernet 0/0/3
    [SwitchB-Eth-Trunk1] port link-type trunk
    [SwitchB-Eth-Trunk1] port trunk allow-pass vlan 100
    [SwitchB-Eth-Trunk1] quit

  2. Enable global LLDP on SwitchA and SwitchB.

    # Configure SwitchA.
    [SwitchA] lldp enable
    # Configure SwitchB.
    [SwitchB] lldp enable

  3. Verify the configurations.

    • Check the SwitchA configuration.

      # Check whether the physical interfaces have been added to Eth-Trunk1.

      [SwitchA] display eth-trunk 1
      Eth-Trunk1's state information is:                                             
      WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP         
      Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8                
      Operate status: up          Number Of Up Port In Trunk: 3                       
      --------------------------------------------------------------------------------
      PortName                      Status      Weight                                
      GigabitEthernet0/0/1          Up          1                                     
      GigabitEthernet0/0/2          Up          1                                     
      GigabitEthernet0/0/3          Up          1  

      # Check neighbor information for SwitchA.

      [SwitchA] display lldp neighbor brief
      Local Intf   Neighbor Dev             Neighbor Intf             Exptime(s)         
      GE0/0/1      SwitchB                  GE0/0/1                   115         
      GE0/0/2      SwitchB                  GE0/0/2                   115
      GE0/0/3      SwitchB                  GE0/0/3                   115       
    • Check the SwitchB configuration.

      Refer to the steps for checking SwitchA.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    lldp enable
    #
    interface Eth-Trunk1
     port link-type trunk                                                           
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/1
     eth-trunk 1
    #
    interface GigabitEthernet0/0/2 
     eth-trunk 1
    #
    interface GigabitEthernet0/0/3
     eth-trunk 1
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    lldp enable
    #
    interface Eth-Trunk1
     port link-type trunk                                                           
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/1
     eth-trunk 1
    #
    interface GigabitEthernet0/0/2 
     eth-trunk 1
    #
    interface GigabitEthernet0/0/3
     eth-trunk 1
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000178020

Views: 63840

Downloads: 7

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next