No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, and sFlow.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an HTTP Test Instance

Example for Configuring an HTTP Test Instance

Networking Requirements

In Figure 4-18, SwitchA is connected to the HTTP server over a WAN to test the speed of SwitchA accessing the HTTP server.

Figure 4-18  Networking diagram for configuring an HTTP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client.

  2. Create and start an HTTP test instance on the SwitchA to check whether SwitchA can set up a connection with the HTTP server and to check the duration for transferring files between SwitchA and the HTTP server.

Procedure

  1. Configure IP addresses for the interfaces on the SwitchA and ensure reachable routes between SwitchA and the HTTP server.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet0/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit

  2. Enable the NQA client and create an NQA HTTP test instance.

    [SwitchA] nqa test-instance admin http
    [SwitchA-nqa-admin-http] test-type http
    [SwitchA-nqa-admin-http] destination-address ipv4 10.2.1.1
    [SwitchA-nqa-admin-http] http-operation get
    [SwitchA-nqa-admin-http] http-url http://www.***.com
    NOTE:
    The URL used to test HTTP must be a valid URL that can be displayed on the browser. In this example, the URL is http://www.***.com.

  3. Start the test instance.

    [SwitchA-nqa-admin-http] start now

  4. Check the configuration.

    [SwitchA-nqa-admin-http] display nqa results test-instance admin http
    
     NQA entry(admin, http) :testflag is inactive ,testtype is http
      1 . Test 1 result   The test is finished
       SendProbe:3                          ResponseProbe:3
       Completion:success                   RTD OverThresholdsnumber: 0
       MessageBodyOctetsSum: 411            TargetAddress: 10.2.1.1
       DNSQueryError number: 0              HTTPError number: 0
       TcpConnError number : 0              System busy operation number:0
       DNSRTT Sum/Min/Max:0/0/0             TCPConnectRTT Sum/Min/Max: 4/1/2
       TransactionRTT Sum/Min/Max: 3/1/1
       RTT Sum/Min/Max/Avg: 7/2/3/2
       DNSServerTimeout:0  TCPConnectTimeout:0  TransactionTimeout: 0
       Lost packet ratio:0%

Configuration Files

SwitchA configuration file

#
sysname SwitchA
#
vlan batch 100
#
interface Vlanif100
 ip address 10.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 100
 port hybrid untagged vlan 100
#
nqa test-instance admin http
 test-type http
 destination-address ipv4 10.2.1.1
 http-url http://www.***.com
#
return
Translation
Download
Updated: 2019-09-23

Document ID: EDOC1000178020

Views: 73989

Downloads: 8

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next