No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S600-E V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON, LLDP, NQA, Service Diagnosis, Mirroring, Packet Capture, and sFlow.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Remote Port Mirroring

Example for Configuring Remote Port Mirroring

Networking Requirements

In Figure 6-10, the administrative department of a school accesses the Internet through SwitchA, and the monitoring device (Server) is connected to SwitchA through SwitchB.

Internet-bound traffic from the administrative department needs to be remotely monitored by the Server.

Figure 6-10  Remote port mirroring networking

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure GE0/0/2 of SwitchA as a remote observing port to forward mirrored packets to the specified VLAN.
  2. Configure GE0/0/1 of SwitchA as a mirrored port to copy Internet-bound traffic from the administrative department and send the traffic to the remote observing port.
  3. Create a VLAN on SwitchB, disable MAC address learning in this VLAN, and add ports to the VLAN to forward the mirrored packets sent from the observing port to the Server.

Procedure

  1. Configure an observing port on SwitchA.

    # Configure GE0/0/2 of SwitchA as a remote observing port and bind the observing port to VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] observe-port 1 interface gigabitethernet 0/0/2 vlan 10

    After the configuration is complete, the observing port forwards mirrored packets to VLAN 10. There is no need to add the observing port to the VLAN.

  2. Configure a mirrored port on SwitchA.

    # Configure GE0/0/1 of SwitchA as a mirrored port to copy the packets received by the mirrored port and send them to the remote observing port.

    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port-mirroring to observe-port 1 inbound
    [SwitchA-GigabitEthernet0/0/1] return

  3. Create a VLAN on SwitchB and add ports to the VLAN.

    # Create VLAN 10 on SwitchB, disable MAC address learning in VLAN 10, and add GE0/0/1 and GE0/0/2 to VLAN 10.

    NOTE:

    VLAN 10 is used for forwarding only mirrored packets. If VLAN 10 already exists and has learned MAC address entries, run the undo mac-address vlan vlan-id command in the system view to delete all MAC address entries in VLAN 10.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 10
    [SwitchB-vlan10] mac-address learning disable
    [SwitchB-vlan10] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type access
    [SwitchB-GigabitEthernet0/0/1] port default vlan 10
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet0/0/2] return

  4. Verify the configuration.

    # Check the observing port configuration.

    <SwitchA> display observe-port
      ----------------------------------------------------------------------
      Index          : 1
      Untag-packet   : No
      Interface      : GigabitEthernet0/0/2
      Vlan           : 10
      ----------------------------------------------------------------------
    

    # Check the mirrored port configuration.

    <SwitchA> display port-mirroring
      ----------------------------------------------------------------------
      Observe-port 1 : GigabitEthernet0/0/2
      ----------------------------------------------------------------------
      Port-mirror:
      ----------------------------------------------------------------------
           Mirror-port               Direction  Observe-port
      ----------------------------------------------------------------------
      1    GigabitEthernet0/0/1      Inbound    Observe-port 1
      ----------------------------------------------------------------------  
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    observe-port 1 interface GigabitEthernet0/0/2 vlan 10
    #
    interface GigabitEthernet0/0/1
     port-mirroring to observe-port 1 inbound
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    vlan 10
     mac-address learning disable
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000178020

Views: 56551

Downloads: 7

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next