No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON and RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, Traffic Distribution, NetStream, sFlow, and TWAMP Light.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring NQA to Check VoIP Service Jitter

Example for Configuring NQA to Check VoIP Service Jitter

Networking Requirements

In Figure 6-39, the headquarters and its subsidiary often hold conferences through VoIP and require that the round-trip delay is shorter than 250 ms and jitter is shorter than 20 ms. The jitter test provided by NQA can be used to simulate VoIP services.

Figure 6-39  Networking diagram for configuring NQA to check VoIP service jitter

Configuration Roadmap

The configuration roadmap is as follows:

  1. Respectively configure SwitchA and SwitchD as the gateways of the headquarters and its subsidiary and ensure reachable routes between them.

  2. Configure SwitchA as an NQA server and SwitchD as an NQA client, and configure a jitter test instance on SwitchD.

  3. Start the test instance on SwitchD.

Procedure

  1. Configure IP addresses for SwitchA and SwitchD according to Figure 6-39, and ensure that they have reachable routes to each other.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255 
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    NOTE:

    For configurations of SwitchD, see the configuration file.

  2. Configure the NQA server on SwitchA.

    [SwitchA] nqa-server udpecho 10.1.1.1 9000

  3. Configure the NQA client on SwitchD.
    1. Set the version number of the jitter test packets.

      <SwitchD> system-view
      [SwitchD] nqa-jitter tag-version 2

    2. Create a jitter test instance and set the destination address to the IP address of SwitchA.

      [SwitchD] nqa test-instance admin udpjitter
      [SwitchD-nqa-admin-udpjitter] test-type jitter
      [SwitchD-nqa-admin-udpjitter] destination-address ipv4 10.1.1.1
      [SwitchD-nqa-admin-udpjitter] destination-port 9000

    3. Set the code type of the simulated VoIP service.

      [SwitchD-nqa-admin-udpjitter] jitter-codec g711a

  4. Start the test instance.

    [SwitchD-nqa-admin-udpjitter] start now

  5. Check the test results, and you can find that the round-trip delay is shorter than 250 ms and jitter is shorter than 20 ms.

    [SwitchD-nqa-admin-udpjitter] display nqa results test-instance admin udpjitter
    NQA entry(admin, udpjitter) :testflag is inactive ,testtype is jitter             
    1 . Test 1 result   The test is finished
       SendProbe:1000                       ResponseProbe:1000
       Completion:success                   RTD OverThresholds number:0
       OWD OverThresholds SD number:0       OWD OverThresholds DS number:0
       Min/Max/Avg/Sum RTT:10/38/13/12963   RTT  Square Sum:171925
       NumOfRTT:1000                        Drop operation number:0
       Operation sequence errors number:0   RTT Stats errors number:0
       System busy operation number:0       Operation timeout number:0
       Min Positive SD:1                    Min Positive DS:1
       Max Positive SD:16                   Max Positive DS:27
       Positive SD Number:288               Positive DS Number:287
       Positive SD Sum:427                  Positive DS Sum:485
       Positive SD Square Sum:1317          Positive DS Square Sum:2455
       Min Negative SD:1                    Min Negative DS:1
       Max Negative SD:16                   Max Negative DS:26
       Negative SD Number:292               Negative DS Number:285
       Negative SD Sum:429                  Negative DS Sum:486
       Negative SD Square Sum:1235          Negative DS Square Sum:2714
       Min Delay SD:5                       Min Delay DS:4
       Avg Delay SD:6                       Avg Delay DS:5
       Max Delay SD:19                    Max Delay DS:18
       Delay SD Square Sum:39901            Delay DS Square Sum:33856
       Packet Loss SD:0                     Packet Loss DS:0
       Packet Loss Unknown:0                Average of Jitter:1
       Average of Jitter SD:1               Average of Jitter DS:1
       Jitter out value:0.0535000           Jitter in value:0.0606875
       NumberOfOWD:1000                     Packet Loss Ratio: 0%
       OWD SD Sum:6239                      OWD DS Sum:5724
       ICPIF value: 0                       MOS-CQ value: 438
       TimeStamp unit: ms                   Packet Rewrite Number: 0
       Packet Rewrite Ratio: 0%             Packet Disorder Number: 0
       Packet Disorder Ratio: 0%            Fragment-disorder Number: 0
       Fragment-disorder Ratio: 0%          Jitter OverThresholds SD number:0       
       Jitter OverThresholds DS number:0    OverallOverThresholds number:0            

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #                                                       
    ospf 1                                                  
     area 0.0.0.0                                   
      network 10.1.1.0 0.0.0.255  
    #
    nqa-server udpecho 10.1.1.1 9000  
    #
    return   
    
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #                                                       
    ospf 1                                                  
     area 0.0.0.0                                   
      network 10.1.2.0 0.0.0.255  
    #
    nqa-jitter tag-version 2   
    #
    nqa test-instance admin udpjitter
     test-type jitter
     destination-address ipv4 10.1.1.1
     destination-port 9000
     jitter-codec g711a
    #
    return   
    
Translation
Download
Updated: 2019-10-21

Document ID: EDOC1000178113

Views: 142387

Downloads: 55

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next