No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON and RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, Traffic Distribution, NetStream, sFlow, and TWAMP Light.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Testing the Jitter and Packet Loss Ratio of a Telepresence Network

Example for Testing the Jitter and Packet Loss Ratio of a Telepresence Network

Networking Requirements

In the telepresence network shown in Figure 6-58, SwitchA is the source node and SwitchD is the destination node.

Figure 6-58  Telepresence network
Switch Interface and IP Address
SwitchA
SwitchD
NOTE:

This example provides the RTP test configuration on SwitchA (NQA client) and configuration of Telepresence packet loss ratio and jitter test on SwitchD (NQA server). After the configurations are complete, the test can be conducted successfully as long as the two switches have reachable route to each other.

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces of SwitchA and SwitchD and ensure that the two switches have reachable routes to each other.

  2. Configure SwitchA as the NQA client for RTP test, and configure SwitchD as the NQA server to test the packet loss ratio and jitter of the Telepresence service.

  3. Configure an RTP test instance on the NQA client and an RTP snooping test instance on the NQA server.

Procedure

  1. Configure IP addresses for interfaces of SwitchA and SwitchD and ensure that the two switches have reachable routes to each other.

    # Configure IP addresses and masks for switch interfaces according to Figure 6-58. Configure OSPF on the switches to ensure that they can communicate at the network layer.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 20
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.2 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.2.1.2 24
    [SwitchA-Vlanif20] quit
    [SwitchA] ospf
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    NOTE:

    For configuration of SwitchD, see the configuration file.

  2. Configure an RTP test instance.

    # On SwitchA, configure an NQA test instance, set the NQA test type to rtptest, and configure the source and destination port numbers and IP addresses.

    [SwitchA] nqa test-instance admin rtptest
    [SwitchA-nqa-admin-rtptest] test-type rtptest
    [SwitchA-nqa-admin-rtptest] source-address ipv4 10.1.1.2
    [SwitchA-nqa-admin-rtptest] source-port 8000
    [SwitchA-nqa-admin-rtptest] destination-address ipv4 10.1.2.2
    [SwitchA-nqa-admin-rtptest] destination-port 9000

    # On SwitchD, configure an NQA test instance, set the NQA test type to rtpsnoop, and configure the source and destination port numbers and IP addresses.

    [SwitchD] nqa test-instance admin rtpsnoop
    [SwitchD-nqa-admin-rtpsnoop] test-type rtpsnoop
    [SwitchD-nqa-admin-rtpsnoop] source-address ipv4 10.1.1.2
    [SwitchD-nqa-admin-rtpsnoop] source-port 8000
    [SwitchD-nqa-admin-rtpsnoop] destination-address ipv4 10.1.2.2
    [SwitchD-nqa-admin-rtpsnoop] destination-port 9000
    [SwitchD-nqa-admin-rtpsnoop] quit

  3. Configure the RTP snooping server.

    # Configure the RTP snooping server on SwitchD.

    [SwitchD] nqa-server rtp-udp 10.1.2.2 9000

  4. Start the NQA test instance.

    # On SwitchA, start the RTP test instance.

    [SwitchA-nqa-admin-rtptest] start now

    # On SwitchD, start the RTP snooping test instance.

    [SwitchD] nqa test-instance admin rtpsnoop
    [SwitchD-nqa-admin-rtpsnoop] start now

  5. Verify test results.

    # On SwitchA, verify RTP test results.

    [SwitchA-nqa-admin-rtptest] display nqa results test-instance admin rtptest
    NQA entry(admin, rtptest) :testflag is inactive ,testtype is rtptest           
                                                                                    
      1 . Test 1 result   The test is finished                                      
       Completion:finished                                                          
       SendProbe:60000       ResponseProbe:59999                                    
       NumOfRTT:59999                                                               
       Packet Loss Ratio:0%                                                         
       Min/Max/Avg/Sum RTT:0/0/0/0 ms                                               
       Min/Max/Avg jitter:0/0/0                                                     
       Destination Port:9000    Source Port:8000                                    
       Destination Address Type/Address:IPv4/10.1.2.2                              
       Source Address Type/Address:IPv4/10.1.1.2 

    # On SwitchD, verify RTP snoop test results.

    [SwitchD-nqa-admin-rtpsnoop] display nqa results test-instance admin rtpsnoop
     NQA entry(admin, rtpsnoop) :testflag is inactive ,testtype is rtpsnoop         
                                                                                    
      1 . Test 1 result   The test is finished                                      
       Completion:finished                                                          
       Snoop Packet:11202       DSCP Value:0                                        
       Min/Max/Avg jitter:0/0/0                                                     
       Max Packet Lost:0                                                            
       Packet Lost Ratio:0%                                                         
       Destination Port:9000  Source Port:8000                                      
       Destination Address Type/Address:IPv4/10.1.2.2                              
       Source Address Type/Address:IPv4/10.1.1.2   

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
    #
    interface  GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface  GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
    #                                                                               
    nqa test-instance admin rtptest     
     test-type rtptest                                                              
     destination-address ipv4 10.1.2.2                                              
     source-address ipv4 10.1.1.2                                                   
     destination-port 9000                                                             
     source-port 8000                                                                  
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 10.1.2.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.2.2.2 255.255.255.0
    #
    interface  GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    interface  GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 20
     port hybrid untagged vlan 20
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    nqa-server rtp-udp 10.1.2.2 9000
    #
    nqa test-instance admin rtpsnoop
     test-type rtpsnoop
     destination-address ipv4 10.1.2.2
     source-address ipv4 10.1.1.2
     destination-port 9000
     source-port 8000
    #
    return
Translation
Download
Updated: 2019-10-21

Document ID: EDOC1000178113

Views: 137138

Downloads: 53

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next