No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON and RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, Traffic Distribution, NetStream, sFlow, and TWAMP Light.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MTrace Test for the RPF Path from the Multicast Source to a Destination Host

Example for Configuring MTrace Test for the RPF Path from the Multicast Source to a Destination Host

Networking Requirements

On a PIM-SM network shown in Figure 6-49, each Switch runs the NTP protocol to ensure time synchronization. Receiver is added to multicast group 225.1.1.1 to receive multicast data from the Source. SwitchB is the last-hop Switch. Requirement: Check how multicast packets are transmitted over the RPF path from the Source to the Receiver.

Solution: Configure the NQA MTrace test on SwitchC to check the RPF path from the multicast source to the destination host.

NOTE:

In this scenario, ensure that all connected interfaces have STP disabled. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network may be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 6-49  Networking diagram for configuring MTrace test for the RPF path from the multicast source to a destination host

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchC as the NQA client and create an MTrace test on it.

  2. Start the test instance and verify the test result.

Procedure

  1. Configure OSPF to implement reachable routes.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 110 170
    [SwitchA] interface vlanif110
    [SwitchA-Vlanif110] ip address 10.1.5.1 24
    [SwitchA-Vlanif110] quit
    [SwitchA] interface vlanif170
    [SwitchA-Vlanif170] ip address 10.1.6.3 24
    [SwitchA-Vlanif170] quit
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 110
    [SwitchA-GigabitEthernet1/0/0] quit
    [SwitchA] interface gigabitethernet 3/0/0
    [SwitchA-GigabitEthernet3/0/0] port link-type trunk
    [SwitchA-GigabitEthernet3/0/0] port trunk allow-pass vlan 170
    [SwitchA-GigabitEthernet3/0/0] quit
    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.5.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.6.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 120 160 170
    [SwitchB] interface vlanif120
    [SwitchB-Vlanif120] ip address 10.1.4.1 24
    [SwitchB-Vlanif120] quit
    [SwitchB] interface vlanif160
    [SwitchB-Vlanif160] ip address 10.1.3.1 24
    [SwitchB-Vlanif160] quit
    [SwitchB] interface vlanif170
    [SwitchB-Vlanif170] ip address 10.1.6.2 24
    [SwitchB-Vlanif170] quit
    [SwitchB] interface gigabitethernet 1/0/0
    [SwitchB-GigabitEthernet1/0/0] port link-type trunk
    [SwitchB-GigabitEthernet1/0/0] port trunk allow-pass vlan 160
    [SwitchB-GigabitEthernet1/0/0] quit
    [SwitchB] interface gigabitethernet 2/0/0
    [SwitchB-GigabitEthernet2/0/0] port link-type trunk
    [SwitchB-GigabitEthernet2/0/0] port trunk allow-pass vlan 120
    [SwitchB-GigabitEthernet2/0/0] quit
    [SwitchB] interface gigabitethernet 3/0/0
    [SwitchB-GigabitEthernet3/0/0] port link-type trunk
    [SwitchB-GigabitEthernet3/0/0] port trunk allow-pass vlan 170
    [SwitchB-GigabitEthernet3/0/0] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.6.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan batch 150 160
    [SwitchC] interface vlanif 150
    [SwitchC-Vlanif150] ip address 10.1.1.1 24
    [SwitchC-Vlanif150] quit
    [SwitchC] interface vlanif 160
    [SwitchC-Vlanif160] ip address 10.1.3.2 24
    [SwitchC-Vlanif160] quit
    [SwitchC] interface gigabitethernet 1/0/0
    [SwitchC-GigabitEthernet1/0/0] port link-type trunk
    [SwitchC-GigabitEthernet1/0/0] port trunk allow-pass vlan 160
    [SwitchC-GigabitEthernet1/0/0] quit
    [SwitchC] interface gigabitethernet 2/0/0
    [SwitchC-GigabitEthernet2/0/0] port link-type trunk
    [SwitchC-GigabitEthernet2/0/0] port trunk allow-pass vlan 150
    [SwitchC-GigabitEthernet2/0/0] quit
    [SwitchC] interface loopback0
    [SwitchC-LoopBack0] ip address 10.2.2.2 32
    [SwitchC-LoopBack0] quit
    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # Configure SwitchD.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchD
    [SwitchD] vlan batch 110 120 130
    [SwitchD] interface vlanif 110
    [SwitchD-Vlanif110] ip address 10.1.5.2 24
    [SwitchD-Vlanif110] quit
    [SwitchD] interface vlanif 120
    [SwitchD-Vlanif120] ip address 10.1.4.2 24
    [SwitchD-Vlanif120] quit
    [SwitchD] interface vlanif 130
    [SwitchD-Vlanif130]  ip address 10.1.2.1 24
    [SwitchD-Vlanif130] quit
    [SwitchD] interface gigabitethernet 1/0/0
    [SwitchD-GigabitEthernet1/0/0] port link-type trunk
    [SwitchD-GigabitEthernet1/0/0] port trunk allow-pass vlan 110
    [SwitchD-GigabitEthernet1/0/0] quit
    [SwitchD] interface gigabitethernet 2/0/0
    [SwitchD-GigabitEthernet2/0/0] port link-type trunk
    [SwitchD-GigabitEthernet2/0/0] port trunk allow-pass vlan 120
    [SwitchD-GigabitEthernet2/0/0] quit
    [SwitchD] interface gigabitethernet 3/0/0
    [SwitchD-GigabitEthernet3/0/0] port link-type trunk
    [SwitchD-GigabitEthernet3/0/0] port trunk allow-pass vlan 130
    [SwitchD-GigabitEthernet3/0/0] quit
    [SwitchD] ospf 1
    [SwitchD-ospf-1] area 0
    [SwitchD-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 10.1.5.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] quit
    [SwitchD-ospf-1] quit

    # Configure SwitchE.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchE
    [SwitchE] vlan batch 130 140 150
    [SwitchE] interface vlanif 130
    [SwitchE-Vlanif130] ip address 10.1.2.2 24
    [SwitchE-Vlanif130] quit
    [SwitchE] interface vlanif 140
    [SwitchE-Vlanif140] ip address 10.1.0.1 24
    [SwitchE-Vlanif140] quit
    [SwitchE] interface vlanif 150
    [SwitchE-Vlanif150] ip address 10.1.1.2 24
    [SwitchE-Vlanif150] quit
    [SwitchE] interface gigabitethernet 1/0/0
    [SwitchE-GigabitEthernet1/0/0] port link-type trunk
    [SwitchE-GigabitEthernet1/0/0] port trunk allow-pass vlan 140
    [SwitchE-GigabitEthernet1/0/0] quit
    [SwitchE] interface gigabitethernet 2/0/0
    [SwitchE-GigabitEthernet2/0/0] port link-type trunk
    [SwitchE-GigabitEthernet2/0/0] port trunk allow-pass vlan 150
    [SwitchE-GigabitEthernet2/0/0] quit
    [SwitchE] interface gigabitethernet 3/0/0
    [SwitchE-GigabitEthernet3/0/0] port link-type trunk
    [SwitchE-GigabitEthernet3/0/0] port trunk allow-pass vlan 130
    [SwitchE-GigabitEthernet3/0/0] quit
    [SwitchE] ospf 1
    [SwitchE-ospf-1] area 0
    [SwitchE-ospf-1-area-0.0.0.0] network 10.1.0.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] quit
    [SwitchE-ospf-1] quit

  2. Configure the multicast network.

    # Configure SwitchA.

    [SwitchA] multicast routing-enable
    [SwitchA] interface vlanif110
    [SwitchA-Vlanif110] pim sm
    [SwitchA-Vlanif110] quit
    [SwitchA] interface vlanif170
    [SwitchA-Vlanif170] pim sm
    [SwitchA-Vlanif170] igmp enable
    [SwitchA-Vlanif170] quit
    [SwitchA] pim
    [SwitchA-pim] quit
    

    # Configure SwitchB.

    [SwitchB] multicast routing-enable
    [SwitchB] interface vlanif120
    [SwitchB-Vlanif120] pim sm
    [SwitchB-Vlanif120] quit
    [SwitchB] interface vlanif160
    [SwitchB-Vlanif160] pim sm
    [SwitchB-Vlanif160] quit
    [SwitchB] interface vlanif170
    [SwitchB-Vlanif170] pim sm
    [SwitchB-Vlanif170] igmp enable
    [SwitchB-Vlanif170] quit

    # Configure SwitchC.

    [SwitchC] multicast routing-enable
    [SwitchC] interface vlanif 150
    [SwitchC-Vlanif150] pim sm
    [SwitchC-Vlanif150] quit
    [SwitchC] interface vlanif 160
    [SwitchC-Vlanif160] pim sm
    [SwitchC-Vlanif160] quit
    [SwitchC] interface loopback0
    [SwitchC-LoopBack0] pim sm
    [SwitchC-LoopBack0] igmp enable
    [SwitchC-LoopBack0] quit
    [SwitchC] pim
    [SwitchC-pim] c-bsr LoopBack0
    [SwitchC-pim] c-rp LoopBack0
    [SwitchC-pim] quit

    # Configure SwitchD.

    [SwitchD] multicast routing-enable
    [SwitchD] interface vlanif 110
    [SwitchD-Vlanif110] pim sm
    [SwitchD-Vlanif110] quit
    [SwitchD] interface vlanif 120
    [SwitchD-Vlanif120] pim sm
    [SwitchD-Vlanif120] quit
    [SwitchD] interface vlanif 130
    [SwitchD-Vlanif130] pim sm
    [SwitchD-Vlanif130] igmp enable
    [SwitchD-Vlanif130] quit
    [SwitchD] pim
    [SwitchD-pim] quit
    

    # Configure SwitchE.

    [SwitchE] multicast routing-enable
    [SwitchE] interface vlanif 130
    [SwitchE-Vlanif130] pim sm
    [SwitchE-Vlanif130] igmp enable
    [SwitchE-Vlanif130] quit
    [SwitchE] interface vlanif 140
    [SwitchE-Vlanif140] pim sm
    [SwitchE-Vlanif140] quit
    [SwitchE] interface vlanif 150
    [SwitchE-Vlanif150] pim sm
    [SwitchE-Vlanif150] quit
    [SwitchE] pim
    [SwitchE-pim] quit

  3. Configure an NQA MTrace test instance on SwitchC.

    [SwitchC] nqa test-instance admin mtrace
    [SwitchC-nqa-admin-mtrace] test-type mtrace
    [SwitchC-nqa-admin-mtrace] mtrace-source-address ipv4 10.1.0.2
    [SwitchC-nqa-admin-mtrace] destination-address ipv4 10.1.6.4
    [SwitchC-nqa-admin-mtrace] mtrace-query-type last-hop
    [SwitchC-nqa-admin-mtrace] mtrace-last-hop-address ipv4 10.1.6.2

  4. Start the test instance.

    # When the network runs stably, verify the test result.

    [SwitchC-nqa-admin-mtrace] start now

  5. Verify the test result. You can find that the RPF path from the multicast source to SwitchC is SwitchE-SwitchD-SwitchB.

    [SwitchC-nqa-admin-mtrace] display nqa results test-instance admin mtrace
    
    NQA entry(admin, mtrace) :testflag is inactive ,testtype is mtrace
      1 . Test 1 result   The test is finished
       Completion: success                 Query Mode: max-hop
       Current Hop:3                        Current Probe:1
       SendProbe:1                          ResponseProbe:1
       Timeout Count:0                      Busy Count:0
       Drop Count:0                         Max Path Ttl:4
       Responser:10.1.0.2                Response Rtt: 62
       mtrace start time: 2009-02-07 17:36:18.1
       Last Good Probe Time: 2009-02-07 17:36:18.1
       Last Good Path Time: 2009-02-07 17:36:18.1
       1 . Hop 1
        Outgoing Interface Address: 10.1.6.2
        Incoming Interface Address: 10.1.4.1
        Prehop Router Address: 10.1.4.2
        Protocol : PIM                  Forward Code:NO_ERROR
        Forward Ttl:1                   Current Path Ttl:4
        SG Packet Count:0xffffffff      Hop Time Delay(ms):65
        Input Packet Count:9424         Output Packet Count:9815
        Input Rate(pps): --     Output Rate(pps): --
        Input Loss Rate: --     SG Loss Rate: --
       2 . Hop 2
        Outgoing Interface Address: 10.1.4.2
        Incoming Interface Address: 10.1.2.1
        Prehop Router Address: 10.1.2.2
        Protocol : PIM                  Forward Code:NO_ERROR
        Forward Ttl:1                   Current Path Ttl:3
        SG Packet Count:0xffffffff      Hop Time Delay(ms):1
        Input Packet Count:9849         Output Packet Count:9429
        Input Rate(pps): --     Output Rate(pps): --
        Input Loss Rate: --     SG Loss Rate: --
       3 . Hop 3
        Outgoing Interface Address: 10.1.2.2
        Incoming Interface Address: 10.1.0.1
        Prehop Router Address: 0.0.0.0
        Protocol : PIM                  Forward Code:NO_ERROR
        Forward Ttl:1                   Current Path Ttl:2
        SG Packet Count:0xffffffff      Hop Time Delay(ms): 0xffffffff
        Input Packet Count:109581       Output Packet Count:16529
        Input Rate(pps): --     Output Rate(pps): --
        Input Loss Rate: --     SG Loss Rate: --
    

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 110 170
    #
    multicast routing-enable
    #
    interface Vlanif110
     ip address 10.1.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif170
     ip address 10.1.6.3 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 110
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 170
    #
    ospf 1
     area 0.0.0.0
      network 10.1.5.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
    #
    pim
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 120 160 170
    #
    multicast routing-enable
    #
    interface Vlanif120
     ip address 10.1.4.1 255.255.255.0
     pim sm
    #
    interface Vlanif160
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif170
     ip address 10.1.6.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 160
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 120
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 170
    #
    ospf 1
     area 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 150 160
    #
    multicast routing-enable
    #
    interface Vlanif150
     ip address 10.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif160
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 160
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 150
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     pim sm
     igmp enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.2.2.2 0.0.0.0
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    nqa test-instance admin mtrace
     test-type mtrace
     destination-address ipv4 10.1.6.4
     mtrace-last-hop-address ipv4 10.1.6.2
     mtrace-source-address ipv4 10.1.0.2 
     mtrace-query-type last-hop
    # 
    return
    
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    vlan batch 110 120 130
    #
    multicast routing-enable
    #
    interface Vlanif110
     ip address 10.1.5.2 255.255.255.0
     pim sm
    #
    interface Vlanif120
     ip address 10.1.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif130
     ip address 10.1.2.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 110
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 120
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 130
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
    #
    pim
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    vlan batch 130 140 150
    #
    multicast routing-enable
    #
    interface Vlanif130
     ip address 10.1.2.2 255.255.255.0
     pim sm
     igmp enable
    #
    interface Vlanif140
     ip address 10.1.0.1 255.255.255.0
     pim sm
    #
    interface Vlanif150
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 140
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 150
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 130
    #
    ospf 1
     area 0.0.0.0
      network 10.1.0.0 0.0.0.255
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    pim
    #
    return
Translation
Download
Updated: 2019-10-21

Document ID: EDOC1000178113

Views: 137533

Downloads: 53

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next