No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON and RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, Traffic Distribution, NetStream, sFlow, and TWAMP Light.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 Original Flow Statistics Exporting

Example for Configuring IPv4 Original Flow Statistics Exporting

Networking Requirements

In Figure 11-3, departments 1 and 2 connect to the Internet through SwitchA. Network administrators want to monitor communication between departments and the Internet, and perform accounting based on the department.

Figure 11-3  Example configuration of IPv4 original flow statistics exporting

Configuration Roadmap

To monitor communication between the departments and the Internet, the network administrator needs to:

  • Configure IPv4 original flow statistics exporting on GE1/0/1 of SwitchA.
  • Collect statistics about incoming and outgoing traffic on the interface.
  • Send statistics to the NetStream server for further analysis.

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces on SwitchA.
  2. Configure NetStream sampling.
  3. Configure NetStream flow aging.
  4. Configure NetStream original flow statistics exporting.
  5. Configure the version for exported packets.
  6. Enable flow statistics collection on the interface.

Procedure

  1. Configure IP addresses for interfaces on SwitchA as shown in Figure 11-3.

    # Configure IP addresses for interfaces on SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA 
    [SwitchA] vlan batch 100 200 300 400
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 200
    [SwitchA-Vlanif200] ip address 10.1.2.1 24
    [SwitchA-Vlanif200] quit
    [SwitchA] interface vlanif 300
    [SwitchA-Vlanif300] ip address 10.1.3.1 24
    [SwitchA-Vlanif300] quit
    [SwitchA] interface vlanif 400
    [SwitchA-Vlanif400] ip address 10.1.4.1 24
    [SwitchA-Vlanif400] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100 
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 200 
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 300 
    [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 300
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type hybrid 
    [SwitchA-GigabitEthernet1/0/4] port hybrid pvid vlan 400 
    [SwitchA-GigabitEthernet1/0/4] port hybrid untagged vlan 400
    [SwitchA-GigabitEthernet1/0/4] quit
    

  2. Configure NetStream sampling.

    # Configure NetStream sampling on GE1/0/1, set the sampling ratio to 1200.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] ip netstream sampler fix-packets 1200 inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream sampler fix-packets 1200 outbound
    [SwitchA-GigabitEthernet1/0/1] quit
    

  3. Configure NetStream flow aging.

    # Set the inactive aging time to 100 seconds and enable FIN- and RST-based aging.

    [SwitchA] ip netstream timeout inactive 100
    [SwitchA] ip netstream tcp-flag enable

  4. Configure exporting of NetStream original flow statistics.

    # Set the source IP address of the exported packets carrying original flow statistics to 10.1.2.1, the destination IP address to 10.1.2.2, and the destination port number to 6000.

    [SwitchA] ip netstream export source 10.1.2.1
    [SwitchA] ip netstream export host 10.1.2.2 6000

  5. Configure the version for exported packets.

    # Set the version of the exported packets to V9.

    [SwitchA] ip netstream export version 9

  6. Enable flow statistics collection on the interface.

    # Enable flow statistics on GE1/0/1 for incoming and outgoing packets.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] ip netstream inbound
    [SwitchA-GigabitEthernet1/0/1] ip netstream outbound
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] quit

  7. Verify the configuration.

    # After configuration is complete, the NetStream server receives the statistics packets from the device. Run the display ip netstream statistics command on the local device to view NetStream statistics.

    <SwitchA> display ip netstream statistics slot 1
     ===== Netstream statistics: =====                                          
     Origin/Flexible ingress entries  : 35
     Origin/Flexible ingress packets  : 381920
     Origin/Flexible ingress octets   : 125269760
     Origin/Flexible egress entries   : 0 
     Origin/Flexible egress packets   : 0 
     Origin/Flexible egress octets    : 0 
     Origin/Flexible total entries    : 35
     Handle origin entries            : 35  
     Handle As aggre entries          : 0 
     Handle ProtPort aggre entries    : 0 
     Handle SrcPrefix aggre entries   : 0 
     Handle DstPrefix aggre entries   : 0 
     Handle Prefix aggre entries      : 0 
     Handle AsTos aggre entries       : 0 
     Handle ProtPortTos aggre entries : 0 
     Handle SrcPreTos aggre entries   : 0 
     Handle DstPreTos aggre entries   : 0 
     Handle PreTos aggre entries      : 0 

Configuration Files

SwitchA configuration file

#                                                                               
sysname SwitchA 
#                                                                               
vlan batch 100 200 300 400 
# 
ip netstream timeout inactive 100
ip netstream export version 9
ip netstream export source 10.1.2.1
ip netstream export host 10.1.2.2 6000
#
ip netstream tcp-flag enable
#                                                                               
interface Vlanif100                                                             
 ip address 10.1.1.1 255.255.255.0 
#                                                                               
interface Vlanif200                                                             
 ip address 10.1.2.1 255.255.255.0 
#                                                                               
interface Vlanif300                                                             
 ip address 10.1.3.1 255.255.255.0 
#                                                                               
interface Vlanif400                                                             
 ip address 10.1.4.1 255.255.255.0 
#                                                                               
interface GigabitEthernet1/0/1                                                  
 port link-type hybrid
 port hybrid pvid vlan 100                                                      
 port hybrid untagged vlan 100  
 ip netstream inbound
 ip netstream outbound
 ip netstream sampler fix-packets 1200 inbound
 ip netstream sampler fix-packets 1200 outbound
#                                                                               
interface GigabitEthernet1/0/2                                                  
 port link-type hybrid
 port hybrid pvid vlan 200                                                      
 port hybrid untagged vlan 200  
#                                                                               
interface GigabitEthernet1/0/3                                                  
 port link-type hybrid
 port hybrid pvid vlan 300                                                      
 port hybrid untagged vlan 300  
#                                                                               
interface GigabitEthernet1/0/4                                                  
 port link-type hybrid
 port hybrid pvid vlan 400                                                      
 port hybrid untagged vlan 400  
#
return
Translation
Download
Updated: 2019-10-21

Document ID: EDOC1000178113

Views: 136561

Downloads: 53

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next