No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

S12700 V200R011C10 Configuration Guide - Network Management and Monitoring

This document provides the configurations of network management and monitoring features supported by the product, including SNMP, RMON and RMON2, LLDP, Performance Management, iPCA, NQA, Service Diagnosis, Mirroring, Packet Capture, Traffic Distribution, NetStream, sFlow, and TWAMP Light.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an SNMP Test Instance

Example for Configuring an SNMP Test Instance

Networking Requirements

In Figure 6-33, SNMP agent is enabled on SwitchA and SwitchC. An NQA SNMP test needs to be performed to obtain the time from when SwitchA sends an SNMP packet to when SwitchA receives an Echo packet.

Figure 6-33  Networking diagram for configuring an SNMP test instance

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure SwitchA as an NQA client.

  2. Enable SNMP agent on SwitchA.

  3. Create and start an SNMP test instance on SwitchA.

  4. Enable the SNMP agent on SwitchC.

Procedure

  1. Configure an IP address for each interface and ensure reachable routes between switches.

    # Configure SwitchA.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan 100
    [SwitchA-vlan100] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] ip route-static 10.2.1.0 255.255.255.0 10.1.1.2

    # Configure SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan 100
    [SwitchB-vlan100] quit
    [SwitchB] vlan 110
    [SwitchB-vlan110] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.1.1.2 24
    [SwitchB-Vlanif100] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/2] port hybrid pvid vlan 110
    [SwitchB-GigabitEthernet1/0/2] port hybrid untagged vlan 110
    [SwitchB-GigabitEthernet1/0/2] quit
    [SwitchB] interface vlanif 110
    [SwitchB-Vlanif110] ip address 10.2.1.1 24
    [SwitchB-Vlanif110] quit
    

    # Configure SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] vlan 110
    [SwitchC-vlan110] quit
    [SwitchC] interface gigabitethernet 1/0/1
    [SwitchC-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchC-GigabitEthernet1/0/1] port hybrid pvid vlan 110
    [SwitchC-GigabitEthernet1/0/1] port hybrid untagged vlan 110
    [SwitchC-GigabitEthernet1/0/1] quit
    [SwitchC] interface vlanif 110
    [SwitchC-Vlanif110] ip address 10.2.1.2 24
    [SwitchC-Vlanif110] quit
    [SwitchC] ip route-static 10.1.1.0 255.255.255.0 10.2.1.1

  2. Enable SNMP agent on SwitchC.

    <SwitchC> system-view
    [SwitchC] snmp-agent

  3. Enable SNMP agent on SwitchA.

    [SwitchA] snmp-agent

  4. Create an SNMP test instance on SwitchA.

    [SwitchA] nqa test-instance admin snmp
    [SwitchA-nqa-admin-snmp] test-type snmp
    [SwitchA-nqa-admin-snmp] destination-address ipv4 10.2.1.2

  5. Start the test instance.

    [SwitchA-nqa-admin-snmp] start now

  6. Check the configuration.

    # Check NQA test results on SwitchA.

    [SwitchA-nqa-admin-snmp] display nqa results test-instance admin snmp
     NQA entry(admin, snmp) :testflag is inactive ,testtype is snmp
      1 . Test 1 result   The test is finished                                      
       Send operation times: 3              Receive response times: 3               
       Completion:success                   RTD OverThresholds number: 0            
       Attempts number:1                    Drop operation number:0                 
       Disconnect operation number:0        Operation timeout number:0              
       System busy operation number:0       Connection fail number:0                
       Operation sequence errors number:0   RTT Status errors number:0              
       Destination ip address:10.2.1.2                                              
       Min/Max/Average Completion Time: 63/172/109                                       
       Sum/Square-Sum  Completion Time: 329/42389                                         
       Last Good Probe Time: 2012-07-25 15:33:49.1                                  
       Lost packet ratio: 0 %                      

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ip route-static 10.2.1.0 255.255.255.0 10.1.1.2
    #
    snmp-agent
    snmp-agent local-engineid 800007DB03020000510162
    snmp-agent sys-info version v3
    #
    nqa test-instance admin snmp                                                    
     test-type snmp                                                                 
     destination-address ipv4 10.2.1.2 
    #
    return   
    
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 110
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif110
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    return   
    
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    vlan batch 110
    #
    interface Vlanif110
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type hybrid
     port hybrid pvid vlan 110
     port hybrid untagged vlan 110
    #
    ip route-static 10.1.1.0 255.255.255.0 10.2.1.1
    #
    snmp-agent
    snmp-agent local-engineid 800007DB03000011110126
    snmp-agent sys-info version v3
    #
    return   
    
Translation
Download
Updated: 2019-10-21

Document ID: EDOC1000178113

Views: 136712

Downloads: 53

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next