No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Basic Configuration

S1720, S2700, S5700, and S6720 V200R011C10

This document describes methods to use command line interface and to log in to the device, file operations, and system startup configurations.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Manually Replacing Faulty Devices Using the Commander

Example for Manually Replacing Faulty Devices Using the Commander

Networking Requirements

The enterprise network shown in Figure 3-21 supports the EasyDeploy function. SwitchA functions as a DHCP relay agent and Commander. SwitchA, DHCP server, and the file server have reachable routes to each other.

Client5 on the network fails, and services of users connected to Client5 are interrupted. To resume services for users, Client5 must be replaced by a new client. The new client needs to take over services of Client5 quickly to minimize impact of the fault.

The MAC address of the new client is 0200-0000-0000, and the new client needs to download the web page file web_1.web.7z.

Figure 3-21  Networking diagram for faulty device replacement using the Commander

Configuration Roadmap

The configuration roadmap is as follows:
  1. Save web_1.web.7z to be loaded on the file server.
  2. Specify client replacement information on SwitchA to enable the new client to obtain the backup configuration file of the faulty client.
NOTE:

Faulty device replacement can be implemented on a network where EasyDeploy has been deployed, and the file server, DHCP server, and Commander have been configured.

Procedure

  1. Configure automatic configuration backup to enable the new client to obtain the configuration file of the faulty client.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] easy-operation
    [SwitchA-easyoperation] backup configuration interval 72
    

  2. Specify client replacement information on SwitchA.

    [SwitchA-easyoperation] client 5 replace mac-address 0200-0000-0000
    [SwitchA-easyoperation] client 5 replace web-file web_1.web.7z

  3. Verify the configuration.

    # Check client replacement information.

    [SwitchA-easyoperation] display easy-operation client replace
    The total number of replacement information is :  1                             
                                                                                    
    -----------------------------------------------------------                     
      ID      Replaced Mac       Replaced Esn                                         
    -----------------------------------------------------------                     
      5       0200-0000-0000   -                                                    
    ----------------------------------------------------------- 

    # After the faulty device replacement process starts, run the display easy-operation client 5 command to check the status of the new client.

    [SwitchA-easyoperation] display easy-operation client 5  
    ---------------------------------------------------------------------------     
     Client ID                    : 5                                               
     Host name                    : HUAWEI                                       
     Mac address                  : 0200-0000-0000                                  
     ESN                          : 210235182810C3001039                             
     IP address                   : 192.168.1.254                                   
     Model                        : S5701-28X-LI-AC 
     Device Type                  : S5700-X-LI 
     System-software file         : flash:/S5700XLI.cc
     System-software version      : V200R005C00                                     
     Configuration file           : -
     Patch file                   : -
     WEB file                     : -
     License file                 : -
     System CPU usage             : 55%
     System Memory usage          : 44%
     Backup configuration file    : vrpcfg-0300-0000-0000.zip
     Backup result                : Successful
     Last operation result        : -
     Last operation time          : 0000-00-00  00:00:00
     State                        : UPGRADING
     Aging time left (hours)      : -
    --------------------------------------------------------------------------- 
    # You can also run the display easy-operation download-status command to check the file downloading progress of the new client.
    [SwitchA-easyoperation] display easy-operation download-status             
    The total number of client in downloading files is : 1                          
                                                                                    
    ------------------------------------------------------------------------------- 
     ID  Mac address      IP address           Method       Phase        Status     
    ------------------------------------------------------------------------------- 
     5   0200-0000-0000   192.168.1.254        Zero-touch   Web-file     Upgrading  

Configuration Files

SwitchA configuration file

#
sysname SwitchA
#
vlan batch 10 20
#
dhcp enable
#
interface Vlanif10
 ip address 192.168.1.6 255.255.255.0
 dhcp select relay
 dhcp relay server-ip 192.168.3.2
#
interface Vlanif20
 ip address 192.168.4.2 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet0/0/2
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet0/0/3
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet0/0/4
 port link-type hybrid
 port hybrid pvid vlan 20
 port hybrid untagged vlan 20
#                                                                               
ip route-static 0.0.0.0 0.0.0.0 192.168.4.1
#
easy-operation commander ip-address 192.168.1.6 
easy-operation commander enable 
# 
easy-operation
 sftp-server 192.168.2.2 username admin password %^%#=.X8C_TN##%&9P>3RK503O@w-=Fr%>naT#E3P4{0%^%#
 backup configuration interval 72 
 client 5 mac-address 0300-0000-0000
# 
return

SwitchB configuration file

#
sysname SwitchB
#
vlan batch 30
#
dhcp enable
#
ip pool easy-operation
 gateway-list 192.168.1.6
 network 192.168.1.0 mask 255.255.255.0
 option 148 ascii ipaddr=192.168.1.6;
#
interface Vlanif30
 ip address 192.168.3.2 255.255.255.0
 dhcp select global
#                                                                               
interface GigabitEthernet0/0/1
 port link-type hybrid
 port hybrid pvid vlan 30
 port hybrid untagged vlan 30 
#
ip route-static 0.0.0.0 0.0.0.0 192.168.3.1
#
return 
Translation
Download
Updated: 2019-10-21

Document ID: EDOC1000178166

Views: 259151

Downloads: 1953

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next