No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R011C10

This document describes the configuration of Ethernet services, including configuring link aggregation, VLANs, Voice VLAN, VLAN mapping, QinQ, GVRP, MAC table, STP/RSTP/MSTP, SEP, and so on.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MAC Address Limiting on an Interface

Example for Configuring MAC Address Limiting on an Interface

Networking Requirements

In Figure 2-15, user network 1 and user network 2 connect to the Switch through the LSW, and the LSW connects to the Switch through GE1/0/1. User network 1 and user network 2 belong to VLAN 10 and VLAN 20 respectively. On the Switch, MAC address limiting can be configured on GE1/0/1 to control the number of access users.

Figure 2-15  Networking for configuring MAC address limiting on an interface

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create VLANs and add the downlink interface to the VLANs to implement Layer 2 forwarding.

  2. Configure MAC address limiting on the interface to control the number of access users.

Procedure

  1. Configure MAC address limiting.

    # Create VLAN 10 and VLAN 20, and add the GigabitEthernet1/0/1 to VLAN 10 and VLAN 20.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type hybrid
    [Switch-GigabitEthernet1/0/1] port hybrid tagged vlan 10 20
    

    # Configure a MAC address limiting rule on GigabitEthernet1/0/1: A maximum of 100 MAC address entries can be learned on the interface. When the number of learned MAC address entries reaches the limit, the Switch directly discards the packets with new source MAC address entries and generates an alarm.

    [Switch-GigabitEthernet1/0/1] mac-limit maximum 100 action discard alarm enable
    [Switch-GigabitEthernet1/0/1] return
    

  2. Verify the configuration.

    # Run the display mac-limit command in any view to check whether the MAC address limiting rule is successfully configured.

    <Switch> display mac-limit
    MAC limit is enabled                                                            
    Total MAC limit rule count : 1                                                  
                                                                                    
    PORT                 VLAN/VSI         SLOT Maximum Rate(ms) Action  Alarm       
    ----------------------------------------------------------------------------    
    GE1/0/1              -                -    100     -        discard enable      
    

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 10 20
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid tagged vlan 10 20
 mac-limit maximum 100
#
return
Translation
Download
Updated: 2019-10-18

Document ID: EDOC1000178310

Views: 285510

Downloads: 141

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next