No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R011C10

This document describes the configuration of Ethernet services, including configuring link aggregation, VLANs, Voice VLAN, VLAN mapping, QinQ, GVRP, MAC table, STP/RSTP/MSTP, SEP, and so on.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an Inter-Chassis Eth-Trunk to Forward Traffic Preferentially Through Local Member Interfaces (CSS)

Example for Configuring an Inter-Chassis Eth-Trunk to Forward Traffic Preferentially Through Local Member Interfaces (CSS)

Networking Requirements

NOTE:

The S7703, and S9703 do not support this configuration.

On the network shown in Figure 3-27, Switch3 and Switch4 are connected through CSS cables to increase the total capacity. The two switches are considered as one logical switch. To improve reliability, physical interfaces on the two switches are added to an Eth-Trunk. When the network runs properly, traffic from VLAN 2 is forwarded through GE1/0/1 and GE1/0/2, and traffic from VLAN 3 is forwarded through GE1/0/1 and GE1/0/2. This increases bandwidth use efficiency between devices and reduces traffic forwarding efficiency.

To improve traffic forwarding efficiency, traffic from VLAN 2 should be forwarded through GE1/0/1 and traffic from VLAN 3 should be forwarded through GE1/0/2. To achieve this goal, configure the Eth-Trunk to preferentially forward local traffic.

Figure 3-27  Preferentially forwarding traffic through the local member interface

Configuration Roadmap

The configuration roadmap is as follows:

  1. Create an Eth-Trunk.

  2. Add member interfaces to the Eth-Trunk.

  3. Configure the Eth-Trunk to preferentially forward local traffic.

  4. Configure the Layer 2 forwarding function.

Procedure

  1. Create an Eth-Trunk and configure the Eth-Trunk to allow packets all VLANs to pass through.

    # Configure the CSS.

    <HUAWEI> system-view
    [HUAWEI] sysname CSS
    [CSS] interface eth-trunk 10
    [CSS-Eth-Trunk10] port link-type trunk 
    [CSS-Eth-Trunk10] port trunk allow-pass vlan all
    [CSS-Eth-Trunk10] quit

    # Configure the PE.

    <HUAWEI> system-view
    [HUAWEI] sysname PE
    [PE] interface eth-trunk 10
    [PE-Eth-Trunk10] port link-type trunk
    [PE-Eth-Trunk10] port trunk allow-pass vlan all
    [PE-Eth-Trunk10] quit

  2. Add member interfaces to the Eth-Trunk.

    # Configure the CSS.

    [CSS] interface gigabitethernet 1/1/0/4
    [CSS-GigabitEthernet1/1/0/4] eth-trunk 10
    [CSS-GigabitEthernet1/1/0/4] quit
    [CSS] interface gigabitethernet 2/1/0/4
    [CSS-GigabitEthernet2/1/0/4] eth-trunk 10
    [CSS-GigabitEthernet2/1/0/4] quit

    # Configure the PE.

    [PE] interface gigabitethernet 1/0/1
    [PE-GigabitEthernet1/0/1] eth-trunk 10
    [PE-GigabitEthernet1/0/1] quit
    [PE] interface gigabitethernet 1/0/2
    [PE-GigabitEthernet1/0/2] eth-trunk 10
    [PE-GigabitEthernet1/0/2] quit

  3. In the CSS view, configure the Eth-Trunk to preferentially forward local traffic.

    [CSS] interface eth-trunk 10
    [CSS-Eth-Trunk10] local-preference enable
    [CSS-Eth-Trunk10] quit

  4. Configure the Layer 2 forwarding function.

    # Configure the CSS.

    [CSS] vlan batch 2 3
    [CSS] interface gigabitethernet 1/1/0/3
    [CSS-GigabitEthernet1/1/0/3] port link-type trunk
    [CSS-GigabitEthernet1/1/0/3] port trunk allow-pass vlan 2
    [CSS-GigabitEthernet1/1/0/3] quit
    [CSS] interface gigabitethernet 2/1/0/3
    [CSS-GigabitEthernet2/1/0/3] port link-type trunk
    [CSS-GigabitEthernet2/1/0/3] port trunk allow-pass vlan 3
    [CSS-GigabitEthernet2/1/0/3] quit

    # Configure Switch1.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch1
    [Switch1] vlan 2
    [Switch1-vlan2] quit
    [Switch1] interface gigabitethernet 1/0/1
    [Switch1-GigabitEthernet1/0/1] port link-type trunk
    [Switch1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [Switch1-GigabitEthernet1/0/1] quit
    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] port link-type trunk
    [Switch1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [Switch1-GigabitEthernet1/0/2] quit

    # Configure Switch2.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch2
    [Switch2] vlan 3
    [Switch2-vlan3] quit
    [Switch2] interface gigabitethernet 1/0/1
    [Switch2-GigabitEthernet1/0/1] port link-type trunk
    [Switch2-GigabitEthernet1/0/1] port trunk allow-pass vlan 3
    [Switch2-GigabitEthernet1/0/1] quit
    [Switch2] interface gigabitethernet 1/0/2
    [Switch2-GigabitEthernet1/0/2] port link-type trunk
    [Switch2-GigabitEthernet1/0/2] port trunk allow-pass vlan 3
    [Switch2-GigabitEthernet1/0/2] quit

  5. Verify the configuration.

    Run the display trunkmembership eth-trunk command in any view to check information about Eth-Trunk member interfaces.

    The display on the CSS is used as an example.

    <CSS> display trunkmembership eth-trunk 10
    Trunk ID: 10
    Used status: VALID
    TYPE: ethernet
    Working Mode : Normal
    Number Of Ports in Trunk = 2
    Number Of Up Ports in Trunk = 2
    Operate status: up
    
    Interface GigabitEthernet1/1/0/4, valid, operate up, weight=1
    Interface GigabitEthernet2/1/0/4, valid, operate up, weight=1

Configuration Files

  • CSS configuration file

    #
     sysname CSS
    #
     vlan batch 2 3
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet1/1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    interface GigabitEthernet2/1/0/3
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    interface GigabitEthernet1/1/0/4
     eth-trunk 10
    #
    interface GigabitEthernet2/1/0/4
     eth-trunk 10
    #
    return         
  • PE configuration file

    #
     sysname PE
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet1/0/1
     eth-trunk 10
    #
    interface GigabitEthernet1/0/2
     eth-trunk 10
    #
    return
  • Switch1 configuration file

    #
     sysname Switch1
    #
     vlan batch 2
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    return
  • Switch2 configuration file

    #
     sysname Switch2
    #
     vlan batch 3
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    return
Translation
Download
Updated: 2019-10-18

Document ID: EDOC1000178310

Views: 287158

Downloads: 141

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next