No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Ethernet Switching

S7700 and S9700 V200R011C10

This document describes the configuration of Ethernet services, including configuring link aggregation, VLANs, Voice VLAN, VLAN mapping, QinQ, GVRP, MAC table, STP/RSTP/MSTP, SEP, and so on.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring LDT to Detect Loops on the Local Network

Example for Configuring LDT to Detect Loops on the Local Network

Networking Requirements

As shown in Figure 20-6, an enterprise uses Layer 2 networking. The Switch is the aggregation switch, and each switch allows packets from VLANs 10 to 20 to pass through. Because employees often move, the network topology changes frequently. Connections or configurations may be incorrect due to misoperations. As a result, loops may occur in VLANs 10 to 20.

Loops cause broadcast storms and affect device and network communication. It is required that loops be detected and eliminated in VLANs in a timely manner to prevent broadcast storms.

Figure 20-6  Networking for configuring LDT to detect loops on the local network

Configuration Roadmap

Loops need to be detected in VLANs 10 to 20. Because there are more than eight VLANs, you can configure LDT to detect loops and configure an action after loops are detected to prevent broadcast storms. All VLANs share a link. To prevent loop removal in a VLAN from affecting data forwarding in other VLANs, configure the QuitVLAN action. The configuration roadmap is as follows:

  1. Enable LDT on GE1/0/0 and GE2/0/0 on the Switch to detect loops in VLANs 10 to 20.

  2. Configure an action taken after a loop is detected on GE1/0/0 and GE2/0/0, and set the recovery time so that the Switch can immediately take the preconfigured action on the interface to prevent broadcast storms after a loop is detected. In addition, the Switch can restore the interface after the loop is eliminated.

NOTE:
  • Configure interfaces on other switching interfaces as trunk or hybrid interfaces and configure these interfaces to allow packets from VLANs to pass through to ensure Layer 2 connectivity.

  • The configurations in this example can also be performed to detect loopbacks on interfaces connecting switching devices.

Procedure

  1. Enable global LDT.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] loop-detection enable

  2. Enable LDT in VLANs.

    [Switch] vlan batch 10 to 20
    [Switch] loop-detection enable vlan 10 to 20

  3. Set the interval for sending LDT packets on the interface.

    [Switch] loop-detection interval-time 10

  4. Configure an action taken after a loop is detected.

    # Enable the trap function for LDT.

    [Switch] snmp-agent trap enable feature-name ldttrap

    Set the action to Quitvlan.

    [Switch] interface gigabitethernet 1/0/0
    [Switch-GigabitEthernet1/0/0] port link-type hybrid
    [Switch-GigabitEthernet1/0/0] stp disable
    [Switch-GigabitEthernet1/0/0] port hybrid tagged vlan 10 to 20
    [Switch-GigabitEthernet1/0/0] loop-detection mode port-quitvlan
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet 2/0/0
    [Switch-GigabitEthernet2/0/0] port link-type hybrid
    [Switch-GigabitEthernet2/0/0] stp disable
    [Switch-GigabitEthernet2/0/0] port hybrid tagged vlan 10 to 20
    [Switch-GigabitEthernet2/0/0] loop-detection mode port-quitvlan
    [Switch-GigabitEthernet2/0/0] quit

  5. Set the interface recovery time.

    [Switch] interface gigabitethernet 1/0/0
    [Switch-GigabitEthernet1/0/0] loop-detection recovery-time 30
    [Switch-GigabitEthernet1/0/0] quit
    [Switch] interface gigabitethernet 2/0/0
    [Switch-GigabitEthernet2/0/0] loop-detection recovery-time 30
    [Switch-GigabitEthernet2/0/0] quit

  6. Verify the configuration.

    1. Check the LDT configuration.

      # After the configuration is complete, run the display loop-detection command to check global LDT information.

      [Switch] display loop-detection
      Loop Detection is enabled.                                                      
      Detection interval time is 10 seconds.                                          
      Following VLANs enable loop-detection:  
       VLAN  10 to 20                         
      Following ports are blocked for loop:                                           
      NULL                                                                            
      Following ports are shutdown for loop:                                          
      NULL                                                                            
      Following ports are nolearning for loop:                                        
      NULL                                                                            
      Following ports are trapped for loop:                                           
      NULL                                                                            
      Following ports are quitvlan for loop:                                          
      GigabitEthernet1/0/0    Include Vlans: 
      10 11 12 16 19 
      GigabitEthernet2/0/0    Include Vlans: 
      13 14 15 17 18 
      20

      # Check LDT information on GE1/0/0 and GE2/0/0.

      [Switch] display loop-detection interface gigabitethernet 1/0/0
      The port is enabled.                                                            
      The port's status list:                                                         
      Status              WorkMode            Recovery-time       EnabledVLAN         
      -----------------------------------------------------------------------         
      Quitvlan         Quitvlan          30               10
      Quitvlan         Quitvlan          30               11                  
      Quitvlan         Quitvlan          30               12                  
      Normal              Quitvlan            30                  13                  
      Normal              Quitvlan            30                  14                  
      Normal              Quitvlan            30                  15                  
      Quitvlan         Quitvlan          30               16                  
      Normal              Quitvlan            30                  17                  
      Normal              Quitvlan            30                  18                  
      Quitvlan         Quitvlan          30               19                  
      Normal              Quitvlan            30                  20                  
      [Switch] display loop-detection interface gigabitethernet 2/0/0
      The port is enabled.                                                            
      The port's status list:                                                         
      Status              WorkMode            Recovery-time       EnabledVLAN         
      -----------------------------------------------------------------------         
      Normal              Quitvlan            30                  10
      Normal              Quitvlan            30                  11                  
      Normal              Quitvlan            30                  12                  
      Quitvlan         Quitvlan          30               13                  
      Quitvlan         Quitvlan          30               14                  
      Quitvlan         Quitvlan          30               15                  
      Normal              Quitvlan            30                  16                  
      Quitvlan         Quitvlan          30               17                  
      Quitvlan         Quitvlan          30               18                  
      Normal              Quitvlan            30                  19                  
      Quitvlan         Quitvlan          30               20                  

      LDT is enabled in VLAN 10 to VLAN 20, the Quitvlan action is taken on GE1/0/0 and GE2/0/0, GE1/0/0 is deleted from VLANs 10, 11, 12, 16, and 19, and GE2/0/0 is deleted from VLAN 13s, 14, 15, 17, 18, and 20.

      NOTE:

      The VLANs where an interface is deleted are uncertain, but the interface is deleted from all VLANs on the network where the loop occurs.

    2. After the loop is eliminated (for example, GE2/0/0 is shut down, and faults in the connection between devices are rectified), check whether GE1/0/0 and GE2/0/0 are restored.

      [Switch] display loop-detection interface gigabitethernet 1/0/0
      The port is enabled.                                                            
      The port's status list:                                                         
      Status              WorkMode            Recovery-time       EnabledVLAN         
      -----------------------------------------------------------------------         
      Normal             Quitvlan            30                  10                  
      Normal             Quitvlan            30                  11                  
      Normal             Quitvlan            30                  12                  
      Normal              Quitvlan            30                  13                  
      Normal              Quitvlan            30                  14                  
      Normal              Quitvlan            30                  15                  
      Normal             Quitvlan            30                  16                  
      Normal              Quitvlan            30                  17                  
      Normal              Quitvlan            30                  18                  
      Normal             Quitvlan            30                  19                  
      Normal              Quitvlan            30                  20                  
      [Switch] display loop-detection interface gigabitethernet 2/0/0
      The port is enabled.                                                            
      The port's status list:                                                         
      Status              WorkMode            Recovery-time       EnabledVLAN         
      -----------------------------------------------------------------------         
      Normal              Quitvlan            30                  10                  
      Normal              Quitvlan            30                  11                  
      Normal              Quitvlan            30                  12                  
      Normal             Quitvlan            30                  13                  
      Normal             Quitvlan            30                  14                  
      Normal             Quitvlan            30                  15                  
      Normal              Quitvlan            30                  16                  
      Normal             Quitvlan            30                  17                  
      Normal             Quitvlan            30                  18                  
      Normal              Quitvlan            30                  19                  
      Normal             Quitvlan            30                  20                  

      The command output shows that GE1/0/0 and GE2/0/0 are restored.

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 10 to 20
#
loop-detection enable
loop-detection interval-time 10
loop-detection enable vlan 10 to 20
#
interface GigabitEthernet1/0/0
 port link-type hybrid
 port hybrid tagged vlan 10 to 20
 stp disable
 loop-detection mode port-quitvlan
 loop-detection recovery-time 30
#
interface GigabitEthernet2/0/0
 port link-type hybrid
 port hybrid tagged vlan 10 to 20
 stp disable
 loop-detection mode port-quitvlan
 loop-detection recovery-time 30
#
snmp-agent
snmp-agent local-engineid 800007DB03020000000211
snmp-agent sys-info version v3 
snmp-agent trap enable feature-name LDTTRAP
#
return
Translation
Download
Updated: 2019-10-18

Document ID: EDOC1000178310

Views: 287476

Downloads: 141

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next