No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Security

S7700 and S9700 V200R011C10

This document describes the configurations of Security, including ACL, reflective ACL, local attack defense, MFF, attack defense, traffic suppression and storm control, ARP security, port security, DHCP snooping, ND snooping, PPPoE+, IPSG, SAVI, URPF, keychain, separating the management plane from the service plane, security risks.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Using Advanced ACLs to Restrict Mutual Access Between Network Segments

Example for Using Advanced ACLs to Restrict Mutual Access Between Network Segments

Networking Requirements

As shown in Figure 1-17, the departments of an enterprise are connected through the Switch. To facilitate network management, the administrator allocates the IP addresses on two network segments to the R&D and marketing departments respectively. In addition, the administrator adds the two departments to different VLANs for broadcast domain isolation. The Switch needs to restrict mutual access between two network segments to ensure information security.

Figure 1-17  Using advanced ACLs to restrict mutual access between network segments

Configuration Roadmap

The following configurations are performed on the Switch. The configuration roadmap is as follows:

  1. Configure an advanced ACL and ACL-based traffic classifier to filter the packets exchanged between R&D and marketing departments.
  2. Configure a traffic behavior to discard the packets matching the ACL.
  3. Configure and apply a traffic policy to make the ACL and traffic behavior take effect.

Procedure

  1. Configure VLANs and IP addresses for interfaces to ensure network connections.

    # Create VLAN 10 and VLAN 20.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 10 20
    

    # Configure GE1/0/1 and GE1/0/2 on the Switch as trunk interfaces and add the interfaces to VLAN 10 and VLAN 20 respectively.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [Switch-GigabitEthernet1/0/2] quit

    # Create VLANIF 10 and VLANIF 20 and assign IP addresses to them.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.1.1.1 24
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 10.1.2.1 24
    [Switch-Vlanif20] quit
    

  2. Configure the ACL.

    # Create advanced ACL 3001 and configure rules for the ACL to block the packets from the R&D department to the marketing department.

    [Switch] acl 3001
    [Switch-acl-adv-3001] rule deny ip source 10.1.1.0 0.0.0.255 destination 10.1.2.0 0.0.0.255
    [Switch-acl-adv-3001] quit

    # Create advanced ACL 3002 and configure rules for the ACL to block the packets from the marketing department to the R&D department.

    [Switch] acl 3002
    [Switch-acl-adv-3002] rule deny ip source 10.1.2.0 0.0.0.255 destination 10.1.1.0 0.0.0.255
    [Switch-acl-adv-3002] quit

  3. Configure an advanced ACL-based traffic classifier.

    # Configure the traffic classifier tc1 to classify packets that match ACL 3001 and ACL 3002.

    [Switch] traffic classifier tc1
    [Switch-classifier-tc1] if-match acl 3001
    [Switch-classifier-tc1] if-match acl 3002
    [Switch-classifier-tc1] quit

  4. Configure a traffic behavior.

    # Configure the traffic behavior tb1 to reject packets.

    [Switch] traffic behavior tb1
    [Switch-behavior-tb1] deny
    [Switch-behavior-tb1] quit

  5. Configure a traffic policy.

    # Define the traffic policy and associate the traffic classifier and traffic behavior with the traffic policy.

    [Switch] traffic policy tp1
    [Switch-trafficpolicy-tp1] classifier tc1 behavior tb1
    [Switch-trafficpolicy-tp1] quit

  6. Apply the traffic policy to interfaces.

    # Packets from the R&D department are received by GE1/0/1 and packets from the marketing department are received by GE1/0/2; therefore, apply the traffic policy to the inbound direction of GE1/0/1 and GE1/0/2.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] traffic-policy tp1 inbound
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] traffic-policy tp1 inbound
    [Switch-GigabitEthernet1/0/2] quit

  7. Verify the configuration.

    # Check the configuration of ACL rules.

    [Switch] display acl 3001
    Advanced ACL 3001, 1 rule                                                       
    Acl's step is 5                                                                 
     rule 5 deny ip source 10.1.1.0 0.0.0.255 destination 10.1.2.0 0.0.0.255   
    
    [Switch] display acl 3002
    Advanced ACL 3002, 1 rule                                                       
    Acl's step is 5                                                                 
     rule 5 deny ip source 10.1.2.0 0.0.0.255 destination 10.1.1.0 0.0.0.255 

    # Check the configuration of the traffic classifier.

    [Switch] display traffic classifier user-defined
      User Defined Classifier Information:
       Classifier: tc1
        Precedence: 5
        Operator: OR
        Rule(s) : if-match acl 3001                                                 
                  if-match acl 3002 
    
    Total classifier number is 1   

    # Check the configuration of the traffic policy.

    [Switch] display traffic policy user-defined tp1
      User Defined Traffic Policy Information:                                      
      Policy: tp1                                                                   
       Classifier: tc1                                                              
        Operator: OR                                                                
         Behavior: tb1                                                              
          Deny  

    # The two network segments where the R&D and marketing departments reside cannot access each other.

Configuration Files

Switch configuration file

#
sysname Switch
#
vlan batch 10 20 
#
acl number 3001                                                                 
 rule 5 deny ip source 10.1.1.0 0.0.0.255 destination 10.1.2.0 0.0.0.255        
acl number 3002                                                                 
 rule 5 deny ip source 10.1.2.0 0.0.0.255 destination 10.1.1.0 0.0.0.255
#
traffic classifier tc1 operator or precedence 5
 if-match acl 3001                                                              
 if-match acl 3002   
#
traffic behavior tb1
 deny
#
traffic policy tp1 match-order config
 classifier tc1 behavior tb1
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif20
 ip address 10.1.2.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type trunk                                                           
 port trunk allow-pass vlan 10 
 traffic-policy tp1 inbound
#
interface GigabitEthernet1/0/2
 port link-type trunk                                                           
 port trunk allow-pass vlan 20 
 traffic-policy tp1 inbound
#
return 

Related Content

Videos

Configure ACL

Translation
Download
Updated: 2019-04-01

Document ID: EDOC1000178319

Views: 145821

Downloads: 78

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next