No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S7700 and S9700 V200R011C10

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IS-IS to Interact with BGP

Example for Configuring IS-IS to Interact with BGP

Networking Requirements

As shown in Figure 7-37, SwitchA and SwitchB belong to the same AS, and the IS-IS neighbor relationship is established between SwitchA and SwitchB. An EBGP connection is established between SwitchB and SwitchC. SwitchA, SwitchB, and SwitchC need to communicate with each other. Besides, the metric of routes need to be changed when AS 65009 sends the routes to AS 65008.

Figure 7-37  Networking diagram for configuring IS-IS to interact with BGP

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces, and enable IS-IS and BGP to ensure that there are reachable routes inside each AS.

  2. Configure IS-IS and BGP to import routes from each other on SwitchB to ensure that there are routes on each network segment. Configure a route-policy to change the metric of imported routes when IS-IS imports BGP routes.

Procedure

  1. Configure VLANs that interfaces belong to.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 10 20
    [SwitchB] interface gigabitethernet 1/0/0
    [SwitchB-GigabitEthernet1/0/0] port link-type trunk
    [SwitchB-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/0] quit
    [SwitchB] interface gigabitethernet 2/0/0
    [SwitchB-GigabitEthernet2/0/0] port link-type trunk
    [SwitchB-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [SwitchB-GigabitEthernet2/0/0] quit

    The configurations of SwitchA and SwitchC are similar to the configuration of SwitchB, and are not mentioned here.

  2. Assign an IP address to each VLANIF interface.

    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ip address 10.1.1.2 24
    [SwitchB-Vlanif10] quit
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ip address 10.2.1.1 24
    [SwitchB-Vlanif20] quit
    [SwitchB] interface LoopBack 0
    [SwitchB-LoopBack0] ip address 172.16.1.1 32
    [SwitchB-LoopBack0] quit

    The configurations of SwitchA and SwitchC are similar to the configuration of SwitchB, and are not mentioned here.

  3. Configure basic IS-IS functions.

    # Configure SwitchA.

    [SwitchA] isis 1
    [SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis enable 1
    [SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [SwitchB] isis 1
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] isis enable 1
    [SwitchB-Vlanif10] quit

  4. Configure an EBGP connection.

    # Configure SwitchB.

    [SwitchB] bgp 65008
    [SwitchB-bgp] router-id 172.16.1.1
    [SwitchB-bgp] peer 10.2.1.2 as-number 65009
    [SwitchB-bgp] ipv4-family unicast
    [SwitchB-bgp-af-ipv4] network 10.2.1.0 255.255.255.0

    # Configure SwitchC.

    [SwitchC] bgp 65009
    [SwitchC-bgp] router-id 172.16.2.2
    [SwitchC-bgp] peer 10.2.1.1 as-number 65008
    [SwitchC-bgp] ipv4-family unicast
    [SwitchC-bgp-af-ipv4] network 10.2.1.0 255.255.255.0

  5. Configure IS-IS to import BGP routes.

    # Configure a static route on SwitchC.

    [SwitchC] ip route-static 192.168.1.1 32 NULL 0

    # On SwitchC, configure BGP to import the static route.

    [SwitchC] bgp 65009
    [SwitchC-bgp] import-route static

    # On SwitchB, configure IS-IS to import the BGP route.

    [SwitchB] isis 1
    [SwitchB-isis-1] import-route bgp
    [SwitchB-isis-1] quit

    # View the routing table of SwitchA, and you can find that IS-IS successfully imports the BGP route 192.168.1.1/32.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5        Routes : 5
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
           10.2.1.0/24  ISIS-L1 15   20          D   10.1.1.2        Vlanif10
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.1/32  ISIS-L2 15   74          D   10.1.1.2        Vlanif10

    # On SwitchB, configure the AS-Path filter, and apply the filter in the routing policy named RTC.

    [SwitchB] ip as-path-filter 1 permit 65009
    [SwitchB] route-policy RTC permit node 0
    [SwitchB-route-policy] if-match as-path-filter 1
    [SwitchB-route-policy] apply cost 20
    [SwitchB-route-policy] quit

    # On SwitchB, configure IS-IS to import the BGP route on SwitchC.

    [SwitchB] isis 1
    [SwitchB-isis-1] import-route bgp route-policy RTC
    [SwitchB-isis-1] quit

    # View the routing table of SwitchA, and you can find that the AS-Path filter is successfully applied and the cost of the imported route 192.168.1.1/32 changes from 74 to 94.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5        Routes : 5
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
           10.2.1.0/24  ISIS-L1 15   20          D   10.1.1.2        Vlanif10
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.1/32  ISIS-L2 15   94          D   10.1.1.2        Vlanif10

  6. Configure BGP to import an IS-IS route.

    [SwitchB] bgp 65008
    [SwitchB-bgp] import-route isis 1
    [SwitchB-bgp] quit

    # View the routing table of SwitchC, and you can find that BGP successfully imports the IS-IS route 10.1.1.0/24.

    [SwitchC] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 6        Routes : 6
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          10.1.1.0/24  EBGP    255  0           D   10.2.1.1        Vlanif20
           10.2.1.0/24  Direct  0    0           D   10.2.1.2        Vlanif20
           10.2.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif20
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
         172.16.2.2/32  Direct  0    0           D   127.0.0.1       LoopBack0
        192.168.1.1/32  Static  60   0           D   0.0.0.0         NULL0
    

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    isis 1
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    isis 1
     network-entity 10.0000.0000.0002.00
     import-route bgp route-policy RTC
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
     isis enable 1
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 172.16.1.1 255.255.255.255
    #
    bgp 65008
     router-id 172.16.1.1
     peer 10.2.1.2 as-number 65009
     #
     ipv4-family unicast
      undo synchronization
      network 10.2.1.0 255.255.255.0
      import-route isis 1
      peer 10.2.1.2 enable
    #
    route-policy RTC permit node 0
     if-match as-path-filter 1
     apply cost 20
    #
    ip as-path-filter 1 permit 65009
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
     vlan batch 20
    #
    interface Vlanif20
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 172.16.2.2 255.255.255.255
    #
    bgp 65009
     router-id 172.16.2.2
     peer 10.2.1.1 as-number 65008
     #
     ipv4-family unicast
      undo synchronization
      network 10.2.1.0 255.255.255.0
      import-route static
      peer 10.2.1.1 enable
    #
    ip route-static 192.168.1.1 255.255.255.255 NULL0
    #
    return
Translation
Download
Updated: 2019-04-01

Document ID: EDOC1000178324

Views: 206293

Downloads: 178

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next