No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S7700 and S9700 V200R011C10

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IS-IS Fast Convergence

Example for Configuring IS-IS Fast Convergence

Networking Requirements

As shown in Figure 7-39, two Switches are connected through a Layer 2 switch. The two switches communicate with each other through the IS-IS protocol. The convergence speed of the two switches needs to be improved.

Figure 7-39  Networking diagram of IS-IS fast convergence

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the IP addresses of interfaces and the IS-IS route-policy on each switch.

  2. Configure BFD sessions on SwitchA and SwitchB to improve the link fault detection speed of the switches.

  3. Set the time parameters of fast convergence on SwitchA and SwitchB to implement IS-IS fast convergence.

Procedure

  1. Configure VLANs that interfaces belong to.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type trunk
    [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/0] quit

    The configurations of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

  2. Assign an IP address to each VLANIF interface.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit

    The configurations of SwitchB is similar to the configuration of SwitchA, and is not mentioned here.

  3. Configure basic IS-IS functions.

    # Configure SwitchA.

    [SwitchA] isis 1
    [SwitchA-isis-1] is-level level-2
    [SwitchA-isis-1] network-entity 10.0000.0000.0001.00
    [SwitchA-isis-1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis enable 1
    [SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [SwitchB] isis 1
    [SwitchB-isis-1] is-level level-2
    [SwitchB-isis-1] network-entity 10.0000.0000.0002.00
    [SwitchB-isis-1] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] isis enable 1
    [SwitchB-Vlanif10] quit

  4. Simulate the link in the Down state on SwitchB. View the neighbor status and the time of route calculation on SwitchA.

    # Enable the debugging on SwitchA and output information to the VTY channel.

    [SwitchA] info-center source bfd channel 1 log level debugging state on
    [SwitchA] quit
    <SwitchA> debugging isis spf-summary
    <SwitchA> terminal debugging
    <SwitchA> terminal monitor

    Run the shutdown command on Vlanif10 of SwitchB.

    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] shutdown

    # View the information about neighbors of SwitchA.

    <SwitchA> display isis peer
                              Peer information for ISIS(1)
                              ----------------------------
      System Id    Interface          Circuit Id         State  HoldTime  Type     PRI
    0000.0000.0002 Vlanif10           0000.0000.0001.01   Up    20s       L2       64
    Total Peer(s): 1

    After the link goes Down, the system does not immediately advertise that the neighbor becomes invalid but deletes the neighbor after the Holdtime timer times out, and then starts route calculation. You can view the time of the SPF calculation through the following debugging information.

    <SwitchA>
    Jan 21 2013 21:15:06.240.3+06:00 SwitchA ISIS/6/ISIS:
     Signal SPF at MSEC(H=0, L=88936241).
    
    <SwitchA>
    Jan 21 2013 21:15:06.240.4+06:00 SwitchA ISIS/6/ISIS:
     Signal SPF at MSEC(H=0, L=88936242).
    
    <SwitchA>
    Jan 21 2013 21:15:06.290.1+06:00 SwitchA ISIS/6/ISIS:
     Run ISPF Calculation at MSEC(H=0, L=88936292).
    
    <SwitchA>
    Jan 21 2013 21:15:06.290.2+06:00 SwitchA ISIS/6/ISIS:
     Run ISPF Job at MSEC(H=0, L=88936292).
    
    <SwitchA>
    Jan 21 2013 21:15:06.290.3+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-DEC: [L2-MT0] SPF starts to run at MSEC(H=0, L=88936293).(IS09_8021)
    
    <SwitchA>
    Jan 21 2013 21:15:06.290.4+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-DEC: [L2-MT0] Calculating SPT completed. (Used-Time=0MS)(IS09_8037)
    
    <SwitchA>
    Jan 21 2013 21:15:06.290.5+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-SPF-PRC: Received MT 0 L2 System Change Event for 0000.0000.0001.01, Change = 2(IS10_7970)
    
    <SwitchA>
    Jan 21 2013 21:15:06.290.6+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-SPF-PRC: Received MT 0 L2 System Change Event for 0000.0000.0002.00, Change = 2(IS10_7970)
    
    <SwitchA>
    Jan 21 2013 21:15:06.290.7+06:00 SwitchA ISIS/6/ISIS:
     Prc job scheduled at MSEC(H=0, L=88936295).
    
    <SwitchA>
    Jan 21 2013 21:15:06.290.8+06:00 SwitchA ISIS/6/ISIS:
     Run ISPF Job at MSEC(H=0, L=88936295).
    
    <SwitchA>
    Jan 21 2013 21:15:06.300.1+06:00 SwitchA ISIS/6/ISIS:
     Prc job starts to run at MSEC(H=0, L=88936301).
    
    <SwitchA>
    Jan 21 2013 21:15:06.300.2+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-SPF-PRC: [L2-MT0] Processing LSPs of System :0000.0000.0002. (ChangeType=2)(IS10_8481)
    
    <SwitchA>
    Jan 21 2013 21:15:06.300.3+06:00 SwitchA ISIS/6/ISIS:
     Prc job completed at MSEC(H=0, L=88936302).
    
    <SwitchA>
    Jan 21 2013 21:15:06.300.4+06:00 SwitchA ISIS/6/ISIS:
     Prc job scheduled at MSEC(H=0, L=88936302).

    In the Holdtime period, packets cannot correctly reach the destination because the route passing through VLANIF10 is discarded. You then need to enable BFD and set the time parameters of fast convergence. The switches can quickly sense the changes of the topology and recalculate routes when the network changes.

  5. Restart the interface on SwitchB to make the link become Up.

    # Run the undo shutdown command on Vlanif10 of SwitchB.

    [SwitchB-Vlanif10] undo shutdown

  6. Configure BFD.

    # Configure SwitchA.

    [SwitchA] bfd
    [SwitchA-bfd] quit
    [SwitchA] bfd atob bind peer-ip 10.1.1.2 interface vlanif 10
    [SwitchA-bfd-session-atob] discriminator local 1
    [SwitchA-bfd-session-atob] discriminator remote 2
    [SwitchA-bfd-session-atob] commit
    [SwitchA-bfd-session-atob] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] isis bfd static
    [SwitchA-Vlanif10] quit

    # Configure SwitchB.

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] bfd btoa bind peer-ip 10.1.1.1 interface vlanif 10
    [SwitchB-bfd-session-btoa] discriminator local 2
    [SwitchB-bfd-session-btoa] discriminator remote 1
    [SwitchB-bfd-session-btoa] commit
    [SwitchB-bfd-session-btoa] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] isis bfd static
    [SwitchB-Vlanif10] quit

  7. Set the time parameters of fast convergence.

    # Configure SwitchA.

    [SwitchA] isis 
    [SwitchA-isis-1] flash-flood
    [SwitchA-isis-1] timer spf 1 20 100
    [SwitchA-isis-1] timer lsp-generation 1 1 120
    [SwitchA-isis-1] quit

    # Configure SwitchB.

    [SwitchB] isis 
    [SwitchB-isis-1] flash-flood
    [SwitchB-isis-1] timer spf 1 20 100
    [SwitchB-isis-1] timer lsp-generation 1 1 120
    [SwitchB-isis-1] quit
    NOTE:
    • In IS-IS, if LSDB changes, routes are calculated and then a new LSP is generated to report this change. Frequent route calculations consume lots of system resources and degrades the system performance. Delaying SPF calculation, generating a new LSP time, and LSP fast flooding improves the efficiency in route calculation and reduces the consumption of system resources.

    • Using the flash-flood command, you can enable LSP fast flooding to speed up the convergence of an IS-IS network.

    • Run the timer spf command to set the interval of the SPF calculation. By default, the interval is 5 seconds.

    • Run the timer lsp-generation command to set the delay for generating an LSP. By default, the delay is 2 seconds.

  8. Verify the configuration.

    # Run the shutdown command on Vlanif10 of SwitchB to simulate the link in the Down state.

    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] shutdown

    # View the information about neighbors of SwitchA.

    [SwitchA] display isis peer

    Information about neighbors of SwitchA does not exist.

    When BFD detects that the link goes Down, it notifies the route management (RM) module immediately. IS-IS then deletes neighbors immediately and triggers the route calculation. This results in the fast convergence of the network. You can view that the time of the SPF calculation is shortened by comparing debugging information displayed before and after fast convergence.

    <SwitchA>
    Jan 21 2014 21:33:45.990.3+06:00 SwitchA ISIS/6/ISIS:
     Signal SPF at MSEC(H=0, L=90055991).
    
    <SwitchA>
    Jan 21 2014 21:33:45.990.4+06:00 SwitchA ISIS/6/ISIS:
     Signal SPF at MSEC(H=0, L=90055991).
    
    <SwitchA>
    Jan 21 2014 21:33:46.10.1+06:00 SwitchA ISIS/6/ISIS:
     Run ISPF Calculation at MSEC(H=0, L=90056011).
    
    <SwitchA>
    Jan 21 2014 21:33:46.10.2+06:00 SwitchA ISIS/6/ISIS:
     Run ISPF Job at MSEC(H=0, L=90056011).
    
    <SwitchA>
    Jan 21 2014 21:33:46.10.3+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-DEC: [L2-MT0] SPF starts to run at MSEC(H=0, L=90056011).(IS09_8021)
    
    <SwitchA>
    Jan 21 2014 21:33:46.10.4+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-DEC: [L2-MT0] Calculating SPT completed. (Used-Time=1MS)(IS09_8037)
    
    <SwitchA>
    Jan 21 2014 21:33:46.10.5+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-SPF-PRC: Received MT 0 L2 System Change Event for 0000.0000.0001.01, Change = 2(IS10_7970)
    
    <SwitchA>
    Jan 21 2014 21:33:46.10.6+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-SPF-PRC: Received MT 0 L2 System Change Event for 0000.0000.0002.00, Change = 2(IS10_7970)
    
    <SwitchA>
    Jan 21 2014 21:33:46.10.7+06:00 SwitchA ISIS/6/ISIS:
     Prc job scheduled at MSEC(H=0, L=90056013).
    
    <SwitchA>
    Jan 21 2014 21:33:46.10.8+06:00 SwitchA ISIS/6/ISIS:
     Run ISPF Job at MSEC(H=0, L=90056014).
    
    <SwitchA>
    Jan 21 2014 21:33:46.20.1+06:00 SwitchA ISIS/6/ISIS:
     Prc job starts to run at MSEC(H=0, L=90056021).
    
    <SwitchA>
    Jan 21 2014 21:33:46.20.2+06:00 SwitchA ISIS/6/ISIS:
     ISIS-1-SPF-PRC: [L2-MT0] Processing LSPs of System :0000.0000.0002. (ChangeType=2)(IS10_8481)
    
    <SwitchA>
    Jan 21 2014 21:33:46.20.3+06:00 SwitchA ISIS/6/ISIS:
     Prc job completed at MSEC(H=0, L=90056022).
    
    <SwitchA>
    Jan 21 2014 21:33:46.20.4+06:00 SwitchA ISIS/6/ISIS:
     Prc job scheduled at MSEC(H=0, L=90056022).

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10
    #
    info-center source BFD channel 1 log level debugging
    #
    bfd
    #
    isis 1
     is-level level-2
     timer lsp-generation 1 1 120 level-1
     timer lsp-generation 1 1 120 level-2
     network-entity 10.0000.0000.0001.00
     flash-flood level-1
     flash-flood level-2
     timer spf 1 20 100
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     isis enable 1
     isis bfd static
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    bfd atob bind peer-ip 10.1.1.2 interface Vlanif10
     discriminator local 1
     discriminator remote 2
     commit
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    bfd
    #
    isis 1
     is-level level-2
     timer lsp-generation 1 1 120 level-1
     timer lsp-generation 1 1 120 level-2
     network-entity 10.0000.0000.0002.00
     flash-flood level-1
     flash-flood level-2
     timer spf 1 20 100
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     isis enable 1
     isis bfd static
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    bfd btoa bind peer-ip 10.1.1.2 interface Vlanif10
     discriminator local 2
     discriminator remote 1
     commit
    #
    return
Translation
Download
Updated: 2019-04-01

Document ID: EDOC1000178324

Views: 222670

Downloads: 194

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next