No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S7700 and S9700 V200R011C10

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IS-IS Auto FRR (TE Protecting IP)

Example for Configuring IS-IS Auto FRR (TE Protecting IP)

Networking Requirements

Figure 7-41 shows the simplified networking diagram of MPLS VPN dual plane, and PEs are dual-homed to the two planes. Routes run IS-IS to implement route reachability. The reliability of data forwarding between PEs needs to be improved so that uninterrupted traffic transmission is ensured when a fault occurs on the network.

NOTE:

In this scenario, ensure that all connected interfaces have STP disabled. If STP is enabled and VLANIF interfaces of switches are used to construct a Layer 3 ring network, an interface on the network will be blocked. As a result, Layer 3 services on the network cannot run normally.

Figure 7-41  Networking diagram of configuring IS-IS Auto FRR

Data Plan

Table 7-12  IP addresses of interconnected interfaces

Link Name

(Local End-Remote End)

Local Interface and IP Address

Remote Interface and IP Address

P1–P2

GE1/0/0

VLANIF10:10.1.1.1/30

GE1/0/0

VLANIF10:10.1.1.2/30

P1–P3

GE2/0/0

VLANIF30:10.1.2.1/30

GE2/0/0

VLANIF30:10.1.2.2/30

P1–P5

GE3/0/0

VLANIF20:10.1.3.1/30

GE2/0/0

VLANIF20:10.1.3.2/30

P2–P4

GE2/0/0

VLANIF70:10.1.4.1/30

GE2/0/0

VLANIF70:10.1.4.2/30

P2–P6

GE3/0/0

VLANIF60:10.1.5.1/30

GE2/0/0

VLANIF60:10.1.5.2/30

P3–P4

GE1/0/0

VLANIF100:10.1.6.1/30

GE1/0/0

VLANIF100:10.1.6.2/30

P3–P5

GE3/0/0

VLANIF90:10.1.7.1/30

GE3/0/0

VLANIF90:10.1.7.2/30

P4–P6

GE3/0/0

VLANIF130:10.1.8.1/30

GE3/0/0

VLANIF130:10.1.8.2/30

P5–P6

GE1/0/0

VLANIF80:10.1.9.1/30

GE1/0/0

VLANIF80:10.1.9.2/30

PE1–P1

GE1/0/0

VLANIF40:10.1.10.1/30

GE4/0/0

VLANIF40:10.1.10.2/30

PE1–P2

GE2/0/0

VLANIF50:10.1.11.1/30

GE4/0/0

VLANIF50:10.1.11.2/30

PE3–P3

GE1/0/0

VLANIF110:10.1.12.1/30

GE4/0/0

VLANIF110:10.1.12.2/30

PE3–P4

GE2/0/0

VLANIF120:10.1.13.1/30

GE4/0/0

VLANIF120:10.1.13.2/30

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure IP addresses for interfaces of each node, configure the IP addresses of loopback interfaces that are used as LSR IDs, and configure IS-IS to implement IP connectivity.

  2. Configure an MPLS TE tunnel between P nodes as the loop-free alternate (LFA) backup path.

  3. Enable IS-IS Auto FRR on P nodes so that traffic can be rapidly switched in the case of a link fault. Disable the interfaces that connect P nodes to PE nodes from becoming LFA backup interfaces and prevent traffic between P nodes from going back to PE nodes.

NOTE:
This example uses two PEs (PE1 and PE3), three P nodes on each plane at the core layer, and one MPLS TE tunnel between P1 and P3 as an example. In practice, there are far more PE nodes, P nodes, and MPLS TE tunnels.

Procedure

  1. Configure VLANs that each interface belongs to.

    <HUAWEI> system-view
    [HUAWEI] sysname P1
    [P1] vlan batch 10 20 30 40
    [P1] interface gigabitethernet 1/0/0
    [P1-GigabitEthernet1/0/0] port link-type trunk
    [P1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [P1-GigabitEthernet1/0/0] quit
    [P1] interface gigabitethernet 3/0/0
    [P1-GigabitEthernet3/0/0] port link-type trunk
    [P1-GigabitEthernet3/0/0] port trunk allow-pass vlan 20
    [P1-GigabitEthernet3/0/0] quit
    [P1] interface gigabitethernet 2/0/0
    [P1-GigabitEthernet2/0/0] port link-type trunk
    [P1-GigabitEthernet2/0/0] port trunk allow-pass vlan 30
    [P1-GigabitEthernet2/0/0] quit
    [P1] interface gigabitethernet 4/0/0
    [P1-GigabitEthernet4/0/0] port link-type trunk
    [P1-GigabitEthernet4/0/0] port trunk allow-pass vlan 40
    [P1-GigabitEthernet4/0/0] quit

    The VLAN configurations of other nodes are similar to the VLAN configuration of P1, and are not mentioned here.

  2. Configure IP addresses to VLANIF interfaces.

    [P1] interface vlanif 10
    [P1-Vlanif10] ip address 10.1.1.1 30
    [P1-Vlanif10] quit
    [P1] interface vlanif 20
    [P1-Vlanif20] ip address 10.1.3.1 30
    [P1-Vlanif20] quit
    [P1] interface vlanif 30
    [P1-Vlanif30] ip address 10.1.2.1 30
    [P1-Vlanif30] quit
    [P1] interface vlanif 40
    [P1-Vlanif40] ip address 10.1.10.2 30
    [P1-Vlanif40] quit

    The VLAN configurations of other nodes are similar to the VLAN configuration of P1, and are not mentioned here.

  3. Configure IS-IS.

    Configure IS-IS on all the PE and P nodes. Configure IS-IS on P1 and PE1. The configurations of other nodes are similar to the configurations of P1 and PE1, and are not mentioned here.

    # Configure P1.

    [P1] router id 172.16.1.1
    [P1] isis 64
    [P1-isis-64] network-entity 86.0010.0010.0100.1001.00
    [P1-isis-64] is-level level-2
    [P1-isis-64] cost-style wide
    [P1-isis-64] is-name P1
    [P1-isis-64] quit
    [P1] interface loopback 0
    [P1-LoopBack0] isis enable 64
    [P1-LoopBack0] quit
    [P1] interface vlanif 10
    [P1-Vlanif10] isis enable 64
    [P1-Vlanif10] isis cost 5
    [P1-Vlanif10] quit
    [P1] interface vlanif 30
    [P1-Vlanif30] isis enable 64
    [P1-Vlanif30] isis cost 5
    [P1-Vlanif30] quit
    [P1] interface vlanif 20
    [P1-Vlanif20] isis enable 64
    [P1-Vlanif20] isis cost 5
    [P1-Vlanif20] quit
    [P1] interface vlanif 40
    [P1-Vlanif40] isis enable 64
    [P1-Vlanif40] isis cost 5
    [P1-Vlanif40] quit

    # Configure PE1.

    [PE1] router id 172.16.7.7
    [PE1] isis 64
    [PE1-isis-64] network-entity 86.0010.0070.0700.7007.00
    [PE1-isis-64] is-level level-2
    [PE1-isis-64] cost-style wide
    [PE1-isis-64] is-name PE1
    [PE1-isis-64] quit
    [PE1] interface loopback 0
    [PE1-LoopBack0] isis enable 64
    [PE1-LoopBack0] quit
    [PE1] interface vlanif 40
    [PE1-Vlanif40] isis enable 64
    [PE1-Vlanif40] isis cost 5
    [PE1-Vlanif40] quit
    [PE1] interface vlanif 50
    [PE1-Vlanif50] isis enable 64
    [PE1-Vlanif50] isis cost 5
    [PE1-Vlanif50] quit

    After the preceding configurations, run the display ip routing-table command on each node, and you can see that the nodes learn routes from each other. For example, when checking whether there are routes to the IP address of Loopback 0 on PE1, you can see the following information:

    [PE1] display ip routing-table 172.16.1.1 32
          Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Table : Public
    Summary Count : 1
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
         172.16.1.1/32  ISIS-L2 15   5           D   10.1.10.2       Vlanif40

  4. Configure an MPLS TE tunnel.

    Enable MPLS, MPLS TE, and RSVP-TE on the interfaces of P1, P2, P3, and P4, and enable CSPF on the ingress of the tunnel.

    Configure P1 and P2. The configuration of P3 is similar to that of P1, and the configuration of P4 is similar to that of P2.

    # Configure P1.

    [P1] mpls lsr-id 172.16.1.1
    [P1] mpls
    [P1-mpls] mpls te
    [P1-mpls] mpls rsvp-te
    [P1-mpls] mpls te cspf
    [P1-mpls] quit
    [P1] interface vlanif 10
    [P1-Vlanif10] mpls
    [P1-Vlanif10] mpls te
    [P1-Vlanif10] mpls rsvp-te
    [P1-Vlanif10] mpls te bandwidth max-reservable-bandwidth 200000
    [P1-Vlanif10] mpls te bandwidth bc0 200000
    [P1-Vlanif10] quit

    # Configure P2.

    [P2] mpls lsr-id 172.16.2.2
    [P2] mpls
    [P2-mpls] mpls te
    [P2-mpls] mpls rsvp-te
    [P2-mpls] quit
    [P2] interface vlanif 10
    [P2-Vlanif10] mpls
    [P2-Vlanif10] mpls te
    [P2-Vlanif10] mpls rsvp-te
    [P2-Vlanif10] mpls te bandwidth max-reservable-bandwidth 200000
    [P2-Vlanif10] mpls te bandwidth bc0 200000
    [P2-Vlanif10] quit
    [P2] interface vlanif 70
    [P2-Vlanif70] mpls
    [P2-Vlanif70] mpls te
    [P2-Vlanif70] mpls rsvp-te
    [P2-Vlanif70] mpls te bandwidth max-reservable-bandwidth 200000
    [P2-Vlanif70] mpls te bandwidth bc0 200000
    [P2-Vlanif70] quit

    # Configure an explicit path for the TE tunnel on P1. The configuration of P3 is similar to the configuration of P1, and is not mentioned here.

    [P1] explicit-path to_P3
    [P1-explicit-path-to_p3] next hop 10.1.1.2
    [P1-explicit-path-to_p3] next hop 10.1.4.2
    [P1-explicit-path-to_p3] next hop 10.1.6.1
    [P1-explicit-path-to_p3] next hop 172.16.3.3
    [P1-explicit-path-to_p3] quit

    # Configure a tunnel interface on P1. The configuration of P3 is similar to the configuration of P1, and is not mentioned here.

    [P1] interface Tunnel 1
    [P1-Tunnel1] ip address unnumbered interface loopback0
    [P1-Tunnel1] tunnel-protocol mpls te
    [P1-Tunnel1] destination 172.16.3.3
    [P1-Tunnel1] mpls te tunnel-id 100
    [P1-Tunnel1] mpls te bandwidth ct0 200000
    [P1-Tunnel1] mpls te path explicit-path to_P3
    [P1-Tunnel1] mpls te commit

    After the preceding configurations, run the display interface tunnel 1 command on P1 and P3, you can see that the status of the tunnel interface is Up.

    [P1] display interface tunnel 1
    Tunnel1 current state : UP
    Line protocol current state : UP
    Last up time: 2009-09-29, 16:35:10
    Description : to_P3

  5. Configuring LDP over TE.

    Enable MPLS LDP. Configure PE1, P1, P3, and P5. The configurations of other nodes are similar to the configurations of PE1, P1, P3, and P5, and are not mentioned here.

    # Configure PE1.

    [PE1] mpls lsr-id 172.16.7.7
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface vlanif 40
    [PE1-Vlanif40] mpls
    [PE1-Vlanif40] mpls ldp
    [PE1-Vlanif40] quit

    # Configure P1.

    [P1] mpls ldp
    [P1] interface vlanif 30
    [P1-Vlanif30] mpls ldp
    [P1-Vlanif30] quit
    [P1] interface vlanif 20
    [P1-Vlanif20] mpls ldp
    [P1-Vlanif20] quit
    [P1] interface vlanif 40
    [P1-Vlanif40] mpls ldp
    [P1-Vlanif40] quit
    [P1] mpls ldp remote-peer to_P3
    [P1-mpls-ldp-remote-to_P3] remote-ip 172.16.3.3
    [P1-mpls-ldp-remote-to_P3] quit

    # Configure P3.

    [P3] mpls ldp
    [P3] interface vlanif 30
    [P3-Vlanif30] mpls ldp
    [P3-Vlanif30] quit
    [P3] interface vlanif 90
    [P3-Vlanif90] mpls ldp
    [P3-Vlanif90] quit
    [P3] interface vlanif 110
    [P3-Vlanif110] mpls ldp
    [P3-Vlanif110] quit
    [P3] mpls ldp remote-peer to_P1
    [P3-mpls-ldp-remote-to_P1] remote-ip 172.16.1.1
    [P3-mpls-ldp-remote-to_P1] quit

    # Configure P5.

    [P5] mpls lsr-id 172.16.5.5
    [P5] mpls
    [P5-mpls] quit
    [P5] mpls ldp
    [P5-mpls-ldp] quit
    [P5] interface vlanif 20
    [P5-Vlanif20] mpls
    [P5-Vlanif20] mpls ldp
    [P5-Vlanif20] quit
    [P5] interface vlanif 90
    [P5-Vlanif90] mpls
    [P5-Vlanif90] mpls ldp
    [P5-Vlanif90] quit

    # On the tunnel interface, enable forwarding adjacency and an IS-IS process, and adjust the metric of the tunnel interface so that the tunnel interface can become the outbound interface of the second best IS-IS route. The following uses the configuration of P1 as an example. The configuration of P3 is similar to the configuration of P1, and is not mentioned here.

    [P1] interface tunnel 1
    [P1-Tunnel1] mpls te igp advertise
    [P1-Tunnel1] mpls te igp metric absolute 6
    [P1-Tunnel1] mpls te commit
    [P1-Tunnel1] isis enable 1

    After the preceding configuration, run the display mpls ldp lsp command on PE1, you can see that an LDP LSP is established. Take the display on PE1 as an example.

    [PE1] display mpls ldp lsp 172.16.8.8 32
    
     LDP LSP Information
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel    UpstreamPeer    NextHop         OutInterface
     -------------------------------------------------------------------------------
     172.16.8.8/32      NULL/3         -               10.1.10.2       Vlanif10
     172.16.8.8/32      1024/3         172.16.1.1      10.1.10.2       Vlanif10
     -------------------------------------------------------------------------------
     TOTAL: 2 Normal LSP(s) Found.
     TOTAL: 0 Liberal LSP(s) Found.
     TOTAL: 0 Frr LSP(s) Found.
     A '*' before an LSP means the LSP is not established
     A '*' before a Label means the USCB or DSCB is stale
     A '*' before a UpstreamPeer means the session is in GR state
     A '*' before a NextHop means the LSP is FRR LSP

  6. Configure IS-IS Auto FRR.

    Enable IS-IS Auto FRR on P1 and P3, and disable the interfaces that connect P nodes to PE nodes from becoming IS-IS LFA backup interfaces.

    # Configure P1.

    [P1] isis 64
    [P1-isis-64] frr
    [P1-isis-64-frr] loop-free-alternate level-2
    [P1-isis-64-frr] quit
    [P1-isis-64] quit
    [P1] interface vlanif 40
    [P1-Vlanif40] undo isis lfa-backup
    [P1-Vlanif40] quit

    # Configure P3.

    [P3] isis 64
    [P3-isis-64] frr
    [P3-isis-64-frr] loop-free-alternate level-2
    [P3-isis-64-frr] quit
    [P3-isis-64] quit
    [P3] interface vlanif 110
    [P3-Vlanif110] undo isis lfa-backup
    [P3-Vlanif110] quit

  7. Verify the configuration.

    # Run the display fib 172.16.3.3 32 verbose command on P1 to view the FIB entry to P3.

    [P1] display fib 172.16.3.3 32 verbose
      Route Entry Count: 1
     Destination: 172.16.3.3          Mask     : 255.255.255.255
     Nexthop    : 10.1.2.2            OutIf    : Vlanif30
     LocalAddr  : 10.1.2.1            LocalMask: 0.0.0.0
     Flags      : DGU                 Age      : 124sec
     ATIndex    : 0                   Slot     : 0
     LspFwdFlag : 0                   LspToken : 0x0
     InLabel    : NULL                OriginAs : 0
     BGPNextHop : 0.0.0.0             PeerAs   : 0
     QosInfo    : 0x0                 OriginQos: 0x0
     NexthopBak : 10.1.1.2            OutIfBak : Tunnel1
     LspTokenBak: 0x0                 InLabelBak : NULL
     LspToken_ForInLabelBak     : 0x0
     EntryRefCount : 0
     VlanId : 0x0                 
     BgpKey : 0                   
     BgpKeyBak : 0 
     LspType         : 0              Label_ForLspTokenBak   : 0
     MplsMtu         : 0              Gateway_ForLspTokenBak : 0.0.0.0
     NextToken       : 0x0            IfIndex_ForLspTokenBak : 0
     Label_NextToken : 0              Label : 0
     LspBfdState     : 0
    
    

    # Run the shutdown command on Vlanif 30 of P1 to simulate a link fault.

    [P1] interface Vlanif 30
    [P1-Vlanif30] shutdown

    # Run the display fib 172.16.3.3 32 verbose command on P1 to view the FIB entry to P3.

    [P1] display fib 172.16.3.3 32 verbose
      Route Entry Count: 1
     Destination: 172.16.3.3          Mask     : 255.255.255.255
     Nexthop    : 10.1.1.2            OutIf    : Tunnel1
     LocalAddr  : 10.1.1.1            LocalMask: 0.0.0.0
     Flags      : DGU                 Age      : 124sec
     ATIndex    : 0                   Slot     : 0
     LspFwdFlag : 0                   LspToken : 0x0
     InLabel    : NULL                OriginAs : 0
     BGPNextHop : 0.0.0.0             PeerAs   : 0
     QosInfo    : 0x0                 OriginQos: 0x0
     NexthopBak : 0.0.0.0             OutIfBak : [No Intf]
     LspTokenBak: 0x0                 InLabelBak : NULL
     LspToken_ForInLabelBak     : 0x0
     EntryRefCount : 0
     VlanId : 0x0                 
     BgpKey : 0                   
     BgpKeyBak : 0 
     LspType         : 0              Label_ForLspTokenBak   : 0
     MplsMtu         : 0              Gateway_ForLspTokenBak : 0.0.0.0
     NextToken       : 0x0            IfIndex_ForLspTokenBak : 0
     Label_NextToken : 0              Label : 0
     LspBfdState     : 0
    
    

    As shown in the command output, traffic from P1 to P3 has been switched to the backup link with the outbound interface being Tunnel1.

Configuration Files

  • Configuration file of P1

    #
    sysname P1
    #
    router id 172.16.1.1
    #
    mpls lsr-id 172.16.1.1
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path to_p3
     next hop 10.1.1.2
     next hop 10.1.4.2
     next hop 10.1.6.1
     next hop 172.16.3.3
    #
    mpls ldp
    #
     mpls ldp remote-peer to_p3
     remote-ip 172.16.3.3
     #
    isis 64
     is-level level-2
     cost-style wide
     network-entity 86.0010.0010.0100.1001.00
     is-name P1
     frr
      loop-free-alternate level-2
    #
    interface LoopBack0
     ip address 172.16.1.1 255.255.255.255
     isis enable 64
    #
    interface Tunnel1
     description to_P3
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 172.16.3.3
     mpls te tunnel-id 100
     mpls te bandwidth ct0 200000
     mpls te path explicit-path to_p3
     mpls te igp advertise
     mpls te igp metric absolute 6
     mpls te commit
     isis enable 64
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls te
     mpls rsvp-te
     mpls te bandwidth max-reservable-bandwidth 200000
     mpls te bandwidth bc0 200000
    #
    interface Vlanif30
     ip address 10.1.2.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.1.3.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 10.1.10.2 255.255.255.252
     isis enable 64
     isis cost 5
     undo isis lfa-backup
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 40 
    #
    return
  • Configuration file of P2

    #
    sysname P2
    #
    router id 172.16.2.2
    #
    mpls lsr-id 172.16.2.2
    mpls
     mpls te
     mpls rsvp-te
    #
    mpls ldp
    #
    isis 64
     is-level level-2
     cost-style wide
     network-entity 86.0010.0020.0200.2002.00
     is-name P2
    #
    interface LoopBack0
     ip address 172.16.2.2 255.255.255.255
     isis enable 64
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls te
     mpls rsvp-te
     mpls te bandwidth max-reservable-bandwidth 200000
     mpls te bandwidth bc0 200000
    #
    interface Vlanif70
     ip address 10.1.4.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 200000
     mpls te bandwidth bc0 200000
     mpls ldp
    #
    interface Vlanif60
     ip address 10.1.5.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif50
     ip address 10.1.11.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 70 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    return
  • Configuration file of P3

    #
    sysname P3
    #
    router id 172.16.3.3
    #
    mpls lsr-id 172.16.3.3
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    explicit-path to_p3
     next hop 172.16.1.1
     next hop 10.1.6.2
     next hop 10.1.4.1
     next hop 10.1.1.1
    #
    mpls ldp
    #
     mpls ldp remote-peer to_p1
     remote-ip 172.16.1.1
     undo remote-ip pwe3
    #
    isis 64
     is-level level-2
     cost-style wide
     network-entity 86.0010.0030.0300.3003.00
     is-name P3
     frr
      loop-free-alternate level-2
    #
    interface LoopBack0
     ip address 172.16.3.3 255.255.255.255
     isis enable 64
    #
    interface Tunnel1
     description to_p1
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 172.16.1.1
     mpls te tunnel-id 100
     mpls te bandwidth ct0 200000
     mpls te path explicit-path to_p1
     mpls te igp advertise
     mpls te igp metric absolute 6
     mpls te commit
     isis enable 64
    #
    interface Vlanif100
     ip address 10.1.6.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls te
     mpls rsvp-te
     mpls te bandwidth max-reservable-bandwidth 200000
     mpls te bandwidth bc0 200000
    #
    interface Vlanif30
     ip address 10.1.2.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif90
     ip address 10.1.7.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif110
     ip address 10.1.12.2 255.255.255.252
     isis enable 64
     isis cost 5
     undo isis lfa-backup
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 90 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 110 
    #
    return
  • Configuration file of P4

    #
    sysname P4
    #
    router id 172.16.4.4
    #
    mpls lsr-id 172.16.4.4
    mpls
     mpls te
     mpls rsvp-te
    #
    mpls ldp
    #
    isis 64
     is-level level-2
     cost-style wide
     network-entity 86.0010.0040.0400.4004.00
     is-name P4
    #
    interface LoopBack0
     ip address 172.16.4.4 255.255.255.255
     isis enable 64
    #
    interface Vlanif100
     ip address 10.1.6.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls te
     mpls rsvp-te
     mpls te bandwidth max-reservable-bandwidth 200000
     mpls te bandwidth bc0 200000
    #
    interface Vlanif70
     ip address 10.1.4.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls te
     mpls te bandwidth max-reservable-bandwidth 200000
     mpls te bandwidth bc0 200000
     mpls ldp
    #
    interface Vlanif130
     ip address 10.1.8.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif120
     ip address 10.1.13.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 70 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 130 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 120 
    #
    return
  • Configuration file of P5

    #
    sysname P5
    #
    router id 172.16.5.5
    #
    mpls lsr-id 172.16.5.5
    mpls
    #
    mpls ldp
    #
    isis 64
     is-level level-2
     cost-style wide
     network-entity 86.0010.0050.0500.5005.00
     is-name P5
    #
    interface LoopBack0
     ip address 172.16.5.5 255.255.255.255
     isis enable 64
    #
    interface Vlanif80
     ip address 10.1.9.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif20
     ip address 10.1.3.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif90
     ip address 10.1.7.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 90 
    #
    return
  • Configuration file of P6

    #
    sysname P6
    #
    router id 172.16.6.6
    #
    mpls lsr-id 172.16.6.6
    mpls
    #
    mpls ldp
    #
    isis 64
     is-level level-2
     cost-style wide
     network-entity 86.0010.0060.0600.6006.00
     is-name P6
    #
    interface LoopBack0
     ip address 172.16.6.6 255.255.255.255
     isis enable 64
    #
    interface Vlanif80
     ip address 10.1.9.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif60
     ip address 10.1.5.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif130
     ip address 10.1.8.2 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 130 
    #
    return
  • Configuration file of PE1

    #
    sysname PE1
    #
    router id 172.16.7.7
    #
    mpls lsr-id 172.16.7.7
    mpls
    #
    mpls ldp
    #
    isis 64
     is-level level-2
     cost-style wide
     network-entity 86.0010.0070.0700.7007.00
     is-name PE1
    #
    interface LoopBack0
     ip address 172.16.7.7 255.255.255.255
     isis enable 64
    #
    interface Vlanif40
     ip address 10.1.10.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif50
     ip address 10.1.11.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    return
  • Configuration file of PE3

    #
    sysname PE3
    #
    router id 172.16.8.8
    #
    mpls lsr-id 172.16.8.8
    mpls
    #
    mpls ldp
    #
    isis 64
     is-level level-2
     cost-style wide
     network-entity 86.0010.0080.0800.8008.00
     is-name PE3
    #
    interface LoopBack0
     ip address 172.16.8.8 255.255.255.255
     isis enable 64
    #
    interface Vlanif110
     ip address 10.1.12.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface Vlanif120
     ip address 10.1.13.1 255.255.255.252
     isis enable 64
     isis cost 5
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 110
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 120 
    #
    return
Translation
Download
Updated: 2019-04-01

Document ID: EDOC1000178324

Views: 204848

Downloads: 178

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next