No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - Basic Configuration

S9300, S9300E, and S9300X V200R011C10

This document describes methods to use command line interface and to log in to the device, file operations, and system startup configurations.
Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Deploying Unconfigured Devices Using the Commander (with Network Topology Collection Disabled)

Example for Deploying Unconfigured Devices Using the Commander (with Network Topology Collection Disabled)

Networking Requirements

Figure 2-12 shows a network of an enterprise on which the file server, DHCP server, and SwitchA have reachable routes to each other. New devices Client1, Client2, and Client3 need to be deployed on the enterprise network. The new devices are located on a different network segment from the DHCP server. To reduce labor costs and save time on device deployment, the enterprise wants to realize automatic batch configuration and maintenance of the new devices.

The address of VLANIF 20 on SwitchA is 192.168.4.2/24 and its peer address is 192.168.4.1/24.

The address of VLANIF 30 on SwitchB is 192.168.3.2/24 and its peer address is 192.168.3.1/24.

Table 2-5 lists information about the new devices to be configured.

Table 2-5  Device information
New Device Device Model Files to Be Loaded
Client1 S5300-HI

s5300-hi.cfg

User-defined file header1.txt

Client2 S5300-HI

s5300-hi.cfg

User-defined file header1.txt

Client3 S5300-X-LI

s5300-x-li.cfg

User-defined file header2.txt

Figure 2-12  Networking diagram for unconfigured device deployment using the commander

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure the file server and save the files to be loaded on the file server.
  2. Configure the DHCP server function based on the global address pool on SwitchB and configure DHCP relay on SwitchA, so that the new devices can obtain IP addresses of their own and the Commander.
  3. Configure the Commander on SwitchA so that the new devices can be configured using the Commander.

    • Enable automatic configuration backup on the Commander to facilitate replacement of faulty devices in future maintenance.
    • Client1 and Client2 are devices of the same type and need to load the same configuration file. Therefore, you can configure a built-in group for them. Client3 needs to load a different configuration file. You can specify the file information exclusively for Client3.
    • Client3 is connected to Client1 in cascading networking. Therefore, an appropriate global file activation delay time needs to be configured on the Commander to ensure that Client3 has enough time to download the required files.

Procedure

  1. Configure the file server.

    Configure the file server according to the server manual.

    After completing the configuration, save the required files on the file server.

  2. Configure the DHCP service.

    # Configure a DHCP server based on the global address pool.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] dhcp enable
    [SwitchB] vlan batch 30
    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] ip address 192.168.3.2 24
    [SwitchB-Vlanif30] dhcp select global
    [SwitchB-Vlanif30] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 30
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 30
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] ip pool easy-operation
    [SwitchB-ip-pool-easy-operation] network 192.168.1.0 mask 255.255.255.0
    [SwitchB-ip-pool-easy-operation] gateway-list 192.168.1.6
    [SwitchB-ip-pool-easy-operation] option 148 ascii ipaddr=192.168.1.6;
    [SwitchB-ip-pool-easy-operation] quit
    

    # Configure a default route on SwitchB.

    [SwitchB] ip route-static 0.0.0.0 0.0.0.0 192.168.3.1
    

    # Configure DHCP relay on SwitchA (Commander).

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] dhcp enable
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.6 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.4.2 24
    [SwitchA-Vlanif20] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port hybrid pvid vlan 20
    [SwitchA-GigabitEthernet1/0/3] port hybrid untagged vlan 20
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] dhcp select relay
    [SwitchA-Vlanif10] dhcp relay server-ip 192.168.3.2
    [SwitchA-Vlanif10] quit

    # Configure a default route on SwitchA.

    [SwitchA] ip route-static 0.0.0.0 0.0.0.0 192.168.4.1
    

  3. Configure basic functions for the Commander.

    [SwitchA] easy-operation commander ip-address 192.168.1.6
    [SwitchA] easy-operation commander enable
    

  4. Configure file server information.

    [SwitchA] easy-operation
    [SwitchA-easyoperation] sftp-server 192.168.2.2 username admin password EasyOperation
    [SwitchA-easyoperation] backup configuration interval 2

  5. Configure information about files to be downloaded.

    # On the Commander, configure a built-in group based on the device type of Client1 and Client2, and specify information about the files to be downloaded in the group.

    [SwitchA-easyoperation] group build-in S5300-HI
    [SwitchA-easyoperation-group-build-in-S5300-HI] configuration-file s5300-hi.cfg
    [SwitchA-easyoperation-group-build-in-S5300-HI] custom-file header1.txt
    [SwitchA-easyoperation-group-build-in-S5300-HI] quit
    [SwitchA-easyoperation] client auto-join enable
    Warning: The commander will create the client information in database automatica
    lly when received message from unknown client. Continue? [Y/N]: y
    [SwitchA-easyoperation] 

    # Specify information about the files to be downloaded to Client3.

    [SwitchA-easyoperation] client 3 mac-address 5489-9875-edff
    [SwitchA-easyoperation] client 3 configuration-file s5300-x-li.cfg custom-file header2.txt 

    # In the Easy-Operation view of the Commander, set the file activation delay time to 15 minutes (900 seconds) based on the size of files that Client3 needs to download.

    [SwitchA-easyoperation] activate-file delay 900
    [SwitchA-easyoperation] quit

  6. Verify the configuration.

    # Check global configuration of the Commander.

    [SwitchA] display easy-operation configuration                             
    ---------------------------------------------------------------------------     
     Role                            : Commander                                     
     Commander IP address            : 192.168.1.6                               
     Commander UDP port              : 60000                                         
     IP address of file server       : 192.168.2.2                                
     Type of file server             : SFTP                                          
     Username of file server         : admin                                         
     Default system-software file    : -                                             
     Default system-software version : -                                             
     Default configuration file      : -                                             
     Default patch file              : -                                             
     Default WEB file                : -                                             
     Default license file            : -                                             
     Default custom file 1           : -                                             
     Default custom file 2           : -                                             
     Default custom file 3           : -   
     Auto clear up                   : Disable                                       
     Auto join in                    : Disable  
     Topology collection             : Disable
     Activating file time            : Delay 900s                                   
     Activating file method          : Default 
     Aging time of lost client(hours): - 
     Backup configuration file mode  : Default                                       
     Backup configuration file interval(hours): 2                                   
    ---------------------------------------------------------------------------

    # Check the file downloading progress on each client after the unconfigured device deployment process starts.

    [SwitchA] display easy-operation download-status             
    The total number of client in downloading files is : 3                          
                                                                                    
    ---------------------------------------------------------------------------- 
      ID     Mac address    IP address      Method      Phase         Status     
    ---------------------------------------------------------------------------- 
      1      00E0-FC12-A34B 192.168.1.254   Zero-touch  Config-file  Upgrading  
      2      00E0-FC34-3190 192.168.1.253   Zero-touch  Config-file  Upgrading  
      3      5489-9875-edff 192.168.1.252   Zero-touch  Config-file  Upgrading  
    

Configuration Files

SwitchA configuration file

#
sysname SwitchA
#
vlan batch 10 20
#
dhcp enable
#
interface Vlanif10
 ip address 192.168.1.6 255.255.255.0
 dhcp select relay
 dhcp relay server-ip 192.168.3.2
#
interface Vlanif20
 ip address 192.168.4.2 255.255.255.0
#
interface GigabitEthernet1/0/1
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet1/0/2
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet1/0/3
 port hybrid pvid vlan 20
 port hybrid untagged vlan 20
#                                                                               
ip route-static 0.0.0.0 0.0.0.0 192.168.4.1
#
easy-operation commander ip-address 192.168.1.6 
easy-operation commander enable 
# 
easy-operation
 sftp-server 192.168.2.2 username admin password %^%#=.X8C_TN##%&9P>3RK503O@w-=Fr%>naT#E3P4{0%^%#
 backup configuration interval 2 
 activate-file delay 900
 client 3 mac-address 5489-9875-EDFF
 client 3 configuration-file s5300-x-li.cfg             
 client 3 custom-file header2.txt 
 group build-in S5300-HI  
  configuration-file s5300-hi.cfg    
  custom-file header1.txt
# 
return

SwitchB configuration file

#
sysname SwitchB
#
vlan batch 30
#
dhcp enable
#
ip pool easy-operation
 gateway-list 192.168.1.6
 network 192.168.1.0 mask 255.255.255.0
 option 148 ascii ipaddr=192.168.1.6;
#
interface Vlanif30
 ip address 192.168.3.2 255.255.255.0
 dhcp select global
#                                                                               
interface GigabitEthernet1/0/1
 port hybrid pvid vlan 30
 port hybrid untagged vlan 30 
#
ip route-static 0.0.0.0 0.0.0.0 192.168.3.1
#
return 
Translation
Download
Updated: 2019-04-17

Document ID: EDOC1000178413

Views: 68388

Downloads: 109

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next