No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S9300, S9300E, and S9300X V200R011C10

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Local OSPF MT

Example for Configuring Local OSPF MT

Networking Requirements

On the network shown in Figure 5-80, multicast and an IGP Shortcut-enabled MPLS TE tunnel are configured on the network. The outbound interface of the route calculated by IGP may be a TE tunnel interface, not a physical interface. The TE tunnel interface on the switch sends multicast Join packets over a unicast route to the multicast source address. The multicast Join packets are transparent to SwitchC through which the TE tunnel passes. As a result, SwitchC cannot generate multicast forwarding entries. To resolve the problem, enable local OSPF MT on SwitchB. After local MT is enabled, if the outbound interface of a calculated route is an IGP Shortcut-enabled TE tunnel interface, the routing management (RM) module creates an independent Multicast IGP (MIGP) routing table, calculates a physical outbound interface for the route, and adds the route to the MIGP routing table. Multicast packets are then forwarded along the routes in the MIGP routing table.

Figure 5-80  Configuring local OSPF MT

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure basic OSPF functions on each switch to implement basic connections on the OSPF network.

  2. Configure multicast PIM-SM on each switch so that the host can receive the multicast data from the source.

  3. Configure the MPLS RSVP-TE tunnel function on SwitchB, SwitchC, and SwitchD, and configure an MPLS TE tunnel interface on SwitchB, and establish a TE tunnel from SwitchB to SwitchD.

  4. Configure the IGP-Shortcut function on SwitchB so that SwitchB uses the TE tunnel interface as the outbound interface.

  5. Configure the local OSPF MT function on SwitchB so that the next-hop of each route whose original outbound interface is a TE tunnel interface is calculated as a physical outbound interface in the MIGP routing table.

Procedure

  1. Configure VLANs for interfaces.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Configure an IP address for each VLANIF and loopback interface.

    # Configure SwitchA. The configurations of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA.

    [SwitchA] interface loopback 0
    [SwitchA-LoopBack0] ip address 10.1.1.1 32
    [SwitchA-LoopBack0] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 172.16.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.0.0.1 24
    [SwitchA-Vlanif20] quit

  3. Configure basic OSPF functions.

    # Configure SwitchA.

    [SwitchA] router id 10.1.1.1
    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.0.0.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] router id 10.2.2.2
    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.0.0.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.0.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] router id 10.3.3.3
    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.3.3.3 0.0.0.0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.0.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.0.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # Configure SwitchD.

    [SwitchD] router id 10.4.4.4
    [SwitchD] ospf 1
    [SwitchD-ospf-1] area 0
    [SwitchD-ospf-1-area-0.0.0.0] network 10.4.4.4 0.0.0.0
    [SwitchD-ospf-1-area-0.0.0.0] network 10.0.2.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 10.0.3.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] quit
    [SwitchD-ospf-1] quit

    # Configure SwitchE.

    [SwitchE] router id 10.5.5.5
    [SwitchE] ospf 1
    [SwitchE-ospf-1] area 0
    [SwitchE-ospf-1-area-0.0.0.0] network 10.5.5.5 0.0.0.0
    [SwitchE-ospf-1-area-0.0.0.0] network 10.0.3.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [SwitchE-ospf-1-area-0.0.0.0] quit
    [SwitchE-ospf-1] quit

  4. Configure PIM-SM.

    # Enable multicast on all switches and enable PIM-SM on all interfaces. The configurations of SwitchB, SwitchC, SwitchD, and SwitchE are similar to the configuration of SwitchA.

    [SwitchA] multicast routing-enable
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] pim sm
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] pim sm
    [SwitchA-Vlanif20] quit

    # Enable Internet Group Management Protocol (IGMP) on the interface connecting SwitchA to the host.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] igmp enable
    [SwitchA-Vlanif10] igmp version 3
    [SwitchA-Vlanif10] quit

    # Configure a C-BSR and a C-RP. Set the RP service range and specify the C-BSR and C-RP locations on SwitchD.

    [SwitchD] pim
    [SwitchD-pim] c-bsr vlanif 50
    [SwitchD-pim] c-rp vlanif 50
    [SwitchD-pim] quit

    # Run the display multicast routing-table command to check the switch multicast routing table. SwitchC is used as an example.

    [SwitchC] display multicast routing-table
    Multicast routing table of VPN-Instance: public net
     Total 1 entry
    
     00001. (192.168.3.2, 225.0.0.1)
           Uptime: 15:03:04
           Upstream Interface: Vlanif40
           List of 1 downstream interface
               1:  Vlanif30

  5. Configure an MPLS RSVP-TE tunnel.

    # Configure SwitchB.

    [SwitchB] mpls lsr-id 10.2.2.2
    [SwitchB] mpls
    [SwitchB-mpls] mpls te
    [SwitchB-mpls] mpls rsvp-te
    [SwitchB-mpls] mpls te cspf
    [SwitchB-mpls] quit
    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] mpls
    [SwitchB-Vlanif30] mpls te
    [SwitchB-Vlanif30] mpls rsvp-te
    [SwitchB-Vlanif30] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] enable traffic-adjustment
    [SwitchB-ospf-1] opaque-capability enable
    [SwitchB-ospf-1] area 0.0.0.0
    [SwitchB-ospf-1-area-0.0.0.0] mpls-te enable
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] mpls lsr-id 10.3.3.3
    [SwitchC] mpls
    [SwitchC-mpls] mpls te
    [SwitchC-mpls] mpls rsvp-te
    [SwitchC-mpls] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] mpls
    [SwitchC-Vlanif30] mpls te
    [SwitchC-Vlanif30] mpls rsvp-te
    [SwitchC-Vlanif30] quit
    [SwitchC] interface vlanif 40
    [SwitchC-Vlanif40] mpls
    [SwitchC-Vlanif40] mpls te
    [SwitchC-Vlanif40] mpls rsvp-te
    [SwitchC-Vlanif40] quit
    [SwitchC] ospf 1
    [SwitchC-ospf-1] opaque-capability enable
    [SwitchC-ospf-1] area 0.0.0.0
    [SwitchC-ospf-1-area-0.0.0.0] mpls-te enable
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # Configure SwitchD.

    [SwitchD] mpls lsr-id 10.4.4.4
    [SwitchD] mpls
    [SwitchD-mpls] mpls te
    [SwitchD-mpls] mpls rsvp-te
    [SwitchD-mpls] quit
    [SwitchD] interface vlanif 40
    [SwitchD-Vlanif40] mpls
    [SwitchD-Vlanif40] mpls te
    [SwitchD-Vlanif40] mpls rsvp-te
    [SwitchD-Vlanif40] quit
    [SwitchD] ospf 1
    [SwitchD-ospf-1] opaque-capability enable
    [SwitchD-ospf-1] area 0.0.0.0
    [SwitchD-ospf-1-area-0.0.0.0] mpls-te enable
    [SwitchD-ospf-1-area-0.0.0.0] quit
    [SwitchD-ospf-1] quit

    Configure an MPLS TE tunnel and enable IGP Shortcut.

    Configure an MPLS TE tunnel and enable IGP Shortcut on SwitchB.

    [SwitchB] interface tunnel 1
    [SwitchB-Tunnel1] ip address unnumbered interface loopback 0
    [SwitchB-Tunnel1] tunnel-protocol mpls te
    [SwitchB-Tunnel1] destination 10.4.4.4
    [SwitchB-Tunnel1] mpls te tunnel-id 100
    [SwitchB-Tunnel1] mpls te igp shortcut ospf
    [SwitchB-Tunnel1] mpls te igp metric relative -10
    [SwitchB-Tunnel1] mpls te commit
    [SwitchB-Tunnel1] quit

    # Check the OSPF routing table on SwitchB. The information shows that an MPLS TE tunnel has been set up.

    [SwitchB] display ip routing-table
    Route Flags: R - relay, D - download to fib                                     
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 15       Routes : 15
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
    
           10.0.0.0/24  Direct  0    0           D   10.0.0.2        Vlanif20
           10.0.0.2/32  Direct  0    0           D   127.0.0.1       Vlanif20
           10.0.1.0/24  Direct  0    0           D   10.0.1.2        Vlanif30
           10.0.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif30
           10.0.2.0/24  OSPF    10   2           D   10.0.1.1        Vlanif30
           10.0.3.0/24  OSPF    10   2           D   10.2.2.2        Tunnel1
           10.1.1.1/32  OSPF    10   1           D   10.0.0.1        Vlanif20 
           10.2.2.2/32  Direct  0    0           D   127.0.0.1       LoopBack0
           10.3.3.3/32  OSPF    10   1           D   10.0.1.1        Vlanif30
           10.4.4.4/32  OSPF    10   1           D   10.2.2.2        Tunnel1
           10.5.5.5/32  OSPF    10   2           D   10.2.2.2        Tunnel1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
         172.16.1.0/24  OSPF    10   2           D   10.0.0.1        Vlanif20
         192.168.3.0/24 OSPF    10   3           D   10.2.2.2        Tunnel1

    # Check the multicast routing table on switchSwitchC spanned by the TE tunnel.

    [SwitchC] display multicast routing-table

    No multicast routing entry is displayed in the multicast routing table on SwitchC, indicating that SwitchC has discarded multicast packets.

  6. Configure local OSPF MT.

    # Enable local OSPF MT on SwitchB.

    [SwitchB] ospf 1
    [SwitchB-ospf-1] local-mt enable
    [SwitchB-ospf-1] quit

  7. Verify the configuration.

    # Check the multicast routing table on SwitchC again. You can find that the multicast route is displayed.

    [SwitchC] display multicast routing-table
    Multicast routing table of VPN-Instance: public net
     Total 1 entry
    
     00001. (192.168.3.2, 225.0.0.1)
           Uptime: 00:00:19
           Upstream Interface: Vlanif40
           List of 1 downstream interface
               1:  Vlanif30

    # Check the MIGP routing table on SwitchB.

    [SwitchB] display migp routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: MIGP
             Destinations : 4        Routes : 4
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
    
           10.0.3.0/24  OSPF    10   3               10.0.1.1        Vlanif30
           10.4.4.4/32  OSPF    10   2               10.0.1.1        Vlanif30
           10.5.5.5/32  OSPF    10   3               10.0.1.1        Vlanif30
        192.168.3.0/24  OSPF    10   4               10.0.1.1        Vlanif30

    The next-hop of each route whose outbound interface is a TE tunnel interface is calculated as a physical outbound interface in the MIGP routing table.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    router id 10.1.1.1
    #
    vlan batch 10 20
    #
    multicast routing-enable
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0 
     pim sm
     igmp enable
     igmp version 3
    #
    interface Vlanif20
     ip address 10.0.0.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10 
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.0.0.0 0.0.0.255
      network 10.1.1.1 0.0.0.0
      network 172.16.1.0 0.0.0.255
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    router id 10.2.2.2
    #
    vlan batch 20 30
    #
    multicast routing-enable
    #
    mpls lsr-id 10.2.2.2
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    interface Vlanif20
     ip address 10.0.0.2 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 10.0.1.2 255.255.255.0
     pim sm
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 10.4.4.4
     mpls te tunnel-id 100
     mpls te igp shortcut ospf
     mpls te igp metric relative -10
     mpls te commit
    #
    ospf 1
     opaque-capability enable
     enable traffic-adjustment
     local-mt enable
     area 0.0.0.0
      network 10.0.0.0 0.0.0.255
      network 10.0.1.0 0.0.0.255
      network 10.2.2.2 0.0.0.0
      mpls-te enable
    #
    return
  • SwitchC configuration file

    #
    sysname SwitchC
    #
    router id 10.3.3.3
    #
    vlan batch 30 40
    #
    multicast routing-enable
    #
    mpls lsr-id 10.3.3.3
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif30
     ip address 10.0.1.1 255.255.255.0
     pim sm
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif40
     ip address 10.0.2.2 255.255.255.0
     pim sm
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.0.1.0 0.0.0.255
      network 10.0.2.0 0.0.0.255
      network 10.3.3.3 0.0.0.0
      mpls-te enable
    #
    return
  • SwitchD configuration file

    #
    sysname SwitchD
    #
    router id 10.4.4.4
    #
    vlan batch 40 50
    #
    multicast routing-enable
    #
    mpls lsr-id 10.4.4.4
    mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif40
     ip address 10.0.2.1 255.255.255.0
     pim sm
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif50
     ip address 10.0.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack0
     ip address 10.4.4.4 255.255.255.255
    #
    ospf 1
     opaque-capability enable
     area 0.0.0.0
      network 10.0.2.0 0.0.0.255
      network 10.0.3.0 0.0.0.255
      network 10.4.4.4 0.0.0.0
      mpls-te enable
    #
    pim
     c-bsr Vlanif50
     c-rp Vlanif50
    #
    return
  • SwitchE configuration file

    #
    sysname SwitchE
    #
    router id 10.5.5.5
    #
    vlan batch 50 60
    #
    multicast routing-enable
    #
    interface Vlanif50
     ip address 10.0.3.3 255.255.255.0
     pim sm
    #
    interface Vlanif60
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 60
    #
    interface LoopBack0
     ip address 10.5.5.5 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.0.3.0 0.0.0.255
      network 10.5.5.5 0.0.0.0
      network 192.168.3.0 0.0.0.255
    #
    return
Translation
Download
Updated: 2019-10-22

Document ID: EDOC1000178418

Views: 197885

Downloads: 37

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next