No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Configuration Guide - IP Unicast Routing

S9300, S9300E, and S9300X V200R011C10

This document describes IP Unicast Routing configurations supported by the switch, including the principle and configuration procedures of IP Routing Overview, Static Route, RIP, RIPng, OSPF, OSPFv3, IS-IS(IPv4), IS-IS(IPv6), BGP, Routing Policy ,and PBR, and provides configuration examples.
Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Local MT

Example for Configuring Local MT

Networking Requirements

As shown in Figure 7-38, switches run IS-IS to implement IP interworking. The switches are Level-2 devices. A TE tunnel is established from SwitchB to SwitchD. Multicast services must be available after multicast and an MPLS TE tunnel are configured and IGP Shortcut is enabled on the MPLS TE tunnel.

Figure 7-38  Configuring local MT

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure the local MT on SwitchC to ensure that multicast services are available when IGP Shortcut is enabled on an MPLS TE tunnel.

Procedure

  1. Configure VLANs that interfaces belong to.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/0
    [SwitchA-GigabitEthernet1/0/0] port link-type access
    [SwitchA-GigabitEthernet1/0/0] port default vlan 10
    [SwitchA-GigabitEthernet1/0/0] quit
    [SwitchA] interface gigabitethernet 2/0/0
    [SwitchA-GigabitEthernet2/0/0] port link-type trunk
    [SwitchA-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet2/0/0] quit

    The configurations of SwitchB, SwitchC, SwitchD and SwitchE are similar to the configuration of SwitchA, and are not mentioned here.

  2. Assign an IP address for each VLANIF interface and enable IS-IS.

    As shown in Figure 7-38, assign an IP address and the mask for each VLANIF interface and enable IS-IS. The configuration details are not mentioned here.

  3. Configure PIM-SM.

    # Enable multicast on all switches and enable PIM-SM on all interfaces except VLANIF10 on SwitchA. The configurations of SwitchB, SwitchC, SwitchD, and SwitchE are similar to that of SwitchA, and are not mentioned here.

    [SwitchA] multicast routing-enable
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] pim sm
    [SwitchA-Vlanif20] quit

    # Enable IGMP on the interface through which SwitchA is connected to hosts.

    [SwitchA]interface vlanif 10
    [SwitchA-Vlanif10] igmp enable
    [SwitchA-Vlanif10] igmp version 3

    # Configure a C-BSR and a C-RP. Set the service range of the RP on SwitchD and specify the locations of the C-BSR and the C-RP.

    [SwitchD] pim
    [SwitchD-pim] c-bsr vlanif 50
    [SwitchD-pim] c-rp vlanif 50

    # Run the display multicast routing-table command to view the multicast routing table of a switch. The multicast routing table on SwitchC is as follows:

    [SwitchC] display multicast routing-table
    Multicast routing table of VPN-Instance: public net
     Total 1 entry
    
     00001. (192.168.3.2, 224.31.31.31)
           Uptime: 15:03:04
           Upstream Interface: Vlanif40
           List of 1 downstream interface
               1:  Vlanif30

  4. Configure an MPLS RSVP-TE tunnel.

    # Configure SwitchB.

    [SwitchB] mpls lsr-id 10.2.2.2
    [SwitchB] mpls
    [SwitchB-mpls] mpls te
    [SwitchB-mpls] mpls rsvp-te
    [SwitchB-mpls] mpls te cspf
    [SwitchB-mpls] quit
    [SwitchB] interface vlanif 30
    [SwitchB-Vlanif30] mpls
    [SwitchB-Vlanif30] mpls te
    [SwitchB-Vlanif30] mpls rsvp-te
    [SwitchB-Vlanif30] quit
    [SwitchB] isis 1
    [SwitchB-isis-1] cost-style wide
    [SwitchB-isis-1] traffic-eng level-2
    [SwitchB-isis-1] quit

    # Configure SwitchC.

    [SwitchC] mpls lsr-id 10.3.3.3
    [SwitchC] mpls
    [SwitchC-mpls] mpls te
    [SwitchC-mpls] mpls rsvp-te
    [SwitchC-mpls] mpls te cspf
    [SwitchC-mpls] quit
    [SwitchC] interface vlanif 30
    [SwitchC-Vlanif30] mpls
    [SwitchC-Vlanif30] mpls te
    [SwitchC-Vlanif30] mpls rsvp-te
    [SwitchC-Vlanif30] quit
    [SwitchC] interface vlanif 40
    [SwitchC-Vlanif40] mpls
    [SwitchC-Vlanif40] mpls te
    [SwitchC-Vlanif40] mpls rsvp-te
    [SwitchC-Vlanif40] quit
    [SwitchC] isis 1
    [SwitchC-isis-1] cost-style wide
    [SwitchC-isis-1] traffic-eng level-2
    [SwitchC-isis-1] quit

    # Configure SwitchD.

    [SwitchD] mpls lsr-id 10.4.4.4
    [SwitchD] mpls
    [SwitchD-mpls] mpls te
    [SwitchD-mpls] mpls rsvp-te
    [SwitchD-mpls] mpls te cspf
    [SwitchD-mpls] quit
    [SwitchD] interface vlanif 40
    [SwitchD-Vlanif40] mpls
    [SwitchD-Vlanif40] mpls te
    [SwitchD-Vlanif40] mpls rsvp-te
    [SwitchD-Vlanif40] quit
    [SwitchD] isis 1
    [SwitchD-isis-1] cost-style wide
    [SwitchD-isis-1] traffic-eng level-2
    [SwitchD-isis-1] quit

    # Configure an MPLS TE tunnel and enable IGP Shortcut.

    Configure an MPLS TE tunnel on SwitchB and enable IGP Shortcut.

    [SwitchB] interface tunnel 1
    [SwitchB-Tunnel1] ip address unnumbered interface loopback 0
    [SwitchB-Tunnel1] tunnel-protocol mpls te
    [SwitchB-Tunnel1] destination 10.4.4.4
    [SwitchB-Tunnel1] mpls te tunnel-id 100
    [SwitchB-Tunnel1] mpls te igp shortcut isis
    [SwitchB-Tunnel1] mpls te igp metric relative -10
    [SwitchB-Tunnel1] isis enable 1
    [SwitchB-Tunnel1] mpls te commit
    [SwitchB-Tunnel1] quit

    # View the routing table of SwitchB. You can find that IGP Shortcut is enabled.

    [SwitchB] display isis route
    
                             Route information for ISIS(1)
                             -----------------------------
    
                            ISIS(1) Level-2 Forwarding Table
                            --------------------------------
    
     IPV4 Destination     IntCost    ExtCost ExitInterface   NextHop          Flags
    --------------------------------------------------------------------------------
     10.3.3.3/32          10         NULL    Vlanif30        10.0.1.1       A/-/-/-
     172.16.1.0/24        20         NULL    Vlanif20        10.0.0.1       A/-/-/-
     10.2.2.2/32          0          NULL    Loopback0       Direct         D/-/L/-
     192.168.3.0/24       25         NULL    Tun1            10.2.2.2       A/S/-/-
     10.5.5.5/32          15         NULL    Tun1            10.2.2.2       A/S/-/-
     10.0.0.0/24          10         NULL    Vlanif10        Direct         D/-/L/-
     10.0.1.0/24          10         NULL    Vlanif20        Direct         D/-/L/-
     10.4.4.4/32          5          NULL    Tun1            10.2.2.2       A/S/-/-
     10.0.2.0/24          15         NULL    Tun1            10.2.2.2       A/S/-/-
     10.0.3.0/24          15         NULL    Tun1            10.2.2.2       A/S/-/-
    
         Flags: D-Direct, A-Added to URT, L-Advertised in LSPs, S-IGP Shortcut,
                                   U-Up/Down Bit Set

    # View the multicast routing table on SwitchC spanned by the TE tunnel.

    [SwitchC] display multicast routing-table

    No multicast routing entry is displayed. This indicates that the multicast packet is discarded.

  5. Configure local MT.

    # Enable local MT on SwitchB.

    [SwitchB] isis 1
    [SwitchB-isis-1] local-mt enable

  6. Verify the configuration.

    # View the multicast routing table on SwitchC again. You can find that multicast routes are displayed.

    [SwitchC] display multicast routing-table
    Multicast routing table of VPN-Instance: public net
     Total 1 entry
     00001. (192.168.3.2, 224.31.31.31)
           Uptime: 00:00:19
           Upstream Interface: Vlanif40
           List of 1 downstream interface
               1:  Vlanif30

    # View the MIGP routing table on SwitchB.

    [SwitchB] display migp routing-table
    Route Flags: R - relied, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: MIGP
             Destinations : 5        Routes : 5
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
         10.0.2.0/24    ISIS   15   20             10.0.1.1        Vlanif20
         10.0.3.0/24    ISIS   15   30             10.0.1.1        Vlanif20
         10.4.4.4/32    ISIS   15   20             10.0.1.1        Vlanif20
         10.5.5.5/32    ISIS   15   30             10.0.1.1        Vlanif20
      192.168.3.0/24    ISIS   15   40             10.0.1.1        Vlanif20

    The physical outgoing interface of the next hop of the route with the previous outgoing interface being a TE tunnel interface is found in the MIGP routing table.

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    router id 10.1.1.1
    #
    multicast routing-enable
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.0001.00
    #
    interface Vlanif10
     ip address 172.16.1.1 255.255.255.0
     isis enable 1
     igmp enable
    #
    interface Vlanif20
     ip address 10.0.0.1 255.255.255.0
     isis enable 1
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    router id 10.2.2.2
    #
    multicast routing-enable
    #
    mpls lsr-id 10.2.2.2
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.0002.00
     traffic-eng level-2
     local-mt enable
    #
    interface Vlanif20
     ip address 10.0.0.2 255.255.255.0
     isis enable 1
     pim sm
    #
    interface Vlanif30
     ip address 10.0.1.2 255.255.255.0
     isis enable 1
     pim sm
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255
     isis enable 1
     pim sm
    #
    interface Tunnel1
     ip address unnumbered interface LoopBack0
     tunnel-protocol mpls te
     destination 10.4.4.4
     mpls te tunnel-id 100
     mpls te igp shortcut isis
     mpls te igp metric relative -10
     mpls te commit
     isis enable 1
     pim sm
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    router id 10.3.3.3
    #
    multicast routing-enable
    #
    mpls lsr-id 10.3.3.3
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.0003.00
     traffic-eng level-2
    #
    interface Vlanif30
     ip address 10.0.1.1 255.255.255.0
     isis enable 1
     pim sm
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif40
     ip address 10.0.2.2 255.255.255.0
     isis enable 1
     pim sm
     mpls
     mpls te
     mpls rsvp-te
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 30 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255
     isis enable 1
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    router id 10.4.4.4
    #
    multicast routing-enable
    #
    mpls lsr-id 10.4.4.4
    mpls
     mpls te
     mpls rsvp-te
     mpls te cspf
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.0004.00
     traffic-eng level-2
    #
    interface Vlanif40
     ip address 10.0.2.1 255.255.255.0
     isis enable 1
     pim sm
     mpls
     mpls te
     mpls rsvp-te
    #
    interface Vlanif50
     ip address 10.0.3.1 255.255.255.0
     isis enable 1
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack0
     ip address 10.4.4.4 255.255.255.255
     isis enable 1
     pim sm
    #
    pim
     c-bsr Vlanif50
     c-rp Vlanif50
    #
    return
  • Configuration file of SwitchE

    #
    sysname SwitchE
    #
    router id 10.5.5.5
    #
    multicast routing-enable
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 10.0000.0000.0005.00
    #
    interface Vlanif50
     ip address 10.0.3.3 255.255.255.0
     isis enable 1
     pim sm
    #
    interface Vlanif60
     ip address 192.168.3.1 255.255.255.0
     isis enable 1
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 50 
    #
    interface GigabitEthernet2/0/0
     port link-type access
     port default vlan 60
    #
    interface LoopBack0
     ip address 10.5.5.5 255.255.255.255
     isis enable 1
     pim sm
    #
    pim
     c-bsr Vlanif50
     c-rp Vlanif50
    #
    return
Translation
Download
Updated: 2019-10-22

Document ID: EDOC1000178418

Views: 197387

Downloads: 37

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next