No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an Agile Distributed WLAN

Example for Configuring an Agile Distributed WLAN

Service Requirements

Students in dormitories need to access the Internet through WLANs.

Walls between numerous rooms in the dormitory building cause serious wireless signal attenuation, degrading signal quality. To resolve this issue, an agile distributed WLAN is used, with a remote unit (RU) deployed in each dormitory. RUs are connected to a central AP, and all RUs and central APs are centrally managed by the AC, delivering high-quality WLAN coverage for each dormitory.

Networking Requirements

  • AC networking mode: Layer 2 networking in inline mode
  • DHCP deployment mode: The AC functions as a DHCP server to assign IP addresses to central APs, RUs, and STAs.
  • Service data forwarding mode: tunnel forwarding
Figure 4-56 Networking for configuring an agile distributed WLAN

Data Planning

Table 4-54 AC data planning

Item

Data

DHCP server The AC functions as a DHCP server to assign IP addresses to central APs, RUs, and STAs.
IP address pool for central APs and RUs 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.2-10.23.101.254/24
AC's source interface address VLANIF 100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 101

  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

Configuration Roadmap

  1. Configure the AC, RUs, central APs, and network devices to communicate at Layer 2.
  2. Configure the AC as a DHCP server to assign IP addresses to central APs, RUs, and STAs.
  3. Configure the central APs and RUs to go online.
    1. Create an AP group and add central APs and RUs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the central APs and RUs.
    3. Configure the AP authentication mode and import the central APs and RUs offline to allow them to go online.
  4. Configure WLAN service parameters for STAs to access the WLAN.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

    # Configure the switch to enable Layer 2 communication between the central AP and RUs. If a Huawei switch is used, interfaces on it are added to VLAN 1 by default and can communicate one another at Layer 2. Therefore, this configuration is not required on the switch. If a non-Huawei switch is used, perform the configuration to enable Layer 2 communication of uplink and downlink interfaces.

    NOTE:
    Service packets must be properly forwarded between the central AP and RUs. In this example, the tunnel forwarding mode is used. Therefore, the network between the central AP and RUs does not need to be configured to permit packets with service VLAN tags to pass through. If the direct forwarding mode is used, configure the network between the central AP and RUs to permit packets with service VLAN tags to pass through depending the central AP model.
    • If the central AP is a gigabit AP (such as the AD9430DN-24), such configuration is not required on the switch. Because all service packets from RUs are first sent to the central AP through MAC-IN-MAC tunnels, these packets need to be permitted only from the upstream direction of the central AP.
    • If the central AP is a 10GE AP (such as the AD9431DN-24X), add uplink and downlink interfaces on the switch to the service VLAN. Because service packets are forwarded starting from the upstream direction of RUs, these packets must be permitted from the upstream direction of RUs.

  2. Configure the AC to communicate with the network devices.

    NOTE:

    If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.

    # On the AC, add GE0/0/1 to VLAN 100, and GE0/0/2 to VLAN 101.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] port-isolate enable
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface gigabitethernet 0/0/2
    [AC-GigabitEthernet0/0/2] port link-type trunk
    [AC-GigabitEthernet0/0/2] port trunk allow-pass vlan 101
    [AC-GigabitEthernet0/0/2] quit
    

  3. Configure a DHCP server to assign IP addresses to central APs, RUs, and STAs.

    # Configure the AC as a DHCP server to assign IP addresses to central APs and RUs from the IP address pool on VLANIF 100, and assign IP addresses to STAs from the IP address pool on VLANIF 101.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    [AC] interface vlanif 101
    [AC-Vlanif101] ip address 10.23.101.1 24
    [AC-Vlanif101] dhcp select interface
    [AC-Vlanif101] quit
    

  4. Configure a central AP and RUs to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    
    # Import the central AP and RUs offline on the AC and add the central AP and RUs to AP group ap-group1. Assume that the central AP's MAC address is 68a8-2845-62fd, name the central AP central_AP; the RU's MAC addresses are fcb6-9897-c520 and fcb6-9897-ca40, name the RUs ru_1 and ru_2, respectively.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 68a8-2845-62fd
    [AC-wlan-ap-0] ap-name central_AP
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac fcb6-9897-c520
    [AC-wlan-ap-1] ap-name ru_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit
    [AC-wlan-view] ap-id 2 ap-mac fcb6-9897-ca40
    [AC-wlan-ap-2] ap-name ru_2
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-2] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-2] quit
    

    # After the central AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the RUs go online successfully.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [3]
    Extra information:
    P  : insufficient power supply
    ------------------------------------------------------------------------------------------------------
    ID   MAC            Name       Group     IP            Type            State STA Uptime      ExtraInfo
    ------------------------------------------------------------------------------------------------------
    0    68a8-2845-62fd central_AP ap-group1 10.23.100.254 AD9430DN-24     nor   0   2M:25S      -
    1    fcb6-9897-c520 ru_1       ap-group1 10.23.100.253 R240D           nor   0   3M:5S       -
    2    fcb6-9897-ca40 ru_2       ap-group1 10.23.100.252 R240D           nor   0   3M:14S      -
    ------------------------------------------------------------------------------------------------------
    Total: 3

  5. Configure WLAN service parameters.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Create SSID profile wlan-net and set the SSID name to wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  6. Set channels and power for the RU radios.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The settings of the RU channel and power in this example are for reference only. You need to configure the RU channel and power based on the actual country code and network planning.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 1
    [AC-wlan-ap-1] radio 0
    [AC-wlan-radio-1/0] calibrate auto-channel-select disable
    [AC-wlan-radio-1/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-1/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-1/0] eirp 127
    [AC-wlan-radio-1/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-1] radio 1
    [AC-wlan-radio-1/1] calibrate auto-channel-select disable
    [AC-wlan-radio-1/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-1/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-1/1] eirp 127
    [AC-wlan-radio-1/1] quit
    [AC-wlan-ap-1] quit

  7. Verify the configuration.

    The AC automatically delivers WLAN service configuration to the RUs. After the configuration is complete, run the display vap ssid wlan-net command. If the Status field is displayed as ON, the VAPs have been successfully created on RU radios.

    [AC-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name    RfID WID  BSSID          Status  Auth type      STA  SSID
    --------------------------------------------------------------------------------
    1     ru_1       0    1    FCB6-9897-C520 ON      WPA/WPA2-PSK   0    wlan-net
    1     ru_1       1    1    FCB6-9897-C530 ON      WPA/WPA2-PSK   0    wlan-net
    2     ru_2       0    1    FCB6-9897-CA40 ON      WPA/WPA2-PSK   0    wlan-net
    2     ru_2       1    1    FCB6-9897-CA50 ON      WPA/WPA2-PSK   0    wlan-net
    --------------------------------------------------------------------------------
    Total: 4

    Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station ssid wlan-net command on the AC. The command output shows that the STAs are connected to the WLAN wlan-net.

    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    -----------------------------------------------------------------------------------------
    STA MAC         AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    -----------------------------------------------------------------------------------------
    e019-1dc7-1e08  1     ru_1      1/1      5G    11n   46/59      -68   101   10.23.101.254
    -----------------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1

Configuration Files

  • Router configuration file

    #
    sysname Router
    #
    vlan batch 101
    #
    interface Vlanif101
     ip address 10.23.101.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    return
    
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable 
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 101
     #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 52 ap-mac 68a8-2845-62fd ap-sn 2102350KGF10F8000012
      ap-name central_AP
      ap-group ap-group1
     ap-id 1 type-id 54 ap-mac fcb6-9897-c520 ap-sn 21500826402SF4900166
      ap-name ru_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
      radio 1
       channel 20mhz 149
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
     ap-id 2 type-id 54 ap-mac fcb6-9897-ca40 ap-sn 21500826402SF4900207
      ap-name ru_2
      ap-group ap-group1
     #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90497

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next