No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring N+1 Backup (APs and ACs in the same network segment)

Example for Configuring N+1 Backup (APs and ACs in the same network segment)

Service Requirements

In public places where a large number of users exist in a large area, many APs are deployed and managed by multiple ACs to provide free-of-charge WLAN access services. These services are value-added services that require low network reliability and allow temporary service interruption. An AC is required to be a backup of all ACs to save costs. To meet this requirement, build an N+1 backup wireless LAN to provide reliable services and reduce device purchase costs. ACs of different models can work in N+1 backup mode, but versions of the ACs must be the same.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: Switch_1 functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 5-45 Networking for configuring N+1 backup

Data Planning

Table 5-50 AC data planning
Item Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

VLAN 102

DHCP server

Switch_1 functions as a DHCP server to assign IP addresses to APs and STAs.

STAs' gateway:
  • 10.23.101.1/24
  • 10.23.102.1/24

APs' gateway: 10.23.100.1/24

IP address pool for APs

10.23.100.5-10.23.100.254/24

IP address pool for STAs

STA1: 10.23.101.3-10.23.101.254/24

STA2: 10.23.102.3-10.23.102.254/24

AC's source interface

VLANIF 100

AC_1's management IP address

VLANIF 100: 10.23.100.2/24

AC_2's management IP address

VLANIF 100: 10.23.100.3/24

AC_3's management IP address

VLANIF 100: 10.23.100.4/24

AP group

On AC_1 (primary AC):
  • Name: ap-group1

  • Referenced profiles: AP system profile ap-system, VAP profile wlan-net, and regulatory domain profile default

On AC_2 (primary AC):
  • Name: ap-group2

  • Referenced profiles: AP system profile ap-system1, VAP profile wlan-net1, and regulatory domain profile default

On AC_3 (backup AC):
  • Name: ap-group1
    • Referenced profiles: AP system profile ap-system, VAP profile wlan-net, and regulatory domain profile default

  • Name: ap-group2
    • Referenced profiles: AP system profile ap-system1, VAP profile wlan-net1, and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: China

SSID profile

AC_1:
  • Name: wlan-net

  • SSID name: wlan-net

AC_2:
  • Name: wlan-net1

  • SSID name: wlan-net1

AC_3:
  • Names: wlan-net and wlan-net1

  • SSID names: wlan-net and wlan-net1

Security profile

AC_1:
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES

  • Password: a1234567

AC_2:
  • Name: wlan-net1
  • Security policy: WPA-WPA2+PSK+AES

  • Password: a1234567

AC_3:
  • Name: wlan-net
    • Security policy: WPA-WPA2+PSK+AES

    • Password: a1234567

  • Name: wlan-net1
    • Security policy: WPA-WPA2+PSK+AES

    • Password: a1234567

VAP profile

AC_1:
  • Name: wlan-net
  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 101

  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

AC_1:
  • Name: wlan-net1
  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 102

  • Referenced profiles: SSID profile wlan-net1 and security profile wlan-net1

AC_3:
  • Name: wlan-net
    • Forwarding mode: direct forwarding

    • Service VLAN: VLAN 101

    • Referenced profiles: SSID profile wlan-net and security profile wlan-net

  • Name: wlan-net1
    • Forwarding mode: direct forwarding

    • Service VLAN: VLAN 102

    • Referenced profiles: SSID profile wlan-net1 and security profile wlan-net1

AP system profile

On AC_1:
  • Name: ap-system
    • Primary AC IP address: 10.23.100.2
    • Backup AC IP address: 10.23.100.4
On AC_2:
  • Name: ap-system1
    • Primary AC IP address: 10.23.100.3
    • Backup AC IP address: 10.23.100.4
On AC_3:
  • Name: ap-system
    • Primary AC IP address: 10.23.100.2
    • Backup AC IP address: 10.23.100.4
  • Name: ap-system1
    • Primary AC IP address: 10.23.100.3
    • Backup AC IP address: 10.23.100.4

Configuration Roadmap

  1. Configure network interworking of each AC and other network devices. Configure Switch_1 as a DHCP server to assign IP addresses to APs and STAs.
  2. Configure AC_1 and AC_2 as the primary ACs of AP_1 and AP_2 respectively, and configure basic WLAN services on AC_1 and AC_2.
  3. Configure AC_3 as the backup AC and configure basic WLAN services on AC_3. Ensure that service configurations on AC_3 are the same as those on AC_1 and AC_2.
  4. Configure N+1 backup on the primary ACs first and then on the backup AC. When N+1 backup is enabled, all APs are restarted.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the switches to enable the ACs to communicate with the APs.

    # On Switch_1, create VLAN 100, VLAN 101, and VLAN 102. Configure VLAN 100 as the management VLAN, VLAN 101 and VLAN 102 as service VLANs. Add GE0/0/1 connected to AC_1 to VLAN 100 and VLAN 101, GE0/0/2 connected to AC_2 to VLAN 100 and VLAN 102, GE0/0/3 and GE0/0/4 respectively connected to AC_3 and Switch_2 to VLAN 100, VLAN 101, and VLAN 102.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 100 to 102
    [Switch_1] interface gigabitethernet 0/0/1
    [Switch_1-GigabitEthernet0/0/1] port link-type trunk
    [Switch_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch_1-GigabitEthernet0/0/1] quit
    [Switch_1] interface gigabitethernet 0/0/2
    [Switch_1-GigabitEthernet0/0/2] port link-type trunk
    [Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [Switch_1-GigabitEthernet0/0/2] quit
    [Switch_1] interface gigabitethernet 0/0/3
    [Switch_1-GigabitEthernet0/0/3] port link-type trunk
    [Switch_1-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 to 102
    [Switch_1-GigabitEthernet0/0/3] quit
    [Switch_1] interface gigabitethernet 0/0/4
    [Switch_1-GigabitEthernet0/0/4] port link-type trunk
    [Switch_1-GigabitEthernet0/0/4] port trunk allow-pass vlan 100 to 102
    [Switch_1-GigabitEthernet0/0/4] quit
    

    # On Switch_2, add GE0/0/3 connected to Switch_1 to VLAN 100, VLAN 101, and VLAN 102, GE0/0/1 connected to AP_1 to VLAN 100 and VLAN 101, and GE0/0/2 connected to AP_2 to VLAN 100 and VLAN 102. Set the PVID of GE0/0/1 and GE0/0/2 to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 100 to 102
    [Switch_2] interface gigabitethernet 0/0/1
    [Switch_2-GigabitEthernet0/0/1] port link-type trunk
    [Switch_2-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch_2-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch_2-GigabitEthernet0/0/1] port-isolate enable
    [Switch_2-GigabitEthernet0/0/1] quit
    [Switch_2] interface gigabitethernet 0/0/2
    [Switch_2-GigabitEthernet0/0/2] port link-type trunk
    [Switch_2-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [Switch_2-GigabitEthernet0/0/2] port-isolate enable
    [Switch_2-GigabitEthernet0/0/2] quit
    [Switch_2] interface gigabitethernet 0/0/3
    [Switch_2-GigabitEthernet0/0/3] port link-type trunk
    [Switch_2-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 to 102
    [Switch_2-GigabitEthernet0/0/3] quit
    

  2. Configure Switch_1 as a DHCP server to assign IP addresses to STAs and APs. Switch_1 allocates IP addresses to APs from the IP address pool on VLANIF 100, and allocates IP addresses to STA_1 and STA_2 from the IP address pool on VLANIF 101 and VLANIF 102 respectively.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [Switch_1] dhcp enable
    [Switch_1] interface vlanif 100
    [Switch_1-Vlanif100] ip address 10.23.100.1 255.255.255.0
    [Switch_1-Vlanif100] dhcp select interface
    [Switch_1-Vlanif100] dhcp server excluded-ip-address 10.23.100.2 10.23.100.4
    [Switch_1-Vlanif100] quit
    [Switch_1] interface vlanif 101
    [Switch_1-Vlanif101] ip address 10.23.101.1 255.255.255.0
    [Switch_1-Vlanif101] dhcp select interface
    [Switch_1-Vlanif101] quit
    [Switch_1] interface vlanif 102
    [Switch_1-Vlanif102] ip address 10.23.102.1 255.255.255.0
    [Switch_1-Vlanif102] dhcp select interface
    [Switch_1-Vlanif102] quit
    

  3. Configure AC_1.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100.
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.2/24.



      # Click OK. An address for VLANIF 100 is configured.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Add APs on AC_1.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services on AC_1.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN.



    # Click Next. The Security Authentication page is displayed.

    # Set Security settings to Key (applicable to personnel networks) and set the key.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    # Click Finish.

  6. Configure IP addresses for primary ACs and the backup AC on AC_1.
    1. # Choose Configuration > AP Config > AP Group > AP Group.
    2. # In the AP group list, click ap-group1. Choose AP > AP System Profile. The AP System Profile page is displayed.
    3. # Click Create. On the page that is displayed, set Profile name to ap-system and click OK.
    4. # Expand Dual-Link/N+1 Backup. Set Configuration mode to IP address-based, Primary AC IP address to 10.23.100.2, and Backup AC IP address to 10.23.100.4.



    5. # Click Apply. In the dialog box that is displayed, click OK.
  7. Configure basic WLAN services and the IP addresses for primary ACs and the backup AC on AC_2.

    The configuration is similar to that on AC_1. The following parameters are different:
    • Set the IP address of VLANIF 100 to 10.23.100.3/24.
    • Add APs to ap-group2.
    • Set the SSID name to wlan-net1 and service VLAN to 102.
    • Set the AP system profile name to ap-system1 and Primary AC IP address to 10.23.100.3.
    Set other parameters similarly as those of AC_1.

  8. Configure basic WLAN services and IP address of the backup AC for AC_3.

    The configuration is similar to that on AC_3. The following parameters are different:

    • Set the IP address of VLANIF 100 to 10.23.100.4/24.
    • Import APs on AC_1 and AC_2 to AC_3, and add the APs to ap-group1 and ap-group2, respectively.
    • When configuring WLAN services on AC_3, choose Configuration > Config Wizard > Wireless Service and create SSIDs wlan-net and wlan-net1. Set parameters on wlan-net to the same as those on AC_1 and parameters on wlan-net1 to the same as those on AC_2.
    • Creates AP system profiles ap-system and ap-system1 in AP groups ap-group1 and ap-group2, respectively. Set parameters on ap-system to the same as those on AC_1 and parameters on ap-system1 to the same as those on AC_2.

  9. Enable N+1 backup on AC_1, AC_2, and AC_3.
    1. Enable N+1 backup on AC_1.

      # On AC_1, choose Configuration > Reliability > Reliability. The Reliability page is displayed.

      # Set Backup mode to N+1 backup, AC dual-link switchover status to ON.

      # Click Apply. In the dialog box that is displayed, click OK.

      # Choose Maintenance > AP Maintenance > AP Restart > Restart All to restart all APs, so that the N+1 backup function can take effect.
      NOTE:
      By default, N+1 backup is enabled. You need to restart all APs on the primary AC. After the APs are restarted, N+1 backup takes effect.

    2. Enable N+1 backup on AC_2 and AC_3. The configuration is similar to that on AC_1.
  10. Verify the configuration.
    1. The WLAN with SSIDs wlan-net and wlan-net1 is available for STAs connected to the APs, and these STAs can connect to the WLAN and go online properly.
    2. When the link between an AP and AC_1 or AC_2 fails, AC_3 takes over the primary role. This ensures accelerate service recovery.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90382

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next