No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring WLAN-based E-Schoolbag

Example for Configuring WLAN-based E-Schoolbag

Service Requirements

E-schoolbag is a digital teaching method. In a class, teachers and students use smart terminals such as PCs, tablets, and mobile phones to participate in teaching and learning activities online.

A teacher can teach students in multiple classrooms without space limitation.

To ensure successful teaching activities, AP4030TNs are used to deploy basic WLAN services to support access of many students and provide sufficient bandwidth.

The AP4030TN has three radios: radios 0, 1, and 2. Radio 0 and radio 2 can switch between 2.4 GHz and 5 GHz while radio 1 operates on the 5 GHz band. By default, radio 0 works on the 2.4 GHz frequency band and radio 2 on the 5 GHz frequency band. If all radios are used for WLAN coverage services, the default frequency bands for radios are recommended. If some radios are used for air scan, run the frequency { 2.4g | 5g } command in the AP radio view or AP group radio view to switch the frequency band of the radios.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to assign IP addresses to APs.
    • The aggregation switch (SwitchB) functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: direct forwarding
Figure 5-68 Networking for configuring the WLAN-based e-schoolbag service

Data Planning

Table 5-75 AC data planning

Item

Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs.

SwitchB functions as a DHCP server to assign IP addresses to STAs. The default gateway address of STAs is 10.23.101.2.

IP address pool for APs 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.3-10.23.101.254/24
AC's source interface address VLANIF 100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net, regulatory domain profile default, 2G radio profile wlan-radio2g, and 5G radio profile wlan-radio5g
Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
  • Maximum number of users: 128
  • EDCA parameters for AC_BE packets on STAs
    • AIFSN: 3
    • ECWmin: 7
    • ECWmax: 10
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Band steering: enabled
  • Broadcast flood detection: enabled
  • Rate threshold for broadcast flood detection: 50 pps
  • Referenced profiles: SSID profile wlan-net, security profile wlan-net, and traffic profile wlan-traffic

RRM profile

  • Name: wlan-rrm

  • Airtime fair scheduling: enabled

2G radio profile

  • Name: wlan-radio2g

  • RTS-CTS operation mode: rts-cts
  • RTS-CTS threshold: 1400 bytes
  • Beacon interval: 160 TUs
  • Short preamble: enabled
  • GI mode: short
  • 802.11bg basic rate: 6, 9, 12, 18, 24, 36, 48, 54, in Mbit/s
  • Multicast rate: 11 Mbit/s
  • EDCA parameters for AC_BE packets on APs:
    • AIFSN: 3
    • ECWmin: 5
    • ECWmax: 6
  • Referenced profile: RRM profile wlan-rrm

5G radio profile

  • Name: wlan-radio5g

  • RTS-CTS operation mode: rts-cts
  • RTS-CTS threshold: 1400 bytes
  • Beacon interval: 160 TUs
  • GI mode: short
  • Multicast rate: 6 Mbit/s
  • EDCA parameters for AC_BE packets on APs:
    • AIFSN: 3
    • ECWmin: 5
    • ECWmax: 6
  • Referenced profile: RRM profile wlan-rrm

Traffic profile
  • Name: wlan-traffic
  • Uplink rate limit for a STA: 4000 kbit/s
  • Downlink rate limit for a STA: 4000 kbit/s

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Select Config Wizard to configure AC system parameters.
  3. Select Config Wizard to configure the APs to go online on the AC.
  4. Select Config Wizard to configure WLAN services on the AC.
  5. Adjust network parameters for e-schoolbag.
  6. Deliver the WLAN services to the APs and verify the configuration.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA to VLAN 100 and VLAN 101. The default VLAN of GE0/0/1 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 on SwitchB (aggregation switch) to VLAN 100 and VLAN 101, GE0/0/2 to VLAN 100, and GE0/0/3 to VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 101
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101
    [SwitchB-GigabitEthernet0/0/3] quit
    
    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Configure a DHCP server to assign IP addresses to STAs and specify the gateway for the STAs.

    # On SwitchB, configure VLANIF 101 to assign IP addresses to STAs and set the default gateway address of STAs to 10.23.101.2.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] quit
    

  3. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and VLAN 101 (service VLAN).
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24. Set DHCP status to ON and DHCP type to Interface address pool.



      # Click OK. An address pool for VLANIF 100 is configured.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN.



    # Click Next. The Security Authentication page is displayed.

    # Set Security settings to Key (applicable to personnel networks) and set the key.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    # Click Finish.

  6. Adjust network parameters for e-schoolbag.
    1. Adjust VAP profile parameters.

      # Choose Configuration > AP Config > AP Group > AP Group.

      # In the AP group list, click ap-group1. Choose VAP Configuration > wlan-net. The VAP Profile page is displayed.

      # Enable the band steering function and the broadcast flood attack function and configure the rate threshold for broadcast flood detection.

      # Click Apply. In the dialog box that is displayed, click OK.

    2. Adjust SSID profile parameters.

      # Choose VAP Configuration > wlan-net > SSID Profile. The SSID Profile page is displayed.

      # Set the maximum number of users to 128. Set EDCA parameters for AC_BE packets on STAs as follows: AIFSN to 3, ECWmin to 7, and ECWmax to 10.

      # Click Apply. In the dialog box that is displayed, click OK.

    3. Create a traffic profile and adjust traffic profile parameters.

      # Choose VAP Configuration > wlan-net > Traffic Profile. The Traffic Profile page is displayed.

      # Click Create. On the Create Traffic Profile page that is displayed, enter the profile name wlan-traffic and click OK. The traffic profile configuration page is displayed.

      # Set the upstream and downstream rate limits to 4000 kbit/s and 4000 kbit/s for STAs, respectively.

      # Click Apply. In the dialog box that is displayed, click OK.

    4. Create a 2G radio profile and adjust 2G radio profile parameters.

      # Choose Radio Management > Radio 0 > 2G Radio Profile. The 2G Radio Profile page is displayed.

      # Click Create. On the Create 2G Radio Profile page that is displayed, enter the profile name wlan-radio2g and click OK. The 2G radio profile configuration page is displayed.

      # Perform the following configurations:
      • Set the RTS-CTS mode to rts-cts and the RTS-CTS threshold to 1400 bytes.
      • Set the interval for sending Beacon frames to 160 TUs.
      • Enable the short preamble function.
      • Set the GI mode to short.
      • Set the 802.11bg basic rate to 6, 9, 12, 18, 24, 36, 48, or 54, in Mbit/s.
      • Set the multicast rate to 11 Mbit/s.
      • Set EDCA parameters for AC_BE packets on APs: AIFSN to 3, ECWmin to 5, and ECWmax to 6.


      # Click Apply. In the dialog box that is displayed, click OK.

    5. Create a 5G radio profile and adjust 5G radio profile parameters.

      # Choose Radio Management > Radio 1 > 5G Radio Profile. The 5G Radio Profile page is displayed.

      # Click Create. On the Create 5G Radio Profile page that is displayed, enter the profile name wlan-radio5g and click OK. The 5G radio profile configuration page is displayed.

      # Perform the following configurations:
      • Set the RTS-CTS mode to rts-cts and the RTS-CTS threshold to 1400 bytes.
      • Set the interval for sending Beacon frames to 160 TUs.
      • Set the GI mode to short.
      • Set the multicast rate to 6 Mbit/s.
      • Set EDCA parameters for AC_BE packets on APs: AIFSN to 3, ECWmin to 5, and ECWmax to 6.


      # Click Apply. In the dialog box that is displayed, click OK.

      # Choose Radio Management > Radio 2 > 5G Radio Profile. The 5G Radio Profile page is displayed.

      # On the 5G radio profile configuration page that is displayed, set 5G Radio Profile to wlan-radio5g and click Apply. In the dialog box that is displayed, click OK.

    6. Create the RRM profile and adjust RRM profile parameters.

      # Choose Radio Management > Radio 0 > 2G Radio Profile > RRM Profile. The RRM Profile page is displayed.

      # Click Create. On the Create RRM Profile page that is displayed, enter the profile name wlan-rrm and click OK. The RRM profile configuration page is displayed.

      # Enable airtime fair scheduling.

      # Click Apply. In the dialog box that is displayed, click OK.

      # Choose Radio Management > Radio 1 > 5G Radio Profile > RRM Profile. The RRM Profile page is displayed.

      # On the RRM profile configuration page that is displayed, set RRM Profile to wlan-rrm and click Apply. In the dialog box that is displayed, click OK.

      # The configuration of Radio 2 is similar to that of Radio 1 and is not mentioned here.

  7. Set the AP channel and power.

    # Choose Configuration > AP Config > AP Config > AP Info. The AP List page is displayed.

    # Click the ID of the AP whose channel and power need to be configured. The AP customized settings page is displayed.

    # Click next to Radio Management. The profiles under Radio Management are displayed.

    # Click Radio0. The Radio 0 Settings(2.4G) page is displayed. Set the AP channel to 20-MHz channel 6 and transmit power to 127 dBm. Disable automatic channel and power calibration functions.

    # Click Radio1 and Radio2 to set the channel to 20-MHz channel 149 and 20-MHz channel 153 respectively and transmit power to 127 dBm. The configuration is similar to that of Radio0.

    # Click Apply. In the dialog box that is displayed, click OK.

  8. Verify the configuration.
    1. Choose Monitoring > SSID > VAP. In VAP List, check VAP status. You can see that the status of the VAP in wlan-net is normal.
    2. The WLAN with the SSID wlan-net is available.
    3. The STA can associate with the WLAN and obtain an IP address 10.23.101.x/24, and its gateway address is 10.23.101.2.



    4. Choose Monitoring > User > User Statistics. In User List, set the search criteria to SSID, enter wlan-net, and click . You can see that the STA goes online successfully and obtains an IP address.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90412

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next