No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring External Portal Authentication

Example for Configuring External Portal Authentication

Service Requirements

To improve WLAN security, an enterprise uses the external Portal authentication mode to control user access.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to assign IP addresses to APs.
    • The aggregation switch (SwitchB) functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: tunnel forwarding
  • Authentication mode: External Portal authentication
  • Security policy: open
Figure 4-32 Networking for configuring external Portal authentication

Data Planning

Table 4-32 AC data planning

Item

Data

Management VLAN for APs

VLAN100

Service VLAN for STAs

VLAN101

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs.

SwitchB functions as a DHCP server to assign IP addresses to STAs. The default gateway address of STAs is 10.23.101.2.

IP address pool for APs 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.3-10.23.101.254/24
AC's source interface address VLANIF100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profile: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: open

RADIUS authentication parameters

Name of the RADIUS authentication scheme: wlan-net

Name of the RADIUS accounting scheme: wlan-net

Name of the RADIUS server template: wlan-net

  • IP address: 10.23.102.1
  • Authentication port number: 1812
  • Shared key: Huawei123
Portal server template
  • Name: wlan-net
  • IP address: 10.23.103.1
  • Destination port number in the packets that the AC sends to the Portal server: 50200
  • Portal shared key: Huawei123

Portal access profile

  • Name: wlan-net
  • Referenced profile: Portal server template wlan-net

Authentication-free rule profile
  • Name:default_free_rule
  • Authentication-free resource: IP address of the DNS server (8.8.8.8)

Authentication Profile

  • Name: wlan-net

  • Referenced profile: Portal access profile wlan-net, RADIUS Server profile wlan-net, authentication-free rule profile default_free_rule and authentication scheme wlan-net

VAP profile

  • Name: wlan-net

  • Forwarding mode: tunnel forwarding

  • Service VLAN: VLAN 101

  • Referenced profile: SSID profile wlan-net, security profile wlan-net and Authentication profile wlan-net

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Configure the APs to go online.
  3. Configure external Portal authentication.
    1. Configure RADIUS server parameters.
    2. Configure a Portal access profile to manage Portal access control parameters.
    3. Configure an authentication-free rule profile so that the AC allows packets to the DNS server to pass through.
    4. Configure an authentication profile to manage external Portal authentication configuration.
  4. Configure WLAN service parameters.
  5. Configure third-party server interconnection parameters.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA to VLAN 100. The default VLAN of GE0/0/1 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 and GE0/0/2 on SwitchB (aggregation switch) to VLAN 100, and GE0/0/2 and GE0/0/3 to VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 101
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101
    [SwitchB-GigabitEthernet0/0/3] quit
    
    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Configure the AC to communicate with the network devices.

    NOTE:

    If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.

    # Add GE0/0/1 on the AC to VLAN 100 and VLAN 101.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [AC-GigabitEthernet0/0/1] quit
    

  3. Configure the DHCP servers to assign IP addresses to APs and STAs.

    # On the AC, configure VLANIF 100 to assign IP addresses to APs.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    
    # On SwitchB, configure VLANIF 101 to assign IP addresses to STAs and set the default gateway address of STAs to 10.23.101.2.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] dhcp server dns-list 8.8.8.8
    [SwitchB-Vlanif101] quit
    

  4. Configure a default route on AC with the outbound interface as the router's VLANIF 101.

    [AC] ip route-static 0.0.0.0 0.0.0.0 10.23.101.2
    

  5. Configure an AP to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    
    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online successfully.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    Extra information:
    P  : insufficient power supply
    --------------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime      ExtraInfo
    --------------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S         -
    --------------------------------------------------------------------------------------------------
    Total: 1

  6. Configure a RADIUS server template, a RADIUS authentication scheme and a RADIUS accounting scheme.

    NOTE:

    Ensure that the RADIUS server IP address, port number, and shared key are configured correctly and are the same as those on the RADIUS server.

    # Configure a RADIUS server template.

    [AC] radius-server template wlan-net
    [AC-radius-wlan-net] radius-server authentication 10.23.102.1 1812
    [AC-radius-wlan-net] radius-server shared-key cipher Huawei123
    [AC-radius-wlan-net] quit

    # Create an authentication scheme and configure the RADIUS authentication mode.

    [AC] aaa
    [AC-aaa] authentication-scheme wlan-net
    [AC-aaa-authen-wlan-net] authentication-mode radius
    [AC-aaa-authen-wlan-net] quit
    

    # Create an authentication scheme and configure the RADIUS authentication mode.

    [AC-aaa] accounting-scheme wlan-net
    [AC-aaa-accounting-wlan-net] accounting-mode radius
    [AC-aaa-accounting-wlan-net] accounting realtime 15
    [AC-aaa-accounting-wlan-net] quit
    [AC-aaa] quit
    NOTE:
    • In this example, the device is connected to the Agile Controller-Campus. The accounting function is not implemented for accounting purposes, and is used to maintain terminal online information through accounting packets.

    • The accounting realtime command sets the real-time accounting interval. A shorter real-time accounting interval requires higher performance of the device and RADIUS server. Set the real-time accounting interval based on the user quantity.

    User Quantity Real-Time Accounting Interval
    1-99 3 minutes
    100-499 6 minutes
    500-999 12 minutes
    ≥ 1000 ≥ 15 minutes

  7. Configure the URL of the Portal authentication page. When a user attempts to access a website before authentication, the AC redirects the website to the Portal server.

    You are advised to configure the URL using a domain name to ensure secure and fast page pushing. Before configuring the URL using a domain name, you must first configure the mapping between the domain name and IP address of the Portal server on the DNS server.

    NOTE:
    Configure parameters carried in the URL, which must be the same as those on the authentication server.
    [AC] url-template name wlan-net
    [AC-url-template-wlan-net] url http://portal.com:8080/portal
    [AC-url-template-wlan-net] url-parameter ssid ssid redirect-url url 
    [AC-url-template-wlan-net] quit

  8. Configure a Portal server template.

    NOTE:

    Ensure that the Portal server IP address, URL address, port number, and shared key are configured correctly and are the same as those on the Portal server.

    [AC] web-auth-server wlan-net
    [AC-web-auth-server-wlan-net] server-ip 10.23.103.1
    [AC-web-auth-server-wlan-net] shared-key cipher Huawei123
    [AC-web-auth-server-wlan-net] port 50200
    [AC-web-auth-server-wlan-net] url-template wlan-net ciphered-parameter-name cpname iv-parameter-name iv-value key cipher Huawei123
    [AC-web-auth-server-wlan-net] quit
    

  9. Configure the Portal access profile wlan-net and configure Layer 2 Portal authentication.

    [AC] portal-access-profile name wlan-net
    [AC-portal-access-profile-wlan-net] web-auth-server wlan-net direct
    [AC-portal-access-profile-wlan-net] quit

  10. Configure an authentication-free rule profile.

    [AC] free-rule-template name default_free_rule
    [AC-free-rule-default_free_rule] free-rule 1 destination ip 8.8.8.8 mask 32
    [AC-free-rule-default_free_rule] quit
    

  11. Configure the authentication profile wlan-net.

    [AC] authentication-profile name wlan-net
    [AC-authentication-profile-wlan-net] portal-access-profile wlan-net
    [AC-authentication-profile-wlan-net] free-rule-template default_free_rule
    [AC-authentication-profile-wlan-net] authentication-scheme wlan-net
    [AC-authentication-profile-wlan-net] radius-server wlan-net
    [AC-authentication-profile-wlan-net] quit

  12. Configure WLAN service parameters.

    # Create security profile wlan-net and set the security policy in the profile. By default, the security policy is open system.

    [AC] wlan
    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] quit
    

    # Create SSID profile wlan-net and set the SSID name to wlan-net.

    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ssid-prof-wlan-net] quit
    

    # Create VAP profile wlan-net, configure the data forwarding mode and service VLANs, and apply the security profile, SSID profile, and authentication profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] authentication-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    

    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

  13. Configure third-party server interconnection parameters.

    • For interconnection with the Cisco ISE, see "Example for Configuring External Portal Authentication (CLI)" in the WLAN Product Interoperation Configuration Guide-Typical Configuration for Interconnection Between AC and Cisco ISE Server.
    • For interconnection with the Agile Controller-Campus, see "Example for Configuring Portal Authentication (Including MAC Address-Prioritized Portal Authentication) for Wireless Users" in the WLAN Product Interoperation Configuration Guide-Typical Configuration for Interconnection Between AC and Huawei Agile Controller-Campus Server.
    • For interconnection with other third-party servers, see the corresponding product manual.

  14. Verify the configuration.

    • The WLAN with the SSID wlan-net is available for STAs after the configuration is complete.

    • The STAs obtain IP addresses when they successfully associate with the WLAN.
    • When a user opens the browser and attempts to access the network, the user is automatically redirected to the authentication page provided by the Portal server. After entering the correct user name and password on the page, the user can access the network.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
     dhcp server gateway-list 10.23.101.2
     dhcp server dns-list 8.8.8.8
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    vlan batch 101
    #
    interface Vlanif101
     ip address 10.23.101.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    return
    
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    authentication-profile name wlan-net
     portal-access-profile wlan-net
     free-rule-template default_free_rule
     authentication-scheme wlan-net
     radius-server wlan-net
    #
    dhcp enable
    #
    aaa
     authentication-scheme wlan-net
      authentication-mode radius
     accounting-scheme wlan-net
      accounting-mode radius
      accounting realtime 15
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 101
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.101.2 
    #
    capwap source interface vlanif100
    #
    radius-server template wlan-net
     radius-server shared-key cipher %^%#Oc6_BMCw#9gZ2@SMVtk!PAC6>Ou*eLW/"qLp+f#$%^%#
     radius-server authentication 10.23.102.1 1812 weight 80
    #
    free-rule-template name default_free_rule
     free-rule 1 destination ip 8.8.8.8 mask 255.255.255.255
    #
    url-template name wlan-net
     url http://portal.com:8080/portal
    #
    web-auth-server wlan-net
     server-ip 10.23.103.1
     port 50200
     shared-key cipher %^%#4~ZXE3]6@BXu;2;aw}hA{rSb,@"L@T#e{%6G1AiD%^%#
     url-template wlan-net ciphered-parameter-name cpname iv-parameter-name iv-value key cipher %^%#4~ZXE3]6@BXu;2;aw}hA{rSb,@"L@T#e{%6G1AiD%^%#
    #
    portal-access-profile name wlan-net
     web-auth-server wlan-net direct
    #
    wlan
     security-profile name wlan-net
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
      authentication-profile wlan-net
     ap-group name ap-group1
      regulatory-domain-profile default
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 91277

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next