No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an Eth-Trunk on an AP's Wired Uplink Interfaces

Example for Configuring an Eth-Trunk on an AP's Wired Uplink Interfaces

Service Requirements

The administrator wants to configure an Eth-Trunk on an AP's wired uplink interfaces to ensure uplink reliability.

Networking Requirements

  • AC networking mode: Layer 2 inline mode

  • Service data forwarding mode: tunnel forwarding

Figure 4-29 Networking for configuring an Eth-Trunk on an AP's wired uplink interfaces

Data Planning

Table 4-31 AC data planning
Item Data

Management VLAN for APs

VLAN 100

AP wired port profile

  • Name: wired-port1
  • Eth-Trunk: Eth-Trunk0

AP group

  • Name: ap-group1
  • Referenced profile: AP wired port profile wired-port1 and wired-port2

Configuration Roadmap

  1. Configure an Eth-Trunk on a switch.
  2. Configure an Eth-Trunk for an AP on the AC.
  3. Restart the AP.
  4. Connect the switch and AP physically.

Configuration Notes

  • This example is applicable to an AP with two or more wired uplink interfaces.

  • This example assumes that the AP has gone online and describes how to configure an Eth-Trunk on the wired uplink interfaces of the AP. Before physical connections, configure the Eth-Trunk. Otherwise, a loop will occur on the network, causing the AP to go offline.

  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Check AP information.

    Check Item

    Command

    Data

    Check the AP group to which an AP belongs.

    display ap all

    AP group: ap-group1

    AP name: AP1

  2. Configure an Eth-Trunk on the switch.

    # Create Eth-Trunk1, and add GE0/0/1 and GE0/0/2 to Eth-Trunk1.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100
    [Switch] interface eth-trunk 1
    [Switch-Eth-Trunk1] description Connect to AP1
    [Switch-Eth-Trunk1] port link-type trunk
    [Switch-Eth-Trunk1] port trunk pvid vlan 100
    [Switch-Eth-Trunk1] port trunk allow-pass vlan 100
    [Switch-Eth-Trunk1] undo port trunk allow-pass vlan 1
    [Switch-Eth-Trunk1] port-isolate enable
    [Switch-Eth-Trunk1] quit
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] eth-trunk 1
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] eth-trunk 1
    [Switch-GigabitEthernet0/0/2] quit
    

  3. Configure an Eth-Trunk for the AP on the AC.

    # Create the AP wired port profile wired-port1. Add GE0 and GE1 on the AP to Eth-Trunk0.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] wlan
    [AC-wlan-view] wired-port-profile name wired-port1
    [AC-wlan-wired-port-wired-port1] eth-trunk 0
    [AC-wlan-wired-port-wired-port1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] wired-port-profile wired-port1 gigabitethernet 0
    [AC-wlan-ap-group-ap-group1] wired-port-profile wired-port1 gigabitethernet 1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Configure Eth-Trunk0.
    [AC-wlan-view] wired-port-profile name wired-port2
    [AC-wlan-wired-port-wired-port1] mode root
    Warning: If the AP goes online through a wired port, the incorrect port mode configuration will cause the AP to go out of management. This fault can be recovered only by modifying the configuration on the AP. Continue? [Y/N]:Y
    [AC-wlan-wired-port-wired-port1] vlan tagged 100
    [AC-wlan-wired-port-wired-port1] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] wired-port-profile wired-port2 eth-trunk 0
    [AC-wlan-ap-group-ap-group1] quit
    

  4. Verify the configuration.

    # Run the display wired-port-profile name wired-port1 command to check the configuration of the AP wired port profile.

    [AC-wlan-view] display wired-port-profile name wired-port1
    ----------------------------------------------------------------------------
    Port link profile                              : default
    Description                                    : 
    Ethernet trunk ID                              : 0 
    ----------------------------------------------------------------------------
    

  5. Restart the AP.

    NOTE:

    The configuration on the AP's wired interfaces takes effect only after the AP is restarted.

    [AC-wlan-view] ap-reset ap-name AP1
    Warning: Reset AP(s), continue?[Y/N]:y

  6. Connect the switch and AP physically.

Configuration Files

  • Switch configuration file

    #
     sysname Switch
    #
     vlan batch 100
    # 
    interface Eth-Trunk1
     description Connect to AP1
     port link-type trunk
     port trunk pvid vlan 100
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/1
     eth-trunk 1
    # 
    interface GigabitEthernet0/0/2
     eth-trunk 1
    # 
    return
  • AC configuration file

    #
    sysname AC
    #
    vlan batch 100
    #
    wlan
     wired-port-profile name wired-port1 
      eth-trunk 0
     wired-port-profile name wired-port2                                            
      mode root                                                                     
      vlan tagged 100 
     ap-group name ap-group1 
      wired-port-profile wired-port1 gigabitethernet 0
      wired-port-profile wired-port1 gigabitethernet 1
      wired-port-profile wired-port2 eth-trunk 0 
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90196

Downloads: 456

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next