No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring MAC Address Authentication (CLI)

Example for Configuring MAC Address Authentication (CLI)

Introduction to MAC Address Authentication

MAC address authentication is a method used for Network Admission Control (NAC). It controls user access rights based on access ports and user MAC addresses to protect security for enterprise networks.

MAC address authentication does not need client software, but user terminals' MAC addresses must be registered on the authentication server. Network configuration and management are complex. In contrast, 802.1x authentication needs client software, allowing low networking flexibility. However, 802.1x authentication is more secure. Portal authentication also does not need client software, allowing flexible deployment. However, it does not provide high security.

MAC address authentication is applicable to dumb terminals such as printers and fax machine.

For details about how to configure MAC address authentication on the AC, see Configure MAC address authentication on the AC.

For details about how to configure MAC address authentication on the Aruba ClearPass server, see Configure the Aruba ClearPass.

Applicable Products and Versions

Table 4-101 Applicable products and versions

Product

Version

Huawei AC

V200R007C10 and later versions

Aruba ClearPass Policy Manager

6.5.0.71095

Service Requirements

MAC address authentication is used to authenticate dumb terminals such as wireless network printers and wireless phones that cannot have an authentication client installed.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: The AC functions as the DHCP server to assign IP addresses to APs, and SwitchB functions as the DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: direct forwarding
  • Authentication mode: open system authentication
Figure 4-88 Networking diagram for configuring MAC address authentication

Data Planning

Table 4-102 Data planning on the AC

Configuration Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

AC's source interface

VLANIF 100: 10.23.100.1/24

DHCP server

The AC functions as the DHCP server to assign IP addresses to APs, and SwitchB functions as the DHCP server to assign IP addresses to STAs.

IP address pool for APs

10.23.100.2-10.23.100.254/24

IP address pool for the STAs

10.23.101.2-10.23.101.254/24

RADIUS authentication parameters

  • RADIUS server template name: wlan-net
  • IP address: 10.23.103.1
  • Authentication port number: 1812
  • Shared key: huawei@123
  • Authentication scheme: wlan-net

MAC access profile

Name: wlan-net

Authentication profile

  • Name: wlan-net
  • Bound profile and authentication scheme: MAC access profile wlan-net, RADIUS server template wlan-net, and authentication scheme wlan-net

AP group

  • Name: ap-group1
  • Bound profile: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: CN

SSID profile

  • Name: wlan-net
  • SSID name: wlan-net

Security profile

  • Name: wlan-net
  • Security policy: open system authentication

VAP profile

  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Bound profiles: SSID profile wlan-net, security profile wlan-net, and authentication profile wlan-net
Table 4-103 Data planning on the Aruba ClearPass

Configuration Item

Data

Terminals

MAC addresses (use the actual MAC addresses of devices)

Device name

AC6605

Device's IP address

10.23.102.2/32

RADIUS shared key

huawei@123

Service

  • Name: Radius
  • Type: MAC authentication
  • Authentication method: MAC AUTH
  • Authentication source: [Endpoints Repository][Local SQL DB]

Configuration Roadmap

  1. Configure network interworking.
  2. Configure the AC and SwitchB to assign IP addresses to APs and STAs, respectively.
  3. Configure APs to go online.
  4. Configure MAC address authentication on the AC.
  5. Configure the Aruba ClearPass server.

Configuration Notes

  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • The AC and server must have the same RADIUS shared key.

Procedure

  1. Configure network interworking.

    # Add GE0/0/1 and GE0/0/2 on SwitchA (access switch) to VLAN 100 and VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 on SwitchB (aggregation switch) to VLAN 100 and VLAN 101, GE0/0/2 to VLAN 100 and VLAN 102, GE0/0/3 to VLAN 103, and GE0/0/4 to VLAN104. Create VLANIF 102, VLANIF 103, and VLANIF 104, and configure a default route with the next hop of the address of Router.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 to 104
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk pvid vlan 103
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 103
    [SwitchB-GigabitEthernet0/0/3] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk pvid vlan 104
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 104
    [SwitchB-GigabitEthernet0/0/4] quit
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] quit
    [SwitchB] interface vlanif 103
    [SwitchB-Vlanif103] ip address 10.23.103.2 24
    [SwitchB-Vlanif103] quit
    [SwitchB] interface vlanif 104
    [SwitchB-Vlanif104] ip address 10.23.104.1 24
    [SwitchB-Vlanif104] quit
    [SwitchB] ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    
    # Add GE0/0/1 on the AC to VLAN 100 and VLAN 102. Create VLANIF 102 and configure the static route to the RADIUS server.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101 102
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 102
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 102
    [AC-Vlanif102] ip address 10.23.102.2 24
    [AC-Vlanif102] quit
    [AC] ip route-static 10.23.103.0 24 10.23.102.1
    
    # Configure the IP address of GE0/0/1 on Router and a static route to the network segment for STAs.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 10.23.104.2 24
    [Router-GigabitEthernet0/0/1] quit
    [Router] ip route-static 10.23.101.0 24 10.23.104.1
    

  2. Configure the AC and SwitchB to function as DHCP servers to assign IP addresses to APs and STAs respectively.

    # On the AC, configure the VLANIF 100 to assign IP addresses to APs.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    # On SwitchB, configure the VLANIF 101 to assign IP addresses to STAs.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] quit

  3. Configure APs to go online.

    # Create an AP group to which the APs with the same configuration can be added.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and bind the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the APs offline to the AC and add the APs to the AP group ap-group1. Configure names for the APs based on the AP locations, so that you can know where the APs are located. For example, if the AP with MAC address 60de-4476-e360 is deployed in area 1, name the AP area_1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 and radio 1. Radio 0 and radio 1 operate on the 2.4 GHz and 5 GHz bands respectively.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field displays nor, the AP has gone online.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    --------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    --------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S
    --------------------------------------------------------------------------------
    Total: 1
    

  4. Configure the AP channel and power.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The settings of the AP channel and power in this example are for reference only. You need to configure the AP channel and power based on the actual country code and network planning.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] calibrate auto-channel-select disable
    [AC-wlan-radio-0/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] calibrate auto-channel-select disable
    [AC-wlan-radio-0/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  5. Configure MAC address authentication on the AC.
    1. Configure RADIUS authentication parameters.

      # Create a RADIUS server template.

      [AC-wlan-view] quit
      [AC] radius-server template wlan-net
      [AC-radius-wlan-net] radius-server authentication 10.23.103.1 1812
      [AC-radius-wlan-net] radius-server shared-key cipher huawei@123
      [AC-radius-wlan-net] radius-attribute set Service-Type 10 auth-type mac
      [AC-radius-wlan-net] quit
      

      # Create a RADIUS authentication scheme.

      [AC] aaa
      [AC-aaa] authentication-scheme wlan-net
      [AC-aaa-authen-wlan-net] authentication-mode radius
      [AC-aaa-authen-wlan-net] quit
      [AC-aaa] quit
      
      # Configure the NAS-Identifier attribute.
      NOTE:

      The NAS-Identifier value must be the same on the AC and ClearPass server. If this attribute is not configured on the AC, set the value of NAS-Identifier on the ClearPass server to the AC name.

      [AC] radius-server template wlan-net
      [AC-radius-wlan-net] radius-attribute set NAS-Identifier huaweiac
      [AC-radius-wlan-net] quit
      

    2. Configure a MAC access profile.

      NOTE:
      In a MAC access profile, a MAC address without hyphens (-) is used as the user name and password for MAC address authentication.

      # Create the MAC access profile wlan-net.

      [AC] mac-access-profile name wlan-net
      [AC-mac-access-profile-wlan-net] quit
      

    3. Create the authentication profile wlan-net and bind it to the MAC access profile, authentication scheme, and RADIUS server template.

      [AC] authentication-profile name wlan-net
      [AC-authentication-profile-wlan-net] mac-access-profile wlan-net
      [AC-authentication-profile-wlan-net] authentication-scheme wlan-net
      [AC-authentication-profile-wlan-net] radius-server wlan-net
      [AC-authentication-profile-wlan-net] quit

    4. Configure WLAN service parameters.

      # Create the security profile wlan-net and set the security policy in the profile. By default, the security policy is open system authentication.

      [AC] wlan
      [AC-wlan-view] security-profile name wlan-net
      [AC-wlan-sec-prof-wlan-net] quit
      

      # Create the SSID profile wlan-net and set the SSID name to wlan-net.

      [AC-wlan-view] ssid-profile name wlan-net
      [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-ssid-prof-wlan-net] quit
      

      # Create the VAP profile wlan-net, configure the direct data forwarding mode and service VLANs, and bind the security profile, authentication profile, and SSID profile to the VAP profile.

      [AC-wlan-view] vap-profile name wlan-net
      [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
      [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
      [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] authentication-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] quit
      

      # Bind the VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.

      [AC-wlan-view] ap-group name ap-group1
      [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
      [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
      [AC-wlan-ap-group-ap-group1] quit
      [AC-wlan-view] quit
      

  6. Configure the Aruba ClearPass.
    1. Log in to the Aruba ClearPass server.

      # Enter the access address of the Aruba ClearPass server in the address box, which is in the format of https://Aruba ClearPass IP. Aruba ClearPass IP is the IP address of the Aruba ClearPass server.

      # Choose ClearPass Policy Manager.

      # On the displayed page, enter the user name and password to log in to the Aruba ClearPass server.

    2. Add STAs.

      # Choose Configuration > Identity > Endpoints. In the pane on the right side, click Add. In the Add Endpoint dialog box, set MAC Address and click Add.



    3. Add the AC so that the Aruba ClearPass can interwork with the AC.

      # Choose Configuration > Network > Devices. In the pane on the right side, click Add. Configure Name, IP or Subnet Address, RADIUS Shared Secret, and Vendor Name. Then, click Add.



    4. Configure the service Radius.

      # Choose Configuration > Services. In the pane on the right side, click Add.

      # On the Service tab, set Type to MAC Authentication and Name to Radius.On the Service Rule tab, click Click to add. On the page that is displayed, set Type to Radius:IETF, Name to NAS-Identifier, Operator to EQUALS, and Value to huaweiac

      NOTE:

      The NAS-Identifier value must be the same on the AC and ClearPass server. If this attribute is not configured on the AC, set the value of NAS-Identifier on the ClearPass server to the AC name.



      # On the Authentication tab, add [MAC AUTH] to Authentication Methods and [Endpoints Repository][Local SQL DB] to Authentication Sources. Then, click Save.



      # On other tabs, use default settings.

  7. On the AC, check whether users can pass RADIUS authentication.

    [AC] test-aaa huawei huawei123 radius-template wlan-net
    Info: Account test succeed.
    

  8. Verify the configuration.

    • After dumb terminals associate with the WLAN, authentication is performed automatically. After the terminals pass authentication, they can access the network.

    • After dumb terminals associate with the WLAN, run the display access-user access-type mac-authen command on the AC. The command output shows that user huawei using the mac-authen authentication mode has successfully gone online.

      [AC] display access-user access-type mac-authen
      ------------------------------------------------------------------------------
      UserID Username                IP address       MAC            Status          
      ------------------------------------------------------------------------------
      460    huawei                  10.23.101.254    8000-6e74-e78a Success 
      ------------------------------------------------------------------------------
      Total: 1, printed: 1
      

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100 to 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 to 104
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
    #
    interface Vlanif103
     ip address 10.23.103.2 255.255.255.0
    #
    interface Vlanif104
     ip address 10.23.104.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 103
     port trunk allow-pass vlan 103
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk pvid vlan 104
     port trunk allow-pass vlan 104
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    interface GigabitEthernet0/0/1
     ip address 10.23.104.2 255.255.255.0
    #
    ip route-static 10.23.101.0 255.255.255.0 10.23.104.1
    #
    return
    
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 102
    #
    authentication-profile name wlan-net
     mac-access-profile wlan-net
     authentication-scheme wlan-net
     radius-server wlan-net
    #
    dhcp enable
    #
    radius-server template wlan-net
     radius-server shared-key cipher %^%#*7d1;XNof/|Q0:DsP!,W51DIYPx}`AARBdJ'0B^$%^%#
     radius-server authentication 10.23.103.1 1812 weight 80
     radius-attribute set Service-Type 10 auth-type mac
     radius-attribute set NAS-Identifier huaweiac
    #
    aaa
     authentication-scheme wlan-net
      authentication-mode radius
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    ip route-static 10.23.103.0 255.255.255.0 10.23.102.1
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
      authentication-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
      radio 1
       channel 20mhz 149
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
    #
    mac-access-profile name wlan-net
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90431

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next