No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Vehicle-Ground Fast Link Handover

Example for Configuring Vehicle-Ground Fast Link Handover

Service Requirements

To reduce network deployment costs and better serve passengers, a rail transportation enterprise wants to use WLAN technology to implement vehicle-ground communications and expects that multicast servers on the ground network can deliver multimedia information services to passengers.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • Wireless backhaul mode: Mesh-based vehicle-ground fast link handover
  • Backhaul radio: 5 GHz radio
Figure 5-53 Networking for configuring vehicle-ground fast link handover

Data Planning

Table 5-59 AP information

AP

Type

MAC Address

Trackside AP (L1_001)

AP9132DN

0046-4b59-1d10

Trackside AP (L1_003)

AP9132DN

0046-4b59-1d20

Trackside AP (L1_010)

AP9132DN

0046-4b59-1d30

Trackside AP (L1_150)

AP9132DN

0046-4b59-1d40

Trackside AP (L1_160)

AP9132DN

0046-4b59-1d50

Trackside AP (L1_170)

AP9132DN

0046-4b59-1d60

......

Vehicle-mounted AP (in the front)

AP9132DN

0046-4b59-2e10

Vehicle-mounted AP (in the rear)

AP9132DN

0046-4b59-2e20

.......
Table 5-60 Data planning

Item

Data

Management VLAN VLAN 100
Multicast service VLAN VLAN 101
Service VLAN for STAs VLAN 200
DHCP server
  • Configure the AC as a DHCP server to assign IP addresses to trackside APs.
  • Configure Switch_A as a DHCP server to assign IP addresses to vehicle-mounted terminals.
AC's source interface address VLANIF 100: 10.23.100.1/24
Gateway address IP address of VLANIF 101 on Switch_A: 10.23.224.1/24
IP address pool for trackside APs 10.23.100.2-10.23.100.254/24
IP address pool for vehicle-mounted terminals 10.23.224.4-10.23.224.254/24
AP group to which trackside APs belong Name: mesh-mpp
IDs of trackside APs
  • Trackside AP (L1_001): 1
  • Trackside AP (L1_003): 2
  • Trackside AP (L1_010): 3
  • Trackside AP (L1_150): 101
  • Trackside AP (L1_160): 102
  • Trackside AP (L1_170): 103
AP wired port profile
  • Name: wired-port
Security profile
  • Name: sp01
  • Security policy: WPA2+PSK+AES
  • Password type: PASS-PHRASE
  • Authentication key: a1234567
Mesh profile
Trackside APs:
  • Name: mesh-net
  • Identifier: mesh-net
Vehicle-mounted APs:
  • Name: mesh-net
  • Identifier: mesh-net
Mesh handover profile

Trackside APs:

  • Name: hand-over

Vehicle-mounted APs:

  • Name: hand-over
Mesh whitelist on trackside APs Name: whitelist01

Add MAC addresses of all vehicle-mounted APs on trains running on the rail to the whitelist according to actual situations.

MAC address of the proxied ground device
  • Gateway: 707b-e8e9-d328
  • Network management device: 286e-d488-12cd
  • Multicast source: 286e-d488-b6ab
MAC address of the proxied vehicle-mounted device
  • Vehicle-mounted terminal_1: 286e-d488-d359
  • Vehicle-mounted terminal_2: 286e-d488-d270
Multicast group 225.1.1.1-225.1.1.3

Configuration Roadmap

  1. Configure the ground network to enable Layer 2 communications between trackside APs and the AC.
  2. Configure multicast services on ground network devices to enable proper multicast data forwarding on the ground network.
  3. Configure vehicle-ground fast link handover on trackside and vehicle-mounted APs so that the vehicle-mounted AP can set up Mesh connections with the trackside APs.
  4. Configure the vehicle-mounted network to enable intra-network data communications.
NOTE:
  • This example uses Huawei AP9132DNs in Fit AP mode as the trackside APs and AP9132DNs in Fat AP mode as the vehicle-mounted APs.
  • Switches and routers used in this example are all Huawei products.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure switches.
    1. Configure Switch_A. Create VLAN 100, VLAN 101 and VLAN 200, add interfaces GE0/0/1 to GE0/0/4 to VLAN 101, and configure these interfaces to allow packets from VLAN 101 to pass through. Set PVIDs of GE0/0/3 and GE0/0/4 to VLAN 101. Add GE0/0/5 to VLAN 200, set its PVID to VLAN 200, and configure GE0/0/5 to allow packets from VLAN 200 to pass through. Configure GE0/0/1, GE0/0/2, and GE0/0/6 to allow packets from VLAN 100 to pass through.

      <HUAWEI> system-view
      [HUAWEI] sysname Switch_A
      [Switch_A] vlan batch 100 101 200
      [Switch_A] interface gigabitEthernet 0/0/1
      [Switch_A-GigabitEthernet0/0/1] port link-type trunk
      [Switch_A-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
      [Switch_A-GigabitEthernet0/0/1] quit
      [Switch_A] interface gigabitEthernet 0/0/2
      [Switch_A-GigabitEthernet0/0/2] port link-type trunk
      [Switch_A-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
      [Switch_A-GigabitEthernet0/0/2] quit
      [Switch_A] interface gigabitEthernet 0/0/3
      [Switch_A-GigabitEthernet0/0/3] port link-type trunk
      [Switch_A-GigabitEthernet0/0/3] port trunk pvid vlan 101
      [Switch_A-GigabitEthernet0/0/3] port trunk allow-pass vlan 101
      [Switch_A-GigabitEthernet0/0/3] quit
      [Switch_A] interface gigabitEthernet 0/0/4
      [Switch_A-GigabitEthernet0/0/4] port link-type trunk
      [Switch_A-GigabitEthernet0/0/4] port trunk pvid vlan 101
      [Switch_A-GigabitEthernet0/0/4] port trunk allow-pass vlan 101
      [Switch_A-GigabitEthernet0/0/4] quit
      [Switch_A] interface gigabitEthernet 0/0/5
      [Switch_A-GigabitEthernet0/0/5] port link-type trunk
      [Switch_A-GigabitEthernet0/0/5] port trunk pvid vlan 200
      [Switch_A-GigabitEthernet0/0/5] port trunk allow-pass vlan 200
      [Switch_A-GigabitEthernet0/0/5] quit
      [Switch_A] interface gigabitEthernet 0/0/6
      [Switch_A-GigabitEthernet0/0/6] port link-type trunk
      [Switch_A-GigabitEthernet0/0/6] port trunk allow-pass vlan 100
      [Switch_A-GigabitEthernet0/0/6] quit

    2. On Switch_A, configure an IP address for VLANIF 101 and enable the DHCP server function to assign IP addresses for vehicle-mounted terminals.

      [Switch_A] dhcp enable
      [Switch_A] interface vlanif 101
      [Switch_A-Vlanif101] ip address 10.23.224.1 24
      [Switch_A-Vlanif101] dhcp select interface
      [Switch_A-Vlanif101] dhcp server excluded-ip-address 10.23.224.2 10.23.224.3
      [Switch_A-Vlanif101] quit
      

    3. Configure an IP address for VLANIF 200 on Switch_A and specify the IP address of GE1/0/0 on the router as the next hop address of the default route so that packets from the vehicle-ground communication network can be forwarded to the egress router.

      [Switch_A] interface vlanif 200
      [Switch_A-Vlanif200] ip address 10.23.200.2 24
      [Switch_A-Vlanif200] quit
      [Switch_A] ip route-static 0.0.0.0 0 10.23.200.1
      

    4. Configure an IP address for GE1/0/0 on Router and configure routes to the internal network segment, with the next hop address 10.23.200.2.

      <Huawei> system-view
      [Huawei] sysname Router
      [Router] interface gigabitethernet 1/0/0
      [Router-GigabitEthernet1/0/0] ip address 10.23.200.1 24
      [Router-GigabitEthernet1/0/0] quit
      [Router] ip route-static 10.23.224.0 24 10.23.200.2
      [Router] ip route-static 10.23.100.0 24 10.23.200.2
      
      NOTE:
      You can configure routes to external networks and the NAT function on the egress router according to service requirements to ensure normal communications between internal and external networks.

    5. Configure Switch_B and Switch_C to enable Layer 2 communications between trackside APs and the ground network.

      # On Switch_B, create VLAN 100 and VLAN 101, configure GE0/0/2 and GE0/0/1 to allow packets from VLAN 100 and VLAN 101 to pass through, and set the PVID of GE0/0/1 to VLAN 100 (management VLAN for trackside APs).

      # Configure other interfaces connected to trackside APs on Switch_B according to GE0/0/1: allow packets from VLAN 100 and VLAN 101 to pass through and set their PVIDs to VLAN 100.
      <HUAWEI> system-view
      [HUAWEI] sysname Switch_B
      [Switch_B] vlan batch 100 101
      [Switch_B] interface gigabitEthernet 0/0/2
      [Switch_B-GigabitEthernet0/0/2] port link-type trunk
      [Switch_B-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
      [Switch_B-GigabitEthernet0/0/2] quit
      [Switch_B] interface gigabitEthernet 0/0/1
      [Switch_B-GigabitEthernet0/0/1] port link-type trunk
      [Switch_B-GigabitEthernet0/0/1] port trunk pvid vlan 100
      [Switch_B-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
      [Switch_B-GigabitEthernet0/0/1] quit

      # On Switch_C, create VLAN 100 and VLAN 101, configure GE0/0/2 and GE0/0/1 to allow packets from VLAN 100 and VLAN 101 to pass through, and set the PVID of GE0/0/1 to VLAN 100.

      # Configure other interfaces connected to trackside APs on Switch_C according to GE0/0/1: allow packets from VLAN 100 and VLAN 101 to pass through and set their PVIDs to VLAN 100.
      <HUAWEI> system-view
      [HUAWEI] sysname Switch_C
      [Switch_C] vlan batch 100 101
      [Switch_C] interface gigabitEthernet 0/0/2
      [Switch_C-GigabitEthernet0/0/2] port link-type trunk
      [Switch_C-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
      [Switch_C-GigabitEthernet0/0/2] quit
      [Switch_C] interface gigabitEthernet 0/0/1
      [Switch_C-GigabitEthernet0/0/1] port link-type trunk
      [Switch_C-GigabitEthernet0/0/1] port trunk pvid vlan 100
      [Switch_C-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
      [Switch_C-GigabitEthernet0/0/1] quit

    6. Enable Layer 2 multicast on Switch_A, Switch_B, and Switch_C to allow them to properly forward multicast data.

      # Enable IGMP snooping globally on Switch_A.

      [Switch_A] igmp-snooping enable

      # Enable IGMP snooping in VLAN 101 on Switch_A.

      [Switch_A] vlan 101
      [Switch_A-vlan101] igmp-snooping enable
      [Switch_A-vlan101] quit
      

      # Configure multicast group filter policies on Switch_A.

      [Switch_A] acl 2000
      [Switch_A-acl-basic-2000] rule permit source 225.1.1.1 0
      [Switch_A-acl-basic-2000] rule permit source 225.1.1.2 0
      [Switch_A-acl-basic-2000] rule permit source 225.1.1.3 0
      [Switch_A-acl-basic-2000] quit
      

      # Apply the multicast group filter policies in VLAN 101 on Switch_A.

      [Switch_A] vlan 101
      [Switch_A-vlan101] igmp-snooping group-policy 2000
      [Switch_A-vlan101] quit
      [Switch_A] quit

      # Complete multicast configuration on Switch_B and Switch_C according to the multicast configuration procedure of Switch_A.

      # Configure the fast leave function on Switch_B and Switch_C.
      If trackside APs are directly connected to the switches and Layer 2 multicast is configured, enabling the fast leave function improves the quality of multicast services. If the trackside APs are not directly connected to the switches or Layer 3 multicast is configured, you cannot configure the fast leave function because this function may interrupt multicast services.
      [Switch_B] vlan 101
      [Switch_B-vlan101] igmp-snooping prompt-leave group-policy 2000
      [Switch_C] vlan 101
      [Switch_C-vlan101] igmp-snooping prompt-leave group-policy 2000

  2. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and VLAN 101 (service VLAN).
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24. Set DHCP status to ON and DHCP type to Interface address pool.



      # Click OK. An address pool for VLANIF 100 is configured.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  3. Configure trackside APs
    1. Choose Configuration > Config Wizard > Mesh.
    2. Create the AP group mesh-mpp for the MPPs.

      # In AP Group List, click Create. The Create AP Group page is displayed.

      # Set the AP group name to mesh-mpp and click OK.

    3. Configure Mesh parameters for the MPPs.

      # In AP Group List, select the AP group mesh-mpp.

      # Click the Service Settings tab and configure Mesh parameters.
      • Set the Mesh role to Mesh-portal.
      • Set the Mesh ID to mesh-net.
      • Select Radio 1 as the radio used by Mesh links. Set the bandwidth of radio 1 to 40+MHz and channel to 157.
      • In Security Settings, set the key type to PASS-PHRASE, and enter the key a1234567.



      • Click Edit in the Mesh whitelist area to add MAC addresses of Mesh nodes. In this example, MAC addresses 0046-4b59-2e10 and 0046-4b59-2e20 are added. Click OK. The Mesh whitelist are added.



        Add MAC addresses of vehicle-mounted APs on other trains to the Mesh whitelist whitelist01 according to the preceding procedure.

      # After configuring Mesh parameters, click Apply.

    4. Add MPPs

      # In AP Group List, select the AP group mesh-mpp.

      # On the AP List tab page, click Add. The Add AP page is displayed.

      # Set Mode to Manually add and manually add APs.

      # In this example, APs with MAC addresses 0046-4b59-1d10, 0046-4b59-1d20, 0046-4b59-1d30, 0046-4b59-1d40, 0046-4b59-1d50, and 0046-4b59-1d60 are added. Set AP ID to 1, 2, 3, 101, 102, and 103 for the APs respectively. Set the AP names to L1_001, L1_003, L1_010, L1_150, L1_160, and L1_170, respectively. Click OK. The APs are added as MPPs.

    5. Configure a Mesh profile.

      # Choose Configuration > AP Config > AP Group > AP Group.

      # In the AP group list, click the AP group mesh-mpp. Choose Mesh > Mesh Profile. The Mesh Profile List page is displayed.

      # Click Create. The Create Mesh Profile page is displayed. Set Profile name to mesh-net.

      # Click OK.

    6. Configure a Mesh handover profile.

      # Choose Mesh > Mesh Profile > mesh-net > Mesh Handover Profile. The Mesh Handover Profile page is displayed.

      # Click Create. The Create Mesh Handover Profile page is displayed. Set Profile name to hand-over and click OK. The Mesh profile configuration page is displayed.

      # Set Position-based handover algorithm to ON.

      # Click Apply. In the dialog box that is displayed, click OK.

    7. Configure the AP's wired port profile.

      # Choose AP > AP Wired Port Settings. Click GE0. The GE0 profile management page is displayed.

      # Click Create. The Create AP Wired Port Profile page is displayed. Set Profile name to wired-port and click OK. The configuration page of the wired port profile is displayed.

      # Set Port mode to Endpoint, add the wired port to VLAN 101 in tagged mode, and set the Port PVID to 101.

      # Click Apply. In the dialog box that is displayed, click OK.

  4. Configure a vehicle-mounted AP.

    NOTE:
    This example provides the detailed configuration procedure of the vehicle-mounted AP in the front of the train. The configuration procedure of the vehicle-mounted AP in the rear is similar to that of the vehicle-mounted AP in the front.

    1. Create VLAN 101 on the vehicle-mounted APs, configure GE0/0/1 to allow packets from VLAN 101 to pass through, and set the PVID of GE0/0/1 to VLAN 101.

      # Choose Configuration > Interface > VLAN. On the VLAN tab, click Create. On the Create VLAN page that is displayed, set VLAN ID to 101.

      # Click OK.

      # Choose Configuration > Interface > ETH Interface and click GigabitEthernet0/0/1. The Modify Interface Settings page is displayed.

      # Set Default VLAN to VLAN 101. Add GigabitEthernet0/0/1 to VLAN 101 in tagged mode.

      # Click OK.

    2. Configure a Mesh profile.

      # Choose Configuration > WLAN Service > WLAN Config. Click Radio1.

      # Choose Mesh > Mesh Profile. The Mesh Profile page is displayed.

      # Click Create. The Create Mesh Profile page is displayed.

      # Set Profile name to mesh-net and click OK. The Mesh Profile page is displayed.

      # Click Apply. In the dialog box that is displayed, click OK.

    3. Configure a security profile.

      # Choose Mesh > Mesh Profile > Security Profile. The Security Profile page is displayed.

      # Click Create. The Create Security Profile page is displayed.

      # Set Profile name to sp01 and click OK. The Security Profile page is displayed.

      # Set Security Mode to WPA2-PSK-AES, Password type to PASS-PHRASE, and Password to a1234567.

      # Click Apply. In the dialog box that is displayed, click OK.

    4. Configure a Mesh handover profile.

      # Choose Mesh > Mesh Profile > Mesh Handover Profile. The Mesh Handover Profile page is displayed.

      # Click Create and create the Mesh handover profile hand-over. Click OK. The Mesh profile configuration page is displayed.

      # Set Position-based handover algorithm to ON and Moving direction to forward. Click Apply. In the dialog box that is displayed, click OK.

  5. Add proxied devices on the vehicle-mounted AP

    # Add proxied ground devices. Add MAC addresses of Switch_A, network management device, and multicast source on the vehicle-mounted AP.

    # Choose Configuration > Proxied Device > Proxied Device > Proxied Ground Device. Click Create and add MAC addresses of proxied ground devices. In this example, MAC addresses 707b-e8e9-d328, 286e-d488-12cd, and 286e-d488-b6ab are added, click OK.

    # Add proxied vehicle-mounted devices. Add MAC addresses of the vehicle-mounted devices on the vehicle-mounted AP.

    # Choose Configuration > Proxied Device > Proxied Device > Proxied Vehicle-mounted Device. Click Create and add MAC addresses of proxied vehicle-mounted devices. In this example, MAC addresses 286e-d488-d359 and 286e-d488-d270 are added, click OK.

  6. Configure IGMP snooping on the vehicle-mounted AP

    # Choose Configuration > Other Service > IGMP-Snooping > IGMP-Snooping. Set IGMP-Snooping to ON in Global Setting.

    # In the VLAN List area, set IGMP-Snooping Status of VLAN 101 to Enable.

  7. Verify the configuration.
    1. On the AC, choose Monitoring > Mesh&WDS > Mesh Link Information to view Mesh link information. If Mesh links are set up successfully, information about Mesh links is displayed.



    2. Verify the configuration on the vehicle-mounted AP.

      # Choose Maintenance > Train To Ground COMM > Mesh Link Information to view Mesh link information. Displayed information is the same as that checked on the AC.

      # Choose Maintenance > Train To Ground COMM > Vehicle-mounted AP Field Strength to view field strength of the vehicle-mounted AP.

      # Choose Maintenance > Train To Ground COMM > Vehicle-mounted AP Roaming Trace to view the roaming trace of the vehicle-mounted AP.

Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 91086

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next