No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring CAC Based on the Number of Multicast Group Memberships

Example for Configuring CAC Based on the Number of Multicast Group Memberships

Service Requirements

Enterprise users can access the network through WLANs, which is the basic requirement of mobile office. Furthermore, users' services are not affected during roaming in the coverage area.

The multicast source for video conferences is deployed on the enterprise network to provide enterprise video conferencing services. The multicast source address ranges from 225.1.1.1 to 225.1.1.5. To restrict the access of employees when the number of multicast group memberships reaches the maximum, administrators need to configure CAC based on the number of multicast group memberships, ensuring the conference access quality.

Networking Requirements

  • AC networking mode: Layer 2 networking in inline mode
  • DHCP deployment mode: The AC functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: tunnel forwarding
Figure 5-73 Networking for configuring CAC based on the number of multicast group memberships

Data Planning

Table 5-80 AC data planning

Item

Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs and STAs.

IP address pool for APs 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.2-10.23.101.254/24
AC's source interface address

VLANIF 100: 10.23.100.1/24

AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net, regulatory domain profile default, and traffic profile wlan-traffic
Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

Traffic profile

  • Name: wlan-traffic

  • Maximum number of multicast group memberships for a VAP: 20

Configuration Roadmap

  1. Configure basic WLAN services to ensure that users can access the WLAN.

  2. Configure multicast-to-unicast conversion to convert multicast packets into unicast packets to improve the efficiency of multicast data transmission.

  3. Configure CAC based on the number of multicast group memberships to control the access of multicast users.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on the access switch to VLAN 100. The default VLAN of GE0/0/1 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/2] quit
    
    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100.
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Set Interface type of GigabitEthernet0/0/2 to Trunk and add the interface to VLAN 101 in the same way.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24. Set DHCP status to ON and DHCP type to Interface address pool.



      # Click OK.

      # Set the IP address of VLANIF 101 to 10.23.101.1/24 and configure the interface address pool on VLANIF 101 in the same way. The IP address 10.23.101.2 cannot be assigned.

      NOTE:

      Configure the DNS server address as required.

      # Under Static Route Table, click Create. The Create Static Route Table page is displayed.

      # Set Destination IP to 0.0.0.0, Subnet Mask to 0(0.0.0.0), and Next hop address to 10.23.101.2.

      # Click OK.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  3. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  4. Configure WLAN services.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN.



    # Click Next. The Security Authentication page is displayed.

    # Set Security settings to Key (applicable to personnel networks), select the AES mode, and set the key.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    # Click Finish.

  5. Set the AP channel and power.
    1. Disable automatic channel and power calibration functions of AP radios, and manually configure the AP channel and power.

      NOTE:

      Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.

      # Choose Configuration > AP Config > AP Config > AP Info. The AP List page is displayed.

      # Click the ID of the AP whose channel and power need to be configured. The AP customized settings page is displayed.

      # Click next to Radio Management. The profiles under Radio Management are displayed.

      # Click Radio 0. The Radio 0 Settings(2.4G) page is displayed. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 6 and transmit power to 127 dBm.



      # The configuration of Radio 1 is similar to that of Radio0. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 149 and transmit power to 127 dBm.

      # Click Apply. In the dialog box that is displayed, click OK.

  6. Configure CAC based on the number of multicast group memberships.

    # Choose Configuration > AP Config > AP Group > AP Group.

    # In the AP group list, click ap-group1. Click in front of VAP Configuration. Under it, click in front of wlan-net. Click Traffic Profile. The Traffic Profile page is displayed.

    # Click Create. The Create Traffic Profile page is displayed.

    # Enter the profile name wlan-traffic in Profile name and click OK. The new traffic profile configuration page is displayed.

    # Enable the function of converting multicast packets into unicast packets and the function of sending packets to all users in unicast mode when broadcast or multicast packets fail to be converted into unicast packets. Enable IGMP snooping and set the number of multicast group memberships for a VAP to 20.



    # Click Apply. In the Info dialog box that is displayed, click OK.

  7. Verify the configuration.
    1. Choose Monitoring > SSID > VAP. In VAP List, check VAP status. You can see that the status of the VAP in wlan-net is normal.
    2. The WLAN with the SSID wlan-net is available.
    3. The STA can associate with the WLAN and obtain an IP address 10.23.101.x/24, and its gateway address is 10.23.101.1.



    4. Choose Monitoring > User > User Statistics. In User List, set the search criteria to SSID, enter wlan-net, and click . You can see that the STA goes online successfully and obtains an IP address.
    5. Run the display wlan igmp-snooping vap-cac ap-id 0 command on the AC to view the configuration and usage of multicast CAC of the VAP.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90154

Downloads: 456

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next