No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Channel Switching Without Service Interruption

Example for Configuring Channel Switching Without Service Interruption

Service Requirements

Enterprise users can access the network through WLANs, which is the basic requirement of mobile office. Furthermore, users' services are not affected during roaming in the coverage area.

The enterprise requires that WLAN services not be interrupted even when the APs change their working channels.

Networking Requirements

  • AC networking mode: Layer 2 networking in bypass mode
  • DHCP deployment mode: Switch functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 5-71 Networking for configuring channel switching without service interruption

Data Planning

Table 5-78 AC data planning

Item

Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

DHCP server

Switch functions as a DHCP server to assign IP addresses to APs and STAs.

IP address pool for APs

10.1.1.3-10.1.1.254/24

IP address pool for STAs

10.1.2.3-10.1.2.254/24

Gateway address for APs

10.1.1.1/24

Gateway address for STAs

10.1.2.1/24

AC's source interface address

VLANIF 100: 10.1.1.2/24

AP group
  • Name: ap-group1
  • Referenced profiles: 2G radio profile wlan-radio2g, 5G radio profile wlan-radio5g, VAP profile wlan-net, and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

2G radio profile

  • Name: wlan-radio2g
  • Channel switch announcement: enabled
  • Channel switch announcement mode: continue-transmitting

5G radio profile

  • Name: wlan-radio5g
  • Channel switch announcement: enabled
  • Channel switch announcement mode: continue-transmitting

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Select Config Wizard to configure system parameters for the AC.
  3. Select Config Wizard to configure the APs to go online on the AC.
  4. Select Config Wizard to configure WLAN services on the AC.
  5. Configure channel switching without service interruption to improve WLAN service reliability so that services are not interrupted even when APs change their working channels.

  6. Deliver the WLAN services to the APs and verify the configuration.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on Switch to VLAN 100 and VLAN 101, and GE0/0/3 to VLAN 100. VLAN 100 is the default VLAN of GE0/0/1 and GE0/0/2.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/2] port-isolate enable
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/3] quit
    
    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Configure the DHCP servers to assign IP addresses to APs and STAs.

    # On Switch, configure VLANIF 100 to assign IP addresses to APs.

    [Switch] dhcp enable
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.1.1.1 255.255.255.0
    [Switch-Vlanif100] dhcp select interface
    [Switch-Vlanif100] dhcp server excluded-ip-address 10.1.1.2
    [Switch-Vlanif100] quit
    

    # On Switch, configure VLANIF 101 to assign IP addresses to STAs.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [Switch] interface vlanif 101
    [Switch-Vlanif101] ip address 10.1.2.1 255.255.255.0
    [Switch-Vlanif101] dhcp select interface
    [Switch-Vlanif101] quit
    

  3. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN).
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.1.1.2/24. You do not need to configure DHCP on the AC.



      # Click OK. An address pool for VLANIF 100 is configured.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN.



    # Click Next. The Security Authentication page is displayed.

    # Set Security settings to Key (applicable to personnel networks) and set the key.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    # Click Finish.

  6. Create radio profiles and configure channel switching without service interruption.

    NOTE:

    The following example configures a 2G radio profile. The configuration of the 5G radio profile is similar.

    # Choose Configuration > AP Config > AP Group. The AP Group page is displayed.

    # Click AP group ap-group1. The AP group configuration page is displayed.

    # Choose Radio Management > Radio 0 > 2G Radio Profile. The 2G Radio Profile page is displayed.

    # Click Create. On the Create 2G Radio Profile page that is displayed, enter the profile name wlan-radio2g and click OK. The 2G radio profile configuration page is displayed.

    # Enable channel switching announcement and configure the AP to continue transmitting data on the current channel when the channel is switched.

    # Click Apply. In the dialog box that is displayed, click OK.

  7. Verify the configuration.

    The WLAN with the SSID wlan-net is available, and STAs can access the WLAN properly. When the channel of AP1 or AP2 is changed, service data forwarding of STAs in Area A is not affected.

Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90530

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next