No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Dual-link Cold Backup (Global Configuration Mode)

Example for Configuring Dual-link Cold Backup (Global Configuration Mode)

Service Requirements

An enterprise uses two APs to deploy WLAN area A to provide WLAN services. The enterprise requires that dual-link backup be configured to improve data transmission reliability.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: The switch functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 5-41 Networking for configuring dual-link cold backup

Data Planning

Table 5-46 AC data planning
Item Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

DHCP server

The switch functions as a DHCP server to assign IP addresses to APs and STAs.

STAs' gateway: 10.23.101.1/24

APs' gateway: 10.23.100.1/24

IP address pool for APs

10.23.100.4-10.23.100.254/24

IP address pool for STAs

10.23.101.2-10.23.101.254/24

AC's source interface

VLANIF 100

AC1's management IP address

VLANIF 100: 10.23.100.2/24

AC2's management IP address

VLANIF 100: 10.23.100.3/24

Active AC

AC1

Local priority: 0

Standby AC

AC2

Local priority: 1

AP group

  • Name: ap-group1

  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: China

SSID profile

  • Name: wlan-net

  • SSID name: wlan-net

Security profile

  • Name: wlan-net

  • Security policy: WPA-WPA2+PSK+AES

  • Password: a1234567

VAP profile

  • Name: wlan-net

  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 101

  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

Configuration Roadmap

  1. Configure network interworking of AC1, AC2, and other network devices. Configure the switch as a DHCP server to assign IP addresses to APs and STAs.
  2. Configure AC1 as the active AC and configure basic WLAN services on AC1.
  3. Configure AC2 as the standby AC and configure basic WLAN services on AC2. Ensure that service configurations on AC1 and AC2 are the same.
  4. Configure dual-link backup on the active AC first and then on the standby AC. When dual-link backup is enabled, all APs are restarted. After dual-link backup configurations are complete, the standby AC replaces the active AC to manage APs if the CAPWAP tunnel between the active AC and APs is disconnected.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the switch.

    # Create VLAN 100 (management VLAN) and VLAN 101 (service VLAN) on the switch. Set the link type of GE0/0/1 and GE0/0/4 that connect the switch to the APs to trunk and PVID of the interfaces to 100, and configure the interfaces to allow packets of VLAN 100 and VLAN 101 to pass through. Set the link type of GE0/0/2 and GE0/0/3 on the switch to trunk, and configure the interfaces to allow packets of VLAN 100 to pass through.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/4
    [Switch-GigabitEthernet0/0/4] port link-type trunk
    [Switch-GigabitEthernet0/0/4] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/4] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/4] port-isolate enable
    [Switch-GigabitEthernet0/0/4] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/3] quit

    Configure the DHCP function on the switch to assign IP addresses to APs and STAs.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.

    # Configure VLANIF 100 to use the interface address pool to assign IP addresses to APs.

    [Switch] dhcp enable
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.23.100.1 255.255.255.0
    [Switch-Vlanif100] dhcp select interface
    [Switch-Vlanif100] dhcp server excluded-ip-address 10.23.100.2 10.23.100.3
    [Switch-Vlanif100] quit
    

    # Configure VLANIF 101 to use the interface address pool to assign IP addresses to STAs.

    [Switch] interface vlanif 101
    [Switch-Vlanif101] ip address 10.23.101.1 255.255.255.0
    [Switch-Vlanif101] dhcp select interface
    [Switch-Vlanif101] quit
    

  2. Configure AC1.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN).
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.2/24.



      # Click OK.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  3. Add APs on AC1.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  4. Configure WLAN services on AC1.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN ID.



    Click Next. The Security Authentication page is displayed.

    # Set Security settings to Key (applicable to personnel networks) and set the key.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    Click Finish.

  5. Configure AC2.

    The configuration is similar to that on AC1. The difference is that the IP address of VLANIF 100 is 10.23.100.3/24.

  6. Add APs on AC2.

    The configuration is similar to that on AC1.

  7. Configure WLAN services on AC2.

    The configuration is similar to that on AC1.

  8. Configure dual-link backup on AC1 and AC2.
    1. Configure dual-link backup on AC1.

      # On AC1, choose Configuration > Reliability > Reliability. The Reliability page is displayed.

      # Set Backup mode to Dual-link cold backup, AC dual-link switchover status to ON and configure Local priority and Backup AC IP address. Set Backup AC IP address to 10.23.100.3 (AC2's IP address).

      NOTE:
      A smaller value of Local priority indicates a higher local priority.

      # Click Apply. In the dialog box that is displayed, click OK.

    2. Configure dual-link backup on AC2.

      # The configuration is similar to that on AC1.

      # Set Local priority to 1, and Backup AC IP address to 10.23.100.2 (IP address of AC1). The other configurations are the same as those of AC1.

    NOTE:

    By default, dual-link backup is disabled. Enabling dual-link backup will restart all APs. After the APs are restarted, the dual-link backup function takes effect.

    If dual-link backup is already enabled, performing the configuration does not restart APs. Choose Maintenance > AP Maintenance > AP Restart on the active AC to restart the APs and make the dual-link backup function take effect.

  9. Verify the configuration.
    1. The WLAN with the SSID wlan-net is available for STAs connected to AP1 and AP2, and the STAs can connect to the WLAN and go online properly.
    2. When the link between an AP and AC1 fails, AC2 takes over the active role. This ensures service stability.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 91158

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next