No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring NAT Traversal Between the AC and APs

Example for Configuring NAT Traversal Between the AC and APs

Service Requirements

Enterprise users can access the network through WLANs, which is the basic requirement of mobile office. Furthermore, users' services are not affected during roaming in the coverage area.

APs are located in an enterprise branch, while the AC is located at the headquarters. Administrators require unified AP management by the AC. Therefore, NAT traversal is configured between the AC and APs to save the enterprise's public IP addresses.

Networking Requirements

  • AC networking mode: NAT traversal between the AC at the headquarters and APs in the branch
  • DHCP deployment mode: Router_1 functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 4-23 Networking for configuring NAT traversal between the AC and APs

Data Planning

Table 4-20 AC data planning
Item Data

Management VLAN for APs

VLAN 200

Service VLAN for STAs

VLAN 101

DHCP server

Router_1 functions as a DHCP server to assign IP addresses to APs and STAs.

IP address pool for APs

10.23.100.2-10.23.100.254/24

IP address pool for STAs

10.23.101.2-10.23.101.254/24

AC's source interface address

VLANIF 200: 10.23.200.1/24

AP group

  • Name: ap-group1

  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: China

SSID profile

  • Name: wlan-net

  • SSID name: wlan-net

Security profile

  • Name: wlan-net

  • Security policy: WPA-WPA2+PSK+AES

  • Password: a1234567

VAP profile

  • Name: wlan-net

  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 101

  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

NAT Outbound

Router_1: translates the private IP addresses in the network segment 10.23.100.0/24 to the public IP addresses in the network segment 2.2.2.1.

Static NAT

Router_2: translates the private IP addresses in the network segment 10.23.200.1 to the public IP addresses in the network segment 3.3.3.3.

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Configure NAT for address translation.
  3. Configure the APs to go online.
    1. Create an AP group and add APs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the APs.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
  4. Configure WLAN service parameters for STAs to access the WLAN.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # On Switch, add GE0/0/1, GE0/0/2, and GE0/0/3 to VLAN 100 and VLAN 101. VLAN 100 is the default VLAN of GE0/0/1 and GE0/0/2.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/2] port-isolate enable
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/3] quit
    
    # On Router_1, add GE1/0/0 to VLAN 100 and VLAN 101. If the peer end of GE0/0/1 is at 2.2.2.2/24, set the IP address of GE0/0/1 to 2.2.2.1/24.
    <Huawei> system-view
    [Huawei] sysname Router_1
    [Router_1] vlan batch 100 101
    [Router_1] interface gigabitethernet1/0/0
    [Router_1-GigabitEthernet1/0/0] port link-type trunk
    [Router_1-GigabitEthernet1/0/0] port trunk allow-pass vlan 100 to 101
    [Router_1-GigabitEthernet1/0/0] quit
    [Router_1] interface gigabitethernet0/0/1
    [Router_1-GigabitEthernet0/0/1] ip address 2.2.2.1 255.255.255.0
    [Router_1-GigabitEthernet0/0/1] quit
    # Configure a default route with the next hop address 2.2.2.2 on Router_1.
    [Router_1] ip route-static 0.0.0.0 0.0.0.0 2.2.2.2
    
    # On Router_2, add GE1/0/0 to VLAN 200. If the peer end of GE0/0/1 is at 3.3.3.2/24, set the IP address of GE0/0/1 to 3.3.3.1/24. Create VLANIF 200 and set its IP address to 10.23.200.2/24.
    <Huawei> system-view
    [Huawei] sysname Router_2
    [Router_2] vlan batch 200
    [Router_2] interface GigabitEthernet1/0/0
    [Router_2-GigabitEthernet1/0/0] port link-type trunk
    [Router_2-GigabitEthernet1/0/0] port trunk allow-pass vlan 200
    [Router_2-GigabitEthernet1/0/0] quit
    [Router_2] interface gigabitethernet 0/0/1
    [Router_2-GigabitEthernet0/0/1] ip address 3.3.3.1 255.255.255.0
    [Router_2-GigabitEthernet0/0/1] quit
    [Router_2] interface vlanif 200
    [Router_2-Vlanif200] ip address 10.23.200.2 24
    [Router_2-Vlanif200] quit
    
    # Configure a default route with the next hop address 3.3.3.2 on Router_2.
    [Router_2] ip route-static 0.0.0.0 0.0.0.0 3.3.3.2
    

  2. Configure the AC to communicate with the network devices.

    # On the AC, add GE0/0/1 to VLAN 200. Create VLANIF 200 and set its IP address to 10.23.200.1/24.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 101 200
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 200
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 200
    [AC-Vlanif200] ip address 10.23.200.1 24
    [AC-Vlanif200] quit
    # Configure a default route with the next hop address 10.23.200.2 on the AC.
    [AC] ip route-static 0.0.0.0 0.0.0.0 10.23.200.2
    

  3. Configure a DHCP server to assign IP addresses to APs and STAs.

    # Configure Router_1 as a DHCP server to assign IP addresses to APs and STAs. The AC's source interface address is translated into the public IP address 3.3.3.3 after NAT mapping.
    [Router_1] dhcp enable
    [Router_1] interface vlanif 100
    [Router_1-Vlanif100] ip address 10.23.100.1 255.255.255.0
    [Router_1-Vlanif100] dhcp select global
    [Router_1-Vlanif100] quit
    [Router_1] ip pool ap
    [Router_1-ip-pool-ap] gateway-list 10.23.100.1
    [Router_1-ip-pool-ap] network 10.23.100.0 mask 24
    [Router_1-ip-pool-ap] option 43 sub-option 3 ascii 3.3.3.3
    [Router_1-ip-pool-ap] quit
    [Router_1] interface vlanif 101
    [Router_1-Vlanif101] ip address 10.23.101.1 255.255.255.0
    [Router_1-Vlanif101] dhcp select interface
    [Router_1-Vlanif101] quit
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.

  4. Configure NAT.

    # Configure outbound NAT on Router_1.
    [Router_1] acl 2000
    [Router_1-acl-basic-2000] rule 5 permit source 10.23.100.0 0.0.0.255
    [Router_1-acl-basic-2000] rule 10 permit source 10.23.101.0 0.0.0.255
    [Router_1-acl-basic-2000] quit
    [Router_1] interface gigabitethernet 0/0/1
    [Router_1-GigabitEthernet0/0/1] nat outbound 2000
    [Router_1-GigabitEthernet0/0/1] quit
    
    # Configure static NAT on Router_2.
    [Router_2] interface gigabitethernet 0/0/1
    [Router_2-GigabitEthernet0/0/1] nat static global 3.3.3.3 inside 10.23.200.1
    [Router_2-GigabitEthernet0/0/1] quit
    

  5. Configure an AP to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 200
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 and radio 1. Radio 0 and radio 1 operate on the 2.4 GHz and 5 GHz bands, respectively.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    [AC-wlan-view] ap-id 1 ap-mac 60de-4474-9640
    [AC-wlan-ap-1] ap-name area_2
    [AC-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit
    
    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online successfully.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S
    1    60de-4474-9640 area_2 ap-group1 10.23.100.253 AP5030DN        nor   0   11S
    -------------------------------------------------------------------------------------
    Total: 2

  6. Configure WLAN service parameters.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Create SSID profile wlan-net and set the SSID name to wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Configure the AP channel and power.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The settings of the AP channel and power in this example are for reference only. You need to configure the AP channel and power based on the actual country code and network planning.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] calibrate auto-channel-select disable
    [AC-wlan-radio-0/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] calibrate auto-channel-select disable
    [AC-wlan-radio-0/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  8. Verify the configuration.

    The AC automatically delivers WLAN service configuration to the AP. After the configuration is complete, run the display vap ssid wlan-net command. If the Status field is displayed as ON, the VAPs have been successfully created on AP radios.

    [AC-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID   BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1     60DE-4476-E360 ON      WPA/WPA2-PSK  0     wlan-net
    0     area_1  1    1     60DE-4476-E370 ON      WPA/WPA2-PSK  0     wlan-net
    0     area_2  0    1     60DE-4474-9640 ON      WPA/WPA2-PSK  0     wlan-net
    0     area_2  1    1     60DE-4474-9650 ON      WPA/WPA2-PSK  0     wlan-net
    -------------------------------------------------------------------------------
    Total: 4

    Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station ssid wlan-net command on the AC. The command output shows that the STAs are connected to the WLAN wlan-net.

    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ---------------------------------------------------------------------------------
    STA MAC         AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ---------------------------------------------------------------------------------
    e019-1dc7-1e08  0     area_1    1/1      5G    11n   46/59      -68   101   10.23.101.254
    ---------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1

Configuration Files

  • Switch configuration file
    #
    sysname Switch
    #
    vlan batch 100 to 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    return
  • Router_1 configuration file
    #
    sysname Router_1
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    acl number 2000  
     rule 5 permit source 10.23.100.0 0.0.0.255 
     rule 10 permit source 10.23.101.0 0.0.0.255
    #
    ip pool ap
     gateway-list 10.23.100.1
     network 10.23.100.0 mask 255.255.255.0
     option 43 sub-option 3 ascii 3.3.3.3
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select global
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
     port-isolate enable
    #
    interface GigabitEthernet0/0/1
     ip address 2.2.2.1 255.255.255.0
     nat outbound 2000
    #
    ip route-static 0.0.0.0 0.0.0.0 2.2.2.2
    #
    return
  • Router_2 configuration file.
    #
    sysname Router_2
    #
    vlan batch 200
    #
    interface Vlanif200
     ip address 10.23.200.2 24
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet0/0/1
     ip address 3.3.3.1 255.255.255.0
     nat static global 3.3.3.3 inside 10.23.200.1
    #
    ip route-static 0.0.0.0 0.0.0.0 3.3.3.2
    #
    return
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 101 200
    #
    interface Vlanif200
     ip address 10.23.200.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.200.2
    #
    capwap source interface vlanif200
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
      radio 1
       channel 20mhz 149
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
     ap-id 1 type-id 35 ap-mac 60de-4474-9640 ap-sn 210235554710CB002312
      ap-name area_2
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90482

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next