No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Inter-AC Layer 3 Roaming

Example for Configuring Inter-AC Layer 3 Roaming

Service Requirements

Enterprise users can access the network through WLANs, which is the basic requirement of mobile office. To differentiate department management, employees are assigned different subnets by department. Furthermore, users' services are not affected during roaming in the coverage area.

Networking Requirement

  • AC networking mode: AC_1 and AC_2 in a mobility group
  • DHCP deployment mode:
    • AC_1 functions as a DHCP server to assign IP addresses to APs and STAs connected to it.

    • AC_2 functions as a DHCP server to assign IP addresses to APs and STAs connected to it.

  • Service data forwarding mode: direct forwarding
Figure 5-49 Networking for configuring inter-AC Layer 3 roaming

Data Planning

Table 5-54 AC data planning

Item

Data

DHCP server

AC_1 functions as a DHCP server to assign IP addresses to STAs and APs connected to it.

AC_2 functions as a DHCP server to assign IP addresses to STAs and APs connected to it.

IP address pool for APs

10.23.100.2-10.23.100.254/24

10.23.200.2-10.23.200.254/24

IP address pool for STAs

10.23.101.2-10.23.101.254/24

10.23.102.2-10.23.102.254/24

AC_1's source interface address

VLANIF 100: 10.23.100.1/24

AC_2's source interface address

VLANIF 200: 10.23.200.1/24

AP group

AC_1:

  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default

AC_2:

  • Name: ap-group2
  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: China
  • Calibration channel set: calibration bandwidth and channels for 2.4 GHz and 5 GHz radios
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile

AC_1:

  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

AC_2:

  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 102
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

Air scan profile

  • Name: wlan-airscan

  • Probe channel set: calibration channels

  • Air scan interval: 60000 ms

  • Air scan period: 60 ms

RRM profile

  • Name: wlan-rrm

  • Automatic channel calibration: enabled

  • Automatic power calibration: enabled

2G radio profile

  • Name: wlan-radio2g

  • Referenced profiles: air scan profile wlan-airscan and RRM profile wlan-rrm

5G radio profile

  • Name: wlan-radio5g

  • Referenced profiles: air scan profile wlan-airscan and RRM profile wlan-rrm

Mobility group
  • Name: mobility
  • Members: AC_1 and AC_2

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Select Config Wizard to configure system parameters for the AC.
  3. Select Config Wizard to configure the APs to go online on the AC.
  4. Select Config Wizard to configure WLAN services on the AC.
  5. Deliver the WLAN services to the APs and verify the configuration.
  6. Configure WLAN roaming on AC_1 and AC_2 to implement inter-AC roaming.
NOTE:

During AP deployment, you can manually specify the working channels of the APs according to network planning or configure the radio calibration function to enable the APs to automatically select the optimal channels.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on Switch_1 to VLAN 100 and VLAN 101. The default VLAN of GE0/0/1 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 100 101
    [Switch_1] interface GigabitEthernet 0/0/1
    [Switch_1-GigabitEthernet0/0/1] port link-type trunk
    [Switch_1-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [Switch_1-GigabitEthernet0/0/1] quit
    [Switch_1] interface gigabitethernet 0/0/2
    [Switch_1-GigabitEthernet0/0/2] port link-type trunk
    [Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [Switch_1-GigabitEthernet0/0/2] quit
    # Add GE0/0/1 and GE0/0/2 on Switch_2 to VLAN 200 and VLAN 102. The default VLAN of GE0/0/1 is VLAN 200.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 200 102
    [Switch_2] interface gigabitethernet 0/0/1
    [Switch_2-GigabitEthernet0/0/1] port link-type trunk
    [Switch_2-GigabitEthernet0/0/1] port trunk pvid vlan 200
    [Switch_2-GigabitEthernet0/0/1] port trunk allow-pass vlan 200 102
    [Switch_2-GigabitEthernet0/0/1] quit
    [Switch_2] interface gigabitethernet 0/0/2
    [Switch_2-GigabitEthernet0/0/2] port link-type trunk
    [Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 200 102
    [Switch_2-GigabitEthernet0/0/2] quit
    # Configure Router.
    <HUAWEI> system-view
    [HUAWEI] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 10.23.100.2 255.255.255.0
    [Router-GigabitEthernet0/0/1] quit
    [Router] interface gigabitethernet 0/0/2
    [Router-GigabitEthernet0/0/2] ip address 10.23.200.2 255.255.255.0
    [Router-GigabitEthernet0/0/2] quit
    

  2. Configure system parameters for AC_1.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and VLAN 101 (service VLAN).
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Set Interface type of GigabitEthernet0/0/2 to Trunk and add the interface to VLAN 100 in the same way.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24. Set DHCP status to ON and DHCP type to Interface address pool.



      # Click OK. Set the IP address of VLANIF 101 to 10.23.101.1/24 and configure the interface address pool on VLANIF 101 in the same way.

      NOTE:

      Configure the DNS server address as required.

      # Under Static Route Table, click Create. The Create Static Route Table page is displayed.

      # Set Destination IP to 10.23.200.0, Subnet Mask to 24(255.255.255.0), and Next hop address to 10.23.100.2.

      # Click OK.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  3. Configure system parameters for AC_2.

    Configure AC_2 according to the configuration of AC_1. The following lists configuration differences between AC_1 and AC_2.
    • Create VLAN 200 and VLAN 102 on AC_2 and add GigabitEthernet0/0/1 to the two VLANs in tagged mode.
    • Add GigabitEthernet0/0/2 to VLAN 200 in tagged mode.
    • Set the IP addresses of VLANIF 200 and VLANIF 102 to 10.23.200.1/24 and 10.23.102.1/24 respectively.
    • Configure an IP address pool on VLANIF 200 and VLANIF 102.
    • Configure the route between AC_2 and AC_1 on AC_2 with the destination address 10.23.100.0/24 and next-hop address 10.23.200.2.

  4. Configure an AP to go online on AC_1.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure an AP to go online on AC_2.

    Configure the AP to go online on AC_2 according to the configuration of AC_1. The following lists configuration differences between AC_1 and AC_2:

    • Add an AP (MAC address dcd2-fc04-b500 and SN 210235554710CB000078) on AC_2, set the AP name to area_2, and add the AP to the AP group ap-group2.

  6. Configure WLAN services on AC_1.

    # Click Create. The Basic Information page is displayed.

    # Set SSID Name to wlan-net, Forwarding mode to Direct, Service VLAN to Single VLAN, and Service VLAN ID to 101.



    Click Next. The Security Authentication page is displayed.

    # Set Security settings to Key (applicable to personnel networks) and set the key.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    Click Finish.

  7. Configure WLAN services on AC_2.

    Configure WLAN services on AC_2 according to the configuration of AC_1. The following lists the configuration difference between AC_1 and AC_2:

    • In the VAP profile wlan-net, set the service VLAN to VLAN 102.

  8. Enable radio calibration to allow APs to automatically select the optimal channels and power.
    1. Enable automatic channel and power calibration functions of radios.

      NOTE:

      Radio 0 is used as an example. The configuration for other radios is similar and will not be mentioned here.

      # Choose Configuration > AP Config > AP Group > AP Group.

      # Click the AP group name ap-group1 in the AP group list. Choose Radio Management > Radio 0. The Radio 0 Settings(2.4G) page is displayed.

      # On the Radio 0 Settings(2.4G) configuration page, enable automatic channel and power calibration.



      # Click Apply. In the dialog box that is displayed, click OK.

    2. Create radio profiles.

      NOTE:

      The following example configures a 2G radio profile. The configuration of a 5G radio profile is similar.

      # Choose Radio 0 > 2G Radio Profile. The 2G Radio Profile page is displayed.

      # Click Create. On the Create 2G Radio Profile page that is displayed, enter the profile name wlan-radio2g and click OK. The 2G radio profile configuration page is displayed.

      # Click Apply. In the dialog box that is displayed, click OK.

    3. Create an air scan profile and configure the probe channel set, scan interval, and scan duration.

      # Click next to 2G Radio Profile. Select Air Scan Profile. The Air Scan Profile page is displayed. Click Create. On the Create Air Scan Profile page that is displayed, enter the profile name wlan-airscan and click OK. The air scan profile configuration page is displayed.

      # Enable scanning, and configure the probe channel set, scan interval, and scan duration.

      # Click Apply. In the dialog box that is displayed, click OK.

    4. Enable radio calibration.

      # Choose Configuration > AC Config > Basic Config > Radio Calibration. The Radio Calibration page is displayed.

      # Set Calibration mode to Manual and click Immediate Calibration. In the dialog box that is displayed, click OK.

      # Choose Monitoring > Radio. In Radio List, check the channel and power of the radio. In this example, three APs have gone online on the AC, and the list shows that AP channels have been automatically assigned through the radio calibration function.



      # Radio calibration stops 1 hour after the radio calibration is manually triggered.

      # Choose Configuration > AC Config > Basic Config > Radio Calibration. The Radio Calibration page is displayed. On the Radio Calibration page, set Calibration mode to Scheduled and set the start time to 3:00 am.

      # Click Apply. In the dialog box that is displayed, click OK.

  9. Configure WLAN roaming on AC_1.
    1. Choose Configuration > AC Config > Basic Config > Inter-AC Roaming. The Inter-AC Roaming page is displayed.



    2. Create a mobility group, and add AC_1 and AC_2 to the mobility group.

      # Click Create. The Create Mobility Group page is displayed.

      # Set Mobility group name to mobility, and add AC_1 and AC_2 to the mobility group.

      Click OK. The Inter-AC Roaming page is displayed.

    3. # Click Apply. In the dialog box that is displayed, click OK.
  10. Configure WLAN roaming on AC_2.

    The configuration is similar to that of AC_1 and is not mentioned here.

  11. Verify the configuration.
    1. Choose Monitoring > SSID > VAP. In VAP List, check VAP status. You can see that the status of the VAP in wlan-net is normal.
    2. The WLAN with the SSID wlan-net is available.
    3. The STA can associate with the WLAN and obtain an IP address 10.23.101.x/24, and its gateway address is 10.23.101.2.



    4. Choose Monitoring > User > User Statistics. In User List, set the search criteria to SSID, enter wlan-net, and click . You can see that the STA goes online successfully and obtains an IP address.
    5. When a STA roams from area_1 to area_2, choose Monitoring > User. In User List, select the STA of which you want to view the roaming tracks and click Roaming Track. The roaming tracks of the STA are displayed.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 91058

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next