No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Soft GRE Service

Example for Configuring the Soft GRE Service

Service Requirements

Enterprise users can access the network through WLANs, which is the basic requirement of mobile office. Furthermore, users' services are not affected during roaming in the coverage area. A wired network has been deployed in an area. To provide more convenient network access services, administrators need to deploy a wireless network in this area. To facilitate the unified management of wired and wireless users, administrators also need to use the existing wired access gateway ME60 for authentication and accounting of wireless users.

Networking Requirements

  • AC networking mode: Layer 2 networking in bypass mode
  • DHCP deployment mode:
    • The ME60 functions as a DHCP server to assign IP addresses to STAs.
    • Switch functions as a DHCP server to assign IP addresses to APs.
  • Service data forwarding mode: soft GRE forwarding
Figure 5-72 Networking for configuring the soft GRE service

Data Planning

Table 5-79 AC data planning

Item

Data

Switch data planning

DHCP server Switch functions as a DHCP server to assign IP addresses to APs.
IP address pool for APs 10.23.100.3-10.23.100.254/24
AC data planning
AC's source interface address VLANIF 100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: open
Soft GRE profile
  • Name: wlan-soft
  • Destination address of the soft GRE tunnel: 10.23.200.1
VAP profile
  • Name: wlan-net
  • Forwarding mode: soft GRE forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net, security profile wlan-net, and soft GRE profile wlan-soft
ME60 data planning
DHCP server The ME60 functions as a DHCP server to assign IP addresses to STAs.
IP address pool for STAs 10.23.101.2-10.23.101.254/24
VE interface for soft GRE Virtual-Ethernet2/0/0
Soft GRE group
  • Name: group1
  • Virtual-Ethernet2/0/0 is referenced.
Destination address of the soft GRE tunnel
  • Name: Loopback 1
  • IP address: 10.23.200.1/24
  • The soft GRE group group1 is referenced.
RADIUS server parameters
  • Server group: radius1
  • Server IP address: 10.1.1.1
  • Authentication port number: 1812
  • Accounting port number: 1813
  • Shared key: 123456
  • RADIUS accounting scheme: radius
  • RADIUS authentication scheme: radius
  • Domain: aaadomain1

Configuration Roadmap

  1. Configure network interworking of the AC, APs, ME60, and other network devices.
  2. Configure the ME60, soft GRE tunnel, and authentication and accounting functions.
  3. Select Config Wizard to configure system parameters for the AC.
  4. Select Config Wizard to configure the APs to go online on the AC.
  5. Select Config Wizard to configure WLAN services on the AC.
  6. Deliver the WLAN service to the AP and verify the configuration.
NOTE:
  • In this example, the ME60 in V600R008C10 is used. The actual configuration may vary depending on versions.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # On Switch, add GE0/0/1 to VLAN 100 and VLAN 101, GE0/0/2 to VLAN 100, and GE0/0/3 to VLAN 199. Set the PVIDs of GE0/0/1 and GE0/0/3 to VLAN 100 and VLAN 199, respectively. Create VLANIF 199 and set its IP address to 10.23.199.2/24.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101 199
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type trunk
    [Switch-GigabitEthernet0/0/3] port trunk allow-pass vlan 199
    [Switch-GigabitEthernet0/0/3] port trunk pvid vlan 199
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] interface vlanif 199
    [Switch-Vlanif199] ip address 10.23.199.2 24
    [Switch-Vlanif199] quit
    

    # On the ME60, set the IP address of GE2/0/0 to 10.23.199.1/24, and configure a route to 10.23.100.0/24.

    <HUAWEI> system-view
    [HUAWEI] sysname ME60
    [ME60] interface gigabitethernet 2/0/0
    [ME60-GigabitEthernet2/0/0] ip address 10.23.199.1 24
    [ME60-GigabitEthernet2/0/0] quit
    [ME60] ip route-static 10.23.100.0 24 10.23.199.2
    

  2. Configure the DHCP servers to assign IP addresses to APs and STAs.

    # Configure Switch as a DHCP server to assign IP addresses to APs, and configure a route to 10.23.200.0/24.

    [Switch] dhcp enable
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.23.100.2 24
    [Switch-Vlanif100] dhcp select interface
    [Switch-Vlanif100] dhcp server excluded-ip-address 10.23.100.1
    [Switch-Vlanif100] quit
    [Switch] ip route-static 10.23.200.0 24 10.23.199.1
    

    # Configure the ME60 as a DHCP server to assign IP addresses to STAs.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [ME60] dhcp enable
    [ME60] ip pool sta-pool bas local
    [ME60-ip-pool-sta-pool] gateway 10.23.101.1 24
    [ME60-ip-pool-sta-pool] section 1 10.23.101.3 10.23.101.254
    [ME60-ip-pool-sta-pool] option 43 ip 10.23.101.1
    [ME60-ip-pool-sta-pool] quit
    

  3. Configure the soft GRE tunnel on the ME60.

    # Create a VE interface to support soft GRE.

    [ME60] interface virtual-ethernet 2/0/0
    [ME60-Virtual-Ethernet2/0/0] soft-gre enable
    [ME60-Virtual-Ethernet2/0/0] quit
    

    # Create a soft GRE group.

    [ME60] soft-gre group group1
    [ME60-softgre-group-group1] master virtual-ethernet 2/0/0
    [ME60-softgre-group-group1] quit
    

    # Configure an IP address for the loopback interface and bind the soft GRE group to it.

    [ME60] interface loopback 1
    [ME60-LoopBack1] ip address 10.23.200.1 255.255.255.0
    [ME60-LoopBack1] binding soft-gre group group1
    [ME60-LoopBack1] quit
    

  4. Configure RADIUS authentication and accounting on the ME60.

    # Configure a RADIUS server profile, an AAA authentication and accounting scheme, and domain information.

    [ME60] radius-server group radius1
    [ME60-radius-radius1] radius-server authentication 10.1.1.1 1812
    [ME60-radius-radius1] radius-server accounting 10.1.1.1 1813
    [ME60-radius-radius1] radius-server shared-key 123456
    [ME60-radius-radius1] quit
    [ME60] aaa
    [ME60-aaa] authentication-scheme radius
    [ME60-aaa-authen-radius] authentication-mode radius
    [ME60-aaa-authen-radius] quit
    [ME60-aaa] accounting-scheme radius
    [ME60-aaa-accounting-radius] accounting-mode radius
    [ME60-aaa-accounting-radius] quit
    [ME60-aaa] domain aaadomain1
    [ME60-aaa-domain-aaadomain1] ip-pool sta-pool
    [ME60-aaa-domain-aaadomain1] authentication-scheme radius
    [ME60-aaa-domain-aaadomain1] accounting-scheme radius
    [ME60-aaa-domain-aaadomain1] radius-server group radius1
    [ME60-aaa-domain-aaadomain1] quit
    [ME60-aaa] quit
    

  5. Configure the BAS interface on the ME60.

    # Create a BAS interface and configure the BAS interface type and authentication mode. Configure the user VLAN and service VLAN as the same VLAN.

    [ME60] interface virtual-ethernet 2/0/0.1
    [ME60-Virtual-Ethernet2/0/0.1] user-vlan 101
    [ME60-Virtual-Ethernet2/0/0.1-vlan-101-101] bas
    [ME60-Virtual-Ethernet2/0/0.1-bas] access-type layer2-subscriber default-domain authentication aaadomain1
    [ME60-Virtual-Ethernet2/0/0.1-bas] authentication-method bind
    

  6. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN).
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24.



      # Click OK. An address pool for VLANIF 100 is configured.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  7. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  8. Configure WLAN services.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN ID.



    Click Next. The Security Authentication page is displayed.

    # Set Authentication mode to No authentication.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    Click Finish.

  9. Create a soft GRE profile.

    # Choose Configuration > AP Config > Profile > Wireless Service > SoftGRE Profile. The SoftGRE Profile List page is displayed.

    # Click Create. The Create SoftGRE Profile page is displayed.

    # Enter the name of the new soft-GRE profile wlan-soft in Profile name.

    # Click OK. Set the destination IPv4 address of the soft GRE tunnel to 10.23.200.1.

    # Click Apply. In the dialog box that is displayed, click OK.

  10. Change the VAP forwarding mode to Soft-GRE.

    # Choose Configuration > AP Config > Profile.

    # Choose Wireless Service > VAP Profile in Profile Management. The VAP Profile List page is displayed.

    # Select VAP profile wlan-net. On the VAP profile configuration page that is displayed, set Forwarding mode to SoftGRE, and SoftGRE profile to wlan-soft.

    # Click Apply. In the dialog box that is displayed, click OK.

  11. Set the AP channel and power.
    1. Disable automatic channel and power calibration functions of AP radios, and manually configure the AP channel and power.

      NOTE:

      Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.

      # Choose Configuration > AP Config > AP Config > AP Info. The AP List page is displayed.

      # Click the ID of the AP whose channel and power need to be configured. The AP customized settings page is displayed.

      # Click next to Radio Management. The profiles under Radio Management are displayed.

      # Click Radio 0. The Radio 0 Settings(2.4G) page is displayed. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 6 and transmit power to 127 dBm.



      # The configuration of Radio 1 is similar to that of Radio0. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 149 and transmit power to 127 dBm.

      # Click Apply. In the dialog box that is displayed, click OK.

  12. Verify the configuration.
    1. Choose Monitoring > SSID > VAP. In VAP List, check VAP status. You can see that the status of the VAP in wlan-net is normal.
    2. The WLAN with the SSID wlan-net is available.
    3. The STA can associate with the WLAN and obtain an IP address 10.23.101.x/24, and its gateway address is 10.23.101.1.



    4. Choose Monitoring > User > User Statistics. In User List, set the search criteria to SSID, enter wlan-net, and click . You can see that the STA goes online successfully and obtains an IP address.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 91217

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next