No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Different Authentication Modes for Multiple SSIDs

Example for Configuring Different Authentication Modes for Multiple SSIDs

Service Requirements

Enterprise users can access the Internet through the WLAN to meet basic mobile office requirements. When roaming occurs in the coverage area, user services will not be interrupted.

Administrators want to deploy different SSIDs for WLAN access of guests and employees, and different authentication modes for them to ensure WLAN security.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to assign IP addresses to APs.
    • The aggregation switch (SwitchB) functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: tunnel forwarding
Figure 5-38 Networking diagram for configuring different authentication modes for multiple SSIDs

Data Planning

Table 5-43 AC data planning

Item

Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

  • Employees: VLAN 101

  • Guests: VLAN 102

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs.

SwitchB functions as a DHCP server to assign IP addresses to STAs. The default gateways for STAs are 10.23.101.2 and 10.23.102.2.

IP address pool for APs 10.23.100.2-10.23.100.254/24
IP address pool for STAs

10.23.101.3-10.23.101.254/24

10.23.102.3-10.23.102.254/24

IP address of the AC's source interface VLANIF 100: 10.23.100.1/24
RADIUS authentication parameters
  • RADIUS server template name: wlan-net
  • IP address: 10.23.102.1
  • Authentication port number: 1812
  • Shared key: Huawei123
  • Authentication scheme: wlan-net
Portal server template
  • Name: wlan-net
  • IP address: 10.23.103.1
  • Port number: 50200
  • Shared key: Huawei123
Portal access profile
  • Name: guest
  • Referenced template: Portal server template wlan-net
MAC access profile

Name: guest

Authentication-free rule profile
  • Name: default_free_rule
  • Authentication-free resource: DNS server with IP address 8.8.8.8
802.1x access profile
  • Name: employee
  • Authentication mode: EAP
Authentication profile
  • Name: employee
  • Referenced profiles and authentication schemes: 802.1x access profile employee, RADIUS server template wlan-net, and authentication scheme employee
  • Name: guest
  • Referenced profiles and authentication schemes: Portal access profile guest, MAC access profile guest, RADIUS server template wlan-net, authentication scheme guest, and authentication-free rule template default_free_rule
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profiles employee and guest, and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: employee
  • SSID name: employee
  • Name: guest
  • SSID name: guest
Security profile
  • Name: employee
  • Security policy: WPA-WPA2+802.1x+AES
  • Name: guest
  • Security policy: open
VAP profile
  • Name: employee
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile employee, security profile employee, and authentication profile employee
  • Name: guest
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 102
  • Referenced profiles: SSID profile guest, security profile guest, and authentication profile guest

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Use the configuration wizard to configure system parameters for the AC.
  3. Use the configuration wizard to configure the APs to go online on the AC.
  4. Use the configuration wizard to configure WLAN services, 802.1x authentication, and MAC address-prioritized Portal authentication on the AC.
  5. Configure authentication-free rules for an AP group.
  6. Deliver WLAN services to the APs and verify the configuration.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA to VLAN 100. The default VLAN of GE0/0/1 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 and GE0/0/2 on SwitchB to VLAN 100, and GE0/0/2 and GE0/0/3 to VLAN 101 and VLAN 102, respectively.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 101 102
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101 102
    [SwitchB-GigabitEthernet0/0/3] quit
    
    # Add GE1/0/0 on the router to VLAN 101 and VLAN 102. Create interfaces VLANIF 101 and VLANIF 102, and set the IP addresses of VLANIF 101 and VLANIF 102 to 10.23.101.2/24 and 10.23.102.2/24, respectively.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101 102
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101 102
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    [Router] interface vlanif 102
    [Router-Vlanif102] ip address 10.23.102.2 24
    [Router-Vlanif102] quit
    

  2. Configure a DHCP server to assign IP addresses to STAs.

    # On SwitchB, configure VLANIF 101 and VLANIF 102 address pools to assign IP addresses to employees and guests, respectively. Set the default gateway address for employees and guests to 10.23.101.2 and 10.23.102.2, respectively. Specify the DNS server address 8.8.8.8 for VLANIF 101 and VLANIF 102 address pools.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] dhcp server dns-list 8.8.8.8
    [SwitchB-Vlanif101] quit
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] dhcp select interface
    [SwitchB-Vlanif102] dhcp server gateway-list 10.23.102.2
    [SwitchB-Vlanif102] dhcp server dns-list 8.8.8.8
    [SwitchB-Vlanif102] quit
    

  3. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1. Expand Batch Modify. Set Interface type to Trunk, and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and service VLANs 101 and 102.
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24, DHCP status to ON, and DHCP type to Interface address pool.



      # Click OK. An address pool for VLANIF 100 is configured.

      # Under Static Route Table, click Create. The Create Static Route Table page is displayed.

      # Configure the default route and set its next hop address to 10.23.101.2.



      # Click OK.

      # Similarly, configure a default route with the next hop of 10.23.102.2.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services.
    1. Configure WLAN services for employees.

      # Click Create. The Basic Information page is displayed.

      # Set the SSID name to employee, forwarding mode to tunnel forwarding, and service VLAN to 101.



      # Click Next. The Security Authentication page is displayed.

      # Set the authentication mode to 802.1x authentication, and configure parameters of the external RADIUS server.



      # Click Next. The Access Control page is displayed.

      # Set Binding the AP group to ap-group1.

      # Click Finish.

    2. Configure WLAN services for guests.

      # Click Create. The Basic Information page is displayed.

      # Set the SSID name to guest, forwarding mode to tunnel forwarding, and service VLAN to 102.



      # Click Next. The Security Authentication page is displayed.

      # Set Security settings to Portal(applicable to enterprise networks) and select MAC address-prioritized. Under External Portal Server Configuration, set the server name, IP address, shared key, port number, and server URL. Under External RADIUS Server Configuration, select the configured server wlan-net.



      # Click Next. The Access Control page is displayed.

      # Set Binding the AP group to ap-group1.

      # Click Finish.

  6. Configure network resources accessible to authentication-free users.

    1. Choose Configuration > AP Config > Profile.The Profile Management page is displayed.
    2. Choose Wireless Service > VAP Profile > guest > Authentication Profile > Authentication-free Rule Profile. The Authentication-free Rule Profile page is displayed.
    3. Set Authentication-free Rule Profile to default_free_rule.
    4. Select Authentication-free Rule in Control mode.
    5. Click Create. On the Create Authentication-free Rule page that is displayed, set Rule ID to 1 and the authentication-free resource to the IP address of the DNS server.

    6. Click OK.
    7. Select the authentication-free rule with the ID 1 and click Apply. In the dialog box that is displayed, click OK.

  7. Set the AP channel and power.
    1. Disable automatic channel and power calibration functions of AP radios, and manually configure the AP channel and power.

      NOTE:

      Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.

      # Choose Configuration > AP Config > AP Config > AP Info. The AP List page is displayed.

      # Click the ID of the AP whose channel and power need to be configured. The AP customized settings page is displayed.

      # Click next to Radio Management. The profiles under Radio Management are displayed.

      # Click Radio 0. The Radio 0 Settings(2.4G) page is displayed. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 6 and transmit power to 127 dBm.



      # The configuration of Radio 1 is similar to that of Radio0. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 149 and transmit power to 127 dBm.

      # Click Apply. In the dialog box that is displayed, click OK.

  8. Verify the configuration.

    • An employee can use a STA to find the WLAN with SSID employee. After being associated with the WLAN, the STA is assigned an IP address. After the employee uses an 802.1x client on the STA for authentication and enter the correct user name and password, the STA is authenticated and can access the WLAN. The configuration method on the 802.1x client is as follows:

      • Configuration on the Windows XP operating system:

        1. On the Association tab page of the Wireless network properties dialog box, add SSID employee, set the authentication mode to WPA2, and encryption algorithm to AES.
        2. On the Authentication tab page, set EAP type to PEAP and click Properties. In the Protected EAP Properties dialog box, deselect Validate server certificate and click Configure. In the displayed dialog box, deselect Automatically use my Windows logon name and password and click OK.
      • Configuration on the Windows 7 operating system:

        1. Access the Manage wireless networks page, click Add, and select Manually create a network profile. Add SSID employee. Set the authentication mode to WPA2-Enterprise, and encryption algorithm to AES. Click Next.
        2. Click Change connection settings. On the Wireless Network Properties page that is displayed, select the Security tab page and click Settings. In the Protected EAP Properties dialog box, deselect Validate server certificate and click Configure. In the displayed dialog box, deselect Automatically use my Windows logon name and password and click OK.
        3. On the Wireless Network Properties page, click Advanced settings. On the Advanced settings page that is displayed, select Specify authentication mode, set the identity authentication mode to User authentication, and click OK.
    • A guest can use a STA to find the WLAN with SSID guest. After being associated with the WLAN, the STA is assigned an IP address. When the STA accesses the Internet through a browser, the authentication page provided by the Portal server is automatically displayed. After the correct user name and password are entered on the page, the STA is authenticated and can access the WLAN. Assume that the MAC address configured on the Portal server is valid for 60 minutes. When the STA is disconnected from the WLAN for 5 minutes, the STA can access the Internet directly when reconnecting to the WLAN. When the STA is disconnected from the WLAN for 65 minutes, it will be redirected to the Portal authentication page when reconnecting to the WLAN.

Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90238

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next