No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring VRRP HSB

Example for Configuring VRRP HSB

Service Requirements

An enterprise deploys a WLAN to provide WLAN services to users. The enterprise requires VRRP HSB to improve data transmission reliability.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: The AC functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
  • Switch cluster: A cluster is set up using a CSS card, containing SwitchB and SwitchC at the core layer. SwitchB is the active switch and SwitchC is the standby switch.
Figure 5-43 Configuring VRRP HSB (direct forwarding)

Data Planning

Table 5-48 AC Data Planning

Item

Configuration

AC1's source interface

VLANIF 100: 10.23.100.3/24

AC2's source interface

VLANIF 100: 10.23.100.3/24

Virtual IP address of the management VRRP group

10.23.100.3/24

Virtual IP address of the service VRRP group

10.23.101.3/24

VAP profile

  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

AP group

  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: China

SSID profile

  • Name: wlan-net
  • SSID name: wlan-net

Security profile

  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567

DHCP server

The AC functions as the DHCP server to assign IP addresses to APs and STAs.

AP's gateway

VLANIF 100: 10.23.100.3/24

IP address pool for APs

10.23.100.4 to 10.23.100.254/24

STA's gateway

VLANIF 101: 10.23.101.3/24

IP address pool for STAs

10.23.101.4 to 10.23.101.254/24

IP addresses and port numbers for the active and standby channels of AC1

IP address: VLANIF 102, 10.23.102.1/24

Port number: 10241

IP addresses and port numbers for the active and standby channels of AC2

IP address: VLANIF 102, 10.23.102.2/24

Port number: 10241

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a cluster between SwitchB and SwitchC through cluster cards to improve the core layer reliability and configure SwitchB as the master switch.
  2. Configure AC1 and AC2 using the configuration wizard.
    • Set up connections between the AP, AC, and other network devices.
    • Configure a VRRP group on AC1 and AC2. Configure a higher priority for AC1 than AC2 so that AC1 functions as the master device to forward traffic and AC2 functions as a backup device.
    • Configure the hot standby (HSB) function so that service information on AC1 is backed up to AC2 in batches and in real time, ensuring seamless service switchover from AC1 to AC2.
    • Add APs on AC1 and AC2, and configure WLAN services.
NOTE:

Check whether loops occur on the wired network. If loops occur, configure MSTP on corresponding NEs.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Establish a cluster through cluster cards.

    # Set the CSS ID, CSS priority, and CSS connection mode to 1, 100, and CSS card connection for SwitchB.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] set css mode css-card
    [SwitchB] set css id 1
    [SwitchB] set css priority 100
    

    # Set the CSS ID, CSS priority, and CSS connection mode to 2, 10, and CSS card connection for SwitchC.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchC
    [SwitchC] set css mode css-card
    [SwitchC] set css id 2
    [SwitchC] set css priority 10
    

    # Check the CSS configuration on SwitchB.

    [SwitchB] display css status saved
    Current Id   Saved Id     CSS Enable   CSS Mode    Priority    Master force     
    ------------------------------------------------------------------------------  
    1            1            Off          CSS card    100         Off             

    # Check the CSS configuration on SwitchC.

    [SwitchC] display css status saved
    Current Id   Saved Id     CSS Enable   CSS Mode    Priority    Master force     
    ------------------------------------------------------------------------------  
    1            2            Off          CSS card    10          Off              

    # Enable the CSS function on SwitchB and restart SwitchB.

    [SwitchB] css enable
    Warning: The CSS configuration will take effect only after the system is rebooted. T
    he next CSS mode is CSS card. Reboot now? [Y/N]:y

    # Enable the CSS function on SwitchC and restart SwitchC.

    [SwitchC] css enable
    Warning: The CSS configuration will take effect only after the system is rebooted. T
    he next CSS mode is CSS card. Reboot now? [Y/N]:y

    # Log in to the CSS through the console port on any MPU to check whether the CSS is established successfully.

    <SwitchB> display device
    Chassis 1 (Master Switch)
    S12708's Device status:
    Slot  Sub Type         Online    Power      Register       Status     Role  
    -------------------------------------------------------------------------------
    1     -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    5     -   ET1D2G48SEC0 Present   PowerOn    Registered     Normal     NA    
    7     -   ET1D2X16SSC0 Present   PowerOn    Registered     Normal     NA    
    9     -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Slave 
    10    -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Master
    12    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    13    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    14    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    PWR1  -   -            Present   PowerOn    Registered     Normal     NA    
    PWR2  -   -            Present   PowerOn    Registered     Normal     NA    
    CMU2  -   EH1D200CMU00 Present   PowerOn    Registered     Normal     Master
    FAN1  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN2  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN3  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN4  -   -            Present   PowerOn    Registered     Normal     NA    
    Chassis 2 (Standby Switch)
    S12708's Device status:
    Slot  Sub Type         Online    Power      Register       Status     Role  
    -------------------------------------------------------------------------------
    1     -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    3     -   ET1D2G48SEC0 Present   PowerOn    Registered     Normal     NA    
    4     -   ET1D2X16SSC0 Present   PowerOn    Registered     Normal     NA    
    9     -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Slave 
    10    -   ET1D2MPUA000 Present   PowerOn    Registered     Normal     Master
    12    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    13    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    14    -   ET1D2SFUD000 Present   PowerOn    Registered     Normal     NA    
          1   EH1D2VS08000 Present   PowerOn    Registered     Normal     NA    
    PWR1  -   -            Present   PowerOn    Registered     Normal     NA    
    PWR2  -   -            Present   PowerOn    Registered     Normal     NA    
    CMU1  -   EH1D200CMU00 Present   PowerOn    Registered     Normal     Master
    FAN1  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN2  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN3  -   -            Present   PowerOn    Registered     Normal     NA    
    FAN4  -   -            Present   PowerOn    Registered     Normal     NA    
    <SwitchB> display css status
    CSS Enable switch On                                                            
                                                                                    
    Chassis Id   CSS Enable   CSS Status      CSS Mode    Priority    Master Force  
    ------------------------------------------------------------------------------  
    1            On           Master          CSS card    100         Off           
    2            On           Standby         CSS card    10          Off   

    The command output shows card status and CSS status of both member switches, indicating that the CSS is established successfully.

    # Check whether the cluster links are normal.

    <SwitchB> display css channel
                   Chassis 1               ||             Chassis 2                 
    --------------------------------------------------------------------------------
    Num      [Port]         [Speed]        ||        [Speed]         [Port]
     1       1/1/0/1        10G                      10G             2/1/0/1      
     2       1/1/0/2        10G                      10G             2/1/0/2      
     3       1/1/0/3        10G                      10G             2/1/0/3      
     4       1/1/0/4        10G                      10G             2/1/0/4      
     5       1/1/0/5        10G                      10G             2/1/0/5      
     6       1/1/0/6        10G                      10G             2/1/0/6      
     7       1/1/0/7        10G                      10G             2/1/0/7      
     8       1/1/0/8        10G                      10G             2/1/0/8      
     9       1/12/0/1       10G                      10G             2/12/0/1      
    10       1/12/0/2       10G                      10G             2/12/0/2      
    11       1/12/0/3       10G                      10G             2/12/0/3      
    12       1/12/0/4       10G                      10G             2/12/0/4      
    13       1/12/0/5       10G                      10G             2/12/0/5      
    14       1/12/0/6       10G                      10G             2/12/0/6      
    15       1/12/0/7       10G                      10G             2/12/0/7      
    16       1/12/0/8       10G                      10G             2/12/0/8      
    17       1/13/0/1       10G                      10G             2/13/0/1      
    18       1/13/0/2       10G                      10G             2/13/0/2      
    19       1/13/0/3       10G                      10G             2/13/0/3      
    20       1/13/0/4       10G                      10G             2/13/0/4      
    21       1/13/0/5       10G                      10G             2/13/0/5      
    22       1/13/0/6       10G                      10G             2/13/0/6      
    23       1/13/0/7       10G                      10G             2/13/0/7      
    24       1/13/0/8       10G                      10G             2/13/0/8      
    25       1/14/0/1       10G                      10G             2/14/0/1      
    26       1/14/0/2       10G                      10G             2/14/0/2      
    27       1/14/0/3       10G                      10G             2/14/0/3      
    28       1/14/0/4       10G                      10G             2/14/0/4      
    29       1/14/0/5       10G                      10G             2/14/0/5      
    30       1/14/0/6       10G                      10G             2/14/0/6      
    31       1/14/0/7       10G                      10G             2/14/0/7      
    32       1/14/0/8       10G                      10G             2/14/0/8      
    --------------------------------------------------------------------------------

    The command output shows that all the cluster links are in Up state, indicating that the CSS has been established successfully.

  2. Configure SwitchA, SwitchB, and SwitchC so that the AC and APs can transmit CAPWAP packets.

    NOTE:

    If direct forwarding is used, configure port isolation on GE0/0/1 of the SwitchA (connecting to the AP). If port isolation is not configured, many broadcast packets will be transmitted in the VLANs or WLAN users on different APs can directly communicate at Layer 2.

    # Set the PVID of GE0/0/1 on SwitchA connected to the AP to management VLAN 100 and add GE0/0/1 to VLAN 100 and service VLAN 101. Add GE0/0/2 on SwitchA connected to SwitchB to VLAN 100 and VLAN 101 and GE0/0/3 on SwitchA connected to SwitchC to Eth-Trunk 10.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface eth-trunk 10
    [SwitchA-Eth-Trunk10] port link-type trunk
    [SwitchA-Eth-Trunk10] undo port trunk allow-pass vlan 1
    [SwitchA-Eth-Trunk10] port trunk allow-pass vlan 100 101
    [SwitchA-Eth-Trunk10] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] undo port link-type
    [SwitchA-GigabitEthernet0/0/2] eth-trunk 10
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] undo port link-type
    [SwitchA-GigabitEthernet0/0/3] eth-trunk 10
    [SwitchA-GigabitEthernet0/0/3] quit
    

    # Add GE1/1/0/2 on SwitchB and GE2/1/0/2 on SwitchC to Eth-Trunk 10, and add E1/1/0/1 on SwitchB and GE2/1/0/1 on SwitchC to VLANs 100 and 101, respectively.

    [SwitchB] sysname CSS
    [CSS] vlan batch 100 101
    [CSS] interface gigabitethernet 1/1/0/1
    [CSS-GigabitEthernet1/1/0/1] port link-type trunk
    [CSS-GigabitEthernet1/1/0/1] undo port trunk allow-pass vlan 1
    [CSS-GigabitEthernet1/1/0/1] port trunk allow-pass vlan 100 101
    [CSS-GigabitEthernet1/1/0/1] quit
    [CSS] interface gigabitethernet 2/1/0/1
    [CSS-GigabitEthernet2/1/0/1] port link-type trunk
    [CSS-GigabitEthernet2/1/0/1] undo port trunk allow-pass vlan 1
    [CSS-GigabitEthernet2/1/0/1] port trunk allow-pass vlan 100 101
    [CSS-GigabitEthernet2/1/0/1] quit
    [CSS] interface eth-trunk 10
    [CSS-Eth-Trunk10] port link-type trunk
    [CSS-Eth-Trunk10] undo port trunk allow-pass vlan 1
    [CSS-Eth-Trunk10] port trunk allow-pass vlan 100 101
    [CSS-Eth-Trunk10] quit
    [CSS] interface gigabitethernet 1/1/0/2
    [CSS-GigabitEthernet1/1/0/2] undo port link-type
    [CSS-GigabitEthernet1/1/0/2] eth-trunk 10
    [CSS-GigabitEthernet1/1/0/2] quit
    [CSS] interface gigabitethernet 2/1/0/2
    [CSS-GigabitEthernet2/1/0/2] undo port link-type
    [CSS-GigabitEthernet2/1/0/2] eth-trunk 10
    [CSS-GigabitEthernet2/1/0/2] quit

  3. Configure AC1.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China, System time to Manual, and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Modify all. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN) and VLAN 101 (service VLAN).

      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply.

      # Deselect GigabitEthernet0/0/1 and then select GigabitEthernet0/0/2. Add GigabitEthernet0/0/2 to VLAN 102 in the same way.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24. Set DHCP status to ON and DHCP type to Interface address pool. Expand Advanced. Click to add 10.23.100.2 and 10.23.100.3 to Excluded IP address.

      NOTE:

      Configure the DNS server address as required.



      # Click OK. An address pool for VLANIF 100 is configured.

      # Repeat the preceding steps to configure an address pool for VLANIF 101. Set the IP address of VLANIF 101 to 10.23.101.1/24. Add 10.23.101.2 and 10.23.101.3 to Excluded IP address.

      # Set the IP address of VLANIF 102 to 10.23.102.1/24.

      # Click Next. The AC Backup Configuration page is displayed.

    4. Configure AC backup.

      # Enable HSB.

      # Click Create. The Create VRID page is displayed.

      # Create a management VRRP group. Set parameters as follows:
      • VLANIF/IP: VLANIF 100
      • VRID: 1
      • VRRP type: mVRRP group
      • Virtual IP address: 10.23.100.3
      • Priority: 120
      • Preemption delay(s): 1800
      • Interval for sending VRRP advertisement packets: 2


      # Click OK.

      # Configure a service VRRP group in the same way. Set parameters as follows:
      • VLANIF/IP: VLANIF 101
      • VRID: 2
      • VRRP type: VRRP group
      • Virtual IP address: 10.23.101.3
      • Preemption delay(s): 1800
      • VRID of the mVRRP group: 1
      • Interval for sending VRRP advertisement packets: 2


      # Click OK.

      # Configure HSB. Set parameters as follows:
      • Local AC IP address: 10.23.102.1
      • Peer AC IP address: 10.23.102.2
      • Local port: 10241
      • Remote port: 10241
      • Associated VRID: 1


      # Click Next. The AC Source Address page is displayed.

    5. Configure the source address for AC1.

      # Set AC source address to IP address and set the IP address to 10.23.100.3.



      # Click Next. The Confirm Settings page is displayed.

    6. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure APs connected to AC1.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If AP authentication mode is set to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If AP authentication mode is set to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next.

    2. Configure an AP group.

      # The AP template file has AP group information added. Click Next. The Confirm Configurations page is displayed.

    3. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure basic WLAN services on AC1.
    1. Configure WLAN services.

      # Click Create. The Basic Information page is displayed.

      # Configure the SSID name, forwarding mode, and service VLAN ID.



      Click Next. The Security Authentication page is displayed.

      # Set Security settings to Key (applicable to personnel networks) and set the key.



      # Click Next. The Access Control page is displayed.

      # Set Binding the AP group to ap-group1.

      Click Finish.

  6. Configure AC2.
    1. Perform basic AC configurations.

      # Configure AC2 in the same way as that for configuring AC1.

    2. Configure interfaces.

      # Configure interfaces on AC2 in the same way as that on AC1.

    3. Configuring network interconnections.

      # Configure network interconnections on AC2 in the same way as that on AC1. The differences are as follows:

      • Set IP addresses of VLANIF 100, VLANIF 101, and VLANIF 102 to 10.23.100.2/24, 10.23.101.2/24, and 10.23.102.2/24, respectively.
      • Add IP addresses 10.23.100.1 and 10.23.100.3 to Excluded IP address of VLANIF 100.
      • Add IP addresses 10.23.101.1 and 10.23.101.3 to Excluded IP address of VLANIF 101.

    4. Configure AC backup.

      # Configure AC backup on AC2 in the same way as that on AC1. The differences are as follows:

      • When configuring VRRP groups, use the default values of Priority and Preemption delay(s).
      • When configuring HSB, set Local AC IP address to 10.23.102.2 and Peer AC IP address to 10.23.102.1.

    5. Configure the source address for AC2.

      # Configure the source address for AC2 in the same way as that for AC1.

    6. Confirm the configuration.

      # Confirm the configuration and click Finish.

  7. Add APs on AC2.

    The configuration is similar to that on AC1.

  8. Configure WLAN services on AC2.

    The configuration is similar to that on AC1.

  9. Verify the configuration.
    1. STAs associated with the AP can find the SSID wlan-net and connect to the WLAN.
    2. If the link between the AP and AC1 is disconnected, AC2 becomes the active AC, ensuring user service continuity.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90254

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next