No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Service Holding upon CAPWAP Link Disconnection

Example for Configuring Service Holding upon CAPWAP Link Disconnection

Service Requirements

Enterprise users can access the network through WLANs, which is the basic requirement of mobile office. Furthermore, users' services are not affected during roaming in the coverage area.

The enterprise requires that data forwarding be not affected even when the AC is faulty to improve data transmission reliability.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: Switch functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 4-76 Networking for configuring service holding upon WLAN CAPWAP link disconnection

Data Planning

Table 4-77 AC data planning

Item

Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

DHCP server

Switch functions as a DHCP server to assign IP addresses to APs and STAs.

IP address pool for APs

10.1.1.3-10.1.1.254/24

IP address pool for STAs

10.1.2.3-10.1.2.254/24

Gateway address for APs

10.1.1.1/24

Gateway address for STAs

10.1.2.1/24

AC source interface

VLANIF 100: 10.1.1.2/24

AP group
  • Name: ap-group1
  • Referenced profiles: AP system profile ap-system, VAP profile wlan-net, and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net
AP system profile
  • Name: ap-system
  • Service holding upon CAPWAP link disconnection: enabled

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Configure the APs to go online.
    1. Create an AP group and add APs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the APs.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
  3. Configure WLAN service parameters for STAs to access the WLAN.
  4. Configure service holding upon CAPWAP link disconnection to improve data transmission reliability so that data forwarding is not affected even when the AC is faulty.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Create VLAN 100 (management VLAN) and VLAN 101 (service VLAN) on the switch. Set the link type of GE0/0/1 that connects the switch to the APs to trunk and PVID of the interface to 100, and configure the interface to allow packets of VLAN 100 and VLAN 101 to pass. Set the link type of GE0/0/2 on the switch to trunk, and configure the interface to allow packets of VLAN 100 to pass.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100 101
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/2] quit
    
    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.1.2.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.1.2.2 24
    [Router-Vlanif101] quit
    

  2. Configure the AC to communicate with the network devices.

    # Add GE0/0/1 that connects the AC to the switch to VLAN 100, Create VLANIF 100 and set its IP address to 10.1.1.2/24.

    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.1.1.2 255.255.255.0
    [AC-Vlanif100] quit
    

  3. Configure the DHCP servers to assign IP addresses to APs and STAs.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.

    # Configure VLANIF 100 to use the interface address pool to allocate IP addresses to APs.

    [Switch] dhcp enable
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.1.1.1 255.255.255.0
    [Switch-Vlanif100] dhcp select interface
    [Switch-Vlanif100] quit
    

    # Configure VLANIF 101 to use the interface address pool to allocate IP addresses to STAs.

    [Switch] interface vlanif 101
    [Switch-Vlanif101] ip address 10.1.2.1 255.255.255.0
    [Switch-Vlanif101] dhcp select interface
    [Switch-Vlanif101] quit
    

  4. Configure an AP to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    
    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online successfully.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.1.2.254    AP5030DN        nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1
    

  5. Configure WLAN service parameters.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Create SSID profile wlan-net and set the SSID name to wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    

    # Create the AP system profile ap-system and configure the service holding function.

    [AC-wlan-view] ap-system-profile name ap-system
    [AC-wlan-ap-system-prof-ap-system] keep-service enable allow new-access
    [AC-wlan-ap-system-prof-ap-system] quit
    

    # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    

    # Bind the AP system profile and VAP profile to the AP group and apply the VAP profile to radio 0 and radio 1 of the AP.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] ap-system-profile ap-system
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  6. Configure the AP channel and power.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The settings of the AP channel and power in this example are for reference only. You need to configure the AP channel and power based on the actual country code and network planning.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] calibrate auto-channel-select disable
    [AC-wlan-radio-0/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] calibrate auto-channel-select disable
    [AC-wlan-radio-0/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  7. Verify the configuration.

    The WLAN with SSID wlan-net is available for STAs connected to the AP, and these STAs can connect to the WLAN without authentication. If the AC is powered off, service data forwarding for wireless users in area A is not affected.

Configuration Files

  • Switch configuration file

    #
     sysname Switch
    #
     vlan batch 100 to 101
    #
     dhcp enable
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif101
     ip address 10.1.2.1 255.255.255.0
     dhcp select interface
    # 
     interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
     interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    vlan batch 101
    #
    interface Vlanif101
     ip address 10.1.2.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    return
    
  • AC configuration file

    #
    sysname AC
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      forward-mode direct-forward
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-system-profile name ap-system
      keep-service enable allow new-access
     ap-group name ap-group1
      ap-system-profile ap-system
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
      radio 1
       channel 20mhz 149
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90714

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next