No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring User Authorization Based on ACL Numbers or Dynamic VLANs (CLI)

Example for Configuring User Authorization Based on ACL Numbers or Dynamic VLANs (CLI)

Introduction to User Authorization

In user authorization, the device controls network access rights based on the user role during each phase of user authentication. After an 802.1x user is successfully authenticated on a RADIUS server, the server sends authorization information to the access device of the user. When the Cisco Identity Services Engine (ISE) functions as a RADIUS server, it can deliver multiple authorization parameters. The following example uses ACL numbers and dynamic VLANs to control user authorization.
  • Authorization based on ACL numbers

    If ACL number delivery is configured on the RADIUS server, authorization information sent to the access device includes the ACL number. The access device matches ACL rules based on the delivered ACL number to control user rights.

    The RADIUS attribute used for ACL number delivery is (011) Filter-Id.

    The ACL numbers supported by the AC range from 3000 to 3031.

  • Authorization based on dynamic VLANs

    If dynamic VLAN delivery is configured on the RADIUS server, authorization information sent to the access device includes the VLAN attribute. After the access device receives the authorization information, it changes the VLAN of the user to the delivered VLAN. The delivered VLAN does not change or affect the interface configuration. The priority of the delivered VLAN, however, is higher than that of the user configured VLAN. That is, the delivered VLAN takes effect after the authentication succeeds and the user-configured VLAN takes effect after the user goes offline.

    The following RADIUS attributes are used for dynamic VLAN delivery:
    • (064) Tunnel-Type (It must be set to VLAN or 13.)
    • (065) Tunnel-Medium-Type (It must be set to 802 or 6.)
    • (081) Tunnel-Private-Group-ID (It can be a VLAN ID or VLAN name.)
    To ensure that the RADIUS server delivers VLAN information correctly, all the three RADIUS attributes must be used. In addition, the Tunnel-Type and Tunnel-Medium-Type attributes must be set to the specified values.

When the AC is interconnected with the Cisco ISE, three authentication methods, that is, Password Authentication Protocol (PAP), Challenge Handshake Authentication Protocol (CHAP), and Extensible Authentication Protocol (EAP), can be used in 802.1x authentication. The configurations for the three authentication methods are similar. The following uses EAP as an example.

For details about how to configure user authorization based on ACL numbers on the AC, see user authorization configuration on the AC.

For details about how to configure user authorization based on ACL numbers on the Cisco ISE server, see Cisco ISE configuration.

Applicable Products and Versions

Table 4-89 Applicable products and versions

Product

Version

Huawei AC

V200R007C10 and later versions

Cisco ISE

2.0.0.306

Service Requirements

Network access rights are controlled based on user roles when users access the WLAN through 802.1x authentication.

A large number of employees use wireless terminals to access an enterprise network. To ensure network security, the administrator needs to control network access rights of terminals. After successful authentication, terminals can access the service server (with IP address 10.23.105.1) and devices in the laboratory (with VLAN ID 20 and IP address segment 10.23.20.2-10.23.20.100).

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to allocate IP addresses to APs.
    • SwitchB functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: direct forwarding
  • WLAN authentication mode: WPA-WPA2+802.1x+AES
Figure 4-84 Networking for configuring user authorization based on ACL numbers or dynamic VLANs

Data Planning

Table 4-90 Data planning on the AC

Configuration Item

Data

Management VLAN

VLAN 100

Service VLAN

VLAN 101

AC's source interface

VLANIF 100: 10.23.100.1/24

DHCP server

  • The AC functions as a DHCP server to allocate IP addresses to APs.
  • SwitchB functions as a DHCP server to assign IP addresses to STAs.

IP address pool for APs

10.23.100.2-10.23.100.254/24

IP address pool for the STAs

10.23.101.2-10.23.101.254/24

10.23.20.101-10.23.20.254/24

RADIUS authentication parameters

  • RADIUS server template name: wlan-net
  • IP address: 10.23.103.1
  • Authentication port number: 1812
  • Shared key: huawei@123
  • Authentication scheme: wlan-net
Resources accessible to users after authentication
  • Access rights to the laboratory are granted using a dynamic VLAN. The VLAN ID is 20.
  • Access rights to the service server are granted using an ACL number. The ACL number is 3002.

802.1x access profile

  • Name: wlan-net
  • Authentication mode: EAP

Authentication profile

  • Name: wlan-net
  • Bound profile and authentication scheme: 802.1x access profile wlan-net, RADIUS server template wlan-net, and authentication scheme wlan-net

AP group

  • Name: ap-group1
  • Bound profile: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: CN
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+802.1x+AES
VAP profile
  • Name: wlan-net
  • Forwarding mode: direct forwarding
  • Service VLAN: VLAN 101
  • Bound profiles: SSID profile wlan-net, security profile wlan-net, and authentication profile wlan-net
Table 4-91 Data planning on the Cisco ISE

Configuration Item

Data

Department

R&D

Account

  • Account: huawei
  • Password: huawei123

Device profile

Huawei

Device name

AC6605

Device's IP address

10.23.102.2/32

RADIUS shared key

huawei@123

Authentication protocol

  • MS-CHAPv2
  • PEAP
  • CHAP (only for the test-aaa test)

Authorization ACL

3002

Dynamic VLAN

VLAN20

Configuration Roadmap

  1. Configure network interworking.
  2. Configure basic WLAN services.
  3. Configure the parameters for interconnecting the AC and RADIUS server and network access rights after successful authentication.
  4. Configure the Cisco ISE server.
    • Add users.
    • Add the AC.
    • Configure the password authentication protocol.
    • Configure authentication policies.
    • Configure authorization policies.

Configuration Notes

  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • The AC and server must have the same RADIUS shared key.

  • If a terminal obtains an IP address using DHCP, you need to manually trigger the DHCP process to request an IP address after VLAN-based authorization is successful or the authorization VLAN changes.

Procedure

  1. Configure network interworking.

    # Add GE0/0/1 and GE0/0/3 on SwitchA (access switch) to VLAN20, VLAN 100 and VLAN 101 and GE0/0/2 to VLAN 20.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 20 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 20 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 20 100 101
    [SwitchA-GigabitEthernet0/0/3] quit
    
    # Add GE0/0/1 on SwitchB (aggregation switch) to VLAN20, VLAN 100 and VLAN 101, GE0/0/2 to VLAN 100 and VLAN 102, GE0/0/3 to VLAN 103, GE0/0/4 to VLAN104, and GE0/0/5 to VLAN 105.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 20 100 to 105
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 20 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk pvid vlan 103
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 103
    [SwitchB-GigabitEthernet0/0/3] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk pvid vlan 104
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 104
    [SwitchB-GigabitEthernet0/0/4] quit
    [SwitchB] interface gigabitethernet 0/0/5
    [SwitchB-GigabitEthernet0/0/5] port link-type trunk
    [SwitchB-GigabitEthernet0/0/5] port trunk pvid vlan 105
    [SwitchB-GigabitEthernet0/0/5] port trunk allow-pass vlan 105
    [SwitchB-GigabitEthernet0/0/5] quit
    
    # Create VLANIF interfaces VLANIF 102, VLANIF 103, VLANIF 104 and VLANIF 105 on SwitchB and configure configure a default route with the next hop of the address of Router.
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] quit
    [SwitchB] interface vlanif 103
    [SwitchB-Vlanif103] ip address 10.23.103.2 24
    [SwitchB-Vlanif103] quit
    [SwitchB] interface vlanif 104
    [SwitchB-Vlanif104] ip address 10.23.104.1 24
    [SwitchB-Vlanif104] quit
    [SwitchB] interface vlanif 105
    [SwitchB-Vlanif105] ip address 10.23.105.2 24
    [SwitchB-Vlanif105] quit
    [SwitchB] ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    
    # On the AC, create VLAN 20 for authorization, add GE0/0/1 connected to SwitchB to VLAN 100 and VLAN 102, create VLANIF 102, and configure the static route to the RADIUS server.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 20 100 102
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 102
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 102
    [AC-Vlanif102] ip address 10.23.102.2 24
    [AC-Vlanif102] quit
    [AC] ip route-static 10.23.103.0 24 10.23.102.1
    
    # Configure the IP address of GE0/0/1 on Router and a static route to the network segment for STAs.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 10.23.104.2 24
    [Router-GigabitEthernet0/0/1] quit
    [Router] ip route-static 10.23.101.0 24 10.23.104.1
    

  2. Configure the AC and SwitchB to function as DHCP servers to assign IP addresses to APs and STAs respectively.

    # On the AC, configure the VLANIF 100 to assign IP addresses to APs.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    # On SwitchB, configure the VLANIF 101 to assign IP addresses to STAs.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] quit
    # On SwitchB, configure the VLANIF 20 to assign IP addresses to authorized STAs. The IP address segment 10.23.20.2-10.23.20.100 cannot be assigned to STAs.
    [SwitchB] interface vlanif 20
    [SwitchB-Vlanif20] ip address 10.23.20.1 24
    [SwitchB-Vlanif20] dhcp select interface
    [SwitchB-Vlanif20] dhcp server excluded-ip-address 10.23.20.2 10.23.20.100
    [SwitchB-Vlanif20] quit

  3. Configure APs to go online.

    # Create an AP group to which the APs with the same configuration can be added.

    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    

    # Create a regulatory domain profile, configure the AC country code in the profile, and bind the profile to the AP group.

    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    

    # Configure the AC's source interface.

    [AC] capwap source interface vlanif 100
    
    # Import the APs offline to the AC and add the APs to the AP group ap-group1. Configure names for the APs based on the AP locations, so that you can know where the APs are located. For example, if the AP with MAC address 60de-4476-e360 is deployed in area 1, name the AP area_1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 and radio 1. Radio 0 and radio 1 operate on the 2.4 GHz and 5 GHz bands respectively.

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

    # After the AP is powered on, run the display ap all command to check the AP state. If the State field displays nor, the AP has gone online.

    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    --------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    --------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S
    --------------------------------------------------------------------------------
    Total: 1
    

  4. Configure the AP channel and power.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The settings of the AP channel and power in this example are for reference only. You need to configure the AP channel and power based on the actual country code and network planning.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] calibrate auto-channel-select disable
    [AC-wlan-radio-0/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] calibrate auto-channel-select disable
    [AC-wlan-radio-0/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  5. Configure 802.1x authentication on the AC.
    1. Configure RADIUS authentication parameters.

      # Create a RADIUS server template.

      [AC-wlan-view] quit
      [AC] radius-server template wlan-net
      [AC-radius-wlan-net] radius-server authentication 10.23.103.1 1812
      [AC-radius-wlan-net] radius-server shared-key cipher huawei@123
      [AC-radius-wlan-net] quit
      

      # Create a RADIUS authentication scheme.

      [AC] aaa
      [AC-aaa] authentication-scheme wlan-net
      [AC-aaa-authen-wlan-net] authentication-mode radius
      [AC-aaa-authen-wlan-net] quit
      [AC-aaa] quit
      

    2. Configure an 802.1x access profile to manage 802.1x access control parameters.

      # Create the 802.1x access profile wlan-net.

      [AC] dot1x-access-profile name wlan-net
      

      # Configure EAP relay authentication.

      [AC-dot1x-access-profile-wlan-net] dot1x authentication-method eap
      [AC-dot1x-access-profile-wlan-net] quit
      

    3. Create the authentication profile wlan-net and bind it to the 802.1x access profile, authentication scheme, and RADIUS server template.

      [AC] authentication-profile name wlan-net
      [AC-authentication-profile-wlan-net] dot1x-access-profile wlan-net
      [AC-authentication-profile-wlan-net] authentication-scheme wlan-net
      [AC-authentication-profile-wlan-net] radius-server wlan-net
      [AC-authentication-profile-wlan-net] quit

    4. Configure WLAN service parameters.

      # Create the security profile wlan-net and set the security policy in the profile.

      [AC] wlan
      [AC-wlan-view] security-profile name wlan-net
      [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 dot1x aes
      [AC-wlan-sec-prof-wlan-net] quit
      

      # Create the SSID profile wlan-net and set the SSID name to wlan-net.

      [AC-wlan-view] ssid-profile name wlan-net
      [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
      [AC-wlan-ssid-prof-wlan-net] quit
      

      # Create the VAP profile wlan-net, configure the direct data forwarding mode and service VLANs, and bind the security profile, authentication profile, and SSID profile to the VAP profile.

      [AC-wlan-view] vap-profile name wlan-net
      [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
      [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
      [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] authentication-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
      [AC-wlan-vap-prof-wlan-net] quit
      

      # Bind the VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.

      [AC-wlan-view] ap-group name ap-group1
      [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
      [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
      [AC-wlan-ap-group-ap-group1] quit
      [AC-wlan-view] quit
      

  6. Configure the authorization parameter ACL 3002 for users who pass authentication.

    [AC] acl 3002
    [AC-acl-adv-3002] rule 1 permit ip destination 10.23.105.1 0
    [AC-acl-adv-3002] rule 2 deny ip destination any
    [AC-acl-adv-3002] quit

  7. Configure the Cisco ISE server.
    1. # Log in to the Cisco ISE server.

      # Enter the access address of the Cisco ISE server in the address box, which is in the format of https://Cisco ISE IP. Cisco ISE IP is the IP address of the Cisco ISE server.

      # On the displayed page, enter the user name and password to log in to the Cisco ISE server.

    2. Create a department and an account.

      # Choose Administration > Identity Management > Groups > User Identity Groups. In the pane on the right side, click Add and create a department named R&D. Then, click Submit.



      # Choose Administration > Identity Management > Identities > Users. In the pane on the right side, click Add to create the account with the user name of huawei and password of huawei123. Add the account to department R&D. Then, click Submit.



    3. Add the AC so that the Cisco ISE can interwork with the AC.

      # Choose Administration > Network Resources > Network Device Profiles. In the pane on the left side, click Add and create a device profile named Huawei. Then, click Submit.



      # Choose Administration > Network Resources > Network Devices. In the pane on the right side, click Add. Set the device name to AC6605, IP address to 10.23.102.2/32, and RADIUS shared key to huawei@123. Then, click Submit.



    4. Configure the authentication protocol.

      # Choose Policy > Policy Elements > Results > Authentication > Allowed Protocols. Select Default Network Access and click Edit.



      # Select Allow CHAP, Allow MS-CHAPv2, and Allow PEAP. For other parameters, use the default settings. Click Save.
      NOTE:

      By default, the Cisco ISE disables the CHAP authentication protocol. You need to select the CHAP authentication protocol on the server so that the CHAP protocol can be used to carry out the test-aaa test on the AC.



    5. Configure the ACL and dynamic VLAN for authorization.

      # Choose Policy > Policy Elements > Results > Authorization > Authorization Profiles. In the pane on the right side, click Add. Enter the name, set the delivery attribute to Radius:Filter-ID, and enter the ACL number 3002.

      # Click Submit to complete the configuration and return to the Authorization Profiles page.

      # In the pane on the right side, click Add, enter the name, and configure the following delivery attributes.
      • Radius:Tunnel-Type: VLAN
      • Radius:Tunnel-Medium-Type: 802
      • Radius:Tunnel-Private-Group-ID: 20


      # Click Submit to complete the configuration.

    6. Add an authorization rule.

      # Choose Policy > Authorization. In the pane on the right side, click the triangle next to Edit. Choose Insert New Rule Above to add a new authorization rule named ACL_VLAN. Set the authorized user group to R&D and select PermitAccess, ACL_3002, and VLAN_20 under Permissions.

      # Click Done on the right side. Then click Save to complete the authorization rule configuration.

  8. On the AC, check whether users can pass RADIUS authentication.

    [AC] test-aaa huawei huawei123 radius-template wlan-net
    Info: Account test succeed.
    

  9. Verify the configuration.

    • An employee can access the service server, and laboratory after passing authentication.
    • After the authentication succeeds, run the display access-user command on the AC. The command output shows online employees.
      [AC] display access-user access-type dot1x 
      ------------------------------------------------------------------------------
      UserID Username                IP address       MAC            Status          
      ------------------------------------------------------------------------------
      460    huawei                  10.23.20.254     8000-6e74-e78a Success 
      ------------------------------------------------------------------------------
      Total: 1, printed: 1
      

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 20 100 to 101
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 20 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 101
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 20 100 to 105
    #
    dhcp enable
    #
    interface Vlanif20
     ip address 10.23.20.1 255.255.255.0
     dhcp select interface
     dhcp server excluded-ip-address 10.23.20.2 10.23.20.100
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
    #
    interface Vlanif103
     ip address 10.23.103.2 255.255.255.0
    #
    interface Vlanif104
     ip address 10.23.104.1 255.255.255.0
    #
    interface Vlanif105
     ip address 10.23.105.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 20 100 to 101
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 103
     port trunk allow-pass vlan 103
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk pvid vlan 104
     port trunk allow-pass vlan 104
    #
    interface GigabitEthernet0/0/5
     port link-type trunk
     port trunk pvid vlan 105
     port trunk allow-pass vlan 105
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.104.2
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    interface GigabitEthernet0/0/1
     ip address 10.23.104.2 255.255.255.0
    #
    ip route-static 10.23.101.0 255.255.255.0 10.23.104.1
    #
    return
    
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 20 100 102
    #
    authentication-profile name wlan-net
     dot1x-access-profile wlan-net
     authentication-scheme wlan-net
     radius-server wlan-net
    #
    dhcp enable
    #
    radius-server template wlan-net
     radius-server shared-key cipher %^%#r2}aCaYC_5+]c@/eolcB+CNMD=m\g2HmQ1/!crRU%^%#
     radius-server authentication 10.23.103.1 1812 weight 80
    #
    acl number 3002
     rule 1 permit ip destination 10.23.105.1 0 
     rule 2 deny ip
    #
    aaa
     authentication-scheme wlan-net
      authentication-mode radius
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    ip route-static 10.23.103.0 255.255.255.0 10.23.102.1
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name wlan-net
      security wpa-wpa2 dot1x aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
      authentication-profile wlan-net
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
      radio 1
       channel 20mhz 149
       eirp 127
    #
    dot1x-access-profile name wlan-net
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 94359

Downloads: 544

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next