No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring an AP to Go Online Using a Static IP Address

Example for Configuring an AP to Go Online Using a Static IP Address

Service Requirements

Administrators need to configure static IP addresses for APs so that the APs can discover an AC. When the APs are authenticated by the AC, the APs go online properly on the AC.

Networking Requirements

AC networking mode: Layer 2 networking (AP goes online using a static IP address.)

Figure 4-78 Networking for configuring an AP to go online using a static IP address

Data Planning

Table 4-79 AC data planning
Item Data

Management VLAN for APs

VLAN 100

AC's source interface address

10.23.100.1/24

AP's static IP address

10.23.100.100/24

AP group

Name: ap-group1

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Configure the APs to go online.
    1. Create an AP group and add APs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the APs.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
    4. Configure static IP addresses for the APs and enable the APs to go online.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on Switch to VLAN 100. VLAN 100 is the default VLAN of GE0/0/1.
    <HUAWEI> system-view
    [HUAWEI] sysname Switch
    [Switch] vlan batch 100
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type trunk
    [Switch-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/1] port-isolate enable
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type trunk
    [Switch-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch-GigabitEthernet0/0/2] quit
    

  2. Configure the AC to communicate with the network devices.

    NOTE:

    If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.

    # On the AC, add GE0/0/1 to VLAN 100. Create VLANIF 100 and set its IP address to 10.23.100.1/24.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] quit
    

  3. Configure an AP to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    

  4. Log in to the AP using the serial port and configure a static IP address for the AP.

    # Configure the AP static IP address and AC IP address.

    <Huawei> system-view
    [Huawei] ap-address mode static
    [Huawei] ap-address static ip-address 10.23.100.100 24 10.23.100.1
    [Huawei] ap-address static ac-list 10.23.100.1
    [Huawei] quit
    <Huawei> reboot
    System will reboot! Continue ? [y/n]:y 

  5. Verify the configuration.

    # After the AP restarts, run the display ap all command on the AC to check the AP state. If the State field is displayed as nor, the AP goes online successfully.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    -------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime
    -------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.100 AP5030DN        nor   0   10S
    -------------------------------------------------------------------------------------
    Total: 1

Configuration Files

  • Switch configuration file

    #
     sysname Switch
    #
     vlan batch 100
    # 
     interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    # 
     interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • AC configuration file

    #
    sysname AC
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    capwap source interface vlanif100
    #
    wlan
     regulatory-domain-profile name default
     ap-group name ap-group1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90483

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next