No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring High-Density WLAN Services

Example for Configuring High-Density WLAN Services

Service Requirements

The WLAN of a stadium needs to provide access for a large number of users; therefore, APs are placed in close proximity, causing severe interference. The IT department of the stadium requires that the interference be eliminated to maximize Internet experience for users.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to assign IP addresses to APs.
    • The aggregation switch (SwitchB) functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: direct forwarding
Figure 4-57 Networking diagram for configuring a high-density WLAN

Data Planning

Table 4-55 Data planning

Item

Data

Management VLAN for APs

VLAN 10 and VLAN 100

Service VLAN for STAs

VLAN pool

  • Name: sta-pool

  • VLANs in the VLAN pool: VLAN 101 and VLAN 102

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs.

The aggregation switch (SwitchB) functions as a DHCP server to assign IP addresses to STAs.

IP address pool for APs

10.23.10.2-10.23.10.254/24

IP address pool for STAs

10.23.101.3-10.23.101.254/24

10.23.102.3-10.23.102.254/24

AC's source interface address

VLANIF 100: 10.23.100.1/24

AP group
  • Name: ap-group1

  • Referenced profiles: VAP profile wlan-net, regulatory domain profile default, 2G radio profile default, and 5G radio profile wlan-radio5g

Regulatory domain profile
  • Name: default

  • Country code: China

SSID profile
  • Name: wlan-net

  • SSID name: wlan-net

Security profile
  • Name: wlan-net

  • Security policy: WPA-WPA2+PSK+AES

  • Password: a1234567

VAP profile
  • Name: wlan-net

  • Forwarding mode: direct forwarding

  • Service VLAN: VLANs in the VLAN pool

  • Referenced profiles: SSID profile wlan-net, security profile wlan-net, and traffic profile wlan-traffic

RRM profile
  • Name: wlan-rrm

  • Airtime fair scheduling: enable
  • Smart roaming: enable
2G radio profile
  • Name: wlan-radio2g

  • Referenced profile: RRM profile wlan-rrm

5G radio profile
  • Name: wlan-radio5g

  • Referenced profile: RRM profile wlan-rrm

Traffic profile
  • Name: wlan-traffic

Configuration Roadmap

  1. Configure network interworking of the APs, AC, and other network devices.
  2. Configure the APs to go online.
    1. Create an AP group and add APs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the APs.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
  3. Configure WLAN service parameters for STAs to access the WLAN.
  4. Adjust WLAN high-density parameters.

    You are advised to adjust WLAN high-density parameters according to Table 4-56.

    Table 4-56 Adjustment recommendations

    Adjustment Item

    Purpose

    Recommendation

    Configure 5G-prior access

    To reduce the burden on the 2.4 GHz radio by preferentially connecting 5G-capable STAs to the 5 GHz radio when a large number of 2.4 GHz STAs exist on the network.

    Enable band steering. By default, band steering is enabled.

    Remove the limit on the number of access users

    To make an AP offer wireless services to more users.

    Increase the maximum number of access users to 128 for an SSID profile.

    Reduce the user association aging time

    To prevent users who frequently disconnect from the wireless network.

    Set the association aging time to 1 minute.

    User isolation

    To prevent mobile terminals from exchanging a large number of ARP packets.

    Enable user isolation on the AC.

    Limit user rates

    To prevent advantaged STAs from occupying too many rate sources and deteriorating service experience of disadvantaged STAs.

    Limit the downstream rate of each STA to 2000 kbit/s in a VAP. Adjust the upstream rate according to actual situations. In this example, the upstream rate is set to 1000 kbit/s.

    Adjust AP channel and power

    To reduce interference between APs.

    • Channel: Prevent adjacent APs from working on overlapping channels. It is recommended that you configure channels 1, 9, 5, and 13 in a high-density WLAN environment.
    • Power: Minimize AP power while ensuring that the RSSI is greater than -65 dBm at the edge of the AP's coverage area.

    Configure smart roaming

    To prevent weak-signal STAs from degrading user experience.

    Enable smart roaming and set the SNR threshold to 15 dB.

    Enable airtime fair scheduling

    To ensure that wireless channel resources can be equally allocated to users.

    Enable airtime fair scheduling.

    Set the RTS-CTS threshold

    To prevent hidden STAs.

    Set the RTS-CTS operation mode to rts-cts and the RTS threshold to 1400 bytes.

    Adjust the interval at which Beacon frames are sent

    To improve the overall data traffic of APs.

    Set the interval for sending Beacon frames to 160 ms.

    Adjust the transmit rate of 2.4 GHz Beacon frames

    To reduce wireless resource occupation of Beacon frames and improve channel usage efficiency.

    Set the transmit rate of 2.4 GHz Beacon frames to 11 Mbit/s.

    Set the guard interval (GI) mode to short GI

    To reduce extra overhead and improve AP transmission efficiency.

    Set the GI mode to short GI.

    Configure the basic rate set

    To improve the overall AP throughput.

    Delete low rates from the basic rate set.

    Configure the multicast rate

    To improve air interface efficiency.

    Use the default values. By default, the multicast transmit rate of wireless packets is 11 Mbit/s for the 2.4 GHz radio and 6 Mbit/s for the 5 GHz radio.

    Configure the short preamble for a radio

    To improve the network synchronization performance.

    Configure the short preamble. If some legacy NICs exist on the network, disable the short preamble function.

    Adjust EDCA parameters

    To improve user experience.

    Set the EDCA parameters of AC_BE packets as follows:
    • AP:
      • ecwmin: 5
      • ecwmax: 6
      • aifsn: 3
    • Client:
      • ecwmin: 7
      • ecwmax: 10
      • aifsn: 3
  5. Deliver WLAN services to the APs and verify the configuration.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA to VLANs 10, 101, and 102. The default VLAN of GE0/0/1 and GE0/0/3 is VLAN 10.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 10 101 102
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 10
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 10 101 102
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 10 101 102
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] port trunk pvid vlan 10
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 10 101 102
    [SwitchA-GigabitEthernet0/0/3] port-isolate enable
    [SwitchA-GigabitEthernet0/0/3] quit
    # On SwitchB (aggregation switch), add GE0/0/1 to VLAN 10, VLAN 101, and VLAN 102, GE0/0/2 to VLAN 100, and GE0/0/3 to VLAN 101 and VLAN 102. Create VLANIF 100 and set its IP address to 10.23.100.2/24.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 10 100 101 102
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 10 101 102
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101 102
    [SwitchB-GigabitEthernet0/0/3] quit
    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] ip address 10.23.100.2 24
    [SwitchB-Vlanif100] quit
    
    # On Router, add GE1/0/0 to VLAN 101 and VLAN 102. Create VLANIF 101 and VLANIF 102 and set the IP address of VLANIF 101 to 10.23.101.2/24 and the IP address of VLANIF 102 to 10.23.102.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101 102
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101 102
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    [Router] interface vlanif 102
    [Router-Vlanif102] ip address 10.23.102.2 24
    [Router-Vlanif102] quit
    

  2. Configure the AC to communicate with the network devices.

    # Add GE0/0/1 on the AC to VLAN 100 and create VLANIF 100.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan 100
    [AC-vlan100] quit
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] quit
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [AC-GigabitEthernet0/0/1] quit
    
    # Configure a route from the AC to the APs with the next hop as SwitchB's VLANIF 100.
    [AC] ip route-static 10.23.10.0 24 10.23.100.2
    

  3. Configure the DHCP services to assign IP addresses to APs and STAs.

    # On SwitchB, configure DHCP relay to assign IP addresses on behalf of the AC.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ip address 10.23.10.1 24
    [SwitchB-Vlanif10] dhcp select relay
    [SwitchB-Vlanif10] dhcp relay server-ip 10.23.100.1
    [SwitchB-Vlanif10] quit
    
    # On SwitchB, configure VLANIF 101 and VLANIF 102 to assign IP addresses to STAs and set the default gateways.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] quit
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] dhcp select interface
    [SwitchB-Vlanif102] dhcp server gateway-list 10.23.102.2
    [SwitchB-Vlanif102] quit
    
    # On the AC, create a global IP address pool to assign IP addresses to APs.
    [AC] dhcp enable
    [AC] ip pool huawei
    [AC-ip-pool-huawei] network 10.23.10.0 mask 24
    [AC-ip-pool-huawei] gateway-list 10.23.10.1
    [AC-ip-pool-huawei] option 43 sub-option 3 ascii 10.23.100.1
    [AC-ip-pool-huawei] quit
    [AC] interface vlanif 100
    [AC-Vlanif100] dhcp select global
    [AC-Vlanif100] quit
    

  4. Configure a VLAN pool for service VLANs.

    # On the AC, create a VLAN pool, add VLAN 101 and VLAN 102 to the pool, and set the VLAN assignment algorithm to hash in the VLAN pool.
    NOTE:

    This example uses the VLAN assignment algorithm hash (default) as an example. If the default setting is not changed before, you do not need to run the assignment hash command.

    In this example, only VLAN 101 and VLAN 102 are added to the VLAN pool. You can use the similar method to add multiple VLANs to a VLAN pool.

    [AC] vlan batch 101 102
    [AC] vlan pool sta-pool
    [AC-vlan-pool-sta-pool] vlan 101 102
    [AC-vlan-pool-sta-pool] assignment hash
    [AC-vlan-pool-sta-pool] quit
    

  5. Configure an AP to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    
    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online successfully.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    Extra information:
    P  : insufficient power supply
    --------------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime      ExtraInfo
    --------------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S         -
    --------------------------------------------------------------------------------------------------
    Total: 1

  6. Configure WLAN service parameters.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Create SSID profile wlan-net and set the SSID name to wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode direct-forward
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-pool sta-pool
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  7. Adjust WLAN high-density parameters.
    1. Adjust VAP profile parameters.

      # Enable the band steering function. By default, the band steering function is enabled.
      [AC-wlan-view] vap-profile name wlan-net
      [AC-wlan-net-prof-wlan-net] undo band-steer disable
      
      # Enable the broadcast flood detection function and set a broadcast flood threshold. By default, the broadcast flood detection function is enabled.
      [AC-wlan-net-prof-wlan-net] undo anti-attack broadcast-flood disable
      [AC-wlan-net-prof-wlan-net] quit

    2. Adjust SSID profile parameters.

      # Set the maximum number of STAs associated with a VAP to 128, association timeout period to 1 minute, EDCA parameters for AC_BE packets of STAs, and the transmit rate of 2.4 GHz Beacon frames to 11 Mbit/s.
      [AC-wlan-view] ssid-profile name wlan-net
      [AC-wlan-ssid-prof-wlan-net] max-sta-number 128
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-ssid-prof-wlan-net] association-timeout 1
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-ssid-prof-wlan-net] wmm edca-client ac-be aifsn 3 ecw ecwmin 7 ecwmax 10
      [AC-wlan-ssid-prof-wlan-net] beacon-2g-rate 11
      [AC-wlan-ssid-prof-wlan-net] quit
      

    3. Create a traffic profile and adjust traffic profile parameters.

      # Create traffic profile wlan-traffic and set the rate limit for upstream and downstream traffic to 4000 kbit/s.
      [AC-wlan-view] traffic-profile name wlan-traffic
      [AC-wlan-traffic-prof-wlan-traffic] rate-limit client down 4000
      [AC-wlan-traffic-prof-wlan-traffic] rate-limit client up 4000
      [AC-wlan-traffic-prof-wlan-traffic] quit
      
      # Bind the traffic profile to the VAP profile.
      [AC-wlan-view] vap-profile name wlan-net
      [AC-wlan-net-prof-wlan-net] traffic-profile wlan-traffic
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-net-prof-wlan-net] quit
      

    4. Create an RRM profile, enable airtime fair scheduling and smart roaming, and set the SNR-based threshold for smart roaming to 15 dB.

      [AC-wlan-view] traffic-profile name wlan-traffic
      [AC-wlan-rrm-prof-wlan-rrm] airtime-fair-schedule enable
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-rrm-prof-wlan-rrm] undo smart-roam disable
      [AC-wlan-rrm-prof-wlan-rrm] smart-roam roam-threshold check-snr
      [AC-wlan-rrm-prof-wlan-rrm] smart-roam roam-threshold snr 15
      [AC-wlan-rrm-prof-wlan-rrm] quit
      

    5. Create a 2G radio profile and adjust 2G radio profile parameters.

      Create 2G radio profile wlan-radio2g and set the parameters as follows:
      • Set the RTS-CTS operation mode to rts-cts and the RTS threshold to 1400 bytes.
      • Set the interval for sending Beacon frames to 160 TUs.
      • Enable the short preamble function. By default, the short preamble function is supported by a radio profile.
      • Set the GI mode to short GI.
      • Set the 802.11bg basic rate to 6 Mbit/s, 9 Mbit/s, 12 Mbit/s, 18 Mbit/s, 24 Mbit/s, 36 Mbit/s, 48 Mbit/s, or 54 Mbit/s.
      • Set the multicast rate to 11 Mbit/s.
      • Set EDCA parameters for AC_BE packets: AIFSN (3); ECWmin (5); ECWmax (6).
      [AC-wlan-view] radio-2g-profile name wlan-radio2g
      [AC-wlan-radio-2g-prof-wlan-radio2g] rts-cts-mode rts-cts
      [AC-wlan-radio-2g-prof-wlan-radio2g] rts-cts-threshold 1400
      [AC-wlan-radio-2g-prof-wlan-radio2g] beacon-interval 160
      [AC-wlan-radio-2g-prof-wlan-radio2g] undo short-preamble disable
      [AC-wlan-radio-2g-prof-wlan-radio2g] guard-interval-mode short
      [AC-wlan-radio-2g-prof-wlan-radio2g] dot11bg basic-rate 6 9 12 18 24 36 48 54
      [AC-wlan-radio-2g-prof-wlan-radio2g] multicast-rate 11
      [AC-wlan-radio-2g-prof-wlan-radio2g] wmm edca-ap ac-be aifsn 3 ecw ecwmin 5 ecwmax 6
      

      # Bind RRM profile wlan-rrm to the radio profile.

      [AC-wlan-radio-2g-prof-wlan-radio2g] rrm-profile wlan-rrm
      [AC-wlan-radio-2g-prof-wlan-radio2g] quit
      

    6. Create a 5G radio profile and adjust 5G radio profile parameters.

      Create 5G radio profile wlan-radio5g and set the parameters as follows:
      • Set the RTS-CTS operation mode to rts-cts and the RTS threshold to 1400 bytes.
      • Set the interval for sending Beacon frames to 160 TUs.
      • Set the GI mode to short GI.
      • Set the multicast rate to 6 Mbit/s.
      • Set EDCA parameters for AC_BE packets: AIFSN (3); ECWmin (5); ECWmax (6).
      [AC-wlan-view] radio-5g-profile name wlan-radio5g
      [AC-wlan-radio-5g-prof-wlan-radio5g] rts-cts-mode rts-cts
      [AC-wlan-radio-5g-prof-wlan-radio5g] rts-cts-threshold 1400
      [AC-wlan-radio-5g-prof-wlan-radio5g] beacon-interval 160
      [AC-wlan-radio-5g-prof-wlan-radio5g] guard-interval-mode short
      [AC-wlan-radio-5g-prof-wlan-radio5g] multicast-rate 6
      [AC-wlan-radio-5g-prof-wlan-radio5g] wmm edca-ap ac-be aifsn 3 ecw ecwmin 5 ecwmax 6
      

      # Bind RRM profile wlan-rrm to the radio profile.

      [AC-wlan-radio-5g-prof-wlan-radio5g] rrm-profile wlan-rrm
      [AC-wlan-radio-5g-prof-wlan-radio5g] quit
      

    7. Enter the AP group ap-group1 and bind it to the radio profiles.

      [AC-wlan-view] ap-group name ap-group1
      [AC-wlan-ap-group-ap-group1] radio-2g-profile wlan-radio2g radio 0
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-ap-group-ap-group1] radio-5g-profile wlan-radio5g radio 1
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-ap-group-ap-group1] quit

  8. Configure the AP channel and power.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The settings of the AP channel and power in this example are for reference only. You need to configure the AP channel and power based on the actual country code and network planning.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] calibrate auto-channel-select disable
    [AC-wlan-radio-0/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] calibrate auto-channel-select disable
    [AC-wlan-radio-0/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  9. Verify the configuration.

    WLAN service configuration is automatically delivered to the APs. After the service configuration is complete, run the display vap ssid wlan-net command. If Status in the command output displays as ON, the VAPs have been successfully created on AP radios.

    [AC-wlan-view] display vap ssid wlan-net
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID   BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1     60DE-4476-E360 ON      WPA/WPA2-PSK  0     wlan-net
    0     area_1  1    1     60DE-4476-E370 ON      WPA/WPA2-PSK  0     wlan-net
    -------------------------------------------------------------------------------
    Total: 2

    Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station ssid wlan-net command on the AC. The command output shows that the STAs are connected to the WLAN wlan-net.

    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ---------------------------------------------------------------------------------
    STA MAC         AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ---------------------------------------------------------------------------------
    e019-1dc7-1e08  0     area_1    1/1      5G    11n   46/59      -68   101   10.23.101.254
    ---------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1

    When a large number of users connect to the network in the stadium, the users still have good Internet experience.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 10 101 to 102
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10 101 to 102
     port-isolate enable
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 101 to 102
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10 101 to 102
     port-isolate enable
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 10 100 to 102
    #
    dhcp enable
    #
    interface Vlanif10
     ip address 10.23.10.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.23.100.1
    #
    interface Vlanif100
     ip address 10.23.100.2 255.255.255.0
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
     dhcp server gateway-list 10.23.101.2
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
     dhcp select interface
     dhcp server gateway-list 10.23.102.2
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 101 to 102
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 101 to 102
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    vlan batch 101 to 102
    #
    interface Vlanif101
     ip address 10.23.101.2 255.255.255.0
    #
    interface Vlanif102
     ip address 10.23.102.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 102
    #
    return
    
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 102
    #
    vlan pool sta-pool
     vlan 101 to 102
    #
    dhcp enable
    #
    ip pool huawei
     gateway-list 10.23.10.1
     network 10.23.10.0 mask 255.255.255.0
     option 43 sub-option 3 ascii 10.23.100.1
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    ip route-static 10.23.10.0 24 10.23.100.2
    #
    capwap source interface vlanif100
    #
    wlan
     traffic-profile name wlan-traffic
      rate-limit client up 4000
      rate-limit client down 4000 
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#wQ}eV*m'Y#f6Mj@h#DxTLrKaYm|)pBm@w$(jpeqE%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
      association-timeout 1
      max-sta-number 128
      wmm edca-client ac-be aifsn 3 ecw ecwmin 7 ecwmax 10 txoplimit 0
      beacon-2g-rate 11
     vap-profile name wlan-net
      service-vlan vlan-pool sta-pool
      ssid-profile wlan-net
      security-profile wlan-net
      traffic-profile wlan-traffic
      anti-attack broadcast-flood sta-rate-threshold 50
     regulatory-domain-profile name default
     rrm-profile name wlan-rrm
      airtime-fair-schedule enable
      smart-roam roam-threshold snr 15
     radio-2g-profile name wlan-radio2g
      dot11bg basic-rate 6 9 12 18 24 36 48 54
      beacon-interval 160
      guard-interval-mode short
      multicast-rate 11
      wmm edca-ap ac-be aifsn 3 ecw ecwmin 5 ecwmax 6 txoplimit 0 ack-policy normal
      rrm-profile wlan-rrm
      rts-cts-threshold 1400
      rts-cts-mode rts-cts
     radio-5g-profile name wlan-radio5g
      beacon-interval 160
      guard-interval-mode short
      wmm edca-ap ac-be aifsn 3 ecw ecwmin 5 ecwmax 6 txoplimit 0 ack-policy normal
      multicast-rate 6
      rrm-profile wlan-rrm
      rts-cts-threshold 1400
      rts-cts-mode rts-cts
     ap-group name ap-group1
      radio 0
       radio-2g-profile wlan-radio2g
       vap-profile wlan-net wlan 1
      radio 1
       radio-5g-profile wlan-radio5g
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 60 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
      radio 1
       channel 20mhz 149
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 91347

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next