No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Intra-VLAN Roaming

Example for Configuring Intra-VLAN Roaming

Service Requirements

Enterprise users can access the network through WLANs, which is the basic requirement of mobile office. Furthermore, users' services are not affected during roaming in the coverage area.

Networking Requirement

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to assign IP addresses to APs.
    • The aggregation switch (SwitchB) functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: tunnel forwarding
Figure 4-52 Networking for configuring intra-VLAN roaming

Data Planning

Table 4-50 AC data planning

Item

Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs.

SwitchB functions as a DHCP server to assign IP addresses to STAs. The default gateway address of STAs is 10.23.101.2.

IP address pool for APs 10.23.100.2-10.23.100.254/24
IP address pool for STAs 10.23.101.3-10.23.101.254/24
AC's source interface address VLANIF 100: 10.23.100.1/24
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profile wlan-net, regulatory domain profile default, 2G radio profile wlan-radio2g, and 5G radio profile wlan-radio5g
Regulatory domain profile
  • Name: default
  • Country code: CN
  • Calibration channel set: calibration bandwidth and channels for 2.4 GHz and 5 GHz radios
SSID profile
  • Name: wlan-net
  • SSID name: wlan-net
Security profile
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES
  • Password: a1234567
VAP profile
  • Name: wlan-net
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

Air scan profile

  • Name: wlan-airscan

  • Probe channel set: calibration channels

  • Air scan interval: 60000 ms

  • Air scan period: 60 ms

2G radio profile

  • Name: wlan-radio2g

  • Referenced profiles: air scan profile wlan-airscan

5G radio profile

  • Name: wlan-radio5g

  • Referenced profiles: air scan profile wlan-airscan

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Configure the APs to go online.
    1. Create an AP group and add APs that require the same configuration to the group for unified configuration.
    2. Configure AC system parameters, including the country code and source interface used by the AC to communicate with the APs.
    3. Configure the AP authentication mode and import the APs offline to allow the APs to go online.
  3. Configure WLAN service parameters for STAs to access the WLAN.
NOTE:

During AP deployment, you can manually specify the working channels of the APs according to network planning situations or configure the radio calibration function to enable the APs to automatically select the optimal channels.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1, GE0/0/2, and GE0/0/3 on SwitchA to VLAN 100. The default VLAN of GE0/0/1 and GE0/0/3 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface gigabitethernet 0/0/3
    [SwitchA-GigabitEthernet0/0/3] port link-type trunk
    [SwitchA-GigabitEthernet0/0/3] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/3] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/3] port-isolate enable
    [SwitchA-GigabitEthernet0/0/3] quit
    # Add GE0/0/1 and GE0/0/2 on SwitchB (aggregation switch) to VLAN 100, and GE0/0/2 and GE0/0/3 to VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 101
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101
    [SwitchB-GigabitEthernet0/0/3] quit
    
    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Configure the AC to communicate with the network devices.

    NOTE:

    If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.

    # Add GE0/0/1 on the AC to VLAN 100 and VLAN 101.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [AC-GigabitEthernet0/0/1] quit
    

  3. Configure the DHCP servers to assign IP addresses to APs and STAs.

    # On the AC, configure VLANIF 100 to assign IP addresses to APs.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    
    # On SwitchB, configure VLANIF 101 to assign IP addresses to STAs and set the default gateway address of STAs to 10.23.101.2.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] quit
    

  4. Configure an AP to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    
    [AC] wlan
    [AC-wlan-view] ap-id 1 ap-mac dcd2-fc04-b500
    [AC-wlan-ap-1] ap-name area_2
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-1] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-1] quit
    
    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online successfully.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [2]
    Extra information:
    P  : insufficient power supply
    --------------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime      ExtraInfo
    --------------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   15S         -
    1    dcd2-fc04-b500 area_2 ap-group1 10.23.100.253 AP5030DN        nor   0   10S         -
    --------------------------------------------------------------------------------------------------
    Total: 2

  5. Configure WLAN service parameters.

    # Create security profile wlan-net and set the security policy in the profile.
    NOTE:

    In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

    [AC-wlan-view] security-profile name wlan-net
    [AC-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC-wlan-sec-prof-wlan-net] quit
    
    # Create SSID profile wlan-net and set the SSID name to wlan-net.
    [AC-wlan-view] ssid-profile name wlan-net
    [AC-wlan-ssid-prof-wlan-net] ssid wlan-net
    [AC-wlan-ssid-prof-wlan-net] quit
    
    # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.
    [AC-wlan-view] vap-profile name wlan-net
    [AC-wlan-vap-prof-wlan-net] forward-mode tunnel
    [AC-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
    [AC-wlan-vap-prof-wlan-net] security-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] ssid-profile wlan-net
    [AC-wlan-vap-prof-wlan-net] quit
    
    # Bind VAP profile wlan-net to the AP group and apply the profile to radio 0 and radio 1 of the AP.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  6. Set channels and power for the AP radios.

    # Enable automatic channel and power calibration functions of the radio.
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] radio 0
    [AC-wlan-group-radio-ap-group1/0] undo calibrate auto-channel-select disable
    [AC-wlan-group-radio-ap-group1/0] undo calibrate auto-txpower-select disable
    [AC-wlan-group-radio-ap-group1/0] quit
    [AC-wlan-ap-group-ap-group1] radio 1
    [AC-wlan-group-radio-ap-group1/1] undo calibrate auto-channel-select disable
    [AC-wlan-group-radio-ap-group1/1] undo calibrate auto-txpower-select disable
    [AC-wlan-group-radio-ap-group1/1] quit
    [AC-wlan-ap-group-ap-group1] quit
    # Configure a calibration channel set in the regulatory domain profile.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] dca-channel 2.4g channel-set 1,6,11
    [AC-wlan-regulate-domain-default] dca-channel 5g bandwidth 20mhz
    [AC-wlan-regulate-domain-default] dca-channel 5g channel-set 149,153,157,161
    [AC-wlan-regulate-domain-default] quit
    

    # Create the air scan profile wlan-airscan and configure the scan channel set, scan interval, and scan duration.

    [AC-wlan-view] air-scan-profile name wlan-airscan
    [AC-wlan-air-scan-prof-wlan-airscan] scan-channel-set dca-channel
    [AC-wlan-air-scan-prof-wlan-airscan] scan-period 60
    [AC-wlan-air-scan-prof-wlan-airscan] scan-interval 60000
    [AC-wlan-air-scan-prof-wlan-airscan] quit

    # Create the 2G radio profile wlan-radio2g and bind the air scan profile wlan-airscan to the 2G radio profile.

    [AC-wlan-view] radio-2g-profile name wlan-radio2g 
    [AC-wlan-radio-2g-prof-wlan-radio2g] air-scan-profile wlan-airscan
    [AC-wlan-radio-2g-prof-wlan-radio2g] quit

    # Create the 5G radio profile wlan-radio5g and bind the air scan profile wlan-airscan to the 5G radio profile.

    [AC-wlan-view] radio-5g-profile name wlan-radio5g 
    [AC-wlan-radio-5g-prof-wlan-radio5g] air-scan-profile wlan-airscan
    [AC-wlan-radio-5g-prof-wlan-radio5g] quit

    # Bind the 5G radio profile wlan-radio5g and 2G radio profile wlan-radio2g to the AP group ap-group1.

    [AC-wlan-view] ap-group name ap-group1 
    [AC-wlan-ap-group-ap-group1] radio-5g-profile wlan-radio5g radio 1
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-ap-group1] radio-2g-profile wlan-radio2g radio 0
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-ap-group-ap-group1] quit

    # Set the radio calibration mode to manual and trigger radio calibration.

    [AC-wlan-view] calibrate enable manual
    [AC-wlan-view] calibrate manual startup
    # Radio calibration stops one hour after the radio calibration is manually triggered. Set the radio calibration mode to scheduled. Configure the APs to perform radio calibration in off-peak hours, for example, between 00:00 am and 06:00 am.
    [AC-wlan-view] calibrate enable schedule time 03:00:00

  7. Verify the configuration.

    The AC automatically delivers WLAN service configuration to the AP. After the service configuration is complete, run the display vap ssid wlan-net command. If Status in the command output is displayed as ON, the VAPs have been successfully created on AP radios.

    [AC-wlan-view] display vap ssid wlan-net
    Info: This operation may take a few seconds, please wait.
    WID : WLAN ID
    --------------------------------------------------------------------------------
    AP ID AP name RfID WID     BSSID          Status  Auth type     STA   SSID
    --------------------------------------------------------------------------------
    0     area_1  0    1       60DE-4476-E360 ON      WPA/WPA2-PSK  0     wlan-net
    0     area_1  1    1       60DE-4476-E370 ON      WPA/WPA2-PSK  0     wlan-net
    1     area_2  0    1       60DE-4474-9640 ON      WPA/WPA2-PSK  0     wlan-net
    1     area_2  1    1       60DE-4474-9650 ON      WPA/WPA2-PSK  0     wlan-net
    -------------------------------------------------------------------------------
    Total: 4

    Connect STAs to the WLAN with SSID wlan-net and enter the password a1234567. Run the display station ssid wlan-net command on the AC. The command output shows that the STAs are connected to the WLAN wlan-net.

    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID
    Rx/Tx: link receive rate/link transmit rate(Mbps)
    ---------------------------------------------------------------------------------
    STA MAC         AP ID Ap name   Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
    ---------------------------------------------------------------------------------
    e019-1dc7-1e08  0     area_1    1/1      5G    11n   46/59      -68   101   10.23.101.254
    ---------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1
    When the STA moves from the coverage area of AP_1 to that of AP_2, run the display station ssid wlan-net command on AC. The command output shows that the STA has associated with AP_2.
    [AC-wlan-view] display station ssid wlan-net
    Rf/WLAN: Radio ID/WLAN ID                                                     
    Rx/Tx: link receive rate/link transmit rate(Mbps)                             
    ----------------------------------------------------------------------------------------
    STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address     
    ----------------------------------------------------------------------------------------
    e019-1dc7-1e08   1     area_2   1/1      5G    11n   46/59      -58   101   10.23.101.254
    ----------------------------------------------------------------------------------------
    Total: 1 2.4G: 0 5G: 1
    Run the display station roam-track sta-mac e019-1dc7-1e08 command on AC to check the STA roaming track.
    [AC-wlan-view] display station roam-track sta-mac e019-1dc7-1e08
    Access SSID:wlan-net    
    Rx/Tx:link receive rate/link transmit rate(Mbps) 
    c:PMK Cache Roam r:802.11r Roam s:Same Frequency Network
    ------------------------------------------------------------------------------
    L2/L3           AC IP                  AP name              Radio ID
    BSSID           TIME                   In/Out RSSI          Out Rx/Tx
    ------------------------------------------------------------------------------
    --              10.23.100.1            area_1               1
    60DE-4476-E370  2016/01/12 16:52:58    -51/-48              46/13
    L2              10.23.100.1            area_2               1
    60DE-4474-9650  2016/01/12 16:55:45    -58/-                -/-
    ------------------------------------------------------------------------------
    Number: 1

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
     dhcp server gateway-list 10.23.101.2
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    vlan batch 101
    #
    interface Vlanif101
     ip address 10.23.101.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    return
    
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 101
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    capwap source interface vlanif100
    #
    wlan
     calibrate enable schedule time 03:00:00
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
      dca-channel 5g channel-set 149,153,157,161
     air-scan-profile name wlan-airscan
      scan-channel-set dca-channel
     radio-2g-profile name wlan-radio2g
      air-scan-profile wlan-airscan 
     radio-5g-profile name wlan-radio5g
      air-scan-profile wlan-airscan 
     ap-group name ap-group1
      radio 0
       radio-2g-profile wlan-radio2g
       vap-profile wlan-net wlan 1
      radio 1
       radio-5g-profile wlan-radio5g 
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
     ap-id 1 type-id 35 ap-mac 60de-4474-9640 ap-sn 210235419610D2000097
      ap-name area_2
      ap-group ap-group1
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90241

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next