No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring N+1 Backup (APs and ACs in the same network segment)

Example for Configuring N+1 Backup (APs and ACs in the same network segment)

Service Requirements

In public places where a large number of users exist in a large area, many APs are deployed and managed by multiple ACs to provide free-of-charge WLAN access services. These services are value-added services that require low network reliability and allow temporary service interruption. An AC is required to be a backup of all ACs to save costs. To meet this requirement, build an N+1 backup wireless LAN to provide reliable services and reduce device purchase costs. ACs of different models can work in N+1 backup mode, but versions of the ACs must be the same.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: Switch_1 functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 4-50 Networking for configuring N+1 backup

Data Planning

Table 4-48 AC data planning
Item Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

VLAN 102

DHCP server

Switch_1 functions as a DHCP server to assign IP addresses to APs and STAs.

STAs' gateway:
  • 10.23.101.1/24
  • 10.23.102.1/24

APs' gateway: 10.23.100.1/24

IP address pool for APs

10.23.100.5-10.23.100.254/24

IP address pool for STAs

STA1: 10.23.101.3-10.23.101.254/24

STA2: 10.23.102.3-10.23.102.254/24

AC's source interface

VLANIF 100

AC_1's management IP address

VLANIF 100: 10.23.100.2/24

AC_2's management IP address

VLANIF 100: 10.23.100.3/24

AC_3's management IP address

VLANIF 100: 10.23.100.4/24

AP group

AC_1 (active AC):
  • Name: ap-group1

  • Referenced profiles: AP system profile ap-system, VAP profile wlan-net, and regulatory domain profile default

AC_2 (active AC):
  • Name: ap-group2

  • Referenced profiles: AP system profile ap-system1, VAP profile wlan-net1, and regulatory domain profile default

AC_3 (standby AC):
  • Name: ap-group1
    • Referenced profiles: AP system profile ap-system, VAP profile wlan-net, and regulatory domain profile default

  • Name: ap-group2
    • Referenced profiles: AP system profile ap-system1, VAP profile wlan-net1, and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: China

SSID profile

AC_1:
  • Name: wlan-net

  • SSID name: wlan-net

AC_2:
  • Name: wlan-net1

  • SSID name: wlan-net1

AC_3:
  • Names: wlan-net and wlan-net1

  • SSID names: wlan-net and wlan-net1

Security profile

AC_1:
  • Name: wlan-net
  • Security policy: WPA-WPA2+PSK+AES

  • Password: a1234567

AC_2:
  • Name: wlan-net1
  • Security policy: WPA-WPA2+PSK+AES

  • Password: a1234567

AC_3:
  • Name: wlan-net
    • Security policy: WPA-WPA2+PSK+AES

    • Password: a1234567

  • Name: wlan-net1
    • Security policy: WPA-WPA2+PSK+AES

    • Password: a1234567

VAP profile

AC_1:
  • Name: wlan-net
  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 101

  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

AC_1:
  • Name: wlan-net1
  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 102

  • Referenced profiles: SSID profile wlan-net1 and security profile wlan-net1

AC_3:
  • Name: wlan-net
    • Forwarding mode: direct forwarding

    • Service VLAN: VLAN 101

    • Referenced profiles: SSID profile wlan-net and security profile wlan-net

  • Name: wlan-net1
    • Forwarding mode: direct forwarding

    • Service VLAN: VLAN 102

    • Referenced profiles: SSID profile wlan-net1 and security profile wlan-net1

AP system profile

  • AC_1: ap-system
  • AC_2: ap-system1
  • AC_3: ap-system and ap-system1

Global priority

AC_1: 6

AC_2: 6

AC_3: 5

Individual priority

AP1: 3

AP2: 3

Configuration Roadmap

  1. Configure network interworking of each AC and other network devices. Configure Switch_1 as a DHCP server to assign IP addresses to APs and STAs.
  2. Configure AC_1 and AC_2 as the active ACs of AP_1 and AP_2 respectively, and configure basic WLAN services on AC_1 and AC_2.
  3. Configure AC_3 as the standby AC and configure basic WLAN services on AC_3. Ensure that service configurations on AC_3 are the same as those on AC_1 and AC_2.
  4. Configure N+1 backup on the active ACs first and then on the standby AC. When N+1 backup is enabled, all APs are restarted.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the switches and ACs to enable the ACs to communicate with the APs.

    # On Switch_1, create VLAN 100, VLAN 101, and VLAN 102. Configure VLAN 100 as the management VLAN, VLAN 101 and VLAN 102 as service VLANs. Add GE0/0/1 connected to AC_1 to VLAN 100 and VLAN 101, GE0/0/2 connected to AC_2 to VLAN 100 and VLAN 102, GE0/0/3 and GE0/0/4 respectively connected to AC_3 and Switch_2 to VLAN 100, VLAN 101, and VLAN 102.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_1
    [Switch_1] vlan batch 100 to 102
    [Switch_1] interface gigabitethernet 0/0/1
    [Switch_1-GigabitEthernet0/0/1] port link-type trunk
    [Switch_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch_1-GigabitEthernet0/0/1] quit
    [Switch_1] interface gigabitethernet 0/0/2
    [Switch_1-GigabitEthernet0/0/2] port link-type trunk
    [Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [Switch_1-GigabitEthernet0/0/2] quit
    [Switch_1] interface gigabitethernet 0/0/3
    [Switch_1-GigabitEthernet0/0/3] port link-type trunk
    [Switch_1-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 to 102
    [Switch_1-GigabitEthernet0/0/3] quit
    [Switch_1] interface gigabitethernet 0/0/4
    [Switch_1-GigabitEthernet0/0/4] port link-type trunk
    [Switch_1-GigabitEthernet0/0/4] port trunk allow-pass vlan 100 to 102
    [Switch_1-GigabitEthernet0/0/4] quit
    

    # On Switch_2, add GE0/0/3 connected to Switch_1 to VLAN 100, VLAN 101, and VLAN 102, GE0/0/1 connected to AP_1 to VLAN 100 and VLAN 101, and GE0/0/2 connected to AP_2 to VLAN 100 and VLAN 102. Set the PVID of GE0/0/1 and GE0/0/2 to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname Switch_2
    [Switch_2] vlan batch 100 to 102
    [Switch_2] interface gigabitethernet 0/0/1
    [Switch_2-GigabitEthernet0/0/1] port link-type trunk
    [Switch_2-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [Switch_2-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [Switch_2-GigabitEthernet0/0/1] port-isolate enable
    [Switch_2-GigabitEthernet0/0/1] quit
    [Switch_2] interface gigabitethernet 0/0/2
    [Switch_2-GigabitEthernet0/0/2] port link-type trunk
    [Switch_2-GigabitEthernet0/0/2] port trunk pvid vlan 100
    [Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 102
    [Switch_2-GigabitEthernet0/0/2] port-isolate enable
    [Switch_2-GigabitEthernet0/0/2] quit
    [Switch_2] interface gigabitethernet 0/0/3
    [Switch_2-GigabitEthernet0/0/3] port link-type trunk
    [Switch_2-GigabitEthernet0/0/3] port trunk allow-pass vlan 100 to 102
    [Switch_2-GigabitEthernet0/0/3] quit
    

    # On AC_1, add GE0/0/1 connected to Switch_1 to VLAN 100 and VLAN 101.

    <AC6605> system-view
    [AC6605] sysname AC_1
    [AC_1] vlan batch 100 101
    [AC_1] interface gigabitethernet 0/0/1
    [AC_1-GigabitEthernet0/0/1] port link-type trunk
    [AC_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 101
    [AC_1-GigabitEthernet0/0/1] quit
    [AC_1] interface vlanif 100
    [AC_1-Vlanif100] ip address 10.23.100.2 255.255.255.0
    [AC_1-Vlanif100] quit
    

    # On AC_2, add GE0/0/1 connected to Switch_1 to VLAN 100 and VLAN 102.

    <AC6605> system-view
    [AC6605] sysname AC_2
    [AC_2] vlan batch 100 102
    [AC_2] interface gigabitethernet 0/0/1
    [AC_2-GigabitEthernet0/0/1] port link-type trunk
    [AC_2-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 102
    [AC_2-GigabitEthernet0/0/1] quit
    [AC_2] interface vlanif 100
    [AC_2-Vlanif100] ip address 10.23.100.3 255.255.255.0
    [AC_2-Vlanif100] quit
    

    # On AC_3, add GE0/0/1 connected to Switch_1 to VLAN 100, VLAN 101, and VLAN 102.

    <AC6605> system-view
    [AC6605] sysname AC_3
    [AC_3] vlan batch 100 to 102
    [AC_3] interface gigabitethernet 0/0/1
    [AC_3-GigabitEthernet0/0/1] port link-type trunk
    [AC_3-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 to 102
    [AC_3-GigabitEthernet0/0/1] quit
    [AC_3] interface vlanif 100
    [AC_3-Vlanif100] ip address 10.23.100.4 255.255.255.0
    [AC_3-Vlanif100] quit
    

  2. Configure Switch_1 as a DHCP server to assign IP addresses to STAs and APs. Switch_1 allocates IP addresses to APs from the IP address pool on VLANIF 100, and allocates IP addresses to STA_1 and STA_2 from the IP address pool on VLANIF 101 and VLANIF 102 respectively.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [Switch_1] dhcp enable
    [Switch_1] interface vlanif 100
    [Switch_1-Vlanif100] ip address 10.23.100.1 255.255.255.0
    [Switch_1-Vlanif100] dhcp select interface
    [Switch_1-Vlanif100] dhcp server excluded-ip-address 10.23.100.2 10.23.100.4
    [Switch_1-Vlanif100] quit
    [Switch_1] interface vlanif 101
    [Switch_1-Vlanif101] ip address 10.23.101.1 255.255.255.0
    [Switch_1-Vlanif101] dhcp select interface
    [Switch_1-Vlanif101] quit
    [Switch_1] interface vlanif 102
    [Switch_1-Vlanif102] ip address 10.23.102.1 255.255.255.0
    [Switch_1-Vlanif102] dhcp select interface
    [Switch_1-Vlanif102] quit
    

  3. Configure basic WLAN services on AC_1.
    1. Configure the APs to go online.

      # Create an AP group to which the APs with the same configuration can be added.

      [AC_1] wlan
      [AC_1-wlan-view] ap-group name ap-group1
      [AC_1-wlan-ap-group-ap-group1] quit
      

      # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

      [AC_1-wlan-view] regulatory-domain-profile name default
      [AC_1-wlan-regulate-domain-default] country-code cn
      [AC_1-wlan-regulate-domain-default] quit
      [AC_1-wlan-view] ap-group name ap-group1
      [AC_1-wlan-ap-group-ap-group1] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC_1-wlan-ap-group-ap-group1] quit
      [AC_1-wlan-view] quit
      

      # Configure the AC's source interface.

      [AC_1] capwap source interface vlanif 100
      
      # Import the APs offline on the AC and add the APs to the AP group ap-group1. In this example, the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is located. For example, if the AP with MAC address 60de-4476-e360 is deployed in area 1, name the AP area_1.
      NOTE:

      The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

      In this example, the AP5030DN is used and has two radios: radio 0 and radio 1.

      [AC_1] wlan
      [AC_1-wlan-view] ap auth-mode mac-auth
      [AC_1-wlan-view] ap-id 0 ap-mac 60de-4476-e360
      [AC_1-wlan-ap-0] ap-name area_1
      [AC_1-wlan-ap-0] ap-group ap-group1
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC_1-wlan-ap-0] quit
      

      # After the APs are powered on, run the display ap all command to check the AP state. If the State field displays nor, the APs have gone online.

      [AC_1-wlan-view] display ap all
      Total AP information:
      nor  : normal          [1]
      Extra information:
      P  : insufficient power supply
      --------------------------------------------------------------------------------------------------
      ID   MAC            Name   Group     IP            Type            State STA Uptime      ExtraInfo
      --------------------------------------------------------------------------------------------------
      0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S         -
      --------------------------------------------------------------------------------------------------
      Total: 1

    2. Configure WLAN service parameters.

      # Create security profile wlan-net and set the security policy in the profile.
      NOTE:

      In this example, the security policy is set to WPA-WPA2+PSK+AES and password to a1234567. In actual situations, the security policy must be configured according to service requirements.

      [AC_1-wlan-view] security-profile name wlan-net
      [AC_1-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
      [AC_1-wlan-sec-prof-wlan-net] quit
      

      # Create SSID profile wlan-net and set the SSID name to wlan-net.

      [AC_1-wlan-view] ssid-profile name wlan-net
      [AC_1-wlan-ssid-prof-wlan-net] ssid wlan-net
      [AC_1-wlan-ssid-prof-wlan-net] quit
      

      # Create AP system profile ap-system and configure the AP's individual priority.

      [AC_1-wlan-view] ap-system-profile name ap-system
      [AC_1-wlan-ap-system-prof-ap-system] priority 3
      Warning: This action will take effect after resetting AP.
      [AC_1-wlan-ap-system-prof-ap-system] quit
      

      # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

      [AC_1-wlan-view] vap-profile name wlan-net
      [AC_1-wlan-vap-prof-wlan-net] forward-mode direct-forward
      [AC_1-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
      [AC_1-wlan-vap-prof-wlan-net] security-profile wlan-net
      [AC_1-wlan-vap-prof-wlan-net] ssid-profile wlan-net
      [AC_1-wlan-vap-prof-wlan-net] quit
      

      # Bind the VAP profile and AP system profile to the AP group and apply the VAP profile wlan-net to radio 0 and radio 1 of the APs.

      [AC_1-wlan-view] ap-group name ap-group1
      [AC_1-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
      [AC_1-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
      [AC_1-wlan-ap-group-ap-group1] ap-system-profile ap-system
      [AC_1-wlan-ap-group-ap-group1] quit
      

  4. Configure basic WLAN services and AP priority for AC_2.

    # Configure basic parameters for AC_2 according to the configurations of AC_1.

    # Configure the source interface of AC_2.

    [AC_2] capwap source interface vlanif 100
    [AC_2] wlan
    

    # Create AP group ap-group2.

    [AC_2-wlan-view] ap-group name ap-group2
    [AC_2-wlan-ap-group-ap-group2] quit
    

    # Import the APs offline on the AC and add the APs to the AP group ap-group2. In this example, the AP's MAC address is 60de-4474-9640. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is located. For example, if the AP with MAC address 60de-4474-9640 is deployed in area 2, name the AP area_2.

    [AC_2-wlan-view] ap auth-mode mac-auth
    [AC_2-wlan-view] ap-id 1 ap-mac 60de-4474-9640
    [AC_2-wlan-ap-1] ap-name area_2
    [AC_2-wlan-ap-1] ap-group ap-group2
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC_2-wlan-ap-1] quit
    

    # Create security profile wlan-net1 and set the security policy in the profile.

    [AC_2-wlan-view] security-profile name wlan-net1
    [AC_2-wlan-sec-prof-wlan-net1] security wpa-wpa2 psk pass-phrase a1234567 aes
    [AC_2-wlan-sec-prof-wlan-net1] quit
    

    # Create an SSID profile and set the SSID name to wlan-net1.

    [AC_2-wlan-view] ssid-profile name wlan-net1
    [AC_2-wlan-ssid-prof-wlan-net1] ssid wlan-net1
    [AC_2-wlan-ssid-prof-wlan-net1] quit
    

    # Create AP system profile ap-system1 and configure the AP priority.

    [AC_2-wlan-view] ap-system-profile name ap-system1
    [AC_2-wlan-ap-system-prof-ap-system1] priority 3
    Warning: This action will take effect after resetting AP.
    [AC_2-wlan-ap-system-prof-ap-system1] quit
    

    # Create VAP profile wlan-net1, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

    [AC_2-wlan-view] vap-profile name wlan-net1
    [AC_2-wlan-vap-prof-wlan-net1] forward-mode direct-forward
    [AC_2-wlan-vap-prof-wlan-net1] service-vlan vlan-id 102
    [AC_2-wlan-vap-prof-wlan-net1] security-profile wlan-net1
    [AC_2-wlan-vap-prof-wlan-net1] ssid-profile wlan-net1
    [AC_2-wlan-vap-prof-wlan-net1] quit
    

    # Bind the VAP profile and AP system profile to the AP group and apply the VAP profile wlan-net1 to radio 0 and radio 1 of the APs.

    [AC_2-wlan-view] ap-group name ap-group2
    [AC_2-wlan-ap-group-ap-group2] vap-profile wlan-net1 wlan 1 radio 0
    [AC_2-wlan-ap-group-ap-group2] vap-profile wlan-net1 wlan 1 radio 1
    [AC_2-wlan-ap-group-ap-group2] ap-system-profile ap-system1
    [AC_2-wlan-ap-group-ap-group2] quit
    

    # Set other parameters similarly as those of AC_1.

  5. Configure basic WLAN services on AC_3.
    1. Configure the APs to go online.

      # Create an AP group to which the APs with the same configuration can be added.

      [AC_3] wlan
      [AC_3-wlan-view] ap-group name ap-group1
      [AC_3-wlan-ap-group-ap-group1] quit
      [AC_3-wlan-view] ap-group name ap-group2
      [AC_3-wlan-ap-group-ap-group2] quit
      

      # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

      [AC_3-wlan-view] regulatory-domain-profile name default
      [AC_3-wlan-regulate-domain-default] country-code cn
      [AC_3-wlan-regulate-domain-default] quit
      [AC_3-wlan-view] ap-group name ap-group1
      [AC_3-wlan-ap-group-ap-group1] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC_3-wlan-ap-group-ap-group1] quit
      [AC_3-wlan-view] ap-group name ap-group2
      [AC_3-wlan-ap-group-ap-group2] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC_3-wlan-ap-group-ap-group2] quit
      [AC_3-wlan-view] quit
      

      # Configure the AC's source interface.

      [AC_3] capwap source interface vlanif 100
      
      NOTE:

      The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

      [AC_3] wlan
      [AC_3-wlan-view] ap auth-mode mac-auth
      [AC_3-wlan-view] ap-id 0 ap-mac 60de-4476-e360
      [AC_3-wlan-ap-0] ap-name area_1
      [AC_3-wlan-ap-0] ap-group ap-group1
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC_3-wlan-ap-0] quit
      [AC_3-wlan-view] ap-id 1 ap-mac 60de-4474-9640
      [AC_3-wlan-ap-1] ap-name area_2
      [AC_3-wlan-ap-1] ap-group ap-group2
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC_3-wlan-ap-1] quit
      

      # After the APs are powered on, run the display ap all command to check the AP state. The command output shows that the status of the APs is both fault.

      [AC_3-wlan-view] display ap all
      Total AP information:
      fault  : fault          [2]
      Extra information:
      P  : insufficient power supply
      ----------------------------------------------------------------------------------------------------
      ID   MAC            Name   Group     IP            Type            State STA Uptime    ExtraInfo
      ----------------------------------------------------------------------------------------------------
      0    60de-4476-e360 area_1 ap-group1 -             AP5030DN        fault 0   -         -
      1    60de-4474-9640 area_2 ap-group2 -             AP5030DN        fault 0   -         -
      ----------------------------------------------------------------------------------------------------
      Total: 2

    2. Configure WLAN service parameters.

      # Create security profiles wlan-net and wlan-net1, and configure security policies.

      [AC_3-wlan-view] security-profile name wlan-net
      [AC_3-wlan-sec-prof-wlan-net] security wpa-wpa2 psk pass-phrase a1234567 aes
      [AC_3-wlan-sec-prof-wlan-net] quit
      [AC_3-wlan-view] security-profile name wlan-net1
      [AC_3-wlan-sec-prof-wlan-net1] security wpa-wpa2 psk pass-phrase a1234567 aes
      [AC_3-wlan-sec-prof-wlan-net1] quit
      

      # Create SSID profile wlan-net and set the SSID name to wlan-net.

      [AC_3-wlan-view] ssid-profile name wlan-net
      [AC_3-wlan-ssid-prof-wlan-net] ssid wlan-net
      [AC_3-wlan-ssid-prof-wlan-net] quit
      

      # Create SSID profile wlan-net1 and set the SSID name to wlan-net1.

      [AC_3-wlan-view] ssid-profile name wlan-net1
      [AC_3-wlan-ssid-prof-wlan-net1] ssid wlan-net1
      [AC_3-wlan-ssid-prof-wlan-net1] quit
      

      # Create AP system profile ap-system and configure the IP address of the standby AC.

      [AC_3-wlan-view] ap-system-profile name ap-system
      [AC_3-wlan-ap-system-prof-ap-system] protect-ac ip-address 10.23.100.2
      Warning: This action will take effect after resetting AP.
      [AC_3-wlan-ap-system-prof-ap-system] quit
      

      # Create AP system profile ap-system1 and configure the IP address of the standby AC.

      [AC_3-wlan-view] ap-system-profile name ap-system1
      [AC_3-wlan-ap-system-prof-ap-system1] protect-ac ip-address 10.23.100.3
      Warning: This action will take effect after resetting AP.
      [AC_3-wlan-ap-system-prof-ap-system1] quit
      

      # Create VAP profile wlan-net, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

      [AC_3-wlan-view] vap-profile name wlan-net
      [AC_3-wlan-vap-prof-wlan-net] forward-mode direct-forward
      [AC_3-wlan-vap-prof-wlan-net] service-vlan vlan-id 101
      [AC_3-wlan-vap-prof-wlan-net] security-profile wlan-net
      [AC_3-wlan-vap-prof-wlan-net] ssid-profile wlan-net
      [AC_3-wlan-vap-prof-wlan-net] quit
      

      # Create VAP profile wlan-net1, set the data forwarding mode and service VLAN, and apply the security profile and SSID profile to the VAP profile.

      [AC_3-wlan-view] vap-profile name wlan-net1
      [AC_3-wlan-vap-prof-wlan-net1] forward-mode direct-forward
      [AC_3-wlan-vap-prof-wlan-net1] service-vlan vlan-id 102
      [AC_3-wlan-vap-prof-wlan-net1] security-profile wlan-net
      [AC_3-wlan-vap-prof-wlan-net1] ssid-profile wlan-net1
      [AC_3-wlan-vap-prof-wlan-net1] quit
      

      # Bind the VAP profile and AP system profile to the AP group and apply the VAP profile wlan-net to radio 0 and radio 1 of the APs.

      [AC_3-wlan-view] ap-group name ap-group1
      [AC_3-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 0
      [AC_3-wlan-ap-group-ap-group1] vap-profile wlan-net wlan 1 radio 1
      [AC_3-wlan-ap-group-ap-group1] ap-system-profile ap-system
      [AC_3-wlan-ap-group-ap-group1] quit
      [AC_3-wlan-view] ap-group name ap-group2
      [AC_3-wlan-ap-group-ap-group2] vap-profile wlan-net1 wlan 1 radio 0
      [AC_3-wlan-ap-group-ap-group2] vap-profile wlan-net1 wlan 1 radio 1
      [AC_3-wlan-ap-group-ap-group2] ap-system-profile ap-system1
      [AC_3-wlan-ap-group-ap-group2] quit
      

  6. Enable N+1 backup on AC_1, AC_2, and AC_3.

    # On AC_1, configure the AC's global priority and IP address of AC_3.
    NOTE:
    AC priorities determine the AC roles. The AC with a higher priority is the active AC, and the AC with a lower priority is the standby AC. A smaller value indicates a higher priority. If the AC priorities are the same, the AC that connects to more APs is the active AC. If the ACs connect to the same number of APs, the AC that connects to more STAs is the active AC. If the ACs connect to the same number of STAs, the AC with a smaller IP address is the active AC.
    [AC_1-wlan-view] ac protect priority 6 protect-ac 10.23.100.4
    
    # On AC_2, configure the AC's global priority and IP address of AC_3.
    [AC_2-wlan-view] ac protect priority 6 protect-ac 10.23.100.4
    
    # Configure the global priority of AC_3.
    [AC_3-wlan-view] ac protect priority 5
    
    # On AC_1, enable N+1 backup and restart all APs to make the function take effect.
    NOTE:
    By default, N+1 backup is enabled. The system displays an Info message if you run the undo ac protect enable command. You need to run the ap-reset all command to restart all APs. After the APs are restarted, N+1 backup starts to take effect.
    [AC_1-wlan-view] undo ac protect enable
    Info: Backup function has already disabled. 
    [AC_1-wlan-view] ap-reset all
    Warning: Reset AP(s), continue?[Y/N]:y
    # On AC_2, enable N+1 backup and restart all APs to make the function take effect.
    [AC_2-wlan-view] undo ac protect enable
    Info: Backup function has already disabled. 
    [AC_2-wlan-view] ap-reset all
    Warning: Reset AP(s), continue?[Y/N]:y
    # Enable revertive switchover and N+1 backup on AC_3.
    NOTE:
    By default, global revertive switchover is enabled. The system displays an Info message if you run the undo ac protect restore disable command.
    [AC_3-wlan-view] undo ac protect restore disable
    Info: Protect restore has already enabled.
    [AC_3-wlan-view] undo ac protect enable
    Info: Backup function has already disabled. 
    [AC_3-wlan-view] ap-reset all
    Warning: Reset AP(s), continue?[Y/N]:y

  7. Verify the configuration.

    # Run the display ac protect and display ap-system-profile commands on AC_1 to check N+1 backup information.

    [AC_1-wlan-view] display ac protect
    ------------------------------------------------------------
    Protect state             : disable
    Protect AC                : 10.23.100.4
    Priority                  : 6
    Protect restore           : enable
    ...
    ------------------------------------------------------------
    [AC_1-wlan-view] display ap-system-profile name ap-system
    ------------------------------------------------------------------------------  
    AC priority                 : 3
    Protect AC IP address       : 10.23.100.4
    Primary AC                                     : -
    Backup AC                                      : -
    ...
    ------------------------------------------------------------------------------ 

    # Run the display ac protect and display ap-system-profile commands on AC_2 to check N+1 backup information.

    [AC_2-wlan-view] display ac protect
    ------------------------------------------------------------
    Protect state             : disable
    Protect AC                : 10.23.100.4
    Priority                  : 6
    Protect restore           : enable
    ...
    ------------------------------------------------------------
    [AC_2-wlan-view] display ap-system-profile name ap-system1
    ------------------------------------------------------------------------------  
    AC priority                                    : 3
    Protect AC IP address                          : 10.23.100.4
    Primary AC                                     : -
    Backup AC                                      : -
    ...
    ------------------------------------------------------------------------------ 

    # Run the display ac protect and display ap-system-profile commands on AC_3 to check N+1 backup information.

    [AC_3-wlan-view] display ac protect
    ------------------------------------------------------------
    Protect state             : disable
    Protect AC                : -
    Priority                  : 5
    Protect restore           : enable
    ...
    ------------------------------------------------------------
    [AC_3-wlan-view] display ap-system-profile name ap-system
    ------------------------------------------------------------------------------  
    AC priority                                    : -            
    Protect AC IP address                          : 10.23.100.2            
    Primary AC                                     : -
    Backup AC                                      : -
    ...
    ------------------------------------------------------------------------------ 
    [AC_3-wlan-view] display ap-system-profile name ap-system1
    ------------------------------------------------------------------------------  
    AC priority                                    : -             
    Protect AC IP address                          : 10.23.100.3             
    Primary AC                                     : -
    Backup AC                                      : -
    ...
    ------------------------------------------------------------------------------ 
    

    The WLAN with the SSID wlan-net or wlan-net1 is available for STAs connected to the APs, and these STAs can connect to the WLAN and go online normally.

    When the link between an AP and AC_1 or AC_2 fails, AC_3 takes over the active role. This ensures accelerate service recovery.

Configuration Files

  • Switch_1 configuration file

    #
    sysname Switch_1
    #
     vlan batch 100 to 102
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
     dhcp server excluded-ip-address 10.23.100.2 10.23.100.4
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 to 102
    #
    interface GigabitEthernet0/0/4
     port link-type trunk
     port trunk allow-pass vlan 100 to 102
    #
    return  
  • Switch_2 configuration file

    #
    sysname Switch_2
    #
     vlan batch 100 to 102
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 to 101
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100 102
     port-isolate enable group 1
    #
     interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 100 to 102
     #
    return  
  • AC_1 configuration file

    #
     sysname AC_1
    #
    vlan batch 100 to 101
    #
    interface Vlanif100
     ip address 10.23.100.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 101
    #
    capwap source interface vlanif100
    #
    wlan
     ac protect protect-ac 10.23.100.4 priority 6
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     regulatory-domain-profile name default
     ap-system-profile name ap-system
      priority 3
     ap-group name ap-group1
      ap-system-profile ap-system
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
    #
    return
  • AC_2 configuration file

    #
     sysname AC_2
    #
    vlan batch 100 102
    #
    interface Vlanif100
     ip address 10.23.100.3 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 102
    #
    capwap source interface vlanif100
    #
    wlan
     ac protect protect-ac 10.23.100.4 priority 6
     security-profile name wlan-net1
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net1
      ssid wlan-net1
     vap-profile name wlan-net1
      service-vlan vlan-id 102
      ssid-profile wlan-net1
      security-profile wlan-net1
     regulatory-domain-profile name default
     ap-system-profile name ap-system1
      priority 3
     ap-group name ap-group2
      ap-system-profile ap-system1
      radio 0
       vap-profile wlan-net1 wlan 1
      radio 1
       vap-profile wlan-net1 wlan 1
     ap-id 1 type-id 35 ap-mac 60de-4474-9640 ap-sn 210235419610D2000097
      ap-name area_2
      ap-group ap-group2
    #
    return
  • AC_3 configuration file

    #
     sysname AC_3
    #
    vlan batch 100 to 102
    #
    interface Vlanif100
     ip address 10.23.100.4 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 102
    #
    capwap source interface vlanif100
    #
    wlan
     ac protect priority 5
     security-profile name wlan-net
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     security-profile name wlan-net1
      security wpa-wpa2 psk pass-phrase %^%#m"tz0f>~7.[`^6RWdzwCy16hJj/Mc!,}s`X*B]}A%^%# aes
     ssid-profile name wlan-net
      ssid wlan-net
     ssid-profile name wlan-net1
      ssid wlan-net1
     vap-profile name wlan-net
      service-vlan vlan-id 101
      ssid-profile wlan-net
      security-profile wlan-net
     vap-profile name wlan-net1
      service-vlan vlan-id 102
      ssid-profile wlan-net1
      security-profile wlan-net1
     regulatory-domain-profile name default
     ap-system-profile name ap-system
      protect-ac ip-address 10.23.100.2
     ap-system-profile name ap-system1
      protect-ac ip-address 10.23.100.3
     ap-group name ap-group1
      ap-system-profile ap-system
      radio 0
       vap-profile wlan-net wlan 1
      radio 1
       vap-profile wlan-net wlan 1
     ap-group name ap-group2
      ap-system-profile ap-system1
      radio 0
       vap-profile wlan-net1 wlan 1
      radio 1
       vap-profile wlan-net1 wlan 1
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
     ap-id 1 type-id 35 ap-mac 60de-4474-9640 ap-sn 210235419610D2000097
      ap-name area_2
      ap-group ap-group2
    #
    return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90475

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next