No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Wireless Configuration Synchronization in Dual-Link HSB Scenarios

Example for Configuring Wireless Configuration Synchronization in Dual-Link HSB Scenarios

Service Requirements

To ensure that services are running normally, an enterprise wants to improve network reliability while reducing the configuration maintenance workload. Wireless configuration synchronization can be deployed in dual-link HSB to meet this requirement. This solution frees active and standby ACs from location restrictions and allows both ACs to be flexibly deployed.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode: The router functions as a DHCP server to assign IP addresses to APs and STAs.
  • Service data forwarding mode: direct forwarding
Figure 5-40 Networking diagram for configuring dual-link HSB

Data Planning

Table 5-45 AC Data planning
Item Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

VLAN 101

AC's backup VLAN VLAN 102

DHCP server

The Router functions as the DHCP server for the APs and STAs.

STAs' gateway: 10.23.101.1/24

APs' gateway: 10.23.100.1/24

IP address pool for APs

10.23.100.4-10.23.100.254/24

IP address pool for STAs

10.23.101.2-10.23.101.254/24

AC's source interface

VLANIF 100

AC1's management IP address

VLANIF 100: 10.23.100.2/24

AC2's management IP address

VLANIF 100: 10.23.100.3/24

Active AC

AC1

Standby AC

AC2

Master AC

AC1

Local AC

AC2

AP group

  • Name: ap-group1

  • Referenced profile: VAP profile wlan-net and regulatory domain profile default

Regulatory domain profile

  • Name: default
  • Country code: China

SSID profile

  • Name: wlan-net

  • SSID name: wlan-net

Security profile

  • Name: wlan-net

  • Security policy: WPA-WPA2+PSK+AES

  • Password: a1234567

VAP profile

  • Name: wlan-net

  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 101

  • Referenced profiles: SSID profile wlan-net and security profile wlan-net

AP system profile

  • Name: wlan-net

  • Primary AC's IP address: 10.23.100.2

  • Backup AC's IP address: 10.23.100.3

Configuration Roadmap

  1. Configure network interconnection. Configure Router as a DHCP server to assign IP addresses to APs and STAs.
  2. Configure AC1, APs going online, and WLAN services following the configuration wizard.
  3. Configure dual-link hot standby (HSB) on AC1.
  4. Configure AC2 following the configuration wizard.
  5. Configure dual-link HSB on AC2.
  6. Trigger wireless configuration synchronization on AC1.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure SwitchA and SwitchB to ensure that the APs and ACs can exchange CAPWAP packets.

    # Set the PVID on GE0/0/1 of SwitchA to management VLAN 100 and add the interface to VLAN 100 and VLAN 101. Add GE0/0/2 of SwitchA to VLAN 100 and VLAN 101.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    

    # Add GE0/0/1 (connecting to SwitchA) of SwitchB to VLAN 100 and VLAN 101. Add GE0/0/2 (connecting to AC1) of SwitchB, and GE0/0/3 (connecting to AC2) of SwitchB to VLAN 100.

    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/3] quit
    

  2. Configure the communication between Router, AC1, and AC2.

    # Add GE0/0/2 and GE0/0/3 of SwitchB to VLAN 102 and add GE0/0/4 of SwitchB connecting to Router to both VLAN 100 and VLAN 101.

    [SwitchB] vlan batch 101 102
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 102
    [SwitchB-GigabitEthernet0/0/3] quit
    [SwitchB] interface gigabitethernet 0/0/4
    [SwitchB-GigabitEthernet0/0/4] port link-type trunk
    [SwitchB-GigabitEthernet0/0/4] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/4] quit
    

  3. Configure Router to assign IP addresses to STAs and APs.

    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 100 101
    [Router] dhcp enable
    [Router] ip pool sta
    [Router-ip-pool-sta] network 10.23.101.0 mask 24
    [Router-ip-pool-sta] gateway-list 10.23.101.1
    [Router-ip-pool-sta] quit
    [Router] ip pool ap
    [Router-ip-pool-ap] network 10.23.100.0 mask 24
    [Router-ip-pool-ap] excluded-ip-address 10.23.100.2
    [Router-ip-pool-ap] excluded-ip-address 10.23.100.3
    [Router-ip-pool-ap] gateway-list 10.23.100.1
    [Router-ip-pool-ap] quit
    [Router] interface vlanif 100
    [Router-Vlanif100] ip address 10.23.100.1 24
    [Router-Vlanif100] dhcp select global
    [Router-Vlanif100] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.1 24
    [Router-Vlanif101] dhcp select global
    [Router-Vlanif101] quit
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] port link-type trunk
    [Router-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [Router-GigabitEthernet0/0/1] quit
    

  4. Configure AC1.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China, System time to Manual, and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 and VLAN 102.

      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configure network interconnection.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.2/24.



      # Click OK. VLANIF 100 is configured.

      # Repeat the preceding steps to configure VLANIF 102. Set the IP address of VLANIF 102 to 10.23.102.1/24.

      # Click Next. The AC Backup Configuration page is displayed.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC1.

      # Set AC source address to VLANIF and set the IP address to Vlanif100.



      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  5. Configure APs connected to AC1.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If AP authentication mode is set to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If AP authentication mode is set to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next.

    2. Configure an AP group.

      # The AP template file has AP group information added. Click Next. The Confirm Configurations page is displayed.

    3. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  6. Configure basic WLAN services on AC1.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN ID.



    Click Next. The Security Authentication page is displayed.

    # Set Security settings to Key (applicable to personnel networks) and set the key.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    Click Finish.

  7. Configure dual-link HSB on AC1.
    1. Configure IP addresses for primary and backup ACs.

      # Choose Configuration > AP Config > AP Group > AP Group.

      # In the AP group list, click ap-group1. On the page that is displayed, click in front of AP. Under it, click AP System Profile. The AP System Profile page is displayed.

      # Click Create. On the Create AP System Profile page that is displayed, enter the profile name wlan-net and click OK. The AP system profile configuration page is displayed.

      # Click in front of Dual-Link/N+1 Backup. On the expanded page, set Primary AC IP address to 10.23.100.2 and Backup AC IP address to 10.23.100.3.



      # Click Apply. In the dialog box that is displayed, click OK.

    2. Configure dual-link HSB.

      # Choose Configuration > Reliability > Reliability. The Reliability page is displayed.



      # Set parameters as follows:
      • Backup mode: Dual-link hot backup
      • Local AC IP address: 10.23.102.1
      • Peer AC IP address: 10.23.102.2
      • Local port: 10241
      • Remote port: 10241
      • Wireless configuration synchronization: ON
      • Synchronization mode: From local to peer
      • Peer AC IP address: 10.23.100.3
      • PSK key and Confirm PSK key: H@123456

  8. Configure AC2.
    1. Perform basic AC configurations.

      # Configure AC2 in the same way as that for configuring AC1.

    2. Configure interfaces.

      # Configure interfaces on AC2 in the same way as that on AC1.

    3. Configure network interconnection.

      # Configure network interconnections on AC2 in the same way as that on AC1. The differences are as follows:

      • Set IP addresses of VLANIF 100 and VLANIF 102 to 10.23.100.3/24 and 10.23.102.2/24, respectively.

    4. Configure the source address for AC2.

      # Configure the source address for AC2 in the same way as that for AC1.

    5. Confirm the configuration.

      # Confirm the configuration and click Finish.

  9. Configure dual-link HSB on AC2.
    1. Configure IP addresses for primary and backup ACs.

      # Choose Configuration > AP Config > AP Group > AP Group.

      # Click Create. On the page that is displayed, create the AP group ap-group1 and click OK.

      # In the AP group list, click ap-group1. On the page that is displayed, click in front of AP. Under it, click AP System Profile. The AP System Profile page is displayed.

      # Click Create. On the Create AP System Profile page that is displayed, enter the profile name wlan-net and click OK. The AP system profile configuration page is displayed.

      # Click in front of Dual-Link/N+1 Backup. On the expanded page, set Primary AC IP address to 10.23.100.2 and Backup AC IP address to 10.23.100.3.



      # Click Apply. In the dialog box that is displayed, click OK.

    2. Configure dual-link HSB.

      # Choose Configuration > Reliability > Reliability. The Reliability page is displayed.



      # Set parameters as follows:
      • Backup mode: Dual-link hot backup
      • Local AC IP address: 10.23.102.2
      • Peer AC IP address: 10.23.102.1
      • Local port: 10241
      • Remote port: 10241
      • Wireless configuration synchronization: ON
      • Synchronization mode: From peer to local
      • Peer AC IP address: 10.23.100.2
      • PSK key and Confirm PSK key: H@123456

  10. Trigger wireless configuration synchronization manually on AC1.

    # Choose Monitoring > AC > Wireless Configuration Synchronization Information. The Wireless Configuration Synchronization Information page is displayed. Set Auto refresh to ON.

    # Click Manual synchronization under Operation. In the Confirm dialog box that is displayed, click OK. AC2 restarts automatically.



  11. Verify the configuration.

    # After AC2 restarts, check the configuration synchronization state on AC1. If Configuration Synchronization State is Synchronization success, wireless configuration synchronization succeeds.



    # STAs associated with the AP can find the SSID wlan-net and connect to the WLAN.

    # If the link between the AP and AC1 is disconnected, AC2 becomes the active AC, ensuring user service continuity.

Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 94640

Downloads: 548

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next