No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Different Authentication Modes for Multiple SSIDs

Example for Configuring Different Authentication Modes for Multiple SSIDs

Service Requirements

Enterprise users can access the Internet through the WLAN to meet basic mobile office requirements. When roaming occurs in the coverage area, user services will not be interrupted.

Administrators want to deploy different SSIDs for WLAN access of guests and employees, and different authentication modes for them to ensure WLAN security.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to assign IP addresses to APs.
    • The aggregation switch (SwitchB) functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: tunnel forwarding
Figure 4-41 Networking diagram for configuring different authentication modes for multiple SSIDs

Data Planning

Table 4-39 AC data planning

Item

Data

Management VLAN for APs

VLAN 100

Service VLAN for STAs

  • Employees: VLAN 101

  • Guests: VLAN 102

DHCP server

The AC functions as a DHCP server to assign IP addresses to APs.

SwitchB functions as a DHCP server to assign IP addresses to STAs. The default gateways for STAs are 10.23.101.2 and 10.23.102.2.

IP address pool for APs 10.23.100.2-10.23.100.254/24
IP address pool for STAs

10.23.101.3-10.23.101.254/24

10.23.102.3-10.23.102.254/24

IP address of the AC's source interface VLANIF 100: 10.23.100.1/24
RADIUS authentication parameters
  • RADIUS server template name: wlan-net
  • IP address: 10.23.102.1
  • Authentication port number: 1812
  • Shared key: Huawei123
  • Authentication scheme: wlan-net
  • Accounting scheme: wlan-net
Portal server template
  • Name: wlan-net
  • IP address: 10.23.103.1
  • Port number: 50200
  • Shared key: Huawei123
  • Referenced template: URL template wlan-net
Portal access profile
  • Name: wlan-net
  • Referenced template: Portal server template wlan-net
MAC access profile

Name: wlan-net

Authentication-free rule profile
  • Name: default_free_rule
  • Authentication-free resource: DNS server with IP address 8.8.8.8
802.1x access profile
  • Name: wlan-net
  • Authentication mode: EAP
Authentication profile
  • Name: employee
  • Referenced profiles and authentication schemes: 802.1x access profile wlan-net, RADIUS server template wlan-net, and authentication scheme wlan-net
  • Name: guest
  • Referenced profiles and authentication schemes: Portal access profile wlan-net, MAC access profile wlan-net, RADIUS server template wlan-net, authentication scheme wlan-net, accounting scheme wlan-net, and authentication-free rule template default_free_rule
AP group
  • Name: ap-group1
  • Referenced profiles: VAP profiles employee and guest, and regulatory domain profile default
Regulatory domain profile
  • Name: default
  • Country code: China
SSID profile
  • Name: employee
  • SSID name: employee
  • Name: guest
  • SSID name: guest
Security profile
  • Name: employee
  • Security policy: WPA-WPA2+802.1x+AES
  • Name: guest
  • Security policy: open
VAP profile
  • Name: employee
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 101
  • Referenced profiles: SSID profile employee, security profile employee, and authentication profile employee
  • Name: guest
  • Forwarding mode: tunnel forwarding
  • Service VLAN: VLAN 102
  • Referenced profiles: SSID profile guest, security profile guest, and authentication profile guest

Configuration Roadmap

  1. Configure network interworking of the AC, APs, and other network devices.
  2. Configure APs to go online.
  3. Configure 802.1x authentication and MAC address-prioritized Portal authentication.
  4. Configure WLAN service parameters for STAs to access the WLAN.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA to VLAN 100. The default VLAN of GE0/0/1 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 and GE0/0/2 on SwitchB to VLAN 100, and GE0/0/2 and GE0/0/3 to VLAN 101 and VLAN 102, respectively.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 101 102
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101 102
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101 102
    [SwitchB-GigabitEthernet0/0/3] quit
    
    # Add GE1/0/0 on the router to VLAN 101 and VLAN 102. Create interfaces VLANIF 101 and VLANIF 102, and set the IP addresses of VLANIF 101 and VLANIF 102 to 10.23.101.2/24 and 10.23.102.2/24, respectively.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101 102
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101 102
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    [Router] interface vlanif 102
    [Router-Vlanif102] ip address 10.23.102.2 24
    [Router-Vlanif102] quit
    

  2. Configure the AC to communicate with the network devices.

    NOTE:

    If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.

    # Add GE0/0/1 on the AC to VLAN 100, VLAN 101, and VLAN 102.
    <AC6605> system-view
    [AC6605] sysname AC
    [AC] vlan batch 100 101 102
    [AC] interface gigabitethernet 0/0/1
    [AC-GigabitEthernet0/0/1] port link-type trunk
    [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101 102
    [AC-GigabitEthernet0/0/1] quit
    

  3. Configure the DHCP servers to assign IP addresses to APs and STAs.

    # On the AC, configure VLANIF 100 to provide IP addresses to APs.
    [AC] dhcp enable
    [AC] interface vlanif 100
    [AC-Vlanif100] ip address 10.23.100.1 24
    [AC-Vlanif100] dhcp select interface
    [AC-Vlanif100] quit
    
    # On SwitchB, configure VLANIF 101 and VLANIF 102 address pools to assign IP addresses to employees and guests, respectively. Set the default gateway address for employees and guests to 10.23.101.2 and 10.23.102.2, respectively. Specify the DNS server address 8.8.8.8 for VLANIF 101 and VLANIF 102 address pools.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] dhcp server dns-list 8.8.8.8
    [SwitchB-Vlanif101] quit
    [SwitchB] interface vlanif 102
    [SwitchB-Vlanif102] ip address 10.23.102.1 24
    [SwitchB-Vlanif102] dhcp select interface
    [SwitchB-Vlanif102] dhcp server gateway-list 10.23.102.2
    [SwitchB-Vlanif102] dhcp server dns-list 8.8.8.8
    [SwitchB-Vlanif102] quit
    

  4. Configure the AC's default routes with VLANIF 101 and VLANIF 102 on the router as the next hops.

    [AC] ip route-static 0.0.0.0 0.0.0.0 10.23.101.2
    [AC] ip route-static 0.0.0.0 0.0.0.0 10.23.102.2
    

  5. Configure an AP to go online.

    # Create an AP group to which the APs with the same configuration can be added.
    [AC] wlan
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] quit
    
    # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.
    [AC-wlan-view] regulatory-domain-profile name default
    [AC-wlan-regulate-domain-default] country-code cn
    [AC-wlan-regulate-domain-default] quit
    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] regulatory-domain-profile default
    Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
    e?[Y/N]:y 
    [AC-wlan-ap-group-ap-group1] quit
    [AC-wlan-view] quit
    
    # Configure the AC's source interface.
    [AC] capwap source interface vlanif 100
    
    # Import the AP offline on the AC and add the AP to AP group ap-group1. Assume that the AP's MAC address is 60de-4476-e360. Configure a name for the AP based on the AP's deployment location, so that you can know where the AP is deployed from its name. For example, name the AP area_1 if it is deployed in Area 1.
    NOTE:

    The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

    In this example, the AP5030DN is used and has two radios: radio 0 (2.4 GHz radio) and radio 1 (5 GHz radio).

    [AC] wlan
    [AC-wlan-view] ap auth-mode mac-auth
    [AC-wlan-view] ap-id 0 ap-mac 60de-4476-e360
    [AC-wlan-ap-0] ap-name area_1
    Warning: This operation may cause AP reset. Continue? [Y/N]:y 
    [AC-wlan-ap-0] ap-group ap-group1
    Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
    s of the radio, Whether to continue? [Y/N]:y 
    [AC-wlan-ap-0] quit
    
    # After the AP is powered on, run the display ap all command to check the AP state. If the State field is displayed as nor, the AP goes online successfully.
    [AC-wlan-view] display ap all
    Total AP information:
    nor  : normal          [1]
    Extra information:
    P  : insufficient power supply
    --------------------------------------------------------------------------------------------------
    ID   MAC            Name   Group     IP            Type            State STA Uptime      ExtraInfo
    --------------------------------------------------------------------------------------------------
    0    60de-4476-e360 area_1 ap-group1 10.23.100.254 AP5030DN        nor   0   10S         -
    --------------------------------------------------------------------------------------------------
    Total: 1

  6. Configure a RADIUS server template, a RADIUS authentication scheme and a RADIUS accounting scheme.

    NOTE:

    Ensure that the RADIUS server IP address, port number, and shared key are configured correctly and are the same as those on the RADIUS server.

    # Configure a RADIUS server template.

    [AC] radius-server template wlan-net
    [AC-radius-wlan-net] radius-server authentication 10.23.102.1 1812
    [AC-radius-wlan-net] radius-server shared-key cipher Huawei123
    [AC-radius-wlan-net] quit

    # Create an authentication scheme and configure the RADIUS authentication mode.

    [AC] aaa
    [AC-aaa] authentication-scheme wlan-net
    [AC-aaa-authen-wlan-net] authentication-mode radius
    [AC-aaa-authen-wlan-net] quit
    

    # Create an authentication scheme and configure the RADIUS authentication mode.

    [AC-aaa] accounting-scheme wlan-net
    [AC-aaa-accounting-wlan-net] accounting-mode radius
    [AC-aaa-accounting-wlan-net] accounting realtime 15
    [AC-aaa-accounting-wlan-net] quit
    [AC-aaa] quit
    NOTE:
    • In this example, the device is connected to the Agile Controller-Campus. The accounting function is not implemented for accounting purposes, and is used to maintain terminal online information through accounting packets.

    • The accounting realtime command sets the real-time accounting interval. A shorter real-time accounting interval requires higher performance of the device and RADIUS server. Set the real-time accounting interval based on the user quantity.

    User Quantity Real-Time Accounting Interval
    1-99 3 minutes
    100-499 6 minutes
    500-999 12 minutes
    ≥ 1000 ≥ 15 minutes

  7. Configure the URL of the Portal authentication page. When a user attempts to access a website before authentication, the AC redirects the website to the Portal server.

    You are advised to configure the URL using a domain name to ensure secure and fast page pushing. Before configuring the URL using a domain name, you must first configure the mapping between the domain name and IP address of the Portal server on the DNS server.

    NOTE:
    Configure parameters carried in the URL, which must be the same as those on the authentication server.
    [AC] url-template name wlan-net
    [AC-url-template-wlan-net] url http://portal.com:8080/portal
    [AC-url-template-wlan-net] url-parameter ssid ssid redirect-url url 
    [AC-url-template-wlan-net] quit

  8. Configure a Portal server template.

    NOTE:

    Ensure that the Portal server IP address, URL address, port number, and shared key are configured correctly and are the same as those on the Portal server.

    [AC] web-auth-server wlan-net
    [AC-web-auth-server-wlan-net] server-ip 10.23.103.1
    [AC-web-auth-server-wlan-net] shared-key cipher Huawei123
    [AC-web-auth-server-wlan-net] port 50200
    [AC-web-auth-server-wlan-net] url-template wlan-net ciphered-parameter-name cpname iv-parameter-name iv-value key cipher Huawei123
    [AC-web-auth-server-wlan-net] quit
    

  9. Configure the Portal access profile wlan-net and configure Layer 2 Portal authentication.

    [AC] portal-access-profile name wlan-net
    [AC-portal-access-profile-wlan-net] web-auth-server wlan-net direct
    [AC-portal-access-profile-wlan-net] quit

  10. Configure a MAC access profile for MAC address-prioritized Portal authentication.

    [AC] mac-access-profile name wlan-net
    [AC-mac-access-profile-wlan-net] quit

  11. Configure an authentication-free rule profile.

    [AC] free-rule-template name default_free_rule
    [AC-free-rule-default_free_rule] free-rule 1 destination ip 8.8.8.8 mask 32
    [AC-free-rule-default_free_rule] quit
    

  12. Configure an 802.1x access profile to manage 802.1x access control parameters.

    # Create 802.1x access profile wlan-net.

    [AC] dot1x-access-profile name wlan-net
    

    # Set the authentication mode to EAP relay.

    [AC-dot1x-access-profile-wlan-net] dot1x authentication-method eap
    [AC-dot1x-access-profile-wlan-net] quit
    

  13. Configure authentication profiles employee and guest.

    [AC] authentication-profile name employee
    [AC-authentication-profile-employee] dot1x-access-profile wlan-net
    [AC-authentication-profile-employee] authentication-scheme wlan-net
    [AC-authentication-profile-employee] radius-server wlan-net
    [AC-authentication-profile-employee] quit
    [AC] authentication-profile name guest
    [AC-authentication-profile-guest] portal-access-profile wlan-net
    [AC-authentication-profile-guest] mac-access-profile wlan-net
    [AC-authentication-profile-guest] free-rule-template default_free_rule
    [AC-authentication-profile-guest] authentication-scheme wlan-net
    [AC-authentication-profile-guest] accounting-scheme wlan-net
    [AC-authentication-profile-guest] radius-server wlan-net
    [AC-authentication-profile-guest] quit

  14. Configure WLAN service parameters.

    # Create security profiles employee and guest, and set the security policies to WPA-WPA2+802.1X+AES and open, respectively.

    [AC] wlan
    [AC-wlan-view] security-profile name employee
    [AC-wlan-sec-prof-employee] security wpa-wpa2 dot1x aes
    [AC-wlan-sec-prof-employee] quit
    [AC-wlan-view] security-profile name guest
    [AC-wlan-sec-prof-guest] quit
    

    # Create SSID profiles employee and guest, and set the SSID names to employee and guest, respectively.

    [AC-wlan-view] ssid-profile name employee
    [AC-wlan-ssid-prof-employee] ssid employee
    [AC-wlan-ssid-prof-employee] quit
    [AC-wlan-view] ssid-profile name guest
    [AC-wlan-ssid-prof-guest] ssid guest
    [AC-wlan-ssid-prof-guest] quit
    

    # Create VAP profiles employee and guest, set the data forwarding mode and service VLANs, and bind the security, SSID, and authentication profiles to the VAP profiles.

    [AC-wlan-view] vap-profile name employee
    [AC-wlan-vap-prof-employee] forward-mode tunnel
    [AC-wlan-vap-prof-employee] service-vlan vlan-id 101
    [AC-wlan-vap-prof-employee] security-profile employee
    [AC-wlan-vap-prof-employee] ssid-profile employee
    [AC-wlan-vap-prof-employee] authentication-profile employee
    [AC-wlan-vap-prof-employee] quit
    [AC-wlan-view] vap-profile name guest
    [AC-wlan-vap-prof-guest] forward-mode tunnel
    [AC-wlan-vap-prof-guest] service-vlan vlan-id 102
    [AC-wlan-vap-prof-guest] security-profile guest
    [AC-wlan-vap-prof-guest] ssid-profile guest
    [AC-wlan-vap-prof-guest] authentication-profile guest
    [AC-wlan-vap-prof-guest] quit
    

    # Bind the VAP profiles to the AP groups, and apply configurations of VAP profiles employee and guest to radio 0 and radio 1 of the APs.

    [AC-wlan-view] ap-group name ap-group1
    [AC-wlan-ap-group-ap-group1] vap-profile employee wlan 1 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile employee wlan 1 radio 1
    [AC-wlan-ap-group-ap-group1] vap-profile guest wlan 2 radio 0
    [AC-wlan-ap-group-ap-group1] vap-profile guest wlan 2 radio 1
    [AC-wlan-ap-group-ap-group1] quit
    

  15. Configure the AP channel and power.

    NOTE:

    Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled. The settings of the AP channel and power in this example are for reference only. You need to configure the AP channel and power based on the actual country code and network planning.

    # Disable automatic channel and power calibration functions of radio 0, and configure the channel and power for radio 0.
    [AC-wlan-view] ap-id 0
    [AC-wlan-ap-0] radio 0
    [AC-wlan-radio-0/0] calibrate auto-channel-select disable
    [AC-wlan-radio-0/0] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/0] channel 20mhz 6
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/0] eirp 127
    [AC-wlan-radio-0/0] quit
    # Disable automatic channel and power calibration functions of radio 1, and configure the channel and power for radio 1.
    [AC-wlan-ap-0] radio 1
    [AC-wlan-radio-0/1] calibrate auto-channel-select disable
    [AC-wlan-radio-0/1] calibrate auto-txpower-select disable
    [AC-wlan-radio-0/1] channel 20mhz 149
    Warning: This action may cause service interruption. Continue?[Y/N]y
    [AC-wlan-radio-0/1] eirp 127
    [AC-wlan-radio-0/1] quit
    [AC-wlan-ap-0] quit

  16. Verify the configuration.

    • An employee can use a STA to find the WLAN with SSID employee. After being associated with the WLAN, the STA is assigned an IP address. After the employee uses an 802.1x client on the STA for authentication and enter the correct user name and password, the STA is authenticated and can access the WLAN. The configuration method on the 802.1x client is as follows:

      • Configuration on the Windows XP operating system:

        1. On the Association tab page of the Wireless network properties dialog box, add SSID employee, set the authentication mode to WPA2, and encryption algorithm to AES.
        2. On the Authentication tab page, set EAP type to PEAP and click Properties. In the Protected EAP Properties dialog box, deselect Validate server certificate and click Configure. In the displayed dialog box, deselect Automatically use my Windows logon name and password and click OK.
      • Configuration on the Windows 7 operating system:

        1. Access the Manage wireless networks page, click Add, and select Manually create a network profile. Add SSID employee. Set the authentication mode to WPA2-Enterprise, and encryption algorithm to AES. Click Next.
        2. Click Change connection settings. On the Wireless Network Properties page that is displayed, select the Security tab page and click Settings. In the Protected EAP Properties dialog box, deselect Validate server certificate and click Configure. In the displayed dialog box, deselect Automatically use my Windows logon name and password and click OK.
        3. On the Wireless Network Properties page, click Advanced settings. On the Advanced settings page that is displayed, select Specify authentication mode, set the identity authentication mode to User authentication, and click OK.
    • A guest can use a STA to find the WLAN with SSID guest. After being associated with the WLAN, the STA is assigned an IP address. When the STA accesses the Internet through a browser, the authentication page provided by the Portal server is automatically displayed. After the correct user name and password are entered on the page, the STA is authenticated and can access the WLAN. Assume that the MAC address configured on the Portal server is valid for 60 minutes. When the STA is disconnected from the WLAN for 5 minutes, the STA can access the Internet directly when reconnecting to the WLAN. When the STA is disconnected from the WLAN for 65 minutes, it will be redirected to the Portal authentication page when reconnecting to the WLAN.

Configuration Files

  • SwitchA configuration file

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     port-isolate enable group 1
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    return
  • SwitchB configuration file

    #
    sysname SwitchB
    #
    vlan batch 100 to 102
    #
    dhcp enable
    #
    interface Vlanif101
     ip address 10.23.101.1 255.255.255.0
     dhcp select interface
     dhcp server gateway-list 10.23.101.2
     dhcp server dns-list 8.8.8.8 
    #
    interface Vlanif102
     ip address 10.23.102.1 255.255.255.0
     dhcp select interface
     dhcp server gateway-list 10.23.102.2
     dhcp server dns-list 8.8.8.8 
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 100 to 102
    #
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 101 to 102
    #
    return
  • Router configuration file

    #
    sysname Router
    #
    vlan batch 101 to 102
    #
    interface Vlanif101
     ip address 10.23.101.2 255.255.255.0
    #
    interface Vlanif102
     ip address 10.23.102.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 101 to 102
    #
    return
    
  • AC configuration file

    #
     sysname AC
    #
    vlan batch 100 to 102
    #
    authentication-profile name employee
     dot1x-access-profile wlan-net
     authentication-scheme wlan-net
     radius-server wlan-net
    authentication-profile name guest
     mac-access-profile wlan-net
     portal-access-profile wlan-net
     free-rule-template default_free_rule
     authentication-scheme wlan-net
     accounting-scheme wlan-net
     radius-server wlan-net
    #
    dhcp enable
    #
    radius-server template wlan-net
     radius-server shared-key cipher %^%#Oc6_BMCw#9gZ2@SMVtk!PAC6>Ou*eLW/"qLp+f#$%^%#
     radius-server authentication 10.23.102.1 1812 weight 80
    #
    free-rule-template name default_free_rule
     free-rule 1 destination ip 8.8.8.8 mask 255.255.255.255
    #
    url-template name wlan-net
     url http://portal.com:8080/portal
     url-parameter ssid ssid redirect-url url
    #
    web-auth-server wlan-net
     server-ip 10.23.103.1
     port 50200
     shared-key cipher %^%#4~ZXE3]6@BXu;2;aw}hA{rSb,@"L@T#e{%6G1AiD%^%#
     url-template wlan-net ciphered-parameter-name cpname iv-parameter-name iv-value key cipher %^%#4~ZXE3]6@BXu;2;aw}hA{rSb,@"L@T#e{%6G1AiD%^%#
    #
    portal-access-profile name wlan-net
     web-auth-server wlan-net direct
    #
    aaa
     authentication-scheme wlan-net
      authentication-mode radius
     accounting-scheme wlan-net
      accounting-mode radius
      accounting realtime 15
    #
    interface Vlanif100
     ip address 10.23.100.1 255.255.255.0
     dhcp select interface
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 100 to 102
    #
    ip route-static 0.0.0.0 0.0.0.0 10.23.101.2
    ip route-static 0.0.0.0 0.0.0.0 10.23.102.2
    #
    capwap source interface vlanif100
    #
    wlan
     security-profile name guest 
     security-profile name employee
      security wpa-wpa2 dot1x aes
     ssid-profile name guest 
      ssid guest
     ssid-profile name employee
      ssid employee
     vap-profile name guest
      forward-mode tunnel
      service-vlan vlan-id 102
      ssid-profile guest
      security-profile guest
      authentication-profile guest
     vap-profile name employee
      forward-mode tunnel
      service-vlan vlan-id 101
      ssid-profile employee
      security-profile employee
      authentication-profile employee
     regulatory-domain-profile name default
     ap-group name ap-group1
      radio 0
       vap-profile employee wlan 1
       vap-profile guest wlan 2
      radio 1
       vap-profile employee wlan 1
       vap-profile guest wlan 2
     ap-id 0 type-id 35 ap-mac 60de-4476-e360 ap-sn 210235554710CB000042
      ap-name area_1
      ap-group ap-group1
      radio 0
       channel 20mhz 6
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
      radio 1
       channel 20mhz 149
       eirp 127
       calibrate auto-channel-select disable
       calibrate auto-txpower-select disable
    #
    dot1x-access-profile name wlan-net
    #
    mac-access-profile name wlan-net
    #
    return
    
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90610

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next