No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring WLAN Hotspot2.0 Services

Example for Configuring WLAN Hotspot2.0 Services

Service Requirements

Enterprise users can access the network through WLANs, which is the basic requirement of mobile office. Furthermore, users' services are not affected during roaming in the coverage area. On a traditional WLAN, users need to manually select an SSID and set authentication information to access the WLAN, causing poor user experience. To enhance user experience, Hotspot2.0 services are deployed using a subscriber identity module (SIM) card for authentication. In this way, users can access the WLAN automatically without awareness.

Networking Requirements

  • AC networking mode: Layer 2 networking in bypass mode
  • DHCP deployment mode:
    • The AC functions as a DHCP server to assign IP addresses to APs.
    • The aggregation switch (Switch_B) functions as a DHCP server to assign IP addresses to STAs.
  • Service data forwarding mode: direct forwarding
Figure 5-69 Networking for configuring WLAN Hotspot2.0 services

Data Planning

Table 5-76 Data planning on the AC
Item Data
Management VLAN for APs VLAN 100
Service VLAN for STAs VLAN 101
DHCP server

The AC functions as a DHCP server to assign IP addresses to APs and STAs.

The aggregation switch (Switch_B) functions as a DHCP server to assign IP addresses to STAs. The default gateway address of STAs is 10.23.101.2.

IP address pool for APs

10.23.100.2-10.23.100.254/24

IP address pool for STAs

10.23.101.3-10.23.101.254/24

AC's source interface address VLANIF 100: 10.23.101.1/24

AP group

  • Name: ap-group1

  • Country code: China

  • Referenced profile: VAP profile wlan-net

SSID profile

  • Name: wlan-net

  • SSID name: wlan-net

Security profile

  • Name: wlan-net

  • Security policy: WPA2-802.1x-AES

Authentication profile

  • Name: wlan-net
  • Access authentication mode: 802.1x

Hotspot2.0 profile

Hotspot2.0 profile
  • Name: wlan-net

  • Network type: free public network

  • Internet access: supported

  • Venue type and name: Assembly and Coffee Shop

  • HESSID: 60de-4476-e360

  • IP address availability: available

  • Network authentication type: acceptance

  • P2P cross connection: disabled

  • Cellular network profile: wlan-net

    • 46000
  • Roaming consortium profile: wlan-net

    • 50-6f-9a
  • NAI realm profile: wlan-net

    • www.mobileA.com
  • Network connection capability profile: wlan-net

    • HTTP service: enabled
  • Operator domain profile: wlan-net

    • www.mobileA.com
  • Operator name profile: wlan-net

    • eng, mobileA
  • Venue name profile: wlan-net

    • eng, Coffee
  • Operating class profile: wlan-net

    • 81

VAP profile

  • Name: wlan-net

  • Forwarding mode: direct forwarding

  • Service VLAN: VLAN 101

  • Referenced profiles: SSID profile wlan-net, security profile wlan-net, authentication profile wlan-net, and Hotspot2.0 profile wlan-net

RADIUS server

  • IP address: 10.23.102.1
  • Port number: 1812
  • Shared key: huawei123

Configuration Roadmap

  1. Select Config Wizard to configure the APs to go online on the AC.
  2. Select Config Wizard to configure WLAN services on the AC. When configuring the security policy, select 802.1x and RADIUS authentication, and set the RADIUS server parameters.
  3. In Profile Management, change the security policy to WPA2, and complete the Hotspot2.0 service configuration based on the data planning.
  4. Complete service verification.

Procedure

  1. Configure the network devices.

    # Add GE0/0/1 and GE0/0/2 on SwitchA to VLAN 100 and VLAN101. The default VLAN of GE0/0/1 is VLAN 100.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchA
    [SwitchA] vlan batch 100 101
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk pvid vlan 100
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/1] port-isolate enable
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type trunk
    [SwitchA-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
    [SwitchA-GigabitEthernet0/0/2] quit
    
    # Add GE0/0/1 on SwitchB (aggregation switch) to VLAN 100 and VLAN101, GE0/0/2 to VLAN100 and GE0/0/3 to VLAN 101.
    <HUAWEI> system-view
    [HUAWEI] sysname SwitchB
    [SwitchB] vlan batch 100 101
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface gigabitethernet 0/0/2
    [SwitchB-GigabitEthernet0/0/2] port link-type trunk
    [SwitchB-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [SwitchB-GigabitEthernet0/0/2] quit
    [SwitchB] interface gigabitethernet 0/0/3
    [SwitchB-GigabitEthernet0/0/3] port link-type trunk
    [SwitchB-GigabitEthernet0/0/3] port trunk allow-pass vlan 101
    [SwitchB-GigabitEthernet0/0/3] quit
    
    # Add GE1/0/0 on Router to VLAN 101. Create VLANIF 101 and set its IP address to 10.23.101.2/24.
    <Huawei> system-view
    [Huawei] sysname Router
    [Router] vlan batch 101
    [Router] interface gigabitethernet 1/0/0
    [Router-GigabitEthernet1/0/0] port link-type trunk
    [Router-GigabitEthernet1/0/0] port trunk allow-pass vlan 101
    [Router-GigabitEthernet1/0/0] quit
    [Router] interface vlanif 101
    [Router-Vlanif101] ip address 10.23.101.2 24
    [Router-Vlanif101] quit
    

  2. Configure the DHCP servers to assign IP addresses to APs and STAs.

    # On SwitchB, configure VLANIF 101 to assign IP addresses to STAs and set the default gateway address of STAs to 10.23.101.2.
    NOTE:
    Configure the DNS server as required. The common methods are as follows:
    • In interface address pool scenarios, run the dhcp server dns-list ip-address &<1-8> command in the VLANIF interface view.
    • In global address pool scenarios, run the dns-list ip-address &<1-8> command in the IP address pool view.
    [SwitchB] dhcp enable
    [SwitchB] interface vlanif 101
    [SwitchB-Vlanif101] ip address 10.23.101.1 24
    [SwitchB-Vlanif101] dhcp select interface
    [SwitchB-Vlanif101] dhcp server gateway-list 10.23.101.2
    [SwitchB-Vlanif101] quit
    

  3. Configure system parameters for the AC.
    1. Perform basic AC configurations.

      # Choose Configuration > Config Wizard > AC. The Basic AC Configuration page is displayed.

      # Set Country/Region based on actual situations. For example, set Country/Region to China. Set System time to Manual and Date and time to PC Time.



      # Click Next. The Port Configuration page is displayed.

    2. Configure interfaces.

      # Select GigabitEthernet0/0/1 and expand Batch Modify. Set Interface type to Trunk and add GigabitEthernet0/0/1 to VLAN 100 (management VLAN).
      NOTE:

      If the AC and APs are directly connected, set the default VLAN of the interfaces connected to the APs to management VLAN 100.



      # Click Apply. In the dialog box that is displayed, click OK.

      # Click Next. The Network Interconnection Configuration page is displayed.

    3. Configuring network interconnections.

      # Click Create under Interface Configuration. The Create Interface Configuration page is displayed.

      # Set the IP address of VLANIF 100 to 10.23.100.1/24. Set DHCP status to ON and DHCP type to Interface address pool.



      # Click OK. An address pool for VLANIF 100 is configured.

      # Click Next.

      # Click Next. The AC Source Address page is displayed.

    4. Configure the source address for AC.

      # Set AC source address to VLANIF. Click the browse button and select Vlanif100.

      # Click Next. The Confirm Settings page is displayed.

    5. Confirm the configuration.

      # Confirm the configuration and click Continue With AP Online.

  4. Configure an AP to go online.
    1. Configure an AP to go online.

      # Click Batch Import. The Batch Import page is displayed. Click to download an AP template file to your local computer.



      # Fill in the AP template file with AP information according to the following example. To add multiple APs, fill in the file with information of the APs.
      • AP MAC: 60de-4476-e360
      • AP SN: 210235419610CB002287
      • AP Name: area_1
      • AP Group: ap-group1
      NOTE:
      • If you set AP authentication mode to MAC address authentication, the AP's MAC address is mandatory and the AP's SN is optional.
      • If you set AP authentication mode to SN authentication, the AP's SN is mandatory and the AP's MAC address is optional.

      You are advised to export the radio ID, AP channel, frequency bandwidth, and power planned on WLAN Planner to a .csv file, and then enter them in the AP template file. Set the longitude and latitude as required.

      # Click next to Import AP File, select the AP template file, and click Import.

      # On the page that displays the template import result, click OK.

      # Click Next. The Group APs page is displayed.

      # AP group information has been added in the AP template file. Click Next. The Confirm Configurations page is displayed.

    2. Confirm the configuration.

      # Confirm the configuration and click Continue With Wireless Service Configuration.

  5. Configure WLAN services.

    # Click Create. The Basic Information page is displayed.

    # Configure the SSID name, forwarding mode, and service VLAN ID.



    Click Next. The Security Authentication page is displayed.

    # Configure security authentication.



    # Click Next. The Access Control page is displayed.

    # Set Binding the AP group to ap-group1.

    Click Finish.

  6. Set the AP channel and power.
    1. Disable automatic channel and power calibration functions of AP radios, and manually configure the AP channel and power.

      NOTE:

      Automatic channel and power calibration functions are enabled by default. The manual channel and power configurations take effect only when these two functions are disabled.

      # Choose Configuration > AP Config > AP Config > AP Info. The AP List page is displayed.

      # Click the ID of the AP whose channel and power need to be configured. The AP customized settings page is displayed.

      # Click next to Radio Management. The profiles under Radio Management are displayed.

      # Click Radio 0. The Radio 0 Settings(2.4G) page is displayed. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 6 and transmit power to 127 dBm.



      # The configuration of Radio 1 is similar to that of Radio0. Disable automatic channel and power calibration functions, and set the AP channel to 20-MHz channel 149 and transmit power to 127 dBm.

      # Click Apply. In the dialog box that is displayed, click OK.

  7. Configure Hotspot2.0 services.
    1. Choose Configuration > AP Config > AP Group > AP Group. Click ap-group1. The AP group configuration page is displayed.
    2. Choose VAP Configuration > wlan-net > Security Profile, set the security policy to WPA2, and click Apply. In the dialog box that is displayed, click OK.



    3. Choose VAP Configuration > wlan-net > Hotspot2.0 Profile. The Hotspot2.0 profile page is displayed. Click Create. On the Create Hotspot2.0 Profile page that is displayed, set Profile name to wlan-net and click OK. Configure parameters and click Apply. In the dialog box that is displayed, click OK.



    4. Click in front of Hotspot2.0 Profile and select Cellular Network Profile. The Cellular Network Profile page is displayed. Click Create. The Create Cellular Network Profile page is displayed. Set Profile name to wlan-net, and click OK. Set PLMN ID, and click Apply. In the dialog box that is displayed, click OK.



    5. Select Roaming Consortium Profile, the Roaming Consortium Profile page is displayed. Click Create. The Create Roaming Consortium Profile page is displayed. Set Profile name to wlan-net, and click OK. Set Roaming consortium OI, and click Apply. In the dialog box that is displayed, click OK.



    6. Select NAI Realm Profile. The NAI Realm Profile page is displayed. Click Create. The Create NAI Realm Profile page is displayed. Set Profile name to wlan-net, and click OK. Set Realm name, and click Apply. In the dialog box that is displayed, click OK.



    7. Select Network Connection Capability Profile. The Network Connection Capability Profile page is displayed. Click Create. The Create Network Connection Capability Profile page is displayed. Set Profile name to wlan-net, and click OK. Set HTTP to ON, and click Apply. In the dialog box that is displayed, click OK.



    8. Select Operator Domain Profile. The Operator Domain Profile page is displayed. Click Create, the Create Operator Domain Profile page is displayed. Set Profile name to wlan-net, and click OK. Set Domain name, and click Apply. In the dialog box that is displayed, click OK.



    9. Select Carrier Name Profile. The Carrier Name Profile page is displayed. Click Create. The Create Carrier Name Profile page is displayed. Set Profile name to wlan-net, and click OK. Set Operator name, and click Apply. In the dialog box that is displayed, click OK.



    10. Select Venue Name Profile. The Venue Name Profile page is displayed. Click Create. The Create Venue Name Profile page is displayed. Set Profile name to wlan-net, and click OK. Set Venue name, and click Apply. In the dialog box that is displayed, click OK.



    11. Select Operating Class Profile. The Operating Class Profile page is displayed. Click Create. The Create Operating Class Profile page is displayed. Set Profile name to wlan-net, and click OK. Set Frequency band indication No., and click Apply. In the dialog box that is displayed, click OK.



  8. Verify the configuration.
    1. Choose Monitoring > SSID > VAP. In VAP List, check VAP status. You can see that the status of the VAP in wlan-net is normal.
    2. The WLAN with the SSID wlan-net is available.
    3. The STA can associate with the WLAN and obtain an IP address 10.23.101.x/24, and its gateway address is 10.23.101.2.



    4. Choose Monitoring > User > User Statistics. In User List, set the search criteria to SSID, enter wlan-net, and click . You can see that the STA goes online successfully and obtains an IP address.
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 90552

Downloads: 458

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next