No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

WLAN V200R008C10 Typical Configuration Examples

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring Rail Transportation WLAN Services

Example for Configuring Rail Transportation WLAN Services

Service Requirements

To reduce network deployment costs and better serve passengers, a rail transportation enterprise wants to use WLAN technology to implement vehicle-ground communications and expects that multicast servers on the ground network can deliver multimedia information services to passengers.

Networking Requirements

  • AC networking mode: Layer 2 bypass mode
  • Wireless backhaul mode: Mesh-based vehicle-ground fast link handover
  • Backhaul radio: 5 GHz radio
Figure 4-5 Networking for configuring vehicle-ground fast link handover

Data Planning

Table 4-7 AP information

AP

Type

MAC Address

Trackside AP (L1_001)

AP9132DN

0046-4b59-1d10

Trackside AP (L1_003)

AP9132DN

0046-4b59-1d20

Trackside AP (L1_010)

AP9132DN

0046-4b59-1d30

Trackside AP (L1_150)

AP9132DN

0046-4b59-1d40

Trackside AP (L1_160)

AP9132DN

0046-4b59-1d50

Trackside AP (L1_170)

AP9132DN

0046-4b59-1d60

......

Vehicle-mounted AP (in the front)

AP9132DN

0046-4b59-2e10

Vehicle-mounted AP (in the rear)

AP9132DN

0046-4b59-2e20

.......
Table 4-8 Data planning

Item

Data

Management VLAN VLAN 100
Multicast service VLAN VLAN 101
Service VLAN for STAs VLAN 200
DHCP server
  • Configure the AC as a DHCP server to assign IP addresses to trackside APs.
  • Configure Switch_A as a DHCP server to assign IP addresses to vehicle-mounted terminals.
AC's source interface address VLANIF 100: 10.23.100.1/24
Gateway address IP address of VLANIF 101 on Switch_A: 10.23.224.1/24
IP address pool for trackside APs 10.23.100.2-10.23.100.254/24
IP address pool for vehicle-mounted terminals 10.23.224.4-10.23.224.254/24
AP group to which trackside APs belong Name: mesh-mpp
IDs of trackside APs
  • Trackside AP (L1_001): 1
  • Trackside AP (L1_003): 2
  • Trackside AP (L1_010): 3
  • Trackside AP (L1_150): 101
  • Trackside AP (L1_160): 102
  • Trackside AP (L1_170): 103
AP wired port profile
  • Name: wired-port
Security profile
  • Name: sp01
  • Security policy: WPA2+PSK+AES
  • Password type: PASS-PHRASE
  • Authentication key: a1234567
AP system profile
  • Name: mesh-sys
  • Mesh role: Mesh-portal
Mesh profile
Trackside APs:
  • Name: mesh-net
  • Identifier: mesh-net
Vehicle-mounted APs:
  • Name: mesh-net
  • Identifier: mesh-net
Mesh handover profile

Trackside APs:

  • Name: hand-over

Vehicle-mounted APs:

  • Name: hand-over
Mesh whitelist on trackside APs Name: whitelist01

Add MAC addresses of all vehicle-mounted APs on trains running on the rail to the whitelist according to actual situations.

MAC address of the proxied ground device
  • Gateway: 707b-e8e9-d328
  • Network management device: 286e-d488-12cd
  • Multicast source: 286e-d488-b6ab
MAC address of the proxied vehicle-mounted device
  • Vehicle-mounted terminal_1: 286e-d488-d359
  • Vehicle-mounted terminal_2: 286e-d488-d270
Multicast group 225.1.1.1-225.1.1.3

Configuration Roadmap

  1. Configure the ground network to enable Layer 2 communications between trackside APs and the AC.
  2. Configure multicast services on ground network devices to enable proper multicast data forwarding on the ground network.
  3. Configure vehicle-ground fast link handover on trackside and vehicle-mounted APs so that the vehicle-mounted AP can set up Mesh connections with the trackside APs.
  4. Configure the vehicle-mounted network to enable intra-network data communications.
NOTE:
  • This example uses Huawei AP9132DNs in Fit AP mode as the trackside APs and AP9132DNs in Fat AP mode as the vehicle-mounted APs.
  • Switches and routers used in this example are all Huawei products.

Configuration Notes

  • No ACK mechanism is provided for multicast packet transmission on air interfaces. In addition, wireless links are unstable. To ensure stable transmission of multicast packets, they are usually sent at low rates. If a large number of such multicast packets are sent from the network side, the air interfaces may be congested. You are advised to configure multicast packet suppression to reduce impact of a large number of low-rate multicast packets on the wireless network. Exercise caution when configuring the rate limit; otherwise, the multicast services may be affected.
    • In direct forwarding mode, you are advised to configure multicast packet suppression on switch interfaces connected to APs.
    • In tunnel forwarding mode, you are advised to configure multicast packet suppression in traffic profiles of the AC.
    For details on how to configure traffic suppression, see How Do I Configure Multicast Packet Suppression to Reduce Impact of a Large Number of Low-Rate Multicast Packets on the Wireless Network?.
  • Configure port isolation on the interfaces of the device directly connected to APs. If port isolation is not configured and direct forwarding is used, a large number of unnecessary broadcast packets may be generated in the VLAN, blocking the network and degrading user experience.

  • In tunnel forwarding mode, the management VLAN and service VLAN cannot be the same. Only packets from the management VLAN are transmitted between the AC and APs. Packets from the service VLAN are not allowed between the AC and APs.

Procedure

  • Configure ground network devices.
    1. Configure Switch_A. Create VLAN 100, VLAN 101 and VLAN 200, add interfaces GE0/0/1 to GE0/0/4 to VLAN 101, and configure these interfaces to allow packets from VLAN 101 to pass through. Set PVIDs of GE0/0/3 and GE0/0/4 to VLAN 101. Add GE0/0/5 to VLAN 200, set its PVID to VLAN 200, and configure GE0/0/5 to allow packets from VLAN 200 to pass through. Configure GE0/0/1, GE0/0/2, and GE0/0/6 to allow packets from VLAN 100 to pass through.

      <HUAWEI> system-view
      [HUAWEI] sysname Switch_A
      [Switch_A] vlan batch 100 101 200
      [Switch_A] interface gigabitEthernet 0/0/1
      [Switch_A-GigabitEthernet0/0/1] port link-type trunk
      [Switch_A-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
      [Switch_A-GigabitEthernet0/0/1] quit
      [Switch_A] interface gigabitEthernet 0/0/2
      [Switch_A-GigabitEthernet0/0/2] port link-type trunk
      [Switch_A-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
      [Switch_A-GigabitEthernet0/0/2] quit
      [Switch_A] interface gigabitEthernet 0/0/3
      [Switch_A-GigabitEthernet0/0/3] port link-type trunk
      [Switch_A-GigabitEthernet0/0/3] port trunk pvid vlan 101
      [Switch_A-GigabitEthernet0/0/3] port trunk allow-pass vlan 101
      [Switch_A-GigabitEthernet0/0/3] quit
      [Switch_A] interface gigabitEthernet 0/0/4
      [Switch_A-GigabitEthernet0/0/4] port link-type trunk
      [Switch_A-GigabitEthernet0/0/4] port trunk pvid vlan 101
      [Switch_A-GigabitEthernet0/0/4] port trunk allow-pass vlan 101
      [Switch_A-GigabitEthernet0/0/4] quit
      [Switch_A] interface gigabitEthernet 0/0/5
      [Switch_A-GigabitEthernet0/0/5] port link-type trunk
      [Switch_A-GigabitEthernet0/0/5] port trunk pvid vlan 200
      [Switch_A-GigabitEthernet0/0/5] port trunk allow-pass vlan 200
      [Switch_A-GigabitEthernet0/0/5] quit
      [Switch_A] interface gigabitEthernet 0/0/6
      [Switch_A-GigabitEthernet0/0/6] port link-type trunk
      [Switch_A-GigabitEthernet0/0/6] port trunk allow-pass vlan 100
      [Switch_A-GigabitEthernet0/0/6] quit

    2. On Switch_A, configure an IP address for VLANIF 101 and enable the DHCP server function to assign IP addresses for vehicle-mounted terminals.

      [Switch_A] dhcp enable
      [Switch_A] interface vlanif 101
      [Switch_A-Vlanif101] ip address 10.23.224.1 24
      [Switch_A-Vlanif101] dhcp select interface
      [Switch_A-Vlanif101] dhcp server excluded-ip-address 10.23.224.2 10.23.224.3
      [Switch_A-Vlanif101] quit
      

    3. Configure an IP address for VLANIF 200 on Switch_A and specify the IP address of GE1/0/0 on the router as the next hop address of the default route so that packets from the vehicle-ground communication network can be forwarded to the egress router.

      [Switch_A] interface vlanif 200
      [Switch_A-Vlanif200] ip address 10.23.200.2 24
      [Switch_A-Vlanif200] quit
      [Switch_A] ip route-static 0.0.0.0 0 10.23.200.1
      

    4. Configure an IP address for GE1/0/0 on Router and configure routes to the internal network segment, with the next hop address 10.23.200.2.

      <Huawei> system-view
      [Huawei] sysname Router
      [Router] interface gigabitethernet 1/0/0
      [Router-GigabitEthernet1/0/0] ip address 10.23.200.1 24
      [Router-GigabitEthernet1/0/0] quit
      [Router] ip route-static 10.23.224.0 24 10.23.200.2
      [Router] ip route-static 10.23.100.0 24 10.23.200.2
      
      NOTE:
      You can configure routes to external networks and the NAT function on the egress router according to service requirements to ensure normal communications between internal and external networks.

    5. Configure Switch_B and Switch_C to enable Layer 2 communications between trackside APs and the ground network.

      # On Switch_B, create VLAN 100 and VLAN 101, configure GE0/0/2 and GE0/0/1 to allow packets from VLAN 100 and VLAN 101 to pass through, and set the PVID of GE0/0/1 to VLAN 100 (management VLAN for trackside APs).

      # Configure other interfaces connected to trackside APs on Switch_B according to GE0/0/1: allow packets from VLAN 100 and VLAN 101 to pass through and set their PVIDs to VLAN 100.
      <HUAWEI> system-view
      [HUAWEI] sysname Switch_B
      [Switch_B] vlan batch 100 101
      [Switch_B] interface gigabitEthernet 0/0/2
      [Switch_B-GigabitEthernet0/0/2] port link-type trunk
      [Switch_B-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
      [Switch_B-GigabitEthernet0/0/2] quit
      [Switch_B] interface gigabitEthernet 0/0/1
      [Switch_B-GigabitEthernet0/0/1] port link-type trunk
      [Switch_B-GigabitEthernet0/0/1] port trunk pvid vlan 100
      [Switch_B-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
      [Switch_B-GigabitEthernet0/0/1] quit

      # On Switch_C, create VLAN 100 and VLAN 101, configure GE0/0/2 and GE0/0/1 to allow packets from VLAN 100 and VLAN 101 to pass through, and set the PVID of GE0/0/1 to VLAN 100.

      # Configure other interfaces connected to trackside APs on Switch_C according to GE0/0/1: allow packets from VLAN 100 and VLAN 101 to pass through and set their PVIDs to VLAN 100.
      <HUAWEI> system-view
      [HUAWEI] sysname Switch_C
      [Switch_C] vlan batch 100 101
      [Switch_C] interface gigabitEthernet 0/0/2
      [Switch_C-GigabitEthernet0/0/2] port link-type trunk
      [Switch_C-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
      [Switch_C-GigabitEthernet0/0/2] quit
      [Switch_C] interface gigabitEthernet 0/0/1
      [Switch_C-GigabitEthernet0/0/1] port link-type trunk
      [Switch_C-GigabitEthernet0/0/1] port trunk pvid vlan 100
      [Switch_C-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
      [Switch_C-GigabitEthernet0/0/1] quit

    6. Enable Layer 2 multicast on Switch_A, Switch_B, and Switch_C to allow them to properly forward multicast data.

      # Enable IGMP snooping globally on Switch_A.

      [Switch_A] igmp-snooping enable

      # Enable IGMP snooping in VLAN 101 on Switch_A.

      [Switch_A] vlan 101
      [Switch_A-vlan101] igmp-snooping enable
      [Switch_A-vlan101] quit
      

      # Configure multicast group filter policies on Switch_A.

      [Switch_A] acl 2000
      [Switch_A-acl-basic-2000] rule permit source 225.1.1.1 0
      [Switch_A-acl-basic-2000] rule permit source 225.1.1.2 0
      [Switch_A-acl-basic-2000] rule permit source 225.1.1.3 0
      [Switch_A-acl-basic-2000] quit
      

      # Apply the multicast group filter policies in VLAN 101 on Switch_A.

      [Switch_A] vlan 101
      [Switch_A-vlan101] igmp-snooping group-policy 2000
      [Switch_A-vlan101] quit
      [Switch_A] quit

      # Complete multicast configuration on Switch_B and Switch_C according to the multicast configuration procedure of Switch_A.

      # Configure the fast leave function on Switch_B and Switch_C.
      If trackside APs are directly connected to the switches and Layer 2 multicast is configured, enabling the fast leave function improves the quality of multicast services. If the trackside APs are not directly connected to the switches or Layer 3 multicast is configured, you cannot configure the fast leave function because this function may interrupt multicast services.
      [Switch_B] vlan 101
      [Switch_B-vlan101] igmp-snooping prompt-leave group-policy 2000
      [Switch_C] vlan 101
      [Switch_C-vlan101] igmp-snooping prompt-leave group-policy 2000

    7. Configure the AC to enable it to communicate with trackside APs at Layer 2.

      # Create VLAN 100 on the AC and configure GE0/0/1 to allow packets from VLAN 100 to pass through.

      <AC6605> system-view
      [AC6605] sysname AC
      [AC] vlan batch 100
      [AC] interface gigabitEthernet 0/0/1
      [AC-GigabitEthernet0/0/1] port link-type trunk
      [AC-GigabitEthernet0/0/1] port trunk allow-pass vlan 100
      [AC-GigabitEthernet0/0/1] quit
      

      # Configure the AC as a DHCP server to assign IP addresses to trackside APs.

      [AC] dhcp enable
      [AC] interface vlanif 100
      [AC-Vlanif100] ip address 10.23.100.1 24
      [AC-Vlanif100] dhcp select interface
      [AC-Vlanif100] quit
      

    8. Configure the AP group, country code, and AC's source interface.

      # Create the AP group mesh-mpp and add trackside APs that require the same configuration to the group.

      [AC] wlan
      [AC-wlan-view] ap-group name mesh-mpp
      [AC-wlan-ap-group-mesh-mpp] quit
      

      # Create a regulatory domain profile, configure the AC country code in the profile, and apply the profile to the AP group.

      [AC-wlan-view] regulatory-domain-profile name default
      [AC-wlan-regulate-domain-default] country-code cn
      [AC-wlan-regulate-domain-default] quit
      [AC-wlan-view] ap-group name mesh-mpp
      [AC-wlan-ap-group-mesh-mpp] regulatory-domain-profile default
      Warning: Modifying the country code will clear channel, power and antenna gain configurations of the radio and reset the AP. Continu
      e?[Y/N]:y 
      [AC-wlan-ap-group-mesh-mpp] quit
      
      [AC-wlan-view] quit
      

      # Configure the AC's source interface.

      [AC] capwap source interface vlanif 100
      
      # Add trackside APs to the AP group mesh-mpp.
      NOTE:

      The default AP authentication mode is MAC address authentication. If the default settings are retained, you do not need to run the ap auth-mode mac-auth command.

      [AC] wlan
      [AC-wlan-view] ap auth-mode mac-auth
      [AC-wlan-view] ap-id 1 ap-mac 0046-4b59-1d10
      [AC-wlan-ap-1] ap-name L1_001
      [AC-wlan-ap-1] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-1] quit
      [AC-wlan-view] ap-id 2 ap-mac 0046-4b59-1d20
      [AC-wlan-ap-2] ap-name L1_003
      [AC-wlan-ap-2] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-2] quit
      [AC-wlan-view] ap-id 3 ap-mac 0046-4b59-1d30
      [AC-wlan-ap-3] ap-name L1_010
      [AC-wlan-ap-3] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-3] quit
      [AC-wlan-view] ap-id 101 ap-mac 0046-4b59-1d40
      [AC-wlan-ap-101] ap-name L1_150
      [AC-wlan-ap-101] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-101] quit
      [AC-wlan-view] ap-id 102 ap-mac 0046-4b59-1d50
      [AC-wlan-ap-102] ap-name L1_160
      [AC-wlan-ap-102] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-102] quit
      [AC-wlan-view] ap-id 103 ap-mac 0046-4b59-1d60
      [AC-wlan-ap-103] ap-name L1_170
      [AC-wlan-ap-103] ap-group mesh-mpp
      Warning: This operation may cause AP reset. If the country code changes, it will clear channel, power and antenna gain configuration
      s of the radio, Whether to continue? [Y/N]:y 
      [AC-wlan-ap-103] quit
      

    9. Configure the trackside APs' uplink wired interfaces to allow packets from VLAN 101 to pass through.

      # Configure the wired port profile wired-port and add the wired interfaces to VLAN 101 in tagged mode.

      [AC-wlan-view] wired-port-profile name wired-port
      [AC-wlan-wired-port-wired-port] vlan tagged 101
      [AC-wlan-wired-port-wired-port] quit
      

      # Bind the wired port profile wired-port to the AP group mesh-mpp.

      [AC-wlan-view] ap-group name mesh-mpp
      [AC-wlan-ap-group-mesh-mpp] wired-port-profile wired-port gigabitethernet 0
      [AC-wlan-ap-group-mesh-mpp] quit
      

    10. Configure Mesh parameters.

      # Create the Mesh whitelist whitelist01 and add MAC addresses of vehicle-mounted APs to the Mesh whitelist.

      [AC-wlan-view] mesh-whitelist name whitelist01
      [AC-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-2e10
      [AC-wlan-mesh-whitelist-whitelist01] peer-ap mac 0046-4b59-2e20
      [AC-wlan-mesh-whitelist-whitelist01] quit
      

      # Add MAC addresses of vehicle-mounted APs on other trains to the Mesh whitelist whitelist01 according to the preceding procedure.

      # Configure the security profile sp01 used by Mesh links. The sp01 supports the security policy WPA2+PSK+AES.

      [AC-wlan-view] security-profile name sp01
      [AC-wlan-sec-prof-sp01] security wpa2 psk pass-phrase a1234567 aes
      [AC-wlan-sec-prof-sp01] quit
      

      # Configure the Mesh role. Set the Mesh role of trackside APs to Mesh-portal through the AP system profile.

      [AC-wlan-view] ap-system-profile name mesh-sys
      [AC-wlan-ap-system-prof-mesh-sys] mesh-role Mesh-portal
      [AC-wlan-ap-system-prof-mesh-sys] quit
      

      # Configure the Mesh handover profile hand-over and enable the location-based fast link handover algorithm.

      [AC-wlan-view] mesh-handover-profile name hand-over
      [AC-wlan-mesh-handover-hand-over] location-based-algorithm enable
      [AC-wlan-mesh-handover-hand-over] quit
      

      # Configure the Mesh profile. Set the ID of the Mesh network to mesh-net and apply the security profile and Mesh handover profile.

      [AC-wlan-view] mesh-profile name mesh-net
      [AC-wlan-mesh-prof-mesh-net] mesh-id mesh-net
      [AC-wlan-mesh-prof-mesh-net] security-profile sp01
      [AC-wlan-mesh-prof-mesh-net] mesh-handover-profile hand-over
      [AC-wlan-mesh-prof-mesh-net] quit
      

    11. Apply the Mesh parameters to radios of trackside APs.

      # Configure the radio and channel used by trackside APs and apply the Mesh whitelist, Mesh profile, and AP system profile.

      [AC-wlan-view] ap-group name mesh-mpp
      [AC-wlan-ap-group-mesh-mpp] ap-system-profile mesh-sys
      [AC-wlan-ap-group-mesh-mpp] radio 1
      [AC-wlan-group-radio-mesh-mpp/1] channel 40mhz-plus 157
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AC-wlan-group-radio-mesh-mpp/1] mesh-whitelist-profile whitelist01
      [AC-wlan-group-radio-mesh-mpp/1] mesh-profile mesh-net
      [AC-wlan-group-radio-mesh-mpp/1] quit
      [AC-wlan-ap-group-mesh-mpp] quit
      [AC-wlan-view] quit
      [AC] quit

  • Configure vehicle-mounted network devices.

    NOTE:
    This example provides the detailed configuration procedure of the vehicle-mounted AP in the front of the train. The configuration procedure of the vehicle-mounted AP in the rear is similar to that of the vehicle-mounted AP in the front.

    1. Create VLAN 101 on the vehicle-mounted APs, configure GE0/0/1 to allow packets from VLAN 101 to pass through, and set the PVID of GE0/0/1 to VLAN 101.

      <Huawei> system-view
      <Huawei> sysname AP
      [AP] vlan batch 101
      [AP] interface gigabitethernet 0/0/1
      [AP-GigabitEthernet0/0/1] port link-type trunk
      [AP-GigabitEthernet0/0/1] port trunk pvid vlan 101
      [AP-GigabitEthernet0/0/1] port trunk allow-pass vlan 101
      [AP-GigabitEthernet0/0/1] quit
      

    2. Configure system parameters for the vehicle-mounted APs.

      # Configure the AP country code.

      [AP] wlan
      [AP-wlan-view] country-code cn
      

    3. Configure vehicle-ground fast link handover parameters.

      # Configure the security profile sp01 used by Mesh links. The sp01 supports the security policy WPA2+PSK+AES.

      [AP-wlan-view] security-profile name sp01
      [AP-wlan-sec-prof-sp01] security wpa2 psk pass-phrase a1234567 aes
      [AP-wlan-sec-prof-sp01] quit
      

      # Configure the Mesh handover profile hand-over, enable the location-based fast link handover algorithm, and set the moving direction of the vehicle-mounted AP to forward.

      [AP-wlan-view] mesh-handover-profile name hand-over
      [AP-wlan-mesh-handover-hand-over] location-based-algorithm enable moving-direction forward 
      [AP-wlan-mesh-handover-hand-over] quit
      
      NOTE:
      In this example, the moving direction of the vehicle-mounted AP in the rear must be set to backward.

      # Configure the Mesh profile. Set the ID of the Mesh network to mesh-net and apply the security profile and Mesh handover profile.

      [AP-wlan-view] mesh-profile name mesh-net
      [AP-wlan-mesh-prof-mesh-net] mesh-id mesh-net
      [AP-wlan-mesh-prof-mesh-net] security-profile sp01
      [AP-wlan-mesh-prof-mesh-net] mesh-handover-profile hand-over
      [AP-wlan-mesh-prof-mesh-net] quit
      [AP-wlan-view] quit
      

    4. Apply the Mesh parameters to radios of vehicle-mounted APs.

      # Configure the radio and channel used by vehicle-mounted APs and apply the Mesh profile.

      [AP] interface wlan-radio 0/0/1
      [AP-Wlan-Radio0/0/1] channel 40mhz-plus 157 
      Warning: This action may cause service interruption. Continue?[Y/N]y
      [AP-Wlan-Radio0/0/1] mesh-profile mesh-net
      [AP-Wlan-Radio0/0/1] quit
      

      # Configure Mesh VAPs for other vehicle-mounted APs according to the preceding configuration procedure.

    5. Add proxied devices on the vehicle-mounted APs.

      # Add proxied ground devices. Add MAC addresses of Switch_A, the network management device, and multicast source on the vehicle-mounted APs.

      [AP] wlan
      [AP-wlan-view] mesh-proxy trackside-equip mac-address 707b-e8e9-d328 vlan 101
      [AP-wlan-view] mesh-proxy trackside-equip mac-address 286e-d488-12cd vlan 101
      [AP-wlan-view] mesh-proxy trackside-equip mac-address 286e-d488-b6ab vlan 101
      

      # Add proxied vehicle-mounted devices. Add MAC addresses of the vehicle-mounted terminals on the vehicle-mounted APs.

      [AP-wlan-view] mesh-proxy onboard-equip mac-address 286e-d488-d359 vlan 101
      [AP-wlan-view] mesh-proxy onboard-equip mac-address 286e-d488-d270 vlan 101
      [AP-wlan-view] quit
      

    6. Enable IGMP snooping on the vehicle-mounted APs.

      [AP] igmp-snooping enable
      [AP] vlan 101
      [AP-vlan101] igmp-snooping enable
      [AP-vlan101] quit
      [AP] quit

  • Verify the configuration.

    # After vehicle-ground fast link handover configuration is complete, run the display wlan mesh link all command on the AC to view Mesh connections between trackside and vehicle-mounted APs.

    <AC> display wlan mesh link all
    Rf   : radio ID             Dis  : coverage distance(100m)
    Ch   : channel              Per  : drop percent(%)
    TSNR : total SNR(dB)        P-   : peer
    Mesh : Mesh mode            Re   : retry ratio(%)
    RSSI : RSSI(dBm)            MaxR : max RSSI(dBm)
    ----------------------------------------------------------------------------------------------------------------------------------
    APName          P-APName        P-APMAC         Rf Dis   Ch      Mesh    P-Status        RSSI  MaxR  Per  Re   TSNR  SNR(Ch0~3:dB)
    ----------------------------------------------------------------------------------------------------------------------------------
    L1_001          AP              0046-4b59-2e10  1  3     157     portal  -               -51   -38   0    0    47    39/47/-/-
    L1_003          AP              0046-4b59-2e10  1  3     157     portal  -               -59   -7    0    0    50    19/14/37/-
    L1_010          AP              0046-4b59-2e10  1  3     157     portal  -               -45   -33   0    0    37    20/17/17/-
    L1_150          AP              0046-4b59-2e10  1  3     157     portal  -               -54   -39   0    0    46    34/43/-/-
    L1_160          AP              0046-4b59-2e10  1  3     157     portal  -               -52   -7    0    0    32    21/18/35/-
    L1_170          AP              0046-4b59-2e10  1  3     157     portal  -               -42   -33   0    0    29    26/14/19/-
    ----------------------------------------------------------------------------------------------------------------------------------
    Total: 6

    # Run the display mesh-neighbor-rssi command on the AC to view RSSI information of trackside APs.

    <AC> display mesh-neighbor-rssi
    Info: This operation may take a few seconds, please wait.done.   
    AP name/MAC/Radio/Location-ID  Neighbor AP/MAC/Location-ID  RSSI  Update Time   
    ------------------------------------------------------------------------------  
    L1_001/0046-4b59-1d10/1/1      -/0046-4b59-2e10/-           -44   18:08:21      
    L1_003/0046-4b59-1d20/1/3      -/0046-4b59-2e10/-           -50   18:08:20      
    L1_010/0046-4b59-1d30/1/10     -/0046-4b59-2e10/-           -28   18:08:21      
    L1_150/0046-4b59-1d40/1/150    -/0046-4b59-2e10/-           -43   18:08:20      
    L1_160/0046-4b59-1d50/1/160    -/0046-4b59-2e10/-           -47   18:08:21      
    L1_170/0046-4b59-1d60/1/170    -/0046-4b59-2e10/-           -38   18:08:21      
    ------------------------------------------------------------------------------  
    Total: 6

    # Run the display mesh-handover-trace command on the vehicle-mounted AP to view roaming traces of the vehicle-mounted AP.

    <AP> display mesh-handover-trace
      Info: This operation may take a few seconds, please wait.done.   
      Index  Timestamp  From AP MAC/RSSI/Location-ID   To AP MAC/RSSI/Location-ID
      ------------------------------------------------------------------------------
      1      18:52:27   0046-4b59-1d50/-95/160         0046-4b59-1d60/-15/170
      2      18:50:46   0046-4b59-1d40/-95/150         0046-4b59-1d50/-34/160
      3      18:49:25   0046-4b59-1d30/-95/10          0046-4b59-1d40/-11/150
      4      18:48:56   0046-4b59-1d20/-95/3           0046-4b59-1d30/-40/10
      5      18:47:39   0046-4b59-1d10/-47/1           0046-4b59-1d20/-36/3
      ------------------------------------------------------------------------------

Configuration Files

  • Ground network devices

    • Router configuration file

      #
      sysname Router
      #
      interface GigabitEthernet0/0/1
       ip address 10.23.200.1 255.255.255.0
      #
      ip route-static 10.23.100.0 255.255.255.0 10.23.200.2
      ip route-static 10.23.224.0 255.255.255.0 10.23.200.2
      #
      return
      
    • Switch_A configuration file

      #
      sysname Switch_A
      #
       vlan batch 100 to 101 200
      #
      igmp-snooping enable
      #
      dhcp enable
      #
      vlan 101
       igmp-snooping enable
       igmp-snooping group-policy 2000
      #
      acl number 2000
       rule 5 permit source 225.1.1.1 0
       rule 10 permit source 225.1.1.2 0
       rule 15 permit source 225.1.1.3 0
      #
      interface Vlanif101
       ip address 10.23.224.1 255.255.255.0
       dhcp select interface
       dhcp server excluded-ip-address 10.23.224.2 10.23.224.3
      #
      interface Vlanif200
       ip address 10.23.200.2 255.255.255.0
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk allow-pass vlan 100 to 101
      #
      interface GigabitEthernet0/0/2
       port link-type trunk
       port trunk allow-pass vlan 100 to 101
      #
      interface GigabitEthernet0/0/3
       port link-type trunk
       port trunk pvid vlan 101
       port trunk allow-pass vlan 101
      #
      interface GigabitEthernet0/0/4
       port link-type trunk
       port trunk pvid vlan 101
       port trunk allow-pass vlan 101
      #
      interface GigabitEthernet0/0/5
       port link-type trunk
       port trunk pvid vlan 200
       port trunk allow-pass vlan 200
      #
      interface GigabitEthernet0/0/6
       port link-type trunk
       port trunk allow-pass vlan 100
      #
      ip route-static 0.0.0.0 0.0.0.0 10.23.200.1
      #
      return
      
    • Switch_B configuration file

      #
      sysname Switch_B
      #
       vlan batch 100 to 101
      #
      igmp-snooping enable
      #
      vlan 101
       igmp-snooping enable
       igmp-snooping group-policy 2000
       igmp-snooping prompt-leave group-policy 2000
      #
      acl number 2000
       rule 5 permit source 225.1.1.1 0
       rule 10 permit source 225.1.1.2 0
       rule 15 permit source 225.1.1.3 0
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 to 101
      #
      interface GigabitEthernet0/0/2
       port link-type trunk
       port trunk allow-pass vlan 100 to 101
      #
      interface GigabitEthernet0/0/3
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 to 101
      #
      interface GigabitEthernet0/0/4
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 to 101
      #
      return
      
    • Switch_C configuration file

      #
      sysname Switch_C
      #
       vlan batch 100 to 101
      #
      igmp-snooping enable
      #
      vlan 101
       igmp-snooping enable
       igmp-snooping group-policy 2000
       igmp-snooping prompt-leave group-policy 2000
      #
      acl number 2000
       rule 5 permit source 225.1.1.1 0
       rule 10 permit source 225.1.1.2 0
       rule 15 permit source 225.1.1.3 0
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 to 101
      #
      interface GigabitEthernet0/0/2
       port link-type trunk
       port trunk allow-pass vlan 100 to 101
      #
      interface GigabitEthernet0/0/3
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 to 101
      #
      interface GigabitEthernet0/0/4
       port link-type trunk
       port trunk pvid vlan 100
       port trunk allow-pass vlan 100 to 101
      #
      return
      
    • AC configuration file

      #
       sysname AC
       #
      vlan batch 100
      #
      dhcp enable
      #
      interface Vlanif100
       ip address 10.23.100.1 255.255.255.0
       dhcp select interface
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk allow-pass vlan 100
      #
      capwap source interface vlanif100
      #
      wlan
       security-profile name sp01                                                     
        security wpa2 psk pass-phrase %^%#yUrI$*AU}-T<aI*$21X8,wdZ>"Q%NVibT@S@ITs<%^%#
       aes 
       mesh-handover-profile name hand-over                                           
        location-based-algorithm enable 
       mesh-whitelist-profile name whitelist01
        peer-ap mac 0046-4b59-2e10
        peer-ap mac 0046-4b59-2e20
       mesh-profile name mesh-net                                                       
        mesh-handover-profile hand-over                                               
        security-profile sp01                                                         
        mesh-id mesh-net  
       regulatory-domain-profile name default
       ap-system-profile name mesh-sys
        mesh-role Mesh-portal
       wired-port-profile name wired-port
        vlan tagged 101
       ap-group name mesh-mpp                                                          
        ap-system-profile mesh-sys                                                    
        wired-port-profile wired-port gigabitethernet 0                               
        radio 1                                                                       
         mesh-profile mesh-net                                                          
         mesh-whitelist-profile whitelist01                                           
         channel 40mhz-plus 157                                                       
       ap-id 1 type-id 48 ap-mac 0046-4b59-1d10 ap-sn 210235554710CB000042            
        ap-name L1_001                                                                
        ap-group mesh-mpp                                                              
       ap-id 2 type-id 48 ap-mac 0046-4b59-1d20 ap-sn 210235555310CC000094            
        ap-name L1_003                                                               
        ap-group mesh-mpp                                                             
       ap-id 3 type-id 48 ap-mac 0046-4b59-1d30 ap-sn 210235419610CB002287            
        ap-name L1_010                                                                
        ap-group mesh-mpp
       ap-id 101 type-id 48 ap-mac 0046-4b59-1d40 ap-sn 210235555310CC00AC69          
        ap-name L1_150                                                                
        ap-group mesh-mpp
       ap-id 102 type-id 48 ap-mac 0046-4b59-1d50 ap-sn 210235555310CC003587           
        ap-name L1_160                                                                
        ap-group mesh-mpp
       ap-id 103 type-id 48 ap-mac 0046-4b59-1d60 ap-sn 210235449210CB000011           
        ap-name L1_170                                                                
        ap-group mesh-mpp
      #
      return
      
  • Vehicle-mounted network devices

    • Vehicle-mounted AP (in the front) configuration file

      #
       sysname AP
      #
      igmp-snooping enable
      #
      vlan batch 101
      #
      vlan 101
       igmp-snooping enable
      #
      interface GigabitEthernet0/0/1
       port link-type trunk
       port trunk pvid vlan 101
       port trunk allow-pass vlan 101
      #
      wlan
       security-profile name sp01                                                     
        security wpa2 psk pass-phrase %^%#yUrI$*AU}-T<aI*$21X8,wdZ>"Q%NVibT@S@ITs<%^%#
       aes 
       mesh-handover-profile name hand-over                                           
        location-based-algorithm enable moving-direction forward                      
       mesh-proxy trackside-equip mac-address 707b-e8e9-d328 vlan 101
       mesh-proxy trackside-equip mac-address 286e-d488-12cd vlan 101
       mesh-proxy trackside-equip mac-address 286e-d488-b6ab vlan 101
       mesh-proxy onboard-equip mac-address 286e-d488-d359 vlan 101
       mesh-proxy onboard-equip mac-address 286e-d488-d270 vlan 101
       mesh-profile name mesh-net
        mesh-handover-profile hand-over
        security-profile sp01 
        mesh-id mesh-net
      #                                                                               
      interface Wlan-Radio0/0/1                                                       
       mesh-profile mesh-net                                                          
       channel 40mhz-plus 157  
      #
      return
Translation
Download
Updated: 2019-03-30

Document ID: EDOC1000184389

Views: 91056

Downloads: 460

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next